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Introduction
Creating a book or other long document for the first time in Affinity or any other professional page layout 
application can be daunting because there are so many ways to approach a project that you might not 
know where to start. This manual will help you master some of Affinity’s most complex features and get 
started more quickly.

This manual describes everything you need to know about page layout but it does not describe the photo 
editing and illustration features of Affinity.

This manual is distributed electronically but it is laid out for print because it is intended to be a demon-
stration of what you can accomplish with Affinity. The tips and recommendations found in this manual 
will help you create similar publications.

Conventions used

The instructions provided here are for both Macintosh and Windows versions of Affinity’s Layout studio.

Menu commands are abbreviated to make this manual more readable. For example, instead of writing 
choose Copy from the Edit menu, this manual uses choose Edit > Copy. Keyboard modifiers are shown as:

Macintosh Windows

⌘ (Command) Ctrl

⌥ (Option) Alt

⇧ (Shift) Shift

⌃ (Ctrl)

Return Enter

You’re welcome to print a copy of this manual for your own use at home or work but redistribution is 
prohibited.



viiiviii
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Affinity has many features, some of which you might never use, 
so it is important to familiarize yourself with the interface and 
customise it to suit your workflows.

You can show and position the panels and tools you need the 
most and hide panels and tools that you will use less frequently.

English users outside the United Kingdom and United States 
may wish to set their spelling and hyphenation dictionaries, and 
other international users may need to set up Affinity to avoid 
having all text flagged as misspelled. English users outside of the 
United Kingdom may also need to customise settings such as 
Title Exceptions to enable these features.

Creating your first documents with Affinity can be overwhelming 
because there are so many options. This chapter also provides 
instructions on the best way to set up a multi-page document 
with linked text frames, headers, and footers.

In this chapter
Setting languages .......................................................................................... 2
Configuring the auto correction features .............................................. 5
Exploring the user interface ....................................................................... 8
Customising measurement units and document presets .............11
Setting up a document ..............................................................................13

Getting started 1

Expert Guide to Affinity by Canva 3.0 1



2 Getting started

Setting languages
You can use Affinity without any additional setup if you live in the United States, 
United Kingdom, France, Germany, Italy, Spain, Portugal, Brazil, China, or 
Japan. American users should consider changing their default hyphenation 
dictionary but everything else is set up for you.

If you live in any other country, you should take set up Affinity before creating or 
importing text.

Installing dictionaries
Affinity uses the spelling dictionaries included with macOS and a limited selec-
tion of dictionaries is included with Affinity for Windows. Affinity for both 
platforms includes a selection of hyphenation dictionaries.

Refer to the list of spelling and hyphenation dictionaries in Installing additional 
dictionaries on page 463 to determine if you need to install your own dictionar-
ies, and then follow the instructions in that section. French and German users 
may also wish to consider installing a different version of the dictionaries that are 
pre-installed.

Setting the interface language
The Affinity user interface can be displayed in English (UK and US), French, 
German, Italian, Spanish, Portuguese, Chinese, and Japanese. Each Affinity 
application will default to your operating system’s language, and if it is not sup-
ported, to one of your operating system’s other preferred languages. If none of 
your operating system’s languages are supported then Affinity will default to 
English.

To set the interface language:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click General in the left pane.

2. Select Default to use your operating system’s language if it matches one of the 
options, or select another of the options manually.
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Setting the default spelling language
If you use Affinity in English but write in a different language, Affinity will 
automatically set the spelling language to English but with a region matching the 
region of your computer. For example, if you are in the Netherlands, your text 
will be formatted as en-NL which is the code for English (Netherlands). You 
must set your default spelling language to avoid this issue.

To set the default spelling language:

1. Create a temporary new document; its settings are unimportant because it 
will be deleted when you’re done.

2. Select the Layout studio if it’s not selected. 

3. Choose the Frame Text  tool.

4. Using the Character panel, set Language > Spelling to the language you wish 
to use. If the language is not listed, refer to Installing additional dictionaries
on page 463.

5. If you want to set the hyphenation language at the same time, set Language > 
Hyphenation to the language you want to use. Refer to Setting the default 
hyphenation language below before changing this option.

6. Choose the Artistic Text  tool.

7. The language you selected with the Frame Text tool will still be selected but 
select it from the list a second time. If you do not select it a second time the 
selection will not be saved.

8. Choose Edit > Defaults > Save to save the session defaults as Affinity’s new 
defaults. You can now close the temporary document.

Setting the default hyphenation language
Most Affinity users can leave hyphenation set to Auto which allows Affinity to 
select the most appropriate hyphenation dictionary. For most languages, this will 
exactly match the spelling language but some languages such as English (Canada)
don’t have their own hyphenation dictionary so Auto uses English (US).

• English users outside the US and UK: It is recommended that you select 
English (United Kingdom) instead of Auto. Even though the patterns in the 
UK hyphenation dictionary were created based on a UK spelling dictionary, 
they work better for Canadian and Australian English than the US English 
hyphenation dictionary.

• US users: The Hunspell hyphenation dictionary for the United States is 
significantly weaker than the UK dictionary. American users should consider 
setting Hyphenation Language to English (United Kingdom) because it will 
usually result in better hyphenation. Doing this will not impact spell check-
ing, only hyphenation. Before making this change, you may wish to try both 
hyphenation dictionaries with your own documents.



4 Getting started

Setting the default text style language
The spelling language for the Base style group in Affinity’s default text styles 
defaults to the current interface language. If you use Affinity in English but write 
in a different language, you will need to change the Base style group on which all 
of the default styles are based.

To set the default spelling language for text styles:

1. Create a temporary new document; its settings are unimportant because it 
will be deleted when you’re done.

2. Select the Layout studio if it’s not selected. 

3. Using the Text Styles panel, choose Edit “<style name>” from the style 
options menu  to the right of the Base style group name, or simply double-
click Base.

4. The Text Style Editor window will be displayed. Click Language in the left 
pane.

5. Set Spelling to the language you wish to use. If you want to set the hyphen-
ation language at the same time, set Hyphenation to the language you want to 
use. Refer to Setting the default hyphenation language above before changing 
this option.

6. Click OK to update the style.

7. Choose Save Styles as Default from the Text Styles panel menu .
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Configuring the auto correction features
If you use Affinity to compose English text in a variant of English other than 
English UK, you will need to configure the AutoCorrect, Abbreviations, and 
Title Exceptions features before using them. Users of English US need only 
configure Title Exceptions.

To configure AutoCorrect:

If you format text as English UK, US, Canada, or Australia, you do not need to 
configure AutoCorrect before using it, but those who set type in other English 
variants must create their own lists of words to replace.

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click AutoCorrect in the left pane.

2. Set Language to English (United Kingdom). Review the list of replacements 
and make written notes of which ones you want for your version of English. 
There are too many words to list in this manual, but it is recommended that 
you add at least the following and any words you commonly misspell.

-- – Replace two hyphens with an en dash

–- — Replace an en dash plus hyphen with an em dash

... … Replace three periods with an ellipsis

3. Select which Language you wish to customise. e.g., English (Canada)

Tip: There is no way to 
copy the list from 
English (United 
Kingdom) to another 
English variant

Tip: Refer to AutoCor-
rect, Abbreviations, 
and Title exceptions
on page 455 for full 
details on these 
features and how to 
configure them

Tip: Windows Cana-
dian and Australian 
users must create their 
own AutoCorrect lists
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4. Enter the first word to replace in Replace, for example, teh., and the replace-
ment text in With, for example, the. You are not limited to single words and 
can enter phrases in either field. Click Add to add the text replacement to the 
list below. Repeat this step for each word you wish to replace.

To configure Abbreviations:

If you format text as English UK, US, Canada, or Australia, you do not need to 
configure Abbreviations before using it, but those who set type in other English 
variants must create their own list of abbreviations.

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Abbreviation in the left pane.

2. Set Language to English (United Kingdom). Review the list of abbreviations 
and make written notes of which ones you want for your version of English. 
You may not need all of them if you don’t format academic or reference text 
so add only the ones you might use.

3. Select which Language you wish to customise. e.g., English (Canada)

4. Enter the first abbreviation into the text field. You can enter any text string 
but only text that ends with a period will have any effect because text will not 
be automatically capitalised following abbreviations without periods. Click 
Add to add the abbreviation to the list below. Repeat this step for each 
abbreviation.

Tip: There is no way to 
copy the list from 
English (United 
Kingdom) to another 
English variant

Tip: Windows Cana-
dian and Australian 
users must create their 
own Abbreviations 
lists
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To add or remove Title Exceptions:

If you format text as English UK, US, Canada, or Australia, you do not need to 
configure Title Exceptions before using the Title Case command, but those who 
set type in other English variants must create their own list of words to except 
from title case capitalisation.

You can define exceptions to the capitalisation of phrases that are formatted with 
the Title Case formatting option.

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Title Exceptions in the left pane.

2. Select which Language you wish to customise. e.g., English (Canada)

3. Enter the first title exception into the text field. Click Add to add the abbrevi-
ation to the list below. Repeat this step for every abbreviation.

The following is a list of the words excepted from title case capitalisation for 
English UK and it is recommended that you add all of them.

Tip: There is no way to 
copy the list from 
English (United 
Kingdom) to another 
English variant

a

amid

an

and

anti

as

at

but

by

down

for

from

in

into

like

near

nor

of

off

on

onto

or

over

past

per

plus

save

so

than

the

to

up

upon

via

with

yet

Tip: Windows US, 
Canadian, and Aus-
tralian users must 
create their own Title 
Exceptions lists
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Exploring the user interface
The Welcome Screen window will appear when you start Affinity to enable you 
to create and open documents.

Studios
Affinity combines photo editing, vector design, and page layout features in a 
unified application window. After you create or open a document, Affinity will 

Recent Documents 
and Favourites, or 

if none exist, 
Document Presets 

Learning Tutorials

Welcome OpenRecent Documents Templates
Favourite PresetsLearning TutorialsHome (this screen)

Account settings New

Toolbar

Navigation controls

Studio Switcher
click to change studios

Welcome Screen
click logo

Studio Manager
click to edit studios

Quick Export
click caret for more

View Modes
right click for more

Tool tipsWord count
click for more

Document name 
(zoom) and * for 
modification status

Context Toolbar
Tools

Left panel dock
click tabs to switch panels

drag tabs to dock, undock, and reorganize
dock panels in group rows

scale height of panel groups

Panel section
click to expand or collapse

Right panel dock

Panel group
double-click a tab to collapse group, 

click a tab to expand group

Panel menu
click to change 
settings
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display it in the most appropriate Studio made up of tools and panels relevant to 
your document. Studios allow you to customise the user interface for the type of 
work you are doing.

Affinity includes default studios for Layout, Vector, and Pixel tasks and the 
Canva AI (Artificial Intelligence) studio for those who wish to use AI to power 
their projects. Affinity also includes several optional studios for specific tasks and 
you can create your own studios that match your personal workflows. Most users 
working on long documents will prefer to use the Layout studio or a personal 
variation of it.

Refer to Customising the Studios on page 426 for more information on studios.

Panels
Most of Affinity’s features can be accessed from the panels that appear on the left 
and right sides of the screen. You can open additional panels with the Window
menu, and close panels by choosing Close from the panel menus.

Panels can be docked in the left and right panel docks which you can show and 
hide independently. You can group panels within a dock, switch between 
grouped panels, adjust the height of panel groups, and collapse groups so that 
you can see other panels better. Panels can also be undocked as floating windows 
that you can position on the screen. Once you have the panels positioned to 
match your workflow, you can save your the panel setup as a panel preset so that 
you can restore it at any time.

Refer to Customising the panels on page 439 for more information on panels.

Toolbar
The Toolbar provides quick access to several commonly-used features. You can 
choose which controls are shown in it and you can hide it entirely but note the 
Status control provides the main indication of the current magnification level so 
it’s recommended that you keep it open.

On macOS, the Close, Minimize, and Maximize buttons (red, yellow, and green 
controls) are located in the Toolbar so closing it will also leave you without 
access to these standard controls. The background of the Toolbar also provides 
the easiest way to drag the document window but if you close it you can drag 
from an empty part of the Tools panel or the Status Bar at the bottom of the 
screen to move the window.

Refer to Customising the Toolbar on page 432 for information on hiding the 
Toolbar and changing its controls.

Tip: Affinity for 
Windows can display 
two columns of panels 
in each panel dock 
while Affinity for 
macOS can display 
only one column in 
each

Definition: Panels are 
windows that remain 
open while you work

Definition: Panel docks
are containers for 
panels on either side 
of the document 
window
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Context toolbar
Below the main Toolbar is a second toolbar named the Context Toolbar, com-
monly referred to as the Context Bar. You can only show and hide this toolbar, 
you cannot choose which controls are shown in it because they change dynami-
cally based on the current tool and selected text or objects.

It is recommended that you keep the Context Toolbar open because it provides 
quick access to the most frequently-used features.

Refer to Showing the Context Toolbar on page 433 for information on hiding this 
toolbar.

Tools
The Tools panel cannot be grouped in a panel dock. It can be displayed docked 
on the left side of the document window or undocked as a floating panel that you 
can position on the screen.

To choose a tool:

1. Click a tool in the Tools panel or press its associated keyboard shortcut.

2. To see a tool’s name and keyboard shortcut, hover the mouse pointer over a 
tool. A tooltip will show the shortcut in brackets if it exists. Refer to Keyboard 
shortcuts on page 452 for information on customising the shortcuts.

To choose a stacked (fly-out) tool:

1. Click the fly-out triangle at the bottom-right of the stacked tool and then 
select the tool from the fly-out menu. The selected tool will be shown in the 
panel.

2. Or if Sub Tools are shown when clicking on a stacked tool, click the tool in 
the floating Sub Tools panel.

You can customise the selection of tools in the panel, change the number of 
columns, and dock and undock it. Refer to Customising Tools on page 435 for 
more information.
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Customising measurement units and docu-
ment presets
Affinity does not allow you to set the default measurement system for new docu-
ments you define it when creating a new document. Affinity’s document presets 
will be useful if you work in millimetres and ISO (International) page sizes or in 
inches and ANSI (North and Latin American) page sizes. For those who prefer to 
work with different units such as picas with ANSI page sizes, you should create 
your own presets to avoid having to set the units each time you select a different 
preset.

Some common sizes are missing from the list but you can add them if you need 
them. The dimensions of the most-common missing sizes are listed below. Note 
that there are two groups of paper size presets but the only differences are colour 
format (space), colour profile, and bleed. Add your new preset to Press Ready if 
the document will be printed on a commercial press or to Print if you will print it 
on a desktop printer.

ISO Sizes   North/Latin American Sizes

A0 841 × 1189 mm B0 1000 × 1414 mm Letter Half 5.5 × 8.5 in

A1 594 × 841 mm B1 707 × 1000 mm Legal Half 7.0 × 8.5 in

A2 420 × 594 mm B2 500 × 707 mm ANSI C 17 × 22 in

A7 74 × 105 mm B6 125 × 176 mm ANSI D 22 × 34 in

A8 52 × 74 mm B7 88 × 125 mm ANSI E 34 × 44 in

A9 37 × 52 mm B8 62 × 88 mm Business Card 3.5 × 2.0 in

A10 26 × 37 mm B9 44 × 62 mm

  B10 31 × 44 mm

Tip: Custom presets 
are sorted from oldest 
to newest so create 
them in the order you 
want them displayed

Tip: You cannot 
change or delete the 
default presets but 
you can create your 
own which will be 
shown at the top of 
the list
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To change the measurement system for an existing document preset:

1. Choose File > New…

2. Select the most similar preset from the list of presets on the left side of the 
window.

3. Set Document Units to the desired measurement system.

4. Change any other settings as required.

5. Edit the preset name to the left of the Create Preset button and then click 
Create Preset. The new preset will be listed in the My Presets category at the 
top of the preset list.

6. Repeat these steps to create other presets.
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Setting up a document
Affinity makes it easy to create new documents but it does not include templates 
to get started quickly. Affinity includes automated features to create linked text 
frames or number pages so that you can immediately start typing or import text 
after creating a document. This section will guide you through the steps required 
to successfully create a standard multi-page document.

Create the document:

1. Choose File > New…

2. Select one of the page presets. There are two groups of page sizes. RGB is best 
for colour documents that will be distributed digitally such as in a PDF while 
CMYK is best for documents that will be printed on a desktop printer or by a 
commercial press.

For a black and white document, select RGB for digital or CMYK for print 
and then change the Colour Format to Grey/8.

3. Click the Portrait  or Landscape  icons to change the orientation.

4. If desired, Select a different measurement systems from the Document units.

5. If you want left and right pages side by side for a book or magazine, select 
Multi-page, which will select Facing pages.

6. Select Default master so that pages are based on a master page. Do not 
change the Number of pages from 1 even if you know how many pages your 
document will need because Affinity doesn’t create text frames for the pages 
created with a document.

Tip: Refer to Creating a 
new document on 
page 22 for informa-
tion on all of the 
options in the New 
Document window

Tip: Affinity can open 
InDesign® IDML files 
so you can use free or 
commercially-avail-
able templates created 
for InDesign

Tip: Page orientation 
is the only option in 
the New Document
window that is not 
controlled by a preset



14 Getting started

7. Select Margins and enter the desired values to create non-printing margin 
guides which will serve as guides to frame the page’s body content. Your 
headers and footers will typically sit outside of the margins.

8. Click Create Document and the new document will be displayed in the 
window. The document will have one master page named Master A which will 
be applied to page 1, the document’s only page.

Create the main text frame(s) for body text on the master page:

1. Choose Document > View Masters to view Master A. You can also use the 
Pages panel to navigate to Master A.

2. Choose View > Show > Text Flow if it is not already selected. It is must easier 
to work with text frames when this command is selected because it will show 
the position of all frames even when they’re not selected.

3. If the margin guides are not visible, choose View > Show > Margins to dis-
play them. These guides, which by default are blue rectangles, indicate where 
the main text frames of your document should be created. If the document is 
facing pages, there will be left and right sides to the master page and two blue 
rectangles.

4. From the Tools panel, choose the Frame Text  tool. The mouse pointer will 
change to a crosshair with the tool icon appended to it: 

5. Move the mouse pointer to the top-left corner of the margin guides—start on 
the left side if you created a facing pages document—and then drag diago-
nally down to the bottom-right corner of the blue rectangle. The mouse 
should snap to the start and end points. Release the mouse button to finish 
creating the text frame. Affinity will display the frame with handles to indi-
cate it is selected and can be modified.

Tip: Refer to Text 
frames on page 102 
for more information

Tip: The screenshots in 
this section show a 
facing pages 
document

Tip: If snapping to 
margin guides is not 
enabled, choose View 
> Snapping… and 
select both Enable 
Snapping and Snap to 
Guides

Margin guides for the left and 
right sides of a facing pages 
document
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6. Select Body from the list of paragraph styles in the Context Toolbar, Text 
Styles panel, or Paragraph panel. It is a good practice to select the paragraph 
style for master page text frames so that the style is already set on document 
pages.

7. If you created a facing pages document, you must create a second frame on 
the right side. Click the first frame’s triangular Text Flow Out control 
toward its bottom-right corner. The mouse pointer will change to a link 
arrow  when you are within range to click it and the frame will turn solid 
blue after you click the control. Now draw a text frame on the right side just 
as you did on the left side and Affinity will link the first frame to the new one.

8. Optional: Choose Text > Insert Filler Text to fill the text frame(s) with place-
holder text (lorem ipsum) to make it easier to see where the body text will be 
positioned.

The second text frame will be 
selected after it is created

This line indicates that text will flow 
from the left frame to the right frame

The text frame border matches the 
margin guides but it is indicated by 
its size handles when selected

Text Flow Out control

Tip: Refer to To link a 
text frame on page 
112 for more 
information
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9. Optional: Set the body text formatting attributes now, such as font family, font 
size, and paragraph leading and spacing by:

• Choose Edit > Select All, set the attributes using the Context Toolbar and 
Character and Paragraph panels and then click the Update Paragraph 
Style  icon in the Context Toolbar to update the Body paragraph style.

• Or choose Edit “Body” from the style options menu  to the right of 
Body in the Text Styles panel, change the style’s formatting attributes in 
the Text Style Editor, and click OK.

Create headers and footers for page numbers and titles:

1. For a footer, draw a text frame below the main text frame(s) and make it the 
same width as the main frame. You can also draw a frame above the main 
frame for a header.

You can vertically align these text frames however you like but drawing them 
the same width as the main frame will simplify aligning the text to either 
margin guide or their centre.

If you try to start drawing too close to a frame you just created, Affinity will 
place the text cursor in the frame so you may have to draw the new frames 
further above or below and then move them. After drawing a footer frame, 
position the mouse pointer over its outline—the mouse pointer will change to 
a drag cursor  when it is over the outline—and drag it into position.

You can align the top of a footer frame with the bottom of the main frame 
and rely on Paragraph Leading or Space Above formatting for adequate 
separation, or you can position the frame a specific amount below the main 
frame.

The frame(s) will be filled by filler 
text; the shading will be shown only 
if you select Text > Highlight Fields
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2. Choose Text > Insert > Fields > Page Number to insert a page number into 
the footer frame. The page number will appear as # on a master page.

3. Optional: Enter other text into the footer such as a document or chapter title, 
separated by whitespace or punctuation as desired.

4. Using the Text Styles panel, create a paragraph style for the footer by clicking 
the Create Paragraph Style  icon. Click Style in the left pane if it is not 
already selected.

5. The new style’s Name will default to Body 1—change this to Footer. The style 
will be based on Body which is good because later if you choose to change the 
font family for Body, the Footer style will update automatically. Click OK to 
create the style.

6. Click the Left , Centre , or Right Align  icon in the Context Toolbar
to align the footer text in the frame.

7. Optional: Choose Edit > Select All, and set any other desired formatting 
attributes using the Context Toolbar and Character and Paragraph panels.

8. Click the Update Paragraph Style  icon in the Context Toolbar to update 
the Footer paragraph style with the formatting changes.

9. If you created a facing pages document, you must create a second footer 
frame on the right side. Hold ⌥ (macOS) or Alt (Windows) and drag on the 
frame’s outline to drag copy the frame. Roughly position the new frame below 
the main frame on the right side and then release ⌥ or Alt so that you can 
snap the new frame into alignment.

Tip: Refer to Creating 
text styles on page 
211 for information on 
paragraph styles

The footer text frame

Tip: Choose Text > 
Highlight Fields to 
make fields such as 
page numbers easier 
to see with non-print-
ing shading

Tip: Refer to Page 
numbering on page 
67 for information on 
changing the page 
number format and 
starting page number
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10. Optional: For a facing pages document, you may need to mirror the align-
ment for the right side’s footer. There is no need to create an additional style 
for this, simply click the desired alignment icon.

11. Choose Document > View Masters again to deselect the command and 
return to page 1.

Bug! Due to an issue in Affinity, the text in the linked frames on a facing 
pages master page may not appear on page 1, so the filler text you inserted 
may not be fully visible. It will appear on subsequent pages if you add pages. 
This issue is not serious because the purpose of filler text is to be replaced.

Importing text

1. Click in the main text frame. Note that the size handles at its corners and 
midpoints are now shown as X‐handles to indicate that you cannot move or 
scale the frame on a document page.

2. Choose File > Place…

3. Select a plain text, RTF, or Microsoft® Word file from the window and click 
Open. For this exercise, select a document longer than one page.

Page 1 with filler text Page 1 without filler text due to 
this issue

Tip: Refer to Importing 
(placing) text on page 
142 for more 
information

A completed facing pages master 
page with linked main text frames 
and footer frames
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4. Affinity will insert the text into the text frame. If you selected a plain text file, 
the text will all be formatted as Body, the paragraph style you selected for the 
master page frame. You could format its headings now by clicking in them 
and selecting Heading 1 or Heading 2 from the Text Styles panel.

If you selected an RTF or Word file, Affinity will also import its text styles so 
the text will appear styled. You can modify those styles in Affinity or select 
the text and apply the Body style to it.

5. If the text was sufficiently long, the text frame will be overset (overflowing) as 
indicated by the red Text Flow Out control  near the frame’s bottom-right 
corner.

6. Press Shift and click the Text Flow Out control ; the mouse pointer will 
change to a link arrow  when you are within range to click it. Shift clicking 
this control will AutoFlow the text to as many pages of text frames as 
required. With View > Show > Text Flow selected, Affinity will show blue 
lines to indicate the links between the text frames.

Tip: Refer to AutoFlow 
text on page 117 for 
more information

Tip: To strip text styles 
and formatting from a 
word processing file, 
open it in the word 
processor, copy all of 
the text, switch to 
Affinity, and choose 
Edit > Paste Without 
Format

Imported plain text
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Document setup 2
Affinity makes it easy to create a new document but understand-
ing layout options and master pages is important for creating a 
publication that is easy to update in the future.

Master pages can be used to insert headers and footers that are 
repeated throughout a publication with automatic page num-
bering and chapter titles.

Affinity provides several tools to help you lay out your docu-
ment, including rulers, guides, and a grid. Using a baseline grid 
can improve the design of a publication with multiple text 
frames and columns to align the baselines of text and objects.

In this chapter
Creating a new document ........................................................................22
Changing layout options ...........................................................................33
Pages, master pages, and spreads .........................................................36
Multi-page spreads ......................................................................................60
Headers, page numbers, and sections .................................................66
Rulers and measurements ........................................................................76
Guides ...............................................................................................................78
Grids ..................................................................................................................85
Baseline grid ...................................................................................................90
Viewing documents ....................................................................................93
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Creating a new document
Before you create a new document, you should plan its size and margins and 
decide whether it will have facing pages. You can change anything about your 
document after creating it, but some changes may require additional effort so it’s 
best to decide on the layout in advance.

If you’re creating a book or magazine, you should create the cover as a separate 
document—most book documents start with an interior title page.

To create a new document:

1. Choose File > New…

2.  Preset: Choose one of the page presets. There are two groups of page sizes. 
RGB is best for colour documents that will be distributed digitally such as in 
a PDF while CMYK is best for documents that will be printed on a desktop 
printer or by a commercial press.

For a black and white document, select RGB for digital or CMYK for print 
and then change the Colour Format to Grey/8.

3.  Orientation: Click the Portrait  or Landscape  icons to change the 
orientation. Although this toggle is above the preset list, orientation is not 
part of a preset.

4.  Document layout settings: Set the document size, resolution, and measure-
ment units.

Tip: The CMYK presets 
have default margins 
and bleed which are 
not set for the RGB 
presets

Preset
search

Preset

Selected
preset

Document layout
Preset
Hide settings

Colour

Linked resources

Multi-page
Margins
Bleed
Drawing scale

Welcome OpenAccount settings New
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• Document units: Select from the list of measurement systems.

• DPI: Enter the document’s resolution. This setting impacts only the 
default dimensions of placed images because you will choose the resolu-
tion when printing or exporting so it’s not that important for page layout 
documents.

• Page width and height: Change the values to customise a preset’s size. The 
maximum width and height are 61440 pt (~853 in or ~21674 mm). Click 
the link  icon if you want changes made to one field to be made propor-
tionally to the other.

5.  Colour settings: Set the document colour format, profile, and background.

• Colour format: The default colour format or space is CMYK/8 for the 
Press Ready presets and RGB/8 for the Print presets. In general, select 
CMYK/8 when printing in colour on a commercial press or Grey/8 for a 
publication that will be printed in black and white. Select RGB/8 for a 
digital publication.

• Colour profile: The default colour profile for CMYK documents is U.S. 
Web Coated (SWOP) v2. Always speak with your print partner before 
selecting a colour profile. Leave this option if you’re unsure because you 
can change it later by choosing Document > Setup > Document Setup…, 
but the colours used may be adjusted for the new profile.

• Transparent background: Select if you don’t want an exported document 
to have a white background.

• Artboards: Deselect for page layout documents. Artboards are used for 
vector and pixel documents.

Tip: Refer to Colour on 
page 447 for a descrip-
tion of colour formats 
(spaces) and profiles

Tip: Measuring 
documents in Pixels is 
not recommended for 
page layout 
documents
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6.  Linked resource settings: Set which resources are embedded and linked.

• Image placement: Choose Prefer Embedded to include all placed images 
and documents inside the document file. For projects with large images 
and documents and for images and documents that may be updated in the 
future, choose Prefer Linked.

• Import text files as linked: Select to include all placed text files (.docx, .rtf, 
and .txt) as linked so that changes made externally will be updated in 
Affinity. Deselect to embed placed text as ordinary text.

• Preserve text styles: Select to not update the text styles used in linked text 
files when the external files are updated. This option is required to pre-
serve modifications you make in Affinity to the file’s text styles.

7. Multi-page: Select for documents with more than one page, facing pages, and 
master pages, and to set how they are arranged.

• Facing pages: Deselect to create a document with single pages instead of 
facing-page spreads. All of the Print and Press Ready presets default to 
facing pages which is commonly used for books and magazines.

• Default master: Select so that all pages will be based on a master page 
unless you’re creating a short document such as a brochure or poster.

• Arrange: Choose the spread direction. Choose Horizontally for most 
facing-page documents with left and right sides or Vertically for a docu-
ment bound at its top like a calendar. If facing-pages is deselected so the 
document does not have a spine, this control will define only the direction 
of multi-page spreads.

• Start on: Choose Right for most books and magazines because the inside 
cover is typically blank. Choose Left to start a document on the left side. 
For a document arranged vertically, choose Bottom (default) or Top.

• Number of pages: Enter the number of pages, up to a maximum of 10000. 
It is recommended to use this option only for short documents because 
Affinity will not create text frames for the pages created with a document. 
New documents will be based on a default master page if Default master

Tip: Using Prefer 
Linked for images is 
recommended for 
smaller document files

Tip: Documents can 
have more than 
10,000 pages but you 
are limited in how 
many you create with 
a document
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is selected on the Layout tab, but they won’t have any text frames. If you 
create many pages when creating a document and later add text frames to 
their master page, the frames won’t be linked from page to page so it’s best 
to create just a single page.
Tip: Affinity doesn’t offer a feature similar to the Primary Text Frame option of 
InDesign® or Automatic Text Box option of QuarkXPress™ so you must create text 
frames on the master page after creating a document; if you accidentally create 
them on document pages and want to move the text in them to text frames on 
document pages, see To move text from linked frames on document pages to… on 
page 116

8.  Margins: Select to customise the preset’s margins. Almost every document 
should have margins, even those with images that bleed off the page, but you 
can omit them. The margins have no impact on the finished document but 
serve as guides to frame the page’s body content. Your headers and footers 
will typically sit outside of the margins.

Facing-page documents and spreads will have inner and outer margins that 
are relative to a spread’s spine, while non-facing page documents and 
ambidextrous spreads will have left and right margins.

• Left/Right or Inner/Outer, and Top/Bottom: The labels will change 
depending on whether the document has facing pages. Change the values 
but they should not exceed half the page width or height. Click the link 
icon if you want changes made to one field to be made proportionally to 
the others.

9.  Bleed: Select to customise the preset’s bleed zone dimensions if the document 
will have images that bleed off the page. This option applies only to docu-
ments that will be professionally printed and trimmed after printing.

Tip: Click the icon to 
the left of text fields to 
Link  the fields and 
set all the fields the 
same when you enter 
changes, or to Unlink

 the fields to set 
them separately

Tip: You can choose to 
show or hide margin 
guides later by choos-
ing View > Show > 
Margins

Tip: Select View > 
Show > Bleed to show 
the bleed guides and 
the objects in the 
bleed zone

Definition: Bleed refers 
to the area beyond the 
edge of the page in 
which text and objects 
will still be printed

The Trim Box is enclosed by the page edges 
and approximates where trimming will occur

Objects must extend to the edge of the Bleed 
Zone when Bleed is set in Document Setup
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Facing-page documents and spreads will have inner and outer bleeds that are 
relative to a spread’s spine, while non-facing page documents and ambidex-
trous spreads will have left and right bleeds.

• Left/Right or Inner/Outer, and Top/Bottom: The labels will change 
depending on whether the document has facing pages. Click the link 
icon if you want changes made to one field to be made proportionally to 
the others. Standard documents usually set bleed to 0.125 in, 0p9, or 3mm 
while large-format posters and banners may have double that. Check with 
your print partner for their exact requirements.

10.  Drawing scale: Deselect for page layout documents. Drawing scale is used for 
vector documents.

11. To save these customised settings as a preset for use in the future, edit the 
preset name to the left of the Create Preset button and then click Create 
Preset. The new preset will be listed in the My Presets category at the top of 
the preset list.

12. Click Create and the new document will be displayed in the window.

13. Select the Layout studio if it’s not selected. 

To create a new document similar to the last document you created:

1. Choose File > New from Last Preset. Affinity will create a new document 
using the same settings as the last document you created.

Tip: Affinity doesn’t 
offer a separate slug 
option so create a 
larger bleed and place 
your slug information 
there and ensure
View > Clip to Canvas
is not selected
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Saving a document
Affinity saves documents in its own .af format which cannot be opened by other 
applications. It saves incrementally to save time so a file may grow somewhat 
larger with each additional save until it reaches a threshold and then Affinity will 
do a full save which will compress the file to its minimum size. You can choose 
Save As… at any time to do a full save rather than an incremental save.

To save a document:

1. Choose File > Save. Affinity will save the document without further prompt-
ing if the document has been previously saved. If it has not been previously 
saved, a file save window will appear to select where to save the document. 

Or choose File > Save As… to save a document with a new name or location.

2. Select the file location and enter a name for the file.

3. Click Save.

Saving a package
Packaging a document bundles a copy of the document with all of the fonts used 
in the document along with its linked images and documents into one folder to 
make it easy to share a document with a print partner or colleague. The original 
document and images are not affected when you save a package. The package 
could then be transferred to a cloud or external drive, or compressed for sending.

To save a package:

1. Choose File > Save As Package…

Tip: The Scope will 
always be for the 
current document so 
you cannot package 
an Affinity Book and 
its Chapters because

Tip: Earlier versions of 
Affinity saved Layout 
documents as .afpub, 
Vector documents as 
.afdesign, and Pixel 
documents as 
.afphoto

Tip: Avoid using File > 
Save History with 
Document, which 
saves the undo history 
with the document, 
because it will dramat-
ically increase the size 
of the file
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2. Select Summary in the left pane to display a summary of your document.

• Deselect Include Fonts, Include Images, Include Linked Text Files, and 
Include CSS Files if you don’t wish to include one or more of them in the 
package. Deselecting all would save only a copy of the document because 
nothing would be packaged with it.

3. Select Fonts in the left pane to see a list of the fonts used in the document and 
to identify which are present or missing. Commercial fonts used in the docu-
ment will be included in the package so ensure that the person you send the 
package to has rights to use them.

Some fonts bundled with macOS are provided with additional restrictions 
and Affinity will warn you when packaging a document that uses them, 
although the fonts will still be included in the package.

The same warning will be shown if you package a document that uses Affinity 
Fonts but these fonts will not be included in the package.

4. Select Images in the left pane to see a list of the images used in the document 
and to identify which are embedded or linked. Linked images will be listed as 
present or missing. You can address issues with linked images using the 
Resource Manager.

5. Select Linked Text Files in the left pane to see a list of the linked text files 
used in the document and to identify which are present or missing. You can 
address issues with linked text files using the Resource Manager.

6. Select CSS Files in the left pane to see a list of the CSS files used in the docu-
ment and to identify which are present or missing. You can address issues 
with linked CSS files using the EPUB panel.

7. Click OK. A file save window will appear to select where to save the package. 
Click New Folder to create and name a folder for the package—Affinity will 
save the files into this folder.

8. Click Package.

Tip: Affinity Fonts are a 
type of font that you 
have installed with the 
Manage Purchased 
Content feature of 
Affinity; they are not 
OpenType or TrueType 
fonts
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Opening a document or image
You can open Affinity layout, vector, and photo documents as well as InDesign® 
IDML documents, PDF and CAD documents (see below), and most common 
image formats.

Affinity documents will always open in the studio they were saved from. Non-na-
tive documents including IDML, PDF, CAD and image formats will open in the 
default studio for that type of file unless you have disabled the Switch studio 
based on file type setting.

To open a document:

1. Choose File > Open… A file open window will appear to select the file to 
open.

Or choose File > Open Recent and select a recent document from the list.

Or if no documents are open, double-click the empty area between the left 
and right panel docks.

Or drag a file’s icon from your computer onto Affinity.

2. Select the file(s) and click Open.

Opening PDF and CAD documents
Saving an opened PDF or CAD document will save it in Affinity format. You can 
export the converted document to PDF or a CAD format if you choose.

To open a PDF document:

1. Open the PDF document as you would an Affinity document.

2. Set the PDF import options.

Tip: Affinity can open 
InDesign® IDML files 
so you can use free or 
commercially-avail-
able templates created 
for InDesign, but you 
cannot open INDD 
files

Tip: Choose Affinity > 
Settings… (macOS) or 
Edit > Settings…
(Windows) and click 
General in the left 
pane to find the 
Switch studio based 
on file type setting

Tip: You can also place 
a PDF or CAD docu-
ment into an Affinity 
document; refer to 
Placing images on 
page 261

Tip: The PDF file 
format is not intended 
for converting files 
from one application 
to another so text 
styles, linked frames, 
and other options 
used in the original 
application are not 
included in a PDF file 
and will be lost
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• Load pages: Select Load All Pages to open every page of the PDF docu-
ment or Load Pages to enter specific page numbers or a page range to 
open. You can specify multiple pages by entering numbers separated by 
commas or a page range with the numbers separated by a hyphen.

• DPI: Sets the Affinity document’s resolution. Leave this set to Estimate to 
use the resolution of the PDF file.

• Colour space: Select the document’s colour space: Gray, CMYK, or RGB, 
or Estimate to use the colour space of the PDF file.

• Favour editable text over fidelity: Select this option if you plan to edit the 
document’s text to avoid spacing issues.

• Group lines of text into text frames: Select this option if you plan to edit 
the document’s text to join separate lines of text into paragraphs in a text 
frame.

• Replace missing fonts: Select to enable specifying the font family and font 
style for fonts used in the PDF file that aren’t available in Affinity. You can 
also deselect this option and choose Document > Font Manager… to 
replace the fonts at a later time.

3. Click Open.

4. To open a CAD document:

To open a CAD (DWG/DXF) document:

1. Open the CAD document as you would any other image.

2. Set the CAD import options.

• Selection: Select:

All Pages To import all paper space layouts, if present

Single Page To select one paper space layout from the Selected Page list

Model To import only the model space



Expert Guide to Affinity by Canva 3.0 31

• Insertion Units (Model only): Select what one unit in the CAD drawing 
corresponds to in the CAD document.

• DPI: Set the resolution for the imported document.

• Background colour: Set a background colour for the CAD document.

• Colour override: Select a colour to override all stroke colours in the 
document

• Remove hidden items: Select to exclude hidden and frozen layers from 
import.

• Display entity handles: Select to append a handle suffix to each named 
entity to assist with troubleshooting.

• Override line weights (Model only): Select to set all strokes to 0.1 pt.

• Sanitize model (Model only): Select to clean the model to remove unnec-
essary detail and correct common map errors.

• Convert hatches to curves: Select to import all hatch patterns as curves 
(paths) rather than as editable patterns.

3. Click OK.

Creating documents from templates
Affinity allows you to create documents from templates. Affinity templates are 
the same as any other document, but they typically have an .aftemplate extension 
and are stored in a separate area from your other documents. When you create a 
new document based on a template, you are opening a copy of it as an untitled 
document ready to be modified and saved.

To specify where templates should be stored:

1. Click the Affinity logo to open the Welcome screen.

2. Click My Templates.

3. Click the Add Template Folder  icon. Affinity will add the folder to the left 
side of the window, and list all of its nested subfolders. Any Affinity docu-
ments in these folders can now be used as a template.

4. You can add multiple template folders. To remove one, select the folder you 
added, not a subfolder, and then click the Remove Template Folder  icon.

To save a document as a template:

1. Choose File > Export > As Template.

2. A file save window will appear to select where to save the template.

3. Select the file location and enter a name for the template.

4. Click Save.

Tip: You cannot 
remove or collapse the 
subfolders so it is best 
to add a folder that 
contains nothing but 
templates and any 
folders used to 
organize them
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To create a document based on a template:

1. Click the Affinity logo to open the Welcome screen.

2. If the template you want is listed on the main welcome screen, double-click it 
to create a document based on it.

Or click My Templates to view all of your templates. Double-click a template 
to create a document based on it.

To edit a template:

1. Choose File > Open… A file open window will appear to select the file to 
open. Select the file(s) and click Open.

Or click the Affinity logo to open the Welcome screen. Click My Templates to 
view all of your templates. Right-click a template and choose Edit.

2. Make the required changes to the template.

3. Choose File > Save.

Closing documents
To close one or all documents:

1. Choose File > Close to close the current document or Close All to close all 
open documents.

If the document window is floating, you can also click the Close button in the 
upper-left corner (macOS) or upper-right corner (Windows).

2. If a file has been modified since it was last saved you will be prompted to save 
the file or close it without saving. Select Apply to All if you want all other 
modified documents to be saved or not saved when you click Save or Don’t 
Save.
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Changing layout options
A document doesn’t have an intrinsic page size, orientation, or margins—these 
are properties of the pages in the document; however, the Document Setup
window allows you to change the properties of all or selected master pages and 
spreads (pages) in the document.

To change the options for a document after creating it:

1. Choose Document > Setup > Document Setup…

Most of the options in this window are the same as for creating a new docu-
ment so refer to Creating a new document on page 22. The unique or modi-
fied options are:

2.  Scope: Select Whole Document to change the entire document or Selected 
Masters or Selected Spreads and then select masters or spreads from the list 
to change specific masters or pages.

3.  Show dimensions of: You can choose whether to show the dimensions of a 
facing-page or multi-page spread or just a page. A list of the Preset page sizes 
are displayed in a list above the Page width and height fields.

Tip: You cannot 
change the size of 
multiple individual 
masters or spreads at 
once—you must 
change one and click 
OK before opening 
the window again and 
changing the next one

Tip: If you select 
Selected Masters or 
Selected Spreads, the 
options shown in this 
window will be for the 
first master or spread 
you selected

Tip: The list of master 
pages and spreads is 
clickable only when 
Selected Masters or 
Selected Spreads is 
selected
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4.  Actual size zoom: Select a different device to use for zooming to Actual Size
for documents measured in pixels or points.

5.  Scaling: If you change the page size you must specify how existing text and 
objects will be positioned or scaled.

• Rescale: Select to scale objects and text proportionally; this option is best 
for projects such as posters and brochures but is not suitable for books or 
magazines.

• Resample: When you choose Rescale, you can select how images are 
resampled:

Nearest Neighbour Fast but lower quality; use for hard-edge images

Bilinear Use when scaling pages smaller

Bicubic Use when scaling pages larger

Lanczos 3 (separable) Very high quality but slower than the above
 options (recommended)

Lanczos 3 (non-separable) Marginally-higher quality than Lanczos 3
 (separable) but slightly slower

• Anchor to Page/Spread: Select to not scale objects and maintain their 
position relative to the page or spread origin. When you anchor the 
objects, you can also choose the anchor position by clicking one of the 
anchor handles.

6.  Model:

• Facing pages: Changing a facing-pages document to single pages will 
separate its facing-page master pages into two single-page master pages, as 
well as separating all of the document’s facing-page spreads into single 
pages. Changing a non-facing-page document to facing pages will convert 
the document’s pages to facing-page spreads but the masters will remain 
single pages.

• Reflow pages: Deselect to prevent facing- and multi-page spreads from 
being affected by adding, moving, or deleting pages in the document. 
When you add, move, or remove pages, Affinity automatically flows 
(shuffles) the following pages which can cause pages to change sides unless 

Tip: Anchor to Spread
will not be shown for 
non-facing pages 
documents

Tip: If you’re unsure 
which Resampling
option to use, select 
Lanczos 3 (separable) 
for best results
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this option is deselected. This option is the same as the Page Move 
Options > Reflow Pages command in the Pages panel menu . You might 
deselect this option temporarily while you rearrange pages or permanently 
for a document that you want to structure manually.

7.  Colour: If you change the Colour format (space) or Colour profile, choose 
Assign from Profile Conversion to keep colours unchanged, including 100% 
Black, although the appearance may change. Choose Convert to modify 
colours to match the new format or profile while maintaining the appearance.

8. Click OK to change the layout options.
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Pages, master pages, and spreads
Affinity documents can include as many pages or spreads as you need. You can 
specify the number of pages to add when creating a new document but it is 
recommended to create only one page with a document and add other pages 
when required. Refer to Creating a new document on page 22 for more 
information.

There are three key terms to know:

• Pages (document pages): This manual refers to pages as document pages to 
distinguish them from the master pages on which they can be based.

• Master pages: Master pages are background pages that provide a template for 
document pages. Content on master pages appears on the document pages to 
which they are applied.

• Spreads: Spreads are pages joined together for viewing and reading. A facing-
page document has facing-page spreads with left and right pages while multi-
page spreads can have more pages for fold-outs. Some features of Affinity are 
specific to a page within a spread while others apply to an entire spread. A 
master page spread is a spread used as a template for document spreads.

Master pages
Document pages are usually based on master pages to create consistency between 
pages. Objects placed on a master page will be visible on all document pages 
based on that master and later changes made to the master will be replicated on 
all the pages.

Objects can’t be moved or modified on document pages unless you break the link 
between them and the master. However, the content of text and picture frames 
on a master page can be modified on a document page. Master pages are fre-
quently used to create the text frames for a long publication.

When you create a new document with the Default master option selected, 
Affinity automatically creates a master page named Master A and applies it to the 
page(s) created for the document. You might not need to use a master page for a 
short document such as a brochure, but they should always be used for long 
publications such as books, magazines, and newspapers.

Definition: A master 
page is a background 
or parent page that 
defines the layout and 
some of the text and 
objects of the regular 
document pages 
based on it; master 
pages are frequently 
referred to simply as 
masters

Tip: You can add tens 
of thousands of pages 
to an Affinity docu-
ment but most 
computers can’t 
handle that many 
pages so if you run 
into performance 
issues you should 
divide your document 
into chapter docu-
ments; refer to Books
on page 281

Tip: Use Edit 
Detached to modify a 
master page’s objects 
on a document page; 
refer to Overriding 
master page objects 
on document pages
on page 57

The document page 
(top) is based on the 
background master page 
(bottom)
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Spreads
A spread is made up of pages joined together for viewing and reading. Objects 
and text positioned on one page of a spread can extend across the spread’s other 
page(s).

Facing-page spreads: Facing-page documents such as books and magazines are 
made up of automatic facing-page spreads, pairs of left (verso) and right (recto) 
pages of the same size and orientation joined together at the spine of the publica-
tion and displayed together. Facing-page spreads are used for books, magazines, 
and any document where the left and right page layouts are mirrored.

Multi-page spreads: Affinity allows you to create multi-page spreads which are 
useful for fold-out pages in books and other publications. Refer to Multi-page 
spreads on page 60 for more information.

Using the Pages panel
The Pages panel is an important one to keep open when working on a multi-page 
document because it allows you to add, move, modify, delete, and change pages. 
Thumbnails are displayed for each page and spread.

To display and customise the Pages panel:

1. Choose Window > Layout > Pages or click the Toggle Pages Panel  icon at 
the bottom left of the document window to show the Pages panel if it is not 
already open.

Tip: In documents 
with pages arranged 
vertically, facing-page 
spreads are made up 
of top and bottom 
pages

Master page area

Panel menu

Document page area

Add, Duplicate, and Delete 
master page

Section Manager, and Add, 
Duplicate, and Delete page

Current spread

Selected spread

Facing-page spread 
of left and right pages

Definition: Spread
refers to pages joined 
together for viewing 
and reading
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The page or spread that you’re currently viewing will be indicated with a grey 
outline. You can select the same or a different page or spread to manipulate it 
without changing to it by single clicking it in the panel. The selected page or 
spread will be indicated with a blue outline.

Affinity will show both absolute and relative page numbers if you have 
restarted page numbering prior to the page. Refer to Page numbering on page 
67 for more information.

2. Collapse or expand the Master Pages or Pages areas by clicking the caret 
icons to the left of their titles. Drag the Pages area title bar up or down to 
resize the Master Page area.

3. Choose Small, Medium, Large, or Extra Large Thumbnails from the panel 
menu  to change the size of the page thumbnails. Change the width of the 
panel to set how many columns of thumbnails can be shown at once. Medium
and Large will fit as many spreads as possible on each row of the panel while 
Extra Large will scale so that the widest spread’s thumbnail will fit in the 
panel’s width. Small lists page spreads in a vertical list.

4. Choose Scroll with View from the panel menu  so that the page(s) visible 
in the document window are visible in the panel.

5. Choose Show Master Page Tags from the panel menu  to show colour tags 
on pages and masters to identify which master page(s) have been applied.

To select pages to manipulate:

• Single-click a page, spread, or master page thumbnail to select it so you can 
perform actions to it. For a spread, you can click one of its page thumbnails to 
select a single page or the page number label below to select the entire spread. 
The selected page, spread, or master is indicated by a blue outline.

• To select a range of pages or spreads, select one by single clicking it and then 
press Shift and click the last one in the range. Alternatively, you can drag 
select a range of pages just as you would drag select file icons on your 
computer.

Definition: Absolute
page number refers to 
the number of the 
page within the 
document; the relative
page number is what 
is displayed on a page 
by restarting page 
numbering

Colour tag to indicate this master

Colour bar to indicate the master 
applied to this spread

Tip: You can’t move 
the Master Pages area 
to the bottom or set 
its thumbnail size 
independently, but 
you can collapse it to 
save space when you 
don’t need it

Tip: The blue highlight 
colour can be cus-
tomised on macOS 
with System Settings 
> Appearance
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• To select multiple pages that aren’t in a continuous range, press ⌘ (macOS) or 
Ctrl (Windows) and click each page thumbnail.

To go to the start of a section:

The Pages panel doesn’t show sections which makes it difficult to find the first 
page of a section. You can work around this limitation with hidden text frames or 
anchors.

1. On the first page of each section, draw a text frame and enter easy-to-remem-
ber text such as s1 for section 1, s2 for section 2, etc.

2. Hide these frames so they won’t be visible or print.

3. To jump to a section, choose Text > Find, type the section identifier you 
typed into the hidden frame, and click Find. With keyboard shortcuts, press 
⌘+F (macOS) or Ctrl+F (Windows), type the section identifier, and press 
Return.

Another way to do this is with anchors. Create an anchor at the start of each 
section and use the Anchors panel to navigate to the anchor. This approach can 
be used without hidden text frames but it doesn’t work as well for those who 
prefer to use keyboard shortcuts.

Working with pages
When working in a facing-page document with facing-page spreads based on 
master pages, the effect of adding, moving, and deleting single pages depends on 
the selected page move option. For more information, see To set how single 
pages should be added, moved, or… on page 45.

To add multiple pages:

1. Choose Document > Add Pages… or select the page or spread in the Pages
panel before or after which you want to add pages and then click the Add 
Pages  icon in the panel.

2.  Master Page: Select the master page on which to base the new pages.

3.  Number of Pages: Enter how many pages to add.

4.  Insert: Choose whether to insert the new pages before or after the page you 
specify in Page. When adding pages immediately before the start of a section, 

Tip: Clicking Next 
Page or Next Spread
in the page navigation 
icons while viewing 
the last page in the 
document will also 
open the Add Pages
window

Tip: The spine location 
cannot be specified 
when adding pages 
and will be based on 
the master page, but 
you can change it 
later; see To change 
the spine location: on 
page 65
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choose After to add the pages to the preceding section or Before to add the 
pages to the following section.

5.  Spread Wrapping: If you choose to add new pages within or after a spread, 
choose how the new pages will be positioned:

• Flow Pages: The new pages will be not be part of a multi-page spread.

• Extend Spread: The new pages will be added to the existing spread, even if 
it is not a multi-page spread.

• New Spread: The new pages will be a new multi-page spread with Reflow 
Through Spread deselected.

6. Click OK.

To add a single page to the end of your document:

The number of pages that will be created will match the number of pages in the 
master.

1. Choose Document > New. One page will be added to the end of the 
document.

To add a single page or spread based on a master page:

The number of pages that will be created will match the number of pages in the 
master.

1. Drag a master page thumbnail before or after another page or spread thumb-
nail in the Pages area in the Pages panel.

2. The mouse pointer will change to  when you have positioned it where a 
new spread can be created. A different pointer will be shown if the mouse is 
over an existing master or spread or where you cannot create a spread.

Mouse Description

Add new spread based on master

Apply master to page(s), replacing the existing master(s)

Add master to page(s) without replacing the existing master(s)

Master cannot be moved or duplicated here

3. Release the mouse button to create the new spread.

Tip: Adding a single 
page to a facing-pages 
document may lead to 
confusing results; refer 
to Multi-page spreads
on page 60
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To view a page or master page:

1. For a single page or spread, double-click its thumbnail in the Pages panel to 
centre the page in the window.

For a facing-page spread, double-click its spine or the page number label 
below its thumbnail to centre the entire spread in the window. 

For a multi-page spread, double-click the page number label below its thumb-
nail to centre the entire spread in the window.

Affinity will always zoom the page or spread to fit it in the window when 
double-clicking in the Pages panel. If you want to maintain the current view 
magnification when changing pages, use one of the following methods.

2. Or choose Document > First Page, Previous Page, Next Page, or Last Page, 
or the equivalent navigation icons at the bottom left of the document window. 
Or click in the Page Number field, enter a page number, and press Return.

If you are viewing a master page, the commands will be replaced by First 
Master, Previous Master, Next Master, and Last Page, and the navigation 
icons will be changed to match.

3. Or choose Document > Go to Page…, enter a page number, and click OK. 
You can also click the icons for First Page, Previous Page, Next Page, and 
Last Page in this window.

If you are viewing a master page, the Go to Page… command will be replaced 
by Go to Master… to allow you to select a master page.

First Page Page Number Previously Viewed PageLast Page

Next PagePrevious Page Toggle Master View

Tip: You can also right-
click a page or spread 
thumbnail in the 
Pages panel and 
choose Go to Page or 
Go to Spread

First Master Master Name Previously Viewed PageLast Master

Next MasterPrevious Master Toggle Master View

Tip: These icons will be 
named First Spread, 
Previous Spread, Next 
Spread, and Last 
Spread in a Facing 
Pages document.
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4. Or use the document window’s vertical scrollbar to scroll until the page you 
want is visible in the document window and then click anywhere on the page.

5. Or to view the master page for the current document page, choose Document 
> View Masters or click the Toggle Master View icon. Choose or click it 
again to view the document page again. If a page has more than one master 
page applied to it, the last master page viewed will be displayed.

To visually reorder or duplicate pages:

In addition to moving and duplicating pages, you can also move and duplicate 
master pages. Changing the order of masters will only change how they are 
organized and not impact the appearance of the document.

1. Select one or more page thumbnails in the Pages panel.

2. Drag the thumbnail(s) before or after another page thumbnail. The mouse
pointer will change to  and a blue line will appear to indicate where the 
pages(s) will be moved.

Hold ⌥ (macOS) or Alt (Windows) while dragging to duplicate the pages 
instead of moving them. The mouse pointer will change to  to indicate that 
the pages will be duplicated.

If you drag the thumbnail(s) before, inside, or after an island spread, the 
mouse pointer will change to indicate how the pages will be moved or dupli-
cated. Refer to Multi-page spreads on page 60 for more information.

Mouse Description

 Move page(s)—the following pages will shuffle

Duplicate page(s)—the following pages will shuffle

Page(s) cannot be moved or duplicated here

3. Release the mouse button to move or duplicate the pages.

To manually reorder or duplicate pages:

1. Right-click the thumbnail of the page to move or duplicate and choose Move 
Pages… from the context menu. You can select multiple page thumbnail(s) in 
the Pages panel before right-clicking any of them to move or duplicate multi-
ple pages.

Tip: If you reorder 
master pages with 
automatic names 
(Master A, Master B…), 
the masters will be 
reordered but their 
names will change to 
maintain the A, B, C… 
sequence

Tip: You can also drag 
a master spread’s 
thumbnail to change 
the way they are 
sorted but it will not 
change the document 
appearance

Tip: If you reorder 
master pages with 
automatic names 
(Master A, Master B…), 
the masters will be 
reordered but their 
names will be updated 
to maintain the A, B, 
C… sequence
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• Pages: If you selected the thumbnails of the pages you want to move or 
duplicate, this option will default to the correct page numbers. Otherwise, 
enter the numbers of the pages to move or duplicate. You can specify 
multiple pages by entering numbers separated by commas or a page range 
with the numbers separated by a hyphen.

• Insert: Choose whether to insert the moved or duplicated pages before or 
after the page you specify in Page.

• Page: Enter the number of the page before or after which the pages should 
be moved or duplicated.

• Move/Copy: Select whether the pages should be moved or duplicated.

2. Click OK.

To manually duplicate pages:

1. Select one or more page thumbnails in the Pages panel.

2. Right-click any of the selected thumbnails and choose Duplicate # Pages
from the context menu, where # is the number of pages selected. The dupli-
cate pages will be added after the last selected page.

To delete pages:

1. Select the page thumbnail(s) to delete in the Pages panel and click the Delete 
Selected Pages  icon. You can also right-click the thumbnail and choose 
Delete # Pages from the context menu, where # is the number of pages 
selected.

Or choose Document > Delete Pages…, enter the number of the first page to 
delete and the number of pages that should be deleted, and click OK.

If a deleted page includes a text frame linked to or from another page, the text 
in the frame will not be deleted. The frame will be removed from the series of 
linked frames without any impact to the text in its story. The story may 
overflow the last text frame in the series.

To copy pages from one document to another:

You can’t drag page thumbnails from one document to another as you can in 
some other applications but you can duplicate pages to another document.

1. Open the document you wish to add page(s) to.
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2. Choose Document > Add Pages from File and then select the other docu-
ment from the Open window. You can also right-click the thumbnail of the 
page after which the page(s) should be added and choose Add Pages from 
File… from the context menu.

3. Select the pages or spreads you want to copy.

4. Click OK. The pages or spreads will be imported and added to the current 
document.

5. Delete the page that you imported which will leave just the imported mas-
ter(s) ready for use.

To change the size of a page without changing its master page:

1. Right-click the page or spread thumbnail in the Pages panel and choose 
Spread Properties… from the context menu. The options shown depend on 
whether or not the page is facing-pages. If you select multiple pages or 
spreads prior to choosing Spread Properties, the similar Document Setup
window will open.

Changing a facing-page spread or page Changing a non-facing-page
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2. For a facing-pages document, choose Spread to change the entire spread or 
Selected Pages and then select the thumbnail(s) of pages in the spread. You 
can also click pages in the preview on the left side of the window to selected 
individual pages, and hold ⌘ (macOS) or Ctrl (Windows) while clicking to 
select multiple pages in the preview.

3.  Show Dimensions of: When Spread is selected above, select Page to specify 
the size for all of the spread’s pages; the spread will be the size of the page 
multiplied by the Page Count. Or select Spread to define the overall size of 
the spread; the size of each page will be the size of the spread divided by the 
Page Count.

4.  X and Y: When one or more pages are selected above, enter the horizontal 
and vertical offset of the page within the spread, relative to the spread origin.

5.  Move Following Pages: Select when changing the size of a page within a 
spread to automatically adjust the X offset for pages to its right, or in a docu-
ment with pages arranged vertically, the Y offset for pages below it.

6.  Reflow Through Spread: Deselect to prevent the spread from being affected 
by adding, moving, or deleting pages before it in the document. When you 
add, move, or remove pages, Affinity automatically flows (shuffles) the follow-
ing pages which can cause pages to change sides unless deselect either Page 
Move Options > Reflow Pages in the panel menu  or Reflow Pages in 
Document Setup. Disabling page reflow with these commands will make the 
spread an island in a document of flowing pages without turning off reflow 
for the entire document.

7. All of the other options in the Spread Properties window are the same as for 
creating a new document and changing its setup, so refer to Creating a new 
document on page 22 and Changing layout options on page 33.

To set how single pages should be added, moved, or deleted:

When you add, move, or delete single or an odd number of pages in a facing-
page document or in a document with multi-page spreads with Reflow Through 
Spread disabled, Affinity will need to shuffle pages. You can control how Affinity 
shuffles pages with the Page Move Options commands and the options you 
select will be saved with the document.

1. If the Pages panel is not already open, choose Window > Layout > Pages.

2. Choose an option for shuffling pages from Page Move Options in the panel 
menu :

• Move Master Content (default): When shifting a page to the other side of 
a facing-page spread or multi-page spread, Affinity will use the appropri-
ate side or page of the master so that master objects are correctly posi-
tioned. If Anchor Toward Spine is selected, Affinity will shift the master 
and non-master objects to mirror them about the spine. The objects will 
remain in their original positions if Anchor Toward Spine is not selected. 

Tip: You don’t need to 
change X and Y
manually if Move 
Following Pages is 
selected unless you 
want an inner bleed 
for spiral or other 
specialty binding

Tip: You cannot 
change the size of 
multiple individual 
pages in a spread at 
once—you must 
change one and click 
OK before opening 
the window again and 
changing the next one
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If your master page sides are asymmetrical, you should consider choosing 
Reapply Masters.

• Reapply Masters: After shifting a page to the other side of a facing-page 
spread or another page in a multi-page spread, Affinity will reapply the 
master pages automatically, just as if you did it yourself after adding, 
moving, or deleting pages. This option is not intended for ambidextrous 
master pages.

• Split Masters: Affinity will make no changes when shifting a page to the 
other side of a facing-page spread or another page in a multi-page spread, 
so pages that were previously on the left side will still use the left side of a 
master even if they are now on the right side of a spread, and vice versa. 
Use this option if you are adjusting single pages but expect that pages will 
end up on the same sides when you are finished, but you may find it easier 
to temporarily turn off Reflow Pages instead.

3. Choose Page Move Options > Anchor Toward Spine (default) from the panel 
menu  to shift non-master objects to mirror them about the spine when 
adding, moving, or deleting a single page in a facing-page spread. Deselecting 
this option will cause pages to be moved in the same manner as Affinity 2.5 
and earlier.



Expert Guide to Affinity by Canva 3.0 47

Creating master pages
You can create additional master pages if you want some pages to have a different 
layout than others; for example, mixing one- and two-column layouts in the 
same book.

Although a document has an inherent size, orientation, colour profile, margins, 
bleed, and more, you can change any of these options for each master page. This 
is useful if you want to mix page sizes in a document, or insert a landscape page 
for a large table in an otherwise portrait document.

To create a master page:

1. If the Pages panel is not already open, choose Window > Layout > Pages.

2. Click the Add Master  icon or right-click in the Master Pages section of the 
Pages panel and choose Insert Master… from the context menu to insert a 
master after the thumbnail you clicked closest to.

The options shown depend on whether or not the document has facing-pages.

3.  Name: Enter the master page’s name for clarity. If you don’t enter a name, it 
will be given an automatic name such as Master B.

4.  Tag: Select a colour tag to identify masters in the Pages panel when Show 
Master Page Tags is selected in the panel menu . The colour tags identify 
the masters and appear on pages and masters to identify which master 
page(s) have been applied.

5.  Show Dimensions of: Select Page to specify the size for all of the spread’s 
pages; the spread will be the size of the page multiplied by the Page Count. 
Or select Spread to define the overall size of the spread; the size of each page 
will be the size of the spread divided by the Page Count.

6.  Page Layout: For a facing-pages document, select Facing to create a facing-
page master with left and right sides for mirrored margins and layouts, as well 

Tip: You can change a 
master’s colour tag by 
right-clicking its 
thumbnail and 
selecting a new colour

Adding a master in a document with facing pages Adding a master in a document without facing pages
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as optional additional pages between them for multi-page spreads. Select 
Ambidextrous to create a master that has no sides and whose margins will be 
identical regardless of which side a page falls on.

7.  Page Count: Enter the number of pages for the master. If you are not using 
multi-page spreads, this value will normally be set to 2 in a facing-page 
document for the left and right sides or to 1 in a non-facing page document. 
This option does not apply to ambidextrous masters.

For multi-page spreads, set the number of pages in the master to match the 
number in the document spreads.

8.  Spine Location: Specify where the spine of a facing-page document should be 
located. Unless you’re using multi-page spreads, the spine location should be 
after page 1. For a multi-page spread, the location depends on how the paper 
is folded.
Tip: You cannot change the number of pages or the spine location after creating a 
master page. If you change your mind later, you will need to create a new master page.

9. All of the other options in this window are the same as for creating a new 
document, so refer to Creating a new document on page 22.

10. Click OK to add the master page.

To delete a master page:

1. Select the master page thumbnail in the Pages panel and click the Delete 
Selected Master  icon. You can also right-click the thumbnail and choose 
Delete from the context menu. If the master page is applied to any pages, you 
will be prompted to confirm deleting the master’s content from those pages.

Tip: You cannot 
change a master page 
from facing pages to 
non-facing pages 
(ambidextrous)
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Changing master page layouts
To change the layout of an existing master page:

1. If the Master Pages section of the Pages panel is collapsed, click the caret 
icon to the left of the Master Pages section title to expand it.

2. Right-click the master page thumbnail in the Pages panel and choose Spread 
Properties… from the context menu. The options shown depend on whether 
or not the master was created with facing-pages.

3. For a facing-pages document, choose Spread to change the entire spread or 
Selected Pages and then select the thumbnail(s) of pages in the spread. You 
can also click pages in the preview on the left side of the window to selected 
individual pages, and hold ⌘ (macOS) or Ctrl (Windows) while clicking to 
select multiple pages in the preview.

4.  X and Y: When one or more pages are selected above, enter the horizontal 
and vertical offset of the page within the spread, relative to the spread origin.

5.  Move Following Pages: Select when changing the size of a page within a 
spread to automatically adjust the X offset for pages to its right, or in a docu-
ment with pages arranged vertically, the Y offset for pages below it.

6.  Resize Linked Pages: If you change the size of the spread or a page within it, 
select whether or not the change should be applied to pages based on the 
master. Choose None to not apply changes, Matching (default) to apply 
changes only to pages whose size match the master page, and All to all pages 
based on the master, even if they have separately been changed in size.

7. All of the other options in the Spread Properties window are the same as for 
creating a new master page or a new document, so refer to Creating a new 
document on page 22 and Changing layout options on page 33.

Tip: You don’t need to 
change X and Y
manually if Move 
Following Pages is 
selected unless you 
want an inner bleed 
for spiral or other 
specialty binding

Tip: You cannot 
change the size of 
multiple individual 
pages in a master 
spread at once—you 
must change one and 
click OK before 
opening the window 
again and changing 
the next one

Changing a master in a document with facing pages Changing a master in a document without facing pages

Tip: You cannot 
change the number of 
pages or the spine 
location for a master 
page or change it from 
facing pages to non-
facing pages 
(ambidextrous)
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Applying master pages to document pages
You can apply a master page to document page(s) when creating a document or 
adding pages. After creating a document or adding pages, you can apply a differ-
ent master page or remove the master applied to the document pages.

If your document requires many similar master pages, you can base a page on 
two or more master pages to avoid duplicating objects on more than one master 
and having to update each of them separately if changes are later required.

There are two ways to use multiple master pages. You can apply multiple masters 
to a document page or you can base one master page on another and apply the 
combined master to a document page. The examples below illustrate combining 
two masters but you can apply many masters to the same page.

While a non-facing-pages document can include only single-page document 
pages and master pages, a facing-pages document can include single-page and 
facing-page document pages and master pages. If you apply a single-page master 
to a facing-pages spread then it will be applied to both sides of the spread. 
Adding a single-page master page to a facing-pages book or magazine might 
seem unusual but some publications have special pages that appear identically on 
the left or right side and it’s easier to use just a single-page master.

You can also apply different master pages to the left and right pages of a spread 
and apply masters of different sizes to the same page(s). If you apply different-
sized masters to a page you will be prompted whether to retain the existing page 
size or resize it to match the new master.

Tip: A popular 
approach is to create a 
main master for the 
guides and header 
and footer text such as 
page numbers and 
running headers, and 
other masters based 
on that for the text 
and picture frames 
needed for the various 
page layouts

Base one master page on another: The 
document page (top) is based on a 
background master page (middle) which 
is based on the background master page 
(bottom)

Apply multiple masters: The document 
page (top) is based on the contents of 
both background master pages applied 
to it (middle and bottom)

Tip: You can apply 
only one master page 
to a page at once so it 
is generally easier to 
base one master page 
on another
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To apply a master page to document page(s) or another master:

1. Right-click a page or master page thumbnail in the Pages panel and choose 
Apply Master… from the context menu.

2. Select which master page to apply and how to apply it in the Apply Master
window:

• Apply Master: Select a master page. You can apply only one master page at 
a time so to apply multiple masters, repeat these steps and deselect 
Replace Existing each time.

• To: Choose which pages to apply the master to. You can enter a range or 
list of page numbers in Specified Pages.

• Replace Existing: Select to remove the current master page(s) from the 
selected pages before applying the new master, or deselect it to layer the 
new master page over the existing one(s).

• Content: If you select Replace Existing, choose Clear to delete the current 
master’s object(s) or Migrate to preserve content in master page text and 
picture frames. Using migrate will move content from the old master’s 
frames to the most similar frames on the new master. If there isn’t a 
matching object then the objects will be detached from the old master and 
promoted to regular objects on the document page.

• Conform Pages: Select Size to make the document pages the same size as 
the master page or Size & Count to also make the number of pages in the 
spread match the master page. Select None to leave the page size and 
count unchanged.

• Conform Page Layout (for a master page): Select to make the target 
master page the same size as the master page you are applying. You cannot 
conform the number of pages in the master page.

3. Click OK.

Tip: Objects other 
than frames will be 
removed regardless of 
whether Clear or 
Migrate is chosen

Tip: To migrate some 
text and images but 
not all, lock the 
objects on the new 
master page that you 
don’t want content 
migrated into with 
Layer > Lock

Apply Master when applying to a document page

Apply Master when applying to a master page
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To change how master page objects and text are scaled to fit a different 
page size:

1. If the Layers panel is not already visible, choose Window > General > Layers.

2. Right-click the master page layer (i.e., Master A or the name you have chosen 
for it) and choose Properties from the context menu.

3. The Master Properties window allows you to choose which pages of a spread 
the master is applied to and how the content should be scaled.

• Master Start Page: Specify the first page of the spread the master should 
be applied to. For a facing-page spread, page 1 refers to the left side and 
page 2 refers to the right side.

• Page Count: Specify how many pages of the spread the master should be 
applied to. For a facing-page spread, setting Master Start Page to 1 and 
Page Count to 2 would apply the master to both sides. Master Start Page
plus Page Count cannot be greater than the length of the spread.

• First Applied Page: Specify the first page of the master that should be 
applied. If a master has 2 pages, entering 2 would apply the second page of 
the master and the master’s first page would not be applied at all.

• Scale: Choose how the content of the master page should be scaled if the 
document page is a different size. Note that text may not fit in its frame 
after scaling and may need to be adjusted.

• None: Applies the master without scaling, even though the content 
may be too small or too large for the page size.

• Stretch (not recommended): Stretches the master content in both 
directions to fill the page.

• Uniform to Fit (default, recommended): Scales the master content 
uniformly so that the content in the larger direction fits the page, 
ensuring that no content is cropped. This option will leave white space 
gaps for the smaller direction.
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• Uniform to Fill: Scales the master content uniformly so that the 
smaller direction fits the page, cropping the content in the larger 
direction.

• Scale Line Style: Select to scale the line style objects with the objects.

• Anchor: Select an anchor point from which the content will be scaled.

4. Click OK.

To apply a master page by dragging its thumbnail:

You can apply master pages to pages visually by dragging thumbnails but the 
Apply Master window will not be displayed, edited objects will be migrated, and 
if the page sizes of the old and new masters do not match, you will not be 
prompted whether to change the page size.

1. If the Master Pages section of the Pages panel is collapsed, click the caret 
icon to the left of its title to expand it.

2. To apply a master page to one page, drag the master’s thumbnail onto the 
page’s thumbnail in the Pages panel. You can also drag the master page 
thumbnail over the actual page in the document window.

To apply a master page to an entire spread, drag the master’s thumbnail over 
the page number label below the spread’s thumbnail.

To apply a master page to multiple pages, select the page thumbnails first—
dragging a master page onto one thumbnail will apply it to all selected pages.

3. If the master page is a different size than the page(s) to which it is being 
applied, you will be prompted when clicking OK to decide whether the 
page(s) should be resized. If you choose No then Affinity will scale the master 
page’s objects and text uniformly from the centre so that they fit on the docu-
ment page.

Tip: Hold down ⌥
(macOS) or Alt (Win-
dows) while dragging 
the master page icon 
to apply the new 
master without 
replacing the existing 
master(s)
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To convert a document page to a master page:

You can’t directly convert a document page to a master page but there is a way to 
accomplish this task.

1. Choose the Move  tool and then choose Edit > Select All.

2. Create a blank master page of the same size and layout. Refer to Creating a 
new document on page 22.

3. Choose Edit > Paste to duplicate the objects onto the new master page.

To unassign a master page from a document page:

1. Right-click a page thumbnail in the Pages panel and choose Clear Master
from the context menu. You can also choose Apply Master and then choose 
None from the list of master pages.

To assign colour tags to master pages to easily identify a page’s master:

1. Right-click a master page in the Pages panel and select a colour tag.

2. Choose Show Master Page Tags from the panel menu  to show colour tags 
on pages and masters. A colour tag will be shown as a circle on its master 
page thumbnail and as colour bars on the top of all the thumbnails of pages 
and other masters to which the master has been applied. If more than one 
master page is applied to a page, the colour bar area will be divided to show 
each of their colour tags side by side.

To see which master page(s) are applied to a document page:

• Position the mouse pointer over a page spread thumbnail and after a 
moment a tooltip will appear listing the master page name(s).

• Or refer to the Layers panel which lists the master page layers.

Tip: You can also 
assign colour tags 
when creating a 
master page or when 
editing it in Spread 
Properties

Colour tag to indicate this master

Colour bar to indicate the master 
applied to this spread
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To import masters from one document into another:

You can’t directly import a master page from another document but there is a 
way to achieve it. This technique is also useful for updating a master page used in 
multiple documents.

1. If you want to import multiple master pages from a document, open that 
document and using the Pages panel, add a new page or spread at the end of 
the document. Select the first master page you want to import when adding 
the page.

Right-click the thumbnail of the new page in the Pages panel and choose 
Apply Master… Select the name of the second master page you want to 
import and deselect Replace Existing. Repeat this step for each additional 
master page and then save the document under a temporary filename.

2. Open the document into which you want to import master page(s). Choose 
Document > Add Pages from File and then select the other document from 
the Open window.

3. Select the page or spread based on the master page(s) you want to import.

4. Click OK. The page and its master(s) will be imported and added to the 
current document.

5. Delete the page that you imported which will leave the imported master(s) 
ready for use.

6. If the imported master page is a revised version of one in the document, apply 
the imported master page to pages.

1. Select the thumbnails of the pages in the Pages panel.

2. Right-click one of the selected page thumbnails and choose Apply 
Master… from the context menu.
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3. Select the revised master page from Apply Master and click OK.

4. Delete the original master page if it is no longer required.

Apply Master when applying to a document page
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Editing master page objects
You can add, transform, and delete master page objects by viewing the master 
page and making changes there. Changes made to a master page will be repli-
cated on all the pages. But you can also edit master page objects while viewing a 
document page so that you can see the impact of the changes in the context of a 
document page.

To edit master page objects while viewing a document page:

1. Choose Layer > Master Page > Edit Linked. A green bar will appear at the 
top of the document window to inform you that you’re editing the master 
page linked. Note: If there is more than one master page applied to the docu-
ment page then this will edit the top master in the layer stack. It is advisable 
to instead right-click the master page layer in the Layers panel and choose 
Edit Linked from the context menu.

2. Transform the master page’s objects as desired. Expand the master page layer 
by clicking its caret  icon in the Layers panel if you want to drag objects 
into and out of the master page layer.

3. Click Finish in the green bar or choose Layer > Master Page > Edit Frame 
Content. The master page will be updated along with all other document 
pages based on that master.

Overriding master page objects on document pages
The content of text and picture frames on a master page can be modified on a 
document page but the frames themselves can’t be transformed, nor can other 
objects such as shapes be changed on a document page.

When editing a document page, you can select a text or picture frame on a 
master page layer so that you can modify its content but you can’t select other 
master objects such as shapes because they don’t have content that can be 
changed on a document page.

Affinity displays master page frames on document pages with different handles 
to indicate that they can’t be transformed on the document page.

Tip: Art text and path 
text objects work like 
text frames when 
placed on a master 
page; their contents 
can be changed on a 
document page

Text and picture frames on 
a document page: Round 
size handles can be used to 
modify the frame

Text and picture frames on 
a master page: X‐handles 
indicate that the frame 
cannot be modified
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Sometimes you may want to change a master page’s objects for just one page 
without creating another master. While you can’t transform master objects on 
document pages, you can detach the master page to override it. This allows you 
to make changes to the master page’s objects for the current page.

Objects that are overridden by detaching the master page will still be updated if 
you change them later on the master page, as long as the updates are different 
from those you made while editing detached. For example, if you change a 
master page object’s colour from red to green on page 3 but later change it from 
red to blue on the master page, the object on page 3 will not change. But if you 
move the object on the master page, the object on page 3 will move.
Warning: While you can scale or move a master page’s text frame while editing detached, 
adding, moving, or deleting a single page before the document page with the override will 
have varying results depending on the selected Page Move Options. If Reapply Masters is 
selected, the frame will be reset to its original size and position. If Split Masters is selected in 
a facing-page document, the frame will not be aligned to the margins. If Move Master 
Content is selected, a duplicate text frame will be created obscuring the one you scaled or 
moved, making it impossible to edit the text in your frame without editing detached again.

To override a master page:

1. Choose Layer > Master Page > Edit Detached. A green bar will appear at the 
top of the document window to inform you that you’re editing the master 
page detached. Note: If there is more than one master page applied to the 
document page then this will edit the top master in the layer stack. It is 
advisable to instead right-click the master page layer in the Layers panel and 
choose Edit Detached from the context menu.

2. Transform the master page’s objects as desired and then click Finish in the 
green bar or choose Layer > Master Page > Edit Frame Content.

To prevent a master page object from being overridden:

1. Select the object on the master page.

2. Choose Window > General > Layers to show the Layers panel if it is not 
already open.

3. Right-click the object in the Layers panel and choose Lock from the context 
menu, or click the Toggle Lock  icon for the layer. You will be unable to 
unlock the object while using Edit Detached on a document page.

To hide master page objects on a document page:

1. Choose Window > General > Layers to show the Layers panel if it is not 
already open.

2. Click the Toggle Visibility  icon for the master page layer.

To remove master page overrides from a document page:

1. Re-apply the master page to the page.

Tip: Affinity’s Edit 
Detached feature is 
similar to the Override 
feature in Adobe®
InDesign® and 
shouldn’t be confused 
with its Detach feature 
that completely breaks 
the link to the master 
page; to fully detach a 
master object in 
Affinity, drag the 
object’s layer out of 
the master page layer 
while using Edit 
Detached
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Changing the stacking order of master page objects
Master page objects are on a master page layer which is positioned below docu-
ment page objects because a master page is the background of a document page. 
If you have multiple masters applied to the same document page you might want 
to change the order of the master page layers, and in rare cases you might want 
the master page layer to be above objects on the document page.

You cannot set master page layers to be permanently shown above document 
page layers but you can change the order for existing pages and objects.

To change the stacking order of master page layers for a single page:

1. Choose Window > General > Layers to show the Layers panel if it is not 
already open.

2. All of the objects on each master page applied to the current page will be 
grouped together on a master page layer. Click that layer in the panel to select 
it and choose Layer > Arrange > Move to Front drag it to a different position 
in the panel’s layer stack.

To change the stacking order of master page layers for all existing pages:

1. Choose Layer > Master Page > Edit Linked. A green bar will appear at the 
top of the document window to inform you that you’re editing the master 
page linked. Note: If there is more than one master page applied to the docu-
ment page then this will edit the top master in the layer stack. It is advisable 
to instead right-click the master page layer in the Layers panel and choose 
Edit Linked from the context menu.

2. All of the objects on the master page will be grouped together on a master 
page layer. Click that layer in the panel to select it and choose Layer > 
Arrange > Move to Front drag it to a different position in the panel’s layer 
stack.

3. Click Finish in the green bar or choose Layer > Master Page > Edit Frame 
Content. The master page will be updated along with all other document 
pages based on that master.

Tip: You can reorder 
the master page layers 
relative to layers on 
the document page, 
but to reorder the 
layers within a master 
page layer you must 
use Edit Detached or 
Edit Linked

Tip: You can’t lock a 
master page layer to 
remain at the top of 
the layer stack—new 
objects drawn on the 
document page will 
be created above of 
the master layer
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Multi-page spreads
Affinity allows you to create multi-page spreads which are useful for fold-out 
pages in books and other publications. You can join up to 10 pages together in a 
multi-page spread, although Affinity will allow you to exceed this limit by joining 
additional pages with the Pages panel.

You can create multi-page spreads directly by joining document pages together, 
or you can create a multi-page master spread that can be used to create docu-
ment-page spreads with the same number of pages, page sizes, and spine location 
as the master.

The spine location determines where a multi-page spread is bound into a publi-
cation such as a book or magazine. If you create multi-page master pages and the 
spine is off centre, you will need two master pages because the spine location is 
part of the master page.

Affinity automatically reflows pages in facing- and multi-page spreads when you 
add or remove pages which can cause left pages to become right pages and the 
pages inside a multi-page spread to shift. Disabling page flow for a spread will 
preserve its pages and form what is sometimes referred to as an island spread 
because the pages form an island in a sea of flowing pages.Tip: Island spreads are 

created by disabling 
Reflow Through 
Spread and are 
indicated with grey 
brackets around the 
spread’s pages

Tip: Pages will not 
reflow if you disable 
Reflow Pages for the 
document

Tip: If you select 
Include Printers 
Marks and Include 
Crop Marks when 
exporting, Affinity will 
also add fold lines to 
indicate where the 
spread should be 
folded

Tip: You can folding 
brochures with a 
multi-page spread, but 
those documents can 
also be created using 
ruler guides to divide a 
single page into 
sections

A pair of multi-page 
spreads in a facing-
page document

Pages 2–3

Pages 4–6

Pages 7–9

Pages C, D, and E are a multi-page spread Deleting page B leaves a “ghost” page to 
preserve the following island spread

Deleting page B causes page C to flow up 
and out of the spread and leave a “ghost” 
page

D EC

BA
Pages 2–3

Pages 4–6

D EC

A
Page 2

Pages 3–5

ED

CA
Pages 2–3

Pages 4–6
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To create a multi-page spread from new pages:

1. Choose Document > Add Pages…

Or select the thumbnail of the page or spread in the Pages panel before or 
after which you want to add pages and click the Add Pages  icon.

2.  Spread wrapping: Choose Extend Spread to extend a facing-page spread or a 
single page into a multi-page spread with pages that flow through the spread, 
or choose New Spread to create an island spread with text reflow disabled.

The other options in this window are described in Working with pages on 
page 39.

3. Click OK.

To create a multi-page master spread:

1. Click the Add Master  icon in the Pages panel or right-click in the Master 
Pages section of the Pages panel and choose Insert Master… from the con-
text menu to insert a master after the thumbnail you clicked closest to.

2.  Page Count: Enter the number of pages up to a maximum of 10—you cannot 
change this after creating the master page so ensure the number is correct.

Tip: The spine location 
cannot be specified 
when adding pages 
and will be based on 
the master page, but 
you can change it 
later; see To change 
the spine location: on 
page 65
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3.  Spine Location: Specify where the spine of a facing-page document is located. 
The location depends on how the paper is folded so speak with your printer if 
there is any doubt because you cannot change the location after creating the 
master page.
Tip: You cannot change the number of pages or the spine location after creating a 
master page. If you change your mind later, you will need to create a new master page.

The other options in this window are described in Creating master pages on 
page 47.

4. Click OK.

To create a multi-page spread from existing pages:

1. Using the Pages panel, right-click the page number label of the page or spread 
to which you want to join other pages or spreads and choose Spread 
Properties.

2. Deselect Reflow Through Spread and click OK to convert the page or spread 
into an island spread. This is a necessary step even if you don’t want an island 
spread because you can’t join pages to a spread unless page reflow is disabled. 
Grey brackets will appear around the spread’s thumbnail in the panel to 
indicate reflow is off.

3. To add a page or spread to the end of the island spread, drag its thumbnail to 
one side of the island spread’s thumbnail. A blue bar will appear immediately 
beside the target thumbnail when you are in the right position. Release the 
mouse button to join the pages. If there is a gap between the spread and blue 
line then you are rearranging pages and not extending the spread.

To add a page or spread between island spread’s pages, drag its thumbnail 
between the island spread’s pages. A blue bar will appear between the pages 
when you are in the right position.

After deselecting Reflow 
Through Spread for spread 2‐3

Before deselecting Reflow 
Through Spread for spread 2‐3
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Optional: Hold ⌥ (macOS) or Alt (Windows) while dragging to duplicate the 
pages instead of moving them.

Mouse Description

  Move page(s)—the following pages will shuffle

Duplicate page(s)—the following pages will shuffle

Insert (+ duplicate) page(s) into an island spread on the left of its spine

Insert (+ duplicate) page(s) into an island spread on the right of its spine

Move (+duplicate) pages to extend the island spread to its left

Move (+duplicate) pages to extend the island spread to its right

Page(s) cannot be moved or duplicated here

4. Release the mouse button to move or duplicate the pages.

5. Repeat to join other pages as required.

6. Optional: Right-click the spread, choose Spread Properties, and select Reflow 
Through Spread to enable text flow if you don’t want an island spread.

To remove a page from a multi-page spread:

• If you no longer need the page, select the page in the spread and click the 
Delete  icon. If the spread is an island and Reflow Through Spread is off, 
the spread will be reduced by one page after deleting the page. If the spread is 
not an island and Reflow Through Spread is on, the page will be deleted and 
the following pages will shift up by one so that the number of pages in the 
spread does not change.

• If you still want the page, drag the page out of the spread and drop it where 
you would like it positioned in the Pages panel. A blue line will appear to 

Tip: You cannot 
remove pages from 
master spreads

Dragging spread 4‐5 to the 
right of island spread 2‐3

Dragging spread 4‐5 between the pages 
of island spread 2‐3 and left of its spine
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indicate where the pages will be moved. Dragging a page out may create 
another multi-page spread. Refer to the instructions below for dissolving a 
spread.

To dissolve a multi-page spread:

Affinity doesn’t include a feature to dissolve a spread but it can be done by apply-
ing a standard master page.

1. Right-click the page number label of the spread and choose Apply Master.

2.  Apply Master: Select a facing-page master or an ambidextrous master.

3.  To: As long as you right-clicked the spread label rather than one page of the 
spread, Specified Pages should be selected and set to the spread’s page 
number range. You can also select Current Spread.

4.  Conform Pages: Select Size & Count. If you don’t select this option, the 
master will be applied without dissolving the spread.
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To change the spine location:

Affinity doesn’t include a feature to move the position of a spread’s spine but you 
can move pages from one side of the spine to the other to do the same thing.

1. If the spread is not an island spread, right-click the spread, choose Spread
Properties… from the context menu, and deselect Reflow Through Spread.

2. To move the spine to the right, select the page first and then drag it to the left 
side of the spine, or vice versa. The mouse pointer will change to indicate the 
side of the spine.

3. If you deselected Reflow Through Spread in step 1, repeat that step to select it 
again.

The spine is positioned 
between pages 3 and 4

To move page 4 to the left of 
the spine, select it and drag it 
to the left of the spine…

…release the mouse button 
when the mouse pointer 
indicates it is on the left side

Tip: While you can 
drag pages from one 
side of the spine to the 
other with reflow 
selected, you won’t be 
able to move a page 
that is immediately to 
the right of the spine 
to immediately of the 
left

Tip: You cannot 
change the spine 
location for an existing 
master spread
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Headers, page numbers, and sections
Most books and magazines have headers or footers at the top or bottom of each 
page to convey information about the document, chapter, and page. Headers and 
footers should be created on master pages so that they will appear on each docu-
ment page without duplicating text frames.

If you want some pages to have a different version of the header or footer or none 
at all, create an additional master page for those pages.

Sections
Affinity uses sections to customise page numbering, to name or number chapters, 
and to exclude a range of pages from being exported.

While it is a best practice to link text frames from page to page in a document, 
you should break the link at the end of each section because the start pages of 
sections are fixed and can’t float with the heading at the start of your next chapter 
as they do in word processors such as Microsoft® Word.

Most books created as a single document in Affinity will have at least two sec-
tions, one for front matter and one for body pages. This book has two sections. 
Using a section for every chapter is useful if you need to insert chapter names or 
numbers into a header or footer.

Definition: A section is 
a range of pages 
starting on a specific 
page and continuing 
until the start of the 
next section or the 
end of the document

Master page layout: This is the master page for this page of this book. Note the mirrored text frames in 
the footer at the bottom for page numbers, and mirrored text frames which are linked from left to the 
right. The other lines are guides.
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Page numbering
Affinity can number your document’s pages automatically. If you want to change 
the numbering format for different parts of your document, you can divide your 
document into sections and use a different numbering format for each section.

To create a header or footer:

1. Using the Pages panel, double-click a master page thumbnail or its name 
below the thumbnail. If the master is set to facing pages, you should add text 
frames to both sides.

2. Using the Frame Text  tool, draw a text frame to include the header or 
footer information. While formatting a header or footer, it is best to type a 
placeholder page number or section name even if that information will be 
updated automatically. Once you have the formatting the way you want it, you 
can delete the placeholder information.

3. Apply the master page to document page(s). Refer to Applying master pages 
to document pages on page 50.

To add automatic page numbers:

1. View the master page and click in the header or footer where you want the 
page number to appear.

2. Choose Text > Insert > Fields > Page Number, or double-click the Docu-
ment Sections > Page Number field name in the Fields panel. The # sign will 
be shown for the page number on a master page.

3. Choose Text > Highlight Fields to add shading behind fields such as page 
numbers to make them easier to see while editing your document. This 
shading will not be printed.

A footer with a page number field on a 
master page

A footer with a page number field on a 
document page

Tip: To right align a 
page number as 
shown in this example, 
choose Text > Insert > 
Spaces and Tabs >> 
Right Indent tab or use 
a standard tab and 
create a right-aligned 
tab stop set to 0 from 
right

Tip: You can also use 
the Artistic Text
tool to create a header 
or footer but it is 
easier to draw a text 
frame aligned to the 
left and right margins 
and then to align the 
text within the frame, 
especially if you insert 
fields which have long 
names when viewed 
on a master
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To change the page number format:

Sections are used to customise the page numbering format.

1. Choose Document > Section Manager or click the Section Manager  icon 
in the Pages panel.

2. Choose the Number style for the default first section. You can also enter a 
Section Name if desired.

3. If you want to change the numbering style for the entire document, click 
Close. Many books use Roman numerals (i, ii, iii, iv…) for the front matter 
pages and Arabic Numbers (1, 2, 3, 4…) for the body pages. To do this, you 
will need at least two sections in your document. Change the first section’s 
Number style to i, ii, iii, iv…

4. Keep the Section Manager window open and in the document window, 
switch to the page on which the page numbering should change.

5. Using the Section Manager, create a second section for the body pages start-
ing on the current page by clicking the Add Section  icon. You can also 
right-click the page’s thumbnail in the Pages panel and choose Start New 
Section… from the context menu.

6. Enter a name for the new section (optional) and enter the absolute page 
number for its first page in Start on page. Set Restart page numbering at to 1, 
and change its Number style to 1, 2, 3, 4…

Tip: The Include on 
Export option is 
intended for sections 
that will be neither 
printed or exported

Definition: Absolute
page number refers to 
the number of the 
page within the 
document; the relative
page number is what 
is displayed on a page 
by restarting page 
numbering
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To number pages separately in each chapter (section):

Some books need pages numbered separately in each chapter (e.g., 1.1, 1.2…, 2.1, 
2.2…) Affinity can’t automatically add a section’s name as a prefix to the page 
number like some other applications but you can do this easily by combining two 
fields.

1. Choose Document > Section Manager or click the Section Manager  icon 
in the Pages panel.

2. Create a section for each chapter of your document by navigating to its first 
page and clicking the Add Section  icon. You can also right-click the page’s 
thumbnail in the Pages panel and choose Start New Section… from the 
context menu. Enter the chapter number as the Section name, and set Restart 
page numbering at to 1 for each section.

3. View the master page and click in the header or footer where you want the 
page number to appear.

4. Choose Text > Insert > Fields > Section Name, type a period, and then 
choose Text > Insert > Fields > Page Number. You can also double-click the 
Document Sections > Name field name in the Fields panel, type a period, 
and then double-click the Document Sections > Page Number field name. 

Tip: Be careful num-
bering your chapters; 
section 1 for most 
books will be for front 
matter so section 2 
will be for chapter 1 
and so on, as shown in 
this screenshot

Tip: Affinity does not 
offer automatic 
section numbering so 
you must enter a 
number for each 
chapter as its Section 
name

Pages panel showing absolute page 
numbers (left) and relative page numbers 
(in parentheses) for a facing-pages 
document
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This will be shown as <Section Name>.# on a master page but will appear as 
1.1 on the first page of chapter 1.

To change or delete a section after creating it:

1. Choose Document > Section Manager or click the Section Manager  icon 
in the Pages panel. You can also right-click the thumbnail of any page in the 
section and choose Edit Section… from the context menu.

2. Make the desired changes to the section or with the section selected in the list 
on the left, click the Remove Section  icon.

To add last and continued page numbers:

Some books need to display page numbers as # of # (for example, 17 or 98) or 
continued to/from page numbers (for example, continued on page 17). 

1. Using the Frame Text  tool, position the text cursor where you want the 
page numbers to be inserted.

2. Insert the desired fields by double-clicking their names in the Fields panel or 
by choosing it from Text > Insert > Fields:

• Page # of # for an entire document: Insert the Page Number field fol-
lowed by “ of ” and then insert the Total Pages field. The Page Number 
field will use the page numbering style defined for the section but the 
Total Pages field will always be displayed in Arabic numerals.

• Page # of # for a section: Insert the Page Number field followed by “ of ” 
and then insert the Last Page in Section field. Both numbers will use the 
page numbering style defined for the section. You can also choose the Last 
Page in Section Run field which refers to the last page before page num-
bering is restarted, whether that is in the next section or several sections 
later.

• Continued on page #: Enter text such as “continued on page ” (or from 
page) and then insert the Next or Previous Frame Page Number field into 
a text frame on a document page (not a master page) that is part of a series 
of linked frames. These fields display the page number of the previous or 
next frame.

Tip: All of these fields 
are shown as # on a 
master page but they 
will display correctly 
on a document page

A footer with section name 
and page number fields on a 
master page

A footer with section name 
and page number fields on a 
document page
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Using sections for chapters
Many books display the chapter name in the header or footer. If you use the 
Books feature and create each chapter as a separate document you can add the 
chapter name as static text in a master page’s header or footer, but if the book is a 
single document, you would need a separate master page for each chapter. The 
Section Manager provides an easier way to add the chapter name to a header or 
footer.

To create sections for a book’s chapters:

1. Choose Document > Section Manager or click the Section Manager  icon 
in the Pages panel.

2. Create a section for each chapter of your document by navigating to its first 
page and clicking the Add Section  icon. You can also right-click the page’s 
thumbnail in the Pages panel and choose Start New Section… from the 
context menu. Enter the chapter name as the Section name.

To display the chapter (section) name in a header or footer:

1. Using the Pages panel, double-click a master page thumbnail or its name 
below the thumbnail.

2. Click in the header or footer where you want the chapter name to appear.

3. Choose Text > Insert > Fields > Section Name. You can also double-click the 
Document Sections > Page Number field name in the Fields panel. This will 
be shown as <Section Name> on a master page but the name of your chapter 
will appear on each page based on this master.

Tip: You cannot use 
the Section Name
field for both the 
chapter name and as a 
chapter prefix to 
number pages sepa-
rately in each chapter, 
you must choose one 
or the other

Tip: You can drag the 
Section Manager
window wider so you 
can see your full 
chapter names on the 
left side
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Running headers
Affinity can repeat heading text in the header or footer automatically. A running 
header helps the reader by describing what information will be found on the 
page. Many books display the current topic within a chapter in the header or 
footer while dictionaries and similar books might display the first and last head-
words on each page. If you format your topics or headwords consistently with a 
specific heading style then Affinity can display them automatically in a running 
header.

To create a running header:

1. View the master page and click in the header or footer where you want the 
page number to appear.

2. Choose Text > Insert > Fields > Running Header. You can also double-click 
the Document Sections > Running Header field name in the Fields panel. 
This will be shown as <Running Header> on a master page but the header text 
will appear on each page based on this master.

3. If you moved the text cursor since inserting the running header field, select it 
or position the cursor immediately after the field. Then click the Edit  icon 
to the right of the field in the Fields panel. You can also right-click the field in 
the text frame and choose Edit Field from the context menu.

4. Select which headings to display as a running header and how to format it.

Tip: If you click the 
icon when a field is 
not selected or the 
cursor is not beside it 
you can set the 
defaults for all running 
headers you subse-
quently create, but 
formatting a running 
header will also set the 
defaults so this is 
unnecessary

Definition: A run is the 
range of text until the 
next instance of the 
same level of heading

Tip: Affinity uses the 
term running header
even if it’s inserted 
into a footer
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• Style: Choose the text style you used for the headings you want to be 
displayed in the running header. For most publications you would choose 
Heading 1 (default), Heading 2, or Heading 3, but you can choose any 
paragraph or character text style.

• Use: Choose whether the first or last instance of the selected style should 
be displayed. The default First on Page option is recommended for most 
publications—it will even use the header text from a previous page if there 
isn’t an instance of the text style on the current page. Use Last on Page
only for the last headword on a page for dictionary-style formats because 
the running header will be blank if there isn’t an instance of the text style 
on the current page.

• Include paragraph numbering: Choose if the heading is a numbered list 
and you want the number displayed in the running header.

• Apply limits: Choose to control the running header’s length. Specify 
which character(s) to end on, whether to include the end character, the 
maximum number of words, and whether a truncated header should be 
displayed with an ellipsis.

• Case change: Choose whether the header should be displayed in its origi-
nal case or changed to upper, lower, title (default), or sentence case.

5. Choose Text > Highlight Fields to add shading behind fields such as page 
numbers to make them easier to see while editing your document. This 
shading will not be printed.

Tip: If there isn’t an 
instance of the header 
style on any previous 
page when using First 
on Page, then the 
running header field 
will be blank
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Sample dictionary-format running header

This example uses three text frames on the master page for the running headers 
and page number. Both running headers are set to a character style used to bold 
the dictionary terms but one is set to First on Page and the other to Last on 
Page.

To format a Running Header:

1. Using the Frame Text  tool, right-click the running header field in the 
document text and choose Edit Field… from the context menu. You can also 
select the field or position the text cursor before or after it and then click the 
Format  icon to the right of the field in the Fields panel.

To use a Running Header with a multi-line heading:

Headings that include line breaks will be displayed on multiple lines in a running 
header. You can convert multi-line headings to a single-line running header with 
this workaround, but you must format the running header with a paragraph 
style.

1. Using the Transform panel, note the width of the text frame containing the 
multi-line header. If the text frame contains multiple columns, you should 
instead note the width of the column using the Text Frame panel.

2. Using the Text Styles panel, choose Edit “<style name>” from the style 
options menu  to the right of the heading’s paragraph style name. The Text 
Style Editor window will be displayed.

Tip: This workaround 
will not work correctly 
if some multi-line 
headings are in text 
frames or columns of 
different widths; you 
may need to use 
unique styles for each 
column width

Running header set to First on Page Page number Running header set to Last on Page

First instance of 
character style on page

Last instance of 
character style on page

Tip: Do not format a 
running header on a 
master page layer 
while on a document 
page or you will 
override the field on 
the master page and 
impact only the 
current document 
page
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3. Click the Add New Tab Stop  icon.

4. Set the value of the new tab stop to the frame or column width you noted 
above and press Tab to accept the value.

5. Click OK to update the style.

6. Delete the line break between the first and second lines of the heading and in 
its place enter a Space and a Tab. Optional: You can also add a colon or other 
separator character before space.

7. Using the Text Styles panel, choose Edit “<style name>” from the style 
options menu  to the right of the running header’s paragraph style name. 
The Text Style Editor window will be displayed.

8. Click Tab Stops in the left pane.

9. Change the Default tab spacing to 0 and press Tab to accept the value. This 
will prevent the tab from adding extra whitespace after the space character.

10. Click OK to update the style.

Tip: If the style already 
has a tab stop, you 
may need to remove it 
if it is set to a position 
to the right of the end 
of the first line of the 
heading
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Rulers and measurements
The measurement system used for a document is defined when you create the 
document but it can be changed at any time. Stroke thickness and text font size 
are normally measured in points, regardless of the document’s measurement 
system, but you can override that in Settings.

Rulers can be displayed in the document window to assist in laying out pages. 
The rulers are numbered using the document’s measurement units.

You can change the ruler’s origin (zero point) which will result in objects being 
measured in negative number to the left and top of the origin.

To change a document’s measurement system:

If the rulers are visible, the abbreviation for the document’s measurement system 
will be displayed at the ruler origin—where the horizontal and vertical rulers 
meet.

1. If the rulers are visible, right-click the ruler origin—where the horizontal and 
vertical rulers meet— and select the desired measurement system from the 
context menu.

Or choose Document > Setup > Document Setup…, click the Document
tab, and select the desired measurement system from Document Units.

Or choose the View  tool or Zoom  tool and select the desired measure-
ment system from the Context Toolbar.

To change how stroke thickness and text font size are measured:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click User Interface in the left pane.

2. Select Show Lines in Points to always measure the thickness of strokes in 
points, regardless of the document’s measurement system.

Select Show Text in Points to always measure the font size of text in points, 
regardless of the document’s measurement system.

3. Click Close.

To show and hide the document rulers:

1. Choose View > Show > Rulers to show or hide the rulers.

Ruler origin

Rulers with origin set to top-left 
corner (default)

Rulers with origin set to bottom-
right corner

Tip: The rulers cannot 
be displayed in 
different measure-
ment units than the 
document itself

Tip: A separate Text 
Ruler can be displayed 
above text frames and 
objects to assist with 
formatting; refer to 
Tab Stops on page 174

Tip: You cannot set the 
default measurement 
system for future 
documents; the 
measurement system 
is defined when 
creating a new 
document
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To change the ruler’s origin (zero point):

A document is normally measured from its top-left corner but you can change 
the origin or zero point.

1. Drag from the ruler origin—where the horizontal and vertical rulers meet. 
Affinity will display crosshair lines to assist with positioning. Release the 
mouse button to set the ruler origin.

2. Or, choose View > Guides… and enter the position of the zero point in 
Spread Origin.

To reset the ruler’s origin (zero point) to the top-left corner:

1. Double-click the ruler origin—where the horizontal and vertical rulers meet.
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Guides
Affinity offers four types of non-printing guides to help you position and align 
text and objects on your pages. Objects can be snapped to the guides to ensure 
exact alignment and the guides can be hidden when not required.

• Margin guides enclose the area within which you place most of a page’s text 
and objects. They are created automatically when you create a document and 
set its margins. Margin guides can be changed after creating a document 
using Document Setup or the Guides window.

• Column guides divide the area of the page inside the margins into columns 
and rows. Column guides allow you to create a layout grid to assist with 
positioning text frames and other objects. Even though these guides can be 
horizontal for rows, they are always referred to as column guides in Affinity.

• Ruler guides are horizontal and vertical guides that you can place anywhere 
on a page, spread, or master page.

• Bleed zone guides form a rectangle surrounding the page to indicate where 
objects must extend to avoid white edges when pages are trimmed by a print 
partner. These guides will appear only when a bleed zone is defined when 
creating a new document or in Document Setup.

To show or hide guides:

• Choose View > Show > Margins to show or hide margin guides.

• Choose View > Show > Column Guides to show or hide column guides.

• Choose View > Show > Guides to show or hide ruler guides. This command 
has no effect on other types of guides. Ruler guides will be unhidden if you 
drag a new one out from the ruler.

• Choose View > Show > Bleed to show or hide the bleed zone guides.

Tip: There is not an 
option to show guides 
behind text and 
objects

Tip: There is not an 
option to hide guides 
below a specified view 
magnification level

Bleed zone guides

Edges of page

Ruler guide on the page or spread

Margin guides

Ruler guide inherited from the master page

Column guides

Gutter between column guides

Tip: Refer to Snapping 
objects on page 240 
for more information 
on snapping objects 
to guides
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To change the colour of guides for all documents:

You can set the colour of margin, column, and ruler guides but these are global 
settings and will affect all documents.

1. Choose View > Guides…

2. To set the colour of Ruler Guides, click the colour sample below Horizontal 
Guides.

3. To set the colour of Column Guides, click the colour sample in this section. 
You can also change these guides from lines to shaded rectangles by setting 
Style to Filled. Set it back to Outlines to switch back to guide lines.

4. To set the colour of Margin Guides, click the colour sample in this section.

5. Click Close.
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Margin and column guides
Margin guides are normally set so that all text and objects fit inside of them, 
other than headers, footers, and background images. Column guides are used to 
indicate where text and picture frames should be created but creating them does 
not create frames, you must do that separately.

Column guides are always created inside the margin guides and cannot extend 
outside the margins.

You can set margin and column guides for master pages as well as for individual 
pages and spreads, but setting them for a master page will promote consistency 
throughout your document.

To set margin and column guides:

1. Use the Pages panel to navigate to the master page, page, or spread.

2. Choose View > Guides…

3. Enter new values for the margin guides.

4. Select the number of columns and rows for the column guides, and the gutter 
space between them. You can specify a maximum of 32 guides in either 
direction.

5. Click Close.

To restore the margin guides of one spread to the values of its master page:

1. Right-click the page or spread in the Pages panel and choose Spread 
Properties.

2. Select Use Master’s Margin Values.

3. Click OK. If the page has multiple master pages applied, the margin values of 
the bottom master in the page’s layer stack will be used.

Tip: The Left and 
Right fields will be 
named Inner and 
Outer for a facing-
page document

Tip: Margin and 
column guides will be 
shown as solid lines 
regardless of whether 
you set them on a 
page or master page
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To restore the margin guides of multiple or all spreads to the values of their 
master page(s):

1. Choose Document > Setup > Document Setup…

2. To restore the margin guides for all pages, select Whole Document. To 
restore the margin guides for multiple spreads, select Multiple Spreads and 
select the individual spreads from the list on the right. Hold ⌘ (macOS) or 
Ctrl (Windows) to select multiple spreads or Shift to select a range of spreads.

3. Select Use Master’s Margin Values.

4. Click OK. If the pages have multiple master pages applied, the margin values 
of the bottom master in each page’s layer stack will be used.

To restore the column guides of one, multiple, or all spreads to the values 
of their master page(s):

• Choose View > Guides… and change the column guide settings back to the 
master page values—there is not an automatic way to restore the settings.

• Or, select the spread(s) in the Pages panel and then drag a master page 
thumbnail onto one of the selected page thumbnails. This will allow you to re-
apply a master page.
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Ruler guides
Ruler guides can be positioned anywhere on a page or spread. You can create 
them visually by dragging them out of the rulers or precisely by using the Guides
window.

Ruler guides can be created on document pages and master pages. Ruler guides 
created on a document page will appear only on that page while guides created 
on a master page will appear on all document pages based on that master. Docu-
ment page guides are shown as solid lines like other guides, but ruler guides 
inherited from a master page are shown as dashed lines.

To create a ruler guide visually:

1. Deselect View > Lock Guides if it is selected.

2. Position the mouse pointer over the vertical or horizontal ruler and then drag 
from the ruler onto the page. The mouse pointer will change to a horizontal 
or vertical  resize pointer while you are dragging and its horizontal or 
vertical position will be shown beside the pointer.

Hold Shift while dragging to snap the guide to the ruler’s tick marks. The 
guide will also snap to other objects and guides if snapping is enabled.

3. Release the mouse button when the guide is correctly positioned.

To move a ruler guide visually:

1. Deselect View > Lock Guides if it is selected.

2. Choose the Move  tool.

3. Position the mouse pointer over the guide to move. The mouse pointer will 
change to a horizontal or vertical  resize pointer when it is over the 
guide.

4. Drag the guide to its new position. The horizontal or vertical position will be 
shown beside the pointer along with the difference (delta Δ) from its existing 
position.

Hold Shift while dragging to snap the guide to the ruler’s tick marks. The 
guide will also snap to other objects and guides if snapping is enabled.

5. Release the mouse button when the guide is correctly positioned.

To lock guides to prevent them from being moved accidentally:

1. Choose View > Lock Guides.

To create a ruler guide precisely:

1. Choose View > Guides…

Tip: Guides inherited 
from a master page 
can only be moved on 
the master page

Tip: You can use any 
tool to move a ruler 
guide if you drag its 
marker on the ruler 
rather than the guide 
on the page

Tip: Choose View > 
Show > Rulers if the 
rulers are not visible

Tip: You can also 
create a new ruler 
guide by holding ⌘
(macOS) or Ctrl 
(Windows) and 
dragging from an 
existing ruler guide
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2. Click the Add New Guide  icon below Horizontal or Vertical Guides.

3. Set the guide’s position by clicking it once to select it and a second time to 
edit its value. Enter a new number and press Tab or Return.

4. Select Percent to show the guide’s position as a percentage of the page width 
or height rather than as fixed value. The percentages are relative to the top-left 
corner of the spread.

To move a ruler guide precisely:

1. Choose View > Guides… You can also choose the Move  tool, position the 
mouse pointer over the guide to move, and double-click it to open the Guides
window and automatically select the guide in the list.

2. Set the guide’s position by clicking it once to select it and a second time to 
edit its value. Enter a new number and press Tab or Return.

To remove one ruler guide:

1. Deselect View > Lock Guides if it is selected.

2. Choose the Move  tool.

3. Position the mouse pointer over the guide to remove. The mouse pointer will 
change to a horizontal or vertical  resize pointer when it is over the 
guide.

4. Press ⌥ (macOS) or Alt (Windows) and click the guide to delete it. You can 
also drag the guide off of the page onto a blank area of the page if you are 
zoomed out enough.

To remove multiple ruler guides:

1. Choose View > Guides…

2. Select a ruler guide in the Horizontal or Vertical Guides lists and click the 
Remove  icon below the list. Repeat as required.

3. Or click Remove All Guides to delete all horizontal and vertical ruler guides.
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To create a ruler guide outside of the page edges:

Affinity won’t allow you to create a guide outside of the page edges either visually 
using the rulers or precisely using the Guides window, but there is a way to create 
guides to the right and below a page.

1. Choose Document > Setup > Document Setup…

2. Set the page Dimensions at least as much larger as required so that the guide 
would be on the page if the page was that large. For example, if the page is 
210 mm wide and you want a guide at 230 mm, change the page width to at 
least 230 mm.

3. Click OK.

4. Deselect View > Lock Guides if it is selected.

5. Position the mouse pointer over the vertical or horizontal ruler and then drag 
from the ruler onto the page. The mouse pointer will change to a horizontal 
or vertical  resize pointer while you are dragging and its horizontal or 
vertical position will be shown beside the pointer. You could also choose 
View > Guides… and add a guide precisely.

6. Release the mouse button when the guide is correctly positioned.

7. Choose Document > Setup > Document Setup…

8. Set the page Dimensions back to the original size. The guide 

9. Click OK.
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Grids
Affinity offers non-printing grids similar to graph paper to help you position and 
align text and objects on your pages. Objects can be snapped to the grid to 
ensure exact alignment and the grid can be hidden when not required.

New documents measured in metric units will have an automatic grid of 10 mm 
while documents measured in imperial (North American) units will have a grid 
of 1 in. Documents measured in pixels will have a grid of 64 px.

The grid can be set differently on every document page and master page. A grid 
set on a document page will appear only on that page while a grid created on a 
master page will appear on all document pages based on that master. Unlike ruler 
guides, there is no visual difference between a grid set on a document page and 
one inherited from a master page.

Most users will find it better to set the grid for a master page rather than for 
individual document pages. If you set the grid for a document page, its master 
page’s grid will be ignored and all future changes to its master page’s grid will 
have no effect on the document page.

To show or hide the grid:

• Choose View > Show > Grid.

• Or choose View > Grid and Axis… and then select Show Grid.

To define a fixed grid:

1. To set the grid for a master page, use the Pages panel to go to that master 
page or choose Document > Pages > View Masters.

To set the grid for all pages of a document, create a master page specifically 
for the grid and apply that master page to all of your other master pages by 
dragging its page thumbnail onto the other master thumbnails one by one. 
Then, with the grid master page displayed in the document window, continue 
with the following steps.

To set the grid for one document page, use the Pages panel to go to that page.

2. Choose View > Grid and Axis…

Tip: There is not an 
option to reset a 
document page to its 
master page’s grid; 
you must re-apply the 
master page to the 
document page

Tip: There is not an 
option to show the 
grid behind text and 
objects

Tip: Some of the grid 
options are specific to 
illustration and are 
beyond the scope of 
this manual which is 
focused on page 
layout

Tip: The grid is shown 
only for the active 
spread—if you zoom 
out so that you can 
see multiple spreads 
at once, the non-active 
spreads will not have a 
grid

Tip: Refer to Snapping 
objects on page 240 
for more information 
on snapping objects 
to grids

Secondary grid lines

Primary grid lines

Tip: There is not an 
option to hide the grid 
below a specified view 
magnification level 
but the Automatic
mode will maintain 
the grid spacing 
regardless of the 
magnification
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3. To create a simple grid with equal horizontal and vertical spacing:

• Select Basic from Mode and set Spacing to the desired grid spacing.

4. To add thinner secondary lines between the thicker primary grid lines:

• Set Divisions to the number of grid cells between the primary grid lines. 
For example, with Spacing set to 50 mm and Divisions set to 5, there 
would be a line every 10 mm.

5. To create a grid with different horizontal and vertical spacing:

• Select Advanced from Mode and deselect Uniform. Set Spacing and 
Division in the First Axis as described above for the vertical lines and set 
the same options in the Second Axis for the horizontal lines. Set Gutter to 
add additional space between repeating blocks.

6. Click Close.

To change the colour of the grid for all documents:

You can set the colour of the grid but this a global setting and will affect all 
documents.

1. Choose View > Grid and Axis…

2. Click the colour sample for Grid Lines or Subdivision lines to change the 
primary (thick) and secondary (thin) grid line colours. Deselect the Link
icon to the right of the colour samples to set them separately.

3. To set the colour of Ruler Guides, click the colour sample below Horizontal 
Guides.

4. To set the colour of Column Guides, click the colour sample in this section. 
You can also change these guides from lines to shaded rectangles by setting 
Style to Filled. Set it back to Outlines to switch back to guide lines.

5. To set the colour of Margin Guides, click the colour sample in this section.

6. Click Close.
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Grid presets
Affinity allows you to save the current grid settings as a preset so that you can use 
the same settings in multiple documents.

To create a grid preset:

1. Choose View > Grid and Axis… and set the grid options for any page as 
desired.

2. Click the menu  icon beside the Preset list and choose Create Preset…
from the popup menu.

3. Enter a Preset name.

4. Optional: Select a Category to group the preset under.

5. Click Create.

To select a grid preset:

1. Choose View > Grid and Axis…

2. Optional: Set the grid options—this will impact the current page’s grid.

3. Select the preset name from the Preset list.

To change a grid preset’s name or settings:

1. Choose View > Grid and Axis…

2. Select the preset name from the Preset list—this will impact the current page’s 
grid.

3.  To change its settings: Set the grid options—this will impact the current 
page’s grid. Click the menu  icon beside the Preset list and choose Replace 
Preset… from the popup menu. Select the preset name from the Preset list in 
the Replace Preset window and click Replace.

4.  To rename the preset: Click the menu  icon beside the Preset list and 
choose Rename Preset… from the popup menu. Enter a new name in the 
Rename Preset window and click Replace.

To delete a grid preset:

1. Choose View > Grid and Axis…

2. Select the preset name from the Preset list—this will impact the current page’s 
grid so if you don’t want this use the Manage Presets… command.



88 Document setup

3. Click the menu  icon beside the Preset list and choose Delete Preset from 
the popup menu.

To set a grid preset as the default for new documents:

1. Choose View > Grid and Axis…

2. Select the preset name from the Preset list.

3. Click the menu  icon beside the Preset list and choose Set As Default from 
the popup menu. The preset name will be appended with [Default].

To remove the default grid preset:

1. Choose View > Grid and Axis…

2. Click the menu  icon the Preset list and choose Clear Default from the 
popup menu. Future documents will have an automatic grid using Affinity’s 
defaults as described the start of this topic.

To organize, import/export, or rename or delete a grid preset:

1. Click the menu  icon to the right of the Preset list and choose Manage 
presets… from the popup menu.

2. To rename or delete a preset, select a preset and click Rename or Delete.

3. To organize presets into categories, click Create Category…, enter a category 
name, and then click OK. Then drag presets into the category—a blue line 
will appear to indicate where the preset will be moved. If you have many 

Tip: You can only 
rename and delete 
your own grid presets 
and not the ones 
included with Affinity

Tip: The Preset 
Manager is shared 
with other parts of 
Affinity and includes 
linked categories, 
linking to the other 
applications in the 
suite, which don’t 
apply to Preflight 
because it is specific to 
Affinity
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presets, you can collapse and expand the categories by clicking their caret 
icon.

4. To rename a category, click the menu  icon to the right of the category list 
and choose Rename Category… from the popup menu. To delete a category, 
delete all of its presets or move them to another category and then click the 
menu  icon to the right of the category name and choose Delete Cate-
gory… from the popup menu.

5. To export grid presets to share them with another user or device, click Export 
User Presets… to export all presets, or to export just those in one category, 
click the menu  icon to the right of the category name and choose Export 
User Presets… from the popup menu. Both options will create an .afgrids file.

6. To import grid presets from an .afgrids file, click Import Presets… to import 
them exactly as they were exported. To import grid presets directly into a 
category, click the menu  icon to the right of the category name and choose 
Import Presets to Category… from the popup menu.
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Baseline grid
A document’s baseline grid will align the baseline of each line of text to horizon-
tal guides spaced equally from the top to the bottom of the page, regardless of the 
paragraph’s leading and paragraph before/after spacing. The baseline grid is like 
writing on ruled paper and is separate from the drawing grid which is used to 
snap objects to uniform grid.

The baseline grid is used to align text vertically across text frames and columns 
on a page and is essential for professional page layout. It is a best practice to set 
the baseline grid’s spacing to the paragraph leading value defined for your body 
text and to define leading as an exact value rather than using the default auto-
matic setting. Headings are typically spaced by a multiple of the baseline grid and 
leading values.

For example, for 12 pt body text, you might set paragraph leading to exactly 14 pt 
and your baseline grid to 14 pt. Because headings would likely be larger than 14 
pt they would have leading of 28 pt, double the baseline grid. You would nor-
mally set space before and after the paragraph to 0 or an increment of the base-
line grid because they would be ignored if they were less than the baseline grid.

While you don’t have to align text frames to the baseline grid—their text base-
lines will be aligned regardless—it is a best practice to align everything on the 
page to a multiple of the baseline grid so position and size frames after setting up 
the baseline grid.

The baseline grid normally starts at the top of the page or spread but you can 

Tip: To snap text 
frames to the baseline 
grid when drawing, 
moving, or scaling 
them, ensure that 
Snap to Baseline Grid
is selected in View > 
Snapping…

Tip: The baselines of 
text in art text and 
path text objects are 
not aligned to the 
baseline grid

Definition: The 
baseline is the invisi-
ble line on which the 
bases of characters 
without descenders 
are aligned

Baseline grid on: The 
text in this 2-column text 
frame is aligned to the 
baseline grid; the text 
frame is also aligned to 
the top margin which 
itself is a multiple of the 
baseline grid

Baseline grid off: The 
text in this 2-column text 
frame is not aligned to 
the baseline grid so the 
baselines of the text in 
the two columns are not 
aligned



Expert Guide to Affinity by Canva 3.0 91

customise the starting position or align the grid to the top margin; however, 
most designers start the baseline grid at the top of the page spread and set the top 
margin to a multiple of the baseline grid.

A document has only one baseline grid but you might choose to ignore or over-
ride the grid for specific text frames used for captions, quotations, or margin 
notes, or for data tables. Refer to Baseline grid on page 123 for more information 
on customising the baseline grid for text frames. You can even ignore the base-
line grid for specific paragraphs within a text frame.

Objects can also be snapped to the baseline grid. Refer to Snapping objects on 
page 240 for more information.

To set and show the baseline grid:

1. Choose View > Baseline Grid…

2. Select Use Baseline Grid and set the Grid Spacing to match the body text’s 
paragraph leading value. You can also set:

• Start Position: Enter a value to offset the baseline grid, the default of 0 is 
recommended for most documents.

• Relative to:

• Select Top of Spread (default) or Top of Page if the margins are set to an 
even multiple of the Grid Spacing value. These options will produce 
identical results except for a page in a multi-page spread that has a 
vertical (Y) offset.

• Select Top Margin if you prefer to set the top margin to a value that is 
not an even multiple of Grid Spacing. For example, if Grid Spacing is set 
to 12 pt and the top margin is set to 1 in (6p or 72 pt), the top margin 
would be an even 6 times the grid spacing. But if you set the top 
margin to 1.25 in (7p6 or 90 pt), the top margin would be an odd 7.5 
times the grid spacing. This is important because the main text frame is 
normally aligned to the top margin and you would not want it to be 
offset from the baseline grid.
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For most documents, Top of Spread (default) and Top of Page are identical; 
the latter is relevant only for facing-page documents arranged vertically 
which will restart the grid at the top of the spread’s bottom page.

• Grid spacing: Enter the amount that each baseline of text should be 
spaced from the line above it.

• Colour: Click the colour sample to set the colour of the baseline grid’s 
lines and drag the slider to change their opacity.

3. Select Show Baseline Grid. You can also change the Display Threshold value 
below which the baseline grid will be hidden.

4. Click Close.

5. Choose View > Show > Baseline Grid to see the grid’s lines when you zoom 
in to above the chosen display threshold.
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Viewing documents

Changing the view magnification
Affinity allows you to zoom out to see your entire document or zoom in to make 
precise changes. The current view magnification level is show in the Status
control at the bottom-right corner of the application window.

To use a preset view magnification level:

• Choose View > Zoom > Actual Size or 100% to display the document at the 
same size it would be printed. There is no difference between these com-
mands unless your document is measured in pixels, which is not a measure-
ment system normally used in publishing. You can also double-click the 
Zoom  tool for 100%.

• Choose View > Zoom > Zoom In and Zoom Out to change the magnifica-
tion by preset amounts. You can also select the Zoom  tool and click on the 
page to zoom in or hold ⌥ (macOS) or Alt (Windows) and click on the page 
to zoom out.

• Choose View > Zoom > Zoom to Fit to centre and display the entire spread 
in the window. You can also double-click the View  tool or double-click the 
centre of the spread’s thumbnail or its page numbers in the Pages panel.

• Choose View > Zoom > Zoom to Width to centre and display the entire 
spread horizontally in the window—the top and bottom of the spread might 
be cut off in smaller windows. If the window is sufficiently tall, this command 
will have the same effect as Zoom to Fit.

• Choose View > Zoom > Zoom to Selection to centre and display the selected 
object(s) in the window.

• Choose View > Zoom > Zoom to Document to centre and display all pages 
of the entire document in the window. This command is useful only for short 
documents.

To use a custom view magnification level:

• Enter a specific magnification level or drag the slider in the Context Toolbar
when the Zoom  or View  tools are selected.

• Enter a specific magnification level, drag the slider, or click the + and –icons 
in the Navigator panel.

Document modified indicator

Magnification levelDocument name
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• Scrubby Zoom: Select the View  tool and drag right on the page to zoom in 
or left to zoom out. If Use Scrubby Zoom is deselected in Settings > Tools, 
you must hold ⌥ (macOS) or Alt (Windows) to zoom in and out by dragging.

• Marquee Zoom: Hold ⌥ (macOS) or Alt (Windows) and drag diagonally on 
the page to define the area you want to fill the window. If Use Scrubby Zoom
is deselected in Settings > Tools, you do not need to hold down a key.

• Scroll to Zoom: Scroll the mouse wheel to zoom in and out. If Use Mouse 
Wheel to Zoom is deselected in Settings > Tools, hold ⌥ (macOS) or Alt
(Windows) to zoom using the mouse wheel.

• Pinch to Zoom: Pinch with two fingers on a trackpad to zoom in and out.

• Smart Zoom: Double-tap with two fingers on a trackpad to zoom in or out 
and back to the original magnification level. (macOS only)

To shift the page in the window:

• Scrollbars: Drag a scrollbar to scroll vertically or horizontally.

• Pan: Select the View  tool and drag on the page to pan it in the window.

• Slide to pan: Slide with two fingers on a trackpad to scroll.

• Navigator Thumbnail: Click or drag in the Navigator panel’s thumbnail to 
centre the page at that position in the window. When you are zoomed in and 
cannot see the entire page, a translucent grey rectangle will indicate the 
visible area.

Visible area indicator
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Saving view points
Affinity allows you to save the current position and magnification level as a view 
point in your document. For example, you could zoom in on one page and save 
that view point, navigate to another page and change the magnification level, and 
then jump back to where you were by selecting the saved view point.

View points are saved with the document but note that they are for specific page 
numbers and do not move with the page as you add and remove pages in your 
document. For example, if you saved a view point for your index and then added 
more pages before it, selecting the view point would take you to a different page.

To create a view point:

• Choose Save Current View Point from the panel menu .

To go to a view point:

• Select the view point from the panel’s list. The list will be visible when the 
document has at least one view point.

• Or select View > Move to Previous View Point or Move to Next View Point
to switch between view points.

To rename a view point:

• Select the view point and choose Rename View Point… from the panel menu 
. Enter a new name in the popup window and click OK.

To delete a view point:

• Select the view point and choose Remove Selected View Point from the panel 
menu .

Tip: If the view point 
you want is already 
shown as selected, 
simply select it again

Selected view point



96 Document setup

Preview mode
Preview mode allows you to hide all non-printing guides and grids so that you 
can focus on the design of your document.

To preview your document:

1. Choose View > Preview Mode or click the Preview Mode  icon in the 
Toolbar to toggle Preview Mode on and off.

2. Choose View > Show > Page Edges in Preview to toggle the display of the 
grey edges around spreads and between their pages in Preview Mode.

View Modes
Affinity allows you to select a view mode to change how a document is displayed 
on screen. View modes do not change how your document will be output.

• Vector: This is the default view mode for the Layout and Vector studios. It 
displays your document exactly as it was designed at the best possible qual-
ity. Most users will never need to switch from this view mode.

• Pixels and Pixels (Retina): Pixels is the default view mode for the Pixel
studio. It displays your document exactly as it would appear if exported to a 
bitmapped image and displayed on a standard display. Pixels (Retina) does 
the same for high-resolution displays.

• Wireframe, Outline and X-Ray: Outline displays objects as paths without 
fills and strokes so you can view and select objects behind other objects. X-
Ray is similar but fills have reduced opacity instead of being transparent to 
maintain more semblance of the design. Both of these modes are useful for 
working with complex illustrations.

• Hairline: All objects are displayed as thin paths like in a CAD application.

You can also divide the window in two to work in Split View with each half set to 
a different mode. You can can choose to hide colours and effects.

To change view modes:

1. Choose View > Mode and select a view mode or click the View Modes 
Switcher in the main Toolbar.

To select Wireframe or Pixels (Retina) which aren’t in the basic switcher, 
right-click the switcher and select Advanced.

Vector Wireframe Pixels Pixels (Retina)

Tip: The Hairline view 
mode is not available 
from the standard 
View Modes Switcher
but you can customise 
the toolbar and add 
another version of the 
switcher that includes 
Hairline

Active studio Inactive studio
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To hide colours and layer effects:

These commands do not change how your document will be output.

1. Choose View > Mode > Greyscale to display your document in colour or 
greyscale.

2. Choose View > Mode > Hide Effects to toggle the display of layer effects.

To divide the window into two view modes:

1. Choose View > Mode > Split View to divide the window into two halves.

2. You can work on either side of the view divider. The side you are currently 
working on will have a black tab at the bottom of the window while the other 
side will have a grey tab.

3. To change the view mode for a side, click that side to make its tab black and 
then select a view mode. To hide colours or layer effects for a side, click that 
side and then select one of those commands.

4. To restore the normal view, choose View > Mode > Single View.
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Entering and editing text in Affinity is similar to most applica-
tions but unlike a word processor, Affinity allows you to create 
and link your own text frames. You can also create text without 
using text frames.

Formatting text is somewhat more complex than in most appli-
cations due to the range of formatting options available. Text 
styles, which are explained in the next chapter, can be used to 
combine formatting options to ensure consistent formatting 
throughout a long document.

This chapter also details text frame properties which will allow 
you to style a text frame and control how text is displayed in it.

In this chapter
Text objects ..................................................................................................100
Text frames ...................................................................................................102
Shape text frames ......................................................................................105
Art text ...........................................................................................................106
Path text .........................................................................................................108
Flowing text ..................................................................................................111
Setting text frame properties ................................................................119
Word processing .........................................................................................125
Importing (placing) text ..........................................................................142
Formatting characters ..............................................................................147
Formatting paragraphs ............................................................................167
Setting default text formatting .............................................................192
Text wrap .......................................................................................................195
Pinning (anchoring) objects ...................................................................197

Basic text 3
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Text objects
All text entered in Affinity is contained within a text object. Affinity offers five 
types of text objects for different purposes:

• Text frame: Use text frames for the main text of your documents. Text frames 
can be linked together so that text flows from one frame to the next. Text 
frames can be divided into multiple columns so there is no need to draw 
separate frames for each column. Scaling a text frame scales the frame with-
out scaling the text size unless you use the content-scaling handle. Refer to 
Text frames on page 102 for more information on text frames.

• Shape text frames: Use shape text frames for special effects. Shape text objects 
are text frames that you have converted from a shape or closed path to a text 
frame. They function identically to text frames and can be divided into multi-
ple columns and linked to another text frame. Refer to Shape text frames on 
page 105 for more information on shape text frames.

• Art text: Use art text for short lines or blocks of text such as display type and 
labels. Art text objects are rectangular like standard text frames but they don’t 
have a constraining frame with a right edge to wrap lines of text so they are 
frameless and scaling them will scale the text size. Typing into an art text 
object will not wrap and will continue until you press Return to start a new 
paragraph or insert a line break. Art text objects can’t be linked together 
because they have no bottom edge. Refer to Art text on page 106 for more 
information on art text objects.

• Path text: Use path text to align the baseline of text to a curved or angled path 
for design effects. Typing into a path text object will continue until the end of 
the path is reached or until you press Return and then will continue on the 
other side of the path. Pressing Return multiple times will enter spaces. Scal-
ing path text will scale the path without scaling the text size. Path text objects 
can’t be linked together, but because the length of the path is finite, it is possi-
ble to overflow path text in the same manner as a text frame. Refer to Path 
text on page 108 for more information on path text objects.

• Tables: Use tables to organize information in rows and columns. Typing into 
a table cell will wrap at the cell’s right edge just as in a text frame. Press Tab to 
move the text cursor to the next cell. Tables are not described in this manual.

Tip: Art text is short for 
artistic text and is 
referred to as point 
text or frameless text in 
other applications; 
you can use them for 
any purpose, they 
don’t have to be 
artistic
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Text tools
Affinity provides three text tools to create text objects but once a text object is 
created you can edit text with any of the text tools.

Affinity works somewhat differently than other applications when it comes to 
creating point text or frameless text. Instead of clicking with an application’s 
single text tool to create point text, Affinity has separate tools for creating text 
frames and art text objects.

• Frame Text  tool: Select to create text frames and to edit the text in any type 
of text object.

• Artistic Text  tool: Select to create art text objects and to edit the text in any 
type of text object.

• Table  tool: Select to create tables and to edit the text in any type of text 
object.

Affinity doesn’t provide specific tools to create shape text frames and path text 
objects because those are created by converting shapes and paths to contain text 
using the commands in the Layer menu.

Stories
The text in a text object is referred to as a story so when you create a text object 
you are also creating a story, even though the text object will be blank until you 
enter text into it. The text in a series of linked text frames is a single story. Refer 
to Single vs. multiple stories on page 284 and Flowing text on page 111 for more 
information on stories.

All of the text in a table is a single story with tabs separating the text in each cell.

The Esc key
When text is selected, press Esc to deselect the selected text. The text cursor will 
appear at the end of the selected text range.

When text is not selected but the text cursor is in text, press Esc to remove the 
text cursor from the text. The text frame or object will be selected so that you can 
modify it instead of the text or press V to switch to the Move  tool.

When a text frame or object is selected and the text cursor is not in its text, press 
Esc to deselect the object.

Tip: To switch to the 
Move tool without 
having to consider 
whether or not text is 
selected, press ⌘
(macOS) or Ctrl
(Windows) + Enter

Definition: The term 
story refers to all the 
text in a text object or 
in a series of linked 
text frames
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Text frames
Text frames are used to contain the main text of a document but can be used for 
any purpose. Unlike word processors such as Microsoft® Word that have a fixed 
text frame on each page linked to the next page, Affinity allows you to create as 
many frames on each page as you like and link them in any direction. This flexi-
bility is what allows the laying out of newspapers, magazines, and newsletters 
that have articles continued elsewhere in the same publication.

When you create a new document with Affinity, its page(s) will be based on a 
default master page if Default master is selected on the Layout tab, but they 
won’t have any text frames. Text frames can be created on master pages or docu-
ment pages. You can edit the text in a master page’s text frame on a document 
page but not otherwise transform the frame, such as by moving or scaling it.

For a short document, you would likely create the text frames directly on the 
document page. For a long publication, it is best to create the document with a 
single page and to create the text frames on master pages to ensure layout consis-
tency and simplify later changes to the layout.

To create a text frame:

1. From Tools, choose the Frame Text  tool. The mouse pointer will change to 
a crosshair with the tool icon appended to it: 

2. Drag diagonally on a blank area of the page. While dragging:

• Hold ⌘ (macOS) or Ctrl (Windows) to draw outward from the centre.

• Hold Shift to constrain drawing to a square.

• Hold Spacebar to move the frame instead of continuing to change its size.

Release the mouse button to finish creating the text frame. Affinity will dis-
play the frame with handles to indicate it is selected and can be modified. If 
you have drawn a text frame on a master page, the frame’s handles will be 
non-editable when viewed on a document page that is based on the master to 
indicate that it can’t be transformed on the document page.

3. If you want more than one column on the same page you can adjust the 
number of columns and the gutter (space) between them with the Context 

A text frame on a document 
page: Round size handles can 
be used to modify the frame

Text frame on a master page: 
X‐handles indicate that the 
frame cannot be transformed

Content-scaling handle

Tip: You can override a 
master page on a 
document page to 
transform a text frame; 
refer to Overriding 
master page objects 
on document pages
on page 57

Definition: A text 
frame is a rectangular 
text container and can 
be linked to other text 
frames to flow text 
between and pages
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Toolbar at the top of the screen. This feature will divide the frame into multi-
ple columns that are permanently linked together and is simpler than draw-
ing multiple frames and then linking them together.

For asymmetrical column layouts, choose Document > Text Frame to display 
the Text Frame panel and expand the Columns section.

4. If you are creating a facing-pages publication then you should create text 
frames on both the left and right sides. You must link the two frames together 
on the master page so that document pages based on this master will have 
linked frames; otherwise, you’ll have to link them together on each facing-
page spread. Refer to To link a text frame on page 112 below for more 
information.

5. Optional: If the text frame is on a master page you can fill it with placeholder 
text to aid in visualizing your layout. Choose Text > Insert Filler Text.

If you added linked frames to a facing-pages master page and were to add more 
pages based on that master to the document now, the text frame on page 1 would 
not be linked to the text frame on page 2 although the frames on all of the newly-
created pages will would be linked. It is best to AutoFlow text or you’ll have to 
manually link the frame from page 1. Refer to AutoFlow text on page 117 for 
more information.

Moving and scaling text frames
To move or scale text frames:

1. To move the text frame, position the mouse pointer over its outline and drag.

2. To scale the text frame, drag the size handles at its corners and midpoints. 
The corner handles will scale the frame symmetrically and the midpoint 
handles will scale it asymmetrically unless you hold Shift while scaling. The 
font size will not change unless you drag the content-scaling handle at the 
bottom-right corner.

To scale the text object from its centre rather than the corner handle, hold ⌘
(macOS) or Ctrl (Windows) while dragging.

To scale the frame and text together, drag the content-scaling handle at its 
bottom-right corner. Hold Shift to scale it asymmetrically. The content-scaling 
handle will change to solid blue to indicate the frame’s text has been scaled. 
You can double-click the handle later to reset the content scaling to 100%.

3. To rotate the text frame, drag the rotation handle above the frame. You can 
also press ⌘ (macOS) or Ctrl (Windows) while dragging to rotate the frame 
around the opposite corner handle at the same time.

4. For more precise changes, enter new values for position, width, height, rota-
tion, and shear with the Transform panel.
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To fit a text frame to its text:

1. If there is overset (overflowing text) and it is not visible, click the red eye icon 
 to make it visible.

2. To fit all the text in the text frame, double-click the bottom-centre size handle 
to change the frame’s height or double–click the right-centre size handle to 
change the frame’s width.

To scale text so that it fits in a text frame:

1. If there is overset (overflowing text) and it is not visible, click the red eye icon 
 to make it visible.

2. Hold Shift and drag from the bottom-right size handle (the inner one) to scale 
the text frame. Release the mouse button when the text exactly fits inside the 
frame and no text is overset (overflowing).

3. Drag from the content-scaling handle to scale the text frame and the text 
inside it back to the frame’s original size.

To convert a text frame to art text:

1. Select the text frame with the Move  tool or any text tool.

2. Choose Layer > Convert to Art Text.

Tip: If the frame is 
linked to another 
frame you must unlink 
it first

Content-scaling handle

Size handle
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Shape text frames
In addition to creating standard text frames, Affinity allows you to convert any 
shape such as an ellipse, triangle, or path to a text frame. You can link these shape 
text frames just as you would any standard text frame.

You can manipulate both the text frame and shape properties for a shape text 
frame. When a shape frame is selected with the Move  tool, the Context Tool-
bar will show a combination of options for text and the original shape; for shape 
frames converted from paths, the Context Toolbar will show the standard text 
options. When a shape frame is selected with the Node  tool, the Context 
Toolbar will show the options for the original shape or path.

All other features of shape text frames are the same as standard text frames.

To convert a shape to a text frame:

Once converted to a text frame, there is no way to convert shape text back to a 
standard shape. It’s not important because you can format the shape text frame 
just as you would a standard shape but the Context Toolbar will show several 
text attributes instead of all the object attributes.

1. Draw a shape using the appropriate shape tool or draw a path with the Pen
tool.

2. Convert the shape to a text frame by doing one of:

• Select the shape and using the Frame Text  tool, click inside the shape to 
position the text cursor. When over the shape, the mouse pointer will 
change to a crosshair with a T inside of a shape: 

• Or with the shape selected, choose Layer > Convert to Text Frame.

• Or right-click the frame and choose Convert to Text Frame.

Definition: A shape 
text frame, commonly 
referred to as shape 
text, is a text container 
that functions identi-
cally to standard text 
frames but retains the 
properties of its 
original shape

Tip: The Context 
Toolbar shows differ-
ent options for 
selected text frames 
and shapes and there 
isn’t room to show 
both sets of options at 
the same time so you 
may need to use other 
panels to access 
options that you 
would normally find in 
the toolbar

Tip: If you do not close 
a path before convert-
ing it to a shape frame, 
an invisible line will 
between the start and 
end points will act as 
the frame’s edge
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Art text
Art text objects are used for short lines or blocks of text such as display type and 
labels. Art text objects are rectangular like standard text frames but they don’t 
have a constraining frame with a right edge to wrap lines of text so they are 
frameless. Scaling art text will scale the text size.

Art text is frequently used in short, design-intensive documents such as 
brochures and posters. It’s sometimes better to use a text frame even for short 
blocks of text such as a caption because a frame provides a right edge to which 
text can be aligned. For example, all of the captions in this manual are text 
frames and not art text.

Typing into an art text object will not wrap and will continue until you press 
Return to start a new paragraph or insert a line break. Most art text objects are a 
single line but you can type an almost unlimited number of lines and paragraphs 
of text.

Art text objects can’t be linked together because they have no bottom edge that 
would cause text to overflow.

To create art text:

1. From Tools, choose the Art Text  tool. The mouse pointer will change to a 
crosshair with the tool icon appended to it: 

2. Click on a blank area of the page to create a new art text object with the 
current font size.

Or drag diagonally on a blank area of the page to define a custom text size.

Affinity will display an empty text object with handles to indicate it is selected 
and can be modified. If you have created an art text object on a master page, 
the frame’s handles will be non-editable when viewed on a document page 
that is based on the master to indicate that it can’t be transformed on the 
document page.

Art text object when first created: 
Round size handles can be used to 
modify the font size; the bounding box is 
wide enough to enclose the End of Story 

 symbol even if Text > Show Special 
Characters is not selected

Art text object after 
typing text: The bounding 
box changes to match the 
size of the characters 
typed

Art text object on a 
master page: X‐handles 
indicate that the object 
cannot be transformed

Definition: Art text is 
a frameless text object 
commonly used for 
display type and is 
known as point text or 
frameless text in other 
applications
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To move or scale art text:

1. To move the text object, position the mouse pointer over its outline and drag.

2. To scale the text object, drag the size handles at its corners and midpoints. 
The corner handles will scale the text symmetrically and the midpoint han-
dles will scale it asymmetrically unless you hold Shift while scaling.

To scale the text object from its centre rather than the corner handle, hold ⌘
(macOS) or Ctrl (Windows) while dragging.

3. To rotate the text object, drag the rotation handle above the text object. You 
can also press ⌘ (macOS) or Ctrl (Windows) while dragging to rotate the 
object around the opposite corner handle at the same time.

4. For more precise changes, enter new values for position, width, height, rota-
tion, and shear with the Transform panel.

To convert art text to frame text:

1. Select the art text object with the Move  tool or any text tool.

2. Choose Layer > Convert to Text Frame. You can also right-click the text 
object and choose Convert to Text Frame from the context menu but only 
with the Move tool selected.
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Path text
Path text objects are used to achieve special design effects by aligning the base-
line of their text to a curved or angled path.

Typing into a path text object will continue until the end of the path is reached or 
until you press Return and then will continue on the other side of the path. 
Pressing Return multiple times will enter spaces.

Any path can be converted to a path text object, including closed paths. Path text 
objects can’t be linked together, but because the length of the path is finite, it is 
possible to overflow path text in the same manner as a text frame.

Overflow control meaning

 The selected path text has hidden overflowing text: click the Eye to view it

 The selected path text has visible overflowing text: click the Eye to hide it

To create path text:

1. Draw a path using the Pen  tool.

Or draw a shape and convert it to a path by selecting it and choosing Layer > 
Convert to Curves.

2. Using the Context Toolbar, set the path’s stroke to solid to make it easier to 
work with, even if it will eventually be turned off.

3. Convert the path to a text path by doing one of:

• Select the path using the Move  tool, and then using the Art Text  tool, 
click on the path. When over the path, the mouse pointer will change to a 
crosshair with a T on a path: 

• Or with the shape selected, choose Layer > Convert to Text Path.

4. Select the path text object with a text tool and type onto the path. Green and 
red triangles will indicate the start and end of the path. Optional: Drag the 
triangles to limit the amount of the path used for text.

5. Set the paragraph alignment to centred if appropriate or scale the text to fill 
the path.

Tip: After conversion 
to a path, you can set 
the path’s fill and 
stroke with the Text 
Frame panel

Ellipse converted to a path and 
text centred on its first side

After pressing Return and 
typing text for the second side

After adjusting the baseline 
offset for the second side

Definition: Path text, 
sometimes referred to 
as a text path, is a text 
object that curves the 
baseline to align to the 
path
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6. Press Return to start a new paragraph on the other side of the path. Dark 
green and red triangles will indicate the start and end of the second side. 
Drag these triangles to limit the amount of the second side used for text. 
Affinity can snap the triangles to the 25%, 50%, and 75% points along the 
path to help you align the triangles with logical points. This is especially 
useful with ellipses and other regular shapes.

If you type more text than will fit on the first side, the text will flow to the 
second side automatically without pressing Return.

7. Set the paragraph alignment and baseline offset to position the text on the 
path and adjust tracking to avoid character collisions. Fonts are designed so 
that characters are positioned on a straight baseline so you may need to adjust 
tracking to avoid characters colliding if the path includes sharp turns.

To switch text to the other side of the path:

1. Click the Reverse Text Path  icon in the Context Toolbar and the text will 
switch to the other side of the path. The green and red triangles used to limit 
the amount of the path used for text wil change sides.

To move or scale a path text object:

1. To move the path text object, position the mouse pointer over its outline and 
drag.

2. To scale the path but not the text, drag the size handles at its corners and 
midpoints. The corner handles will scale the text symmetrically and the 
midpoint handles will scale it asymmetrically unless you hold Shift while 
scaling.

To scale from its centre rather than the corner handle, hold ⌘ (macOS) or Ctrl
(Windows) while dragging.

To scale the path and text together, drag the content-scaling handle at its 
bottom-right corner. Hold Shift to scale it asymmetrically. The content-scaling 
handle will change to solid blue to indicate the path’s text has been scaled. You 
can double-click the handle later to reset the content scaling to 100%.

3. To rotate the path text object, drag the rotation handle above the text object. 
You can also press ⌘ (macOS) or Ctrl (Windows) while dragging to rotate the 
object around the opposite corner handle at the same time.

Ellipse converted to a path and 
text centred on its first side

After pressing Return and 
typing text for the second side
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4. For more precise changes, enter new values for position, width, height, rota-
tion, and shear with the Transform panel.

To convert a path text object back to a path:

There isn’t a direct way to convert a path text object back to a path and delete its 
text but it’s easy to do.

1. Select the path text object with any tool and choose Layer > Convert to 
Curves.

2. Using the Layers panel, click the caret  icon to the left of the group to 
expand it. Drag the original path (curve) layer out of the group; it will be the 
bottom object in the group.

3. Delete the group. If there was text in the path text object, the characters 
would have been converted to individual curve layers which can be deleted.
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Flowing text
You can link and unlink text frames at any time to flow text from one frame to 
the next. When you link two frames together their stories are joined into a single 
story. If the text frames were empty this won’t make any difference but if they 
both contained text then the first character of the second frame’s story will 
immediately follow the last character of the first frame. Ensure that there is a 
paragraph return at the end of the first story before linking two filled text frames.

When you unlink two frames, all of the text from the story will be in the frame 
before the broken link while the frame(s) after the broken link will be empty—
they will have a new blank story.

The end of a story is marked by the End of Story  symbol, a special character 
you can see by selecting Text > Show Special Characters. The symbol will be 
shown at the end of the story text, or if the frames are empty, at the top-left of the 
story’s first text frame.

Every text frame has two controls that define the flow of text in and out of the 
frame. The Text Flow In control near the top-left corner is used to link to a 
previous frame while the Text Flow Out control near the bottom-right corner is 
used to link to the next frame. These controls will have a hollow icon if the frame 
is not linked in that direction or a solid icon if it is linked.

The Text Flow In and Out controls will change from blue to red if the story text 
for the text frame or frames is overflowing.

Text Flow control meaning

 The selected frame is not linked in this direction

 The selected frame is linked in this direction

 The selected frame has overflowing text or is linked to an overflowing frame

 The selected frame is linked to a frame with overflowing text

 The selected frame has hidden overflowing text: click the Eye to view it

 The selected frame has visible overflowing text: click the Eye to hide it

 The selected frame has hidden overflowing whitespace; ignore this

 The selected frame has visible overflowing whitespace; ignore this

 The deselected frame has overflowing text or is linked to an overflowing frame*

* Shown only when 
View > Show > Text 
Flow is enabled

Text Flow In

End of story

Text Flow Out

Definition: The Text 
Flow In and Out
controls will be hidden 
if you zoom out too far 
due to lack of space
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To link a text frame to an existing unlinked frame:

1. Choose View > Show > Text Flow if it is not already selected so that you can 
see the outlines of text frames and their connecting lines.

2. From Tools, choose the Frame Text  tool or the Move  tool.

3. Click the first text frame’s triangular Text Flow Out control  toward its 
bottom-right corner; the mouse pointer will change to a link arrow  when 
you are within range to click it. The frame will turn solid blue after you click 
it.

4. Move the mouse pointer over the second text frame. It will turn blue when 
you are within range to click it.

5. Click anywhere on the second text frame. A non-printing text flow line will 
be shown between the frames.

If the text in the frame you linked to is scaled larger or smaller than it should 
be compared to the first frame, you likely scaled that frame’s contents with the 
content-scaling handle. This handle is below and to the right of the bottom-
right size handle and scales the frame and the text in it together. The handle 
will be solid blue when text in the frame is scaled and a blue circle when the 
frame is unscaled. Double-click the solid blue handle to restore a frame to 
unscaled text.

Content-scaling handle

Content-scaling handle

Unscaled content Scaled content

Tip: If you find the 
Text Flow In and Out
controls are too small, 
you can increase their 
size; open Settings
…(Preferences), select 
Tools in the left pane, 
and select a different 
Tool Handle Size
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To create a new frame linked to an existing one:

1. Choose View > Show > Text Flow if it is not already selected so that you can 
see the outlines of text frames and their connecting lines.

2. From Tools, choose the Frame Text  tool or the Move  tool.

3. Instead of creating the second text frame before linking the first to it, click the 
first frame’s triangular Text Flow Out control  toward its bottom-right 
corner. The mouse pointer will change to a link arrow  when you are within 
range to click it and the frame will turn solid blue after you click the control. 

4. Now draw a new text frame on the desired page and Affinity will link the first 
frame to the new one.

To add a text frame between two linked frames:

1. Choose View > Show > Text Flow if it is not already selected so that you can 
see the outlines of text frames and their connecting lines.

2. From Tools, choose the Frame Text  tool or the Move  tool.

3. If you have already created the new text frame:

• Click the first frame’s triangular Text Flow Out control  toward its 
bottom-right corner. The mouse pointer will change to a link arrow
when you are within range to click it and the frame will turn solid blue 
after you click the control.

• Move the mouse pointer over the new text frame. It will turn blue when 
you are within range and then click anywhere on it. Affinity will link the 
first frame to the new one, and link the new frame to the frame which the 
first had been linked to.

4. If you haven’t already created the new text frame:

• Click the first frame’s triangular Text Flow Out control  toward its 
bottom-right corner. The mouse pointer will change to a link arrow
when you are within range to click it and the frame will turn solid blue 
after you click the control.

• Draw a new text frame and Affinity will link the first frame to the new 
one, and link the new frame to the frame which the first had been linked 
to.

To remove a text frame from the middle of a series of linked frames:

1. From Tools, choose the Move  tool.

2. Select the text frame to remove.

3. Choose Edit > Delete or press Backspace—the frame will be deleted and the 
previous text frame will be linked to the next frame in the series.
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To unlink text frames:

1. Choose View > Show > Text Flow if it is not already selected so that you can 
see the outlines of text frames and their connecting lines.

2. From Tools, choose the Frame Text  tool or the Move  tool.

3. Select the text frame that you want to unlink. To unlink it from the next 
frame, click its triangular Text Flow Out control  toward its bottom-right 
corner or to unlink it from the previous frame click the matching Text Flow 
In control near the top-left corner. The mouse pointer will change to a link 
arrow  when you are within range to click it. The frame will turn solid blue 
after you click it.

4. Mouse anywhere over the text frame. The mouse pointer will change to a link 
arrow .

5. Click anywhere on the text frame to unlink it. The story for the linked frames 
will now be entirely in the frame(s) before the one you unlinked from and any 
text that does not fit will be overset (overflowing). The frame after the point at 
which you unlinked will have a new blank story.

To split a story when unlinking frames:

Affinity doesn’t provide an automatic way to split a story between frames but it’s 
not hard to copy and paste the text. Follow the instructions above to unlink text 
frames and then follow these steps.

1. Ensure you have a keyboard shortcut for Select Story End. Unless you have 
changed it, the shortcut will be Shift + ⌘ + End (macOS) or Shift + Ctrl + End
(Windows). 

If you use a keyboard without an End key you will need to modify the default 
shortcut first because you’ll be unable to type it. Go to Settings… (Prefer-
ences), select Shortcuts in the left pane, and choose Text Input from the 
second list (the one that defaults to Affinity). Scroll down the list of shortcuts 
until you find the one for Select Story End and change it to something that 
works for your keyboard. The arrow pointing down to the right in this macOS 
screenshot is for a Mac’s End key.
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2. From Tools, choose the Frame Text  tool.

3. Position the text cursor at the end of the text in the last frame before you 
unlinked.

4. Press the keyboard shortcut for Select Story End to select all of the text from 
the text cursor to the end of the story. All of the text that is overset (overflow-
ing) from the text frame will now be selected even though you can’t see it.

5. Choose Edit > Cut to cut the text to the pasteboard (clipboard).

6. Click in the empty text frame where you want the text to appear and then 
choose Edit > Paste to paste the text into the frame.

If you split a story that has anchors generated by the Table of Contents feature, 
the links between the table of contents and the anchors will be broken and Affin-
ity will insert duplicate anchors when you next update the table. If you don’t want 
the duplicate anchors, delete them before updating the table of contents.

If you split a story that includes the targets for cross-references the cross-refer-
ences will be broken because their target will be missing. To fix these, double-
click each cross-reference that has a Target Missing  icon in the Cross-Refer-
ences panel and reselect the target.

Tip: If the missing 
targets were to 
anchors generated by 
the Table of Contents 
feature, fix the table of 
contents first
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To move text from linked frames on document pages to master pages:

A common issue for new Affinity users is to have created linked text frames on 
document pages instead of master pages and then needing to change the size and 
position of each frame. There is no simple solution to that so it’s usually better to 
switch to using text frames on master pages. Making this change will be time 
consuming but it will simplify all future changes. 

1. Select View > Show > Text Flow if it is not already selected to make it easier 
to work with text frames.

2. Using the Frame Text  tool, draw a new text frame of the correct size on a 
master page. If the document is facing pages, draw frames on both sides and 
link them together by clicking the Text Flow Out control  near the left 
frame’s bottom-right corner and then clicking anywhere on the right frame.

3. If the master page is not already applied to the pages with document frames, 
use the Pages panel and right-click the first of the required page spreads and 
choose Apply Master. Select the master page name and click OK.

4. Double-click the thumbnail of the first of the pages to view it.

5. Position the text cursor in the original text frame that is on the document 
page—the new master page text frame will be below it.

6. Choose Edit > Select All and then Edit > Cut to cut all text from the story to 
the pasteboard (clipboard).

7. Using the Move  tool, choose Edit > Delete. If it’s a facing pages document, 
delete the original frames from both sides.

8. The blank text frame inherited from the master page should now be visible. 
Double-click it which will switch to the Frame Text  tool and position the 
text cursor in the frame.

9. Choose Edit > Paste to paste all of the text you previously cut.

10. All of the pages after the current one that previously contained text will now 
be blank. Select all of their thumbnails in the Pages panel and click the Delete 
Selected Pages  icon.

11. Double-click the thumbnail of the page in which you pasted the text.

12. Select or click in the text frame.

13. Press Shift and click the red Text Flow Out control  near the overflowing 
text frame’s bottom-right corner; the mouse pointer will change to a link 
arrow  when you are within range to click it. Affinity will create as many 
new pages based on the same master page and link all their frames together 
automatically.

Tip: Ensure you right-
click the spread and 
not one side of a 
facing-pages spread or 
you will apply the 
master to only one 
side
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AutoFlow text
Affinity doesn’t create additional pages automatically if there’s too much text to fit 
in a text frame or in the last text frame of a series of linked frames. The excess 
text, known as overset text, will be hidden by default.

When there is overflowed text Affinity will change the Text Flow controls from 
blue to red and the last text frame will have an eye icon to indicate if the over-
flowing text is hidden  or visible  below the frame. Refer to the list of text 
flow control shapes and colours in Flowing text on page 111 for more informa-
tion.

You could create additional text frames to contain the overflowed text but Affin-
ity can do this for you. AutoFlow will create as many additional pages of text 
frames as required to contain all the text in a story, all linked together automati-
cally. AutoFlow will first create a text frame on the next blank page in the current 
section and will create a page if there isn’t a blank one. Affinity does not have an 
option to AutoFlow text only at the end of the current story.

To AutoFlow text to as many new text frames as required:

1. From Tools, choose the Frame Text  tool or the Move  tool and then click 
in or select the text frame.

2. Press Shift and click the red Text Flow Out control  near the overflowing 
text frame’s bottom-right corner; the mouse pointer will change to a link 
arrow  when you are within range to click it. Affinity will create as many 
pages of text frames as required.

Tip: Text frames 
created by AutoFlow 
will match the settings 
and even shape of the 
last frame in the story

Tip: AutoFlow will 
create text frames on 
pages with master 
page text frames that 
aren’t actually blank

Tip: In a document 
with just the single 
default section, 
AutoFlow will create 
new pages at the end 
of the document

Tip: AutoFlow is not 
fully automatic, you 
must direct Affinity to 
automatically flow text 
each time a text frame 
is overset

Overflowing
text
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To AutoFlow text to a single new text frame:

1. From Tools, choose the Frame Text  tool or the Move  tool and then click 
in or select the text frame.

2. Press ⌥ (macOS) or Alt (Windows) and click the Text Flow Out control 
near the text frame’s bottom-right corner; the mouse pointer will change to a 
link arrow  when you are within range to click it. If the new frame is not 
large enough to contain overflowing text, it will also have a red Text Flow Out
control.

Interrupting text flow
You can interrupt the flow of story text to force it to start at the top of a new 
column, frame, or page by inserting a break. Using breaks is preferable to adding 
blank lines because if you add or remove text earlier in the story, you can be 
assured that the text after the break will remain at the top of the column, frame, 
or page.

To insert a break:

1. Position the text cursor before the text you want to shift to the new column, 
frame, or page.

2. Choose Text > Insert > Breaks and select one of the following:

Break type Description Symbol

Column break Forces text to the next column, regardless of
 whether that column is in the same frame or in the 
 next linked frame

Frame break Forces text to the next text frame

Page break Forces text to the next page, even if there are other
 linked frames before it 

Odd page break Forces text to the next odd page, even if there are 
 other linked frames before it 

Even page break Forces text to the next even page, even if there are 
 other linked frames before it 

Tip: Choose Text > 
Show Special Charac-
ters when working 
with breaks to see 
their invisible symbols 
and avoid accidentally 
deleting them
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Setting text frame properties
Text frames and other text objects have properties to control their appearance 
and change how text within them is displayed. New text objects will be created 
with the properties you last used. Some properties can be changed directly from 
the Context Toolbar but most require use of the Text Frame panel.

Using the Text Frame panel
To display the Text Frame panel:

1. Click the Show Text Frame panel  icon in the Context Toolbar or choose 
Window > Text > Text Frame to display the Text Frame panel.

Panel menu

Expand/collapse section

Indent text from the frame

Show/hide overflowing 
text below frame

Balance columns without 
inserting a column break

Add a rule between 
columns

Use a different baseline 
grid than the document

Set frame stroke and colour

Ignore objects with text wrap
Ignore document’s baseline grid

Set frame background colour

Align text vertically

Add/remove columns

Customise column widths and 
gutters

Tip: The Text Frame
panel is misleadingly 
named because it is 
used to change the 
properties of all text 
objects, including art 
text and path text; 
controls that don’t 
apply to art text or 
path text will be 
disabled



120 Basic text

2. Collapse and expand the panel’s sections by clicking the caret  icons to the 
left of their titles.

General

The General section of the panel allows you to change the text object’s fill and 
stroke and the inset of the text from a frame’s edges.

• Fill: Click the colour sample to set the colour of the text object’s fill.

• Stroke: Click the colour sample to set the colour of the text object’s stroke 
(outline) and click the stroke control on its right to set its thickness, dash 
pattern, and other properties.

• Insets: Enter values for how much text should be inset from a text frame’s 
borders. Click the Link icon to their right so that they all change together.

• Hide Overflow: Select to hide overflowing text for a text frame or path text or 
deselect to show the overflowing text below the frame or after the end of the 
path. You can also click the Text Flow Out  control to toggle this setting 
on and off.

• Ignore Text Wraps: Select so that text in the frame will not wrap around 
objects with text wrap set.

• Ignore Baseline Grid: Select so that text in the frame will not be aligned to 
the document’s baseline grid. Selecting this option will disable Independent 
Baseline Grid at the bottom of the panel.

Tip: Disable Hide 
Overflow if you want 
to edit the overflow-
ing text to make it fit 
in the frame

Tip: Specify Insets
when you assign a fill 
or stroke to a text 
frame to avoid having 
the text immediately 
adjacent to the frame’s 
borders

Tip: Although art text 
and path text are 
frameless text objects, 
the Text Frame panel
allows you to set their 
fill colour and stroke

Tip: Refer to Fill, 
stroke, and colour on 
page 249 for more 
information on 
selecting colours
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Columns

The Columns section of the panel allows you to set the number of columns, the 
gutter (space) between them, and whether text should be balanced across the 
columns.

• Columns: Enter the number of columns to create within the text frame. You 
can also choose this from the Context Toolbar.

• Width: Specify the width of each column. Select Preserve Width to maintain 
the width of the frame when changing a column’s width or deselect it to 
preserve the width of the adjacent column. You can also set column widths by 
dragging the column edges in the text frame.

• Gutter: Specify the space between columns. By default, the gutters are linked 
so changing one value will change them all. Click the Link icon to the right of 
the Gutter label to change the gutter values separately. You can also specify 
gutter from the Context Toolbar but not separately for each pair of columns.

• Balance text in columns: Select to distribute text evenly across the columns 
in a text frame. This will have no effect if the story is longer than the text 
frame.

Balanced columns off Balanced columns on
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Column rules

The Column Rules section of the panel allows you to specify if a rule should be 
drawn between multiple columns and how the rule should appear.

• Stroke: Click the colour sample to set the colour of the vertical rule (line) 
between columns and click the stroke control on its right to set its thickness, 
dash pattern, and other properties.

• Gap: Enter how much the rule should be inset from the top or bottom of the 
frame—you cannot enter negative values to extend the rule outside of the 
frame.

Vertical position

The Vertical Position section of the panel allows you to set how the text should 
be vertically aligned within the frame and the baseline of the first line of text.

• Alignment: Choose whether to align text to the top, centre, or bottom of the 
text frame, or whether it should be vertically justified (distributed). You can 
also choose this from the Vertical Alignment  icon in the Context Tool-
bar or from the Text > Vertical Alignment menu.

• Maximum Paragraph Space: When text is vertically justified, enter the 
maximum space between the baseline of the last line in one paragraph and 
the first baseline of the next.

• Initial Advance: Choose how the baseline of the first line of text in the frame 
is positioned relative to the top inset of the frame:

• Default: For a standalone text frame, this is the same as Cap Height, it 
uses the largest cap height of all the characters on the first line as the 
baseline value. For a text frame pinned in another frame or for a footnote 
or sidenote, it defaults to the Initial Advance value of the parent frame.

• Leading: Uses the first paragraph’s leading as the baseline value.

• Pointsize: Uses the largest point size of all the characters on the first line as 
the baseline value.

• Ascent: Uses the largest ascent of all the characters on the first line as the 
baseline value to ensure that the top of a lowercase “d” fits inside the top 

Tip: Set the maximum 
to the height of the 
text frame to add 
space only between 
paragraphs and not 
lines
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inset of the frame; for most fonts there will be space between the top of the 
frame and the top of the “d”.

• Cap Height: Uses the largest cap height of any character on the first line as 
the baseline value to align the flat tops of uppercase letters with the top 
inset of the frame; rounded or pointed tops may appear above.

• X Height: Uses the largest x height of any character on the first line as the 
baseline value.

• Fixed: Specify the baseline value in Minimum; a value of 0 will set the 
baseline to the top inset of the frame.

• Minimum: Enter a minimum value for the baseline; will have no effect unless 
you enter a value greater than it would otherwise be

Baseline grid

The Baseline Grid section of the panel allows you to override the document’s 
baseline grid for a text frame. These options are disabled if you select Ignore 
Baseline Grid near the top of the panel.

• Use Independent Baseline Grid: Select to override the document’s baseline 
grid; refer to Baseline grid on page 90 for more information.

• Start Position and Relative to: Enter an offset from the top of the page, top 
margin, top of the frame, or its top inset. You can also set the start position 
relative to the artboard but that feature is less relevant in Affinity.

• Colour: Click the colour sample to set the colour of this baseline grid to 
differentiate it from the document’s baseline grid.

Independent baseline grid off Independent baseline grid on

Tip: To see the base-
line grid, choose View
> Show > Baseline 
Grid; note that the 
grid will not be shown 
if you zoom out below 
the threshold set with 
View > Baseline 
Grid…
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To align only the first line to the baseline grid:

Often in magazines and reports, only the first line of an image caption or sidebar 
will be aligned to the document’s baseline grid.

1. Align the top of the image caption or sidebar’s text frame with the document’s 
baseline grid.

2. Using the Text Frame panel, select Baseline Grid > Use Independent Base-
line Grid.

3. Set Start Position to the document’s baseline grid value.

4. Set Relative To to Top of Frame.

5. Set Grid Spacing to the leading used in the image caption or sidebar.
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Word processing

Positioning the text cursor
To position the text cursor with the mouse

1. Choose the Frame Text , Artistic Text , or Table  tool.

2. Position the mouse pointer  between the characters where you want to make 
changes and click the mouse. You can click anywhere on an empty text frame.

A blinking vertical bar will appear to represent the text cursor position, also 
known as the insertion point.

To change the position of the text cursor with the keyboard:

1. Press one of the following keyboard shortcuts. You can press all of the keys at 
the same time, or the modifier keys first (⌘, Shift, Ctrl) followed by the action 
key (such as an arrow key).

Action macOS Windows

Move one character left or right � or � � or �

Move one line up or down ↑ or ↓ ↑ or ↓

Move to the start or end of the current word and then to ⌘ + � or � Ctrl + � or �
subsequent words

Move to the start or end of the current paragraph and then to ⌘ + ↑ or ↓ Ctrl + ↑ or ↓
subsequent paragraphs

Move to the start or end of the current line fn + � or � Home / End

Move to the start or end of the story fn + ⌘ + � or � Ctrl + Home / End

Text cursor

Tip: If you’ve changed 
your shortcuts by 
choosing Apple 
Defaults (macOS only) 
or creating custom 
shortcuts, your actual 
modifiers may vary
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Typing text
To type basic characters:

1. Position the text cursor in a text frame or other text object.

2. Enter text as you would in any text editor or word processor. Affinity will 
automatically wrap text to a new line when it reaches the right edge of the text 
frame or table cell. For an art text object, you must press Return to start a new 
paragraph.

3. Press Return to start a new paragraph or Shift + Return to start a new line 
within a paragraph.

4. Press Delete (macOS) or Backspace (Widows) to erase characters, including 
erasing a paragraph or line break.

To type special characters:

1. Position the text cursor in a text frame, art text object, or table.

2. Type the character’s Unicode value and choose Text > Toggle Unicode, or 
choose Text > Insert and select from the list.

3. Choose Text > View Special Characters to show the invisible symbols for 
special characters.

To select characters from a list of those available in the selected font:

Affinity allows you to select characters to insert from a visual browser.

1. Position the text cursor in a text frame or other text object.

2. Choose Window > Text > Glyph Browser to display the Glyph Browser
panel.

3. Affinity will select the Font Family and Font Style automatically based on the 
text cursor position but you can change these options. Affinity will display a 
list of all of the characters (glyphs) for the selected font. If the glyphs are too 
small, choose Large Size or Largest Size from the panel menu . 

Panel menu

Lock Font Family and Font Style (Traits)

Subset (Unicode block)

Search

Font Family and
Font Style (traits)

Recently used

Tip: A list of the most 
common special 
characters is provided 
in Appendix A on page 
467
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4. Select the Subset (Unicode block) to reduce the number of characters shown 
and find one more easily. You can search for glyphs by name; for example, 
type “a” into Search to filter the list to glyphs that include “a” in their Unicode 
names, including all of the variations with accents, or type “acute” to see 
glyphs that include an acute accent.

5. Double-click a glyph symbol to insert it at the text cursor position. The glyph, 
including the font family and font style (traits) selected will be added to 
Recently used in case you need to insert it again this session. Choose Clear 
Recently Used from the panel menu  to clear the list of recently-used 
characters.

6. Select the Lock Font Family and Font Style (Traits)  icon to prevent the 
font family and style from changing automatically when you position the text 
cursor in text with different formatting. 

macOS users can also use the system-wide Emoji & Symbols feature but while 
it’s the best choice for inserting the wide range of emojis, it’s not as useful for 
inserting standard characters and typographic symbols because it’s harder to 
know what characters are available in certain fonts.

To insert filler text, also known as placeholder text or lorem ipsum:

1. Position the text cursor in a text frame; filler text cannot be inserted in other 
types of text objects.

2. Choose Text > Insert Filler Text. Affinity will fill the text frame (and any 
linked frames) with enough filler text to fill all of the frames. There will never 
be overflowing text even if you reduce the size of a frame because Affinity will 
add and remove filler text automatically.

The filler text is actually a text field so it will not be directly editable unless 
you right-click it and choose Expand Field from the context menu.

3. To modify the Insert Filler Text command to always insert filler text as 
regular, editable text, choose Affinity > Settings…, click General in the left 
pane, and then select Text > Insert filler text as text.

4. To modify the filler text that is inserted, choose Affinity > Settings…, click 
Filler Text in the left pane, select the language you wish to customise, enter 
the new filler text, and click Save as Default. Refer to Filler text on page 461 
for more information.

Tip: You can change 
the sort order from 
Unicode ID to Glyph ID
but this is not recom-
mended as the same 
Glyph ID may be used 
for a different charac-
ter in another font

Tip: You can only save 
filler text as the default 
with an open 
document

Tip: Many Unicode 
character names are 
descriptive so typing 
“a” will display unex-
pected results
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Selecting text
Before you can modify text and applying formatting, you need to select the text 
using the Frame Text , Artistic Text , or Table  tool.

• Select any range of text: Click the mouse pointer  at the start or end of the 
text you want to select and then drag to the other end. Affinity will indicate 
the selected text by highlighting it. If you drag past an edge of the document 
window then Affinity will scroll the page in the window automatically.

Or click the mouse pointer at the start or end of the text and Shift + click at 
the other end.

• Extend or shorten the selected text range: Hold Shift and click again to select 
the text from the start of the text selection range to where you clicked.

• Select an additional range of text without deselecting the selected text: Hold 
⌘ (macOS) or Ctrl (Windows) and click. This modifier key enables you to 
select multiple disconnected ranges of text in the same story.

• Select a word, line, or paragraph: Double-click to select a word, triple-click 
to select a line of text, or quadruple-click to select an entire paragraph.

To select an entire story, quintuple-click, choose Edit > Select All, or press 
⌘ + A (macOS) or Ctrl + A (Windows).

• Select a word, line, or paragraph without deselecting the selected text: Hold 
⌘ (macOS) or Ctrl (Windows) while double-, triple-, or quadruple-clicking to 
add disconnected words, lines, and paragraphs to the selected text.

To select text with the keyboard:

1. Position the text cursor at the start or end of the text to select.

2. Press one of the following keyboard shortcuts. You can press all of the keys at 
the same time, or the modifier keys first (⌘, Shift, Ctrl) followed by the action 
key (such as an arrow key).

Action macOS Windows

Extend selection one character left or right Shift + � or � Shift + � or �

Extend selection one line up or down Shift + ↑ or ↓ Shift + ↑ or ↓

Extend selection to the start or end of the current word Shift + ⌘ + � or � Shift + Ctrl + � or �
and then to subsequent words

Extend selection to the start or end of the current Shift + ⌘ + ↑ or ↓ Shift + Ctrl + ↑ or ↓
paragraph and then to subsequent paragraphs

Extend selection to the start or end of the current line Shift + fn + � or � Shift + Home or End

Extend selection to the start or end of the story Shift + fn + ⌘ + � or � Shift + Ctrl + Home or End

Tip: If you’ve changed 
your shortcuts by 
choosing Apple 
Defaults (macOS only) 
or creating custom 
shortcuts, your actual 
modifiers may vary

Tip: You don’t have to 
use the Frame Text
tool to edit text in a 
text frame, the Frame 
Text, Art Text, and 
Table are interchange-
able when editing text 
in a text frame, art text 
object, path text 
object, or table
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To deselect text:

1. Press Esc to deselect text without moving the text cursor.

2. Or press any of the arrow keys or click the mouse to reposition the text cursor 
which will deselect the text.

Copying and deleting text
You can move and duplicate text from one location to another with copy and 
paste or by dragging selected text. Both methods will move or duplicate pinned 
objects, note and index mark, and anchors.

Affinity uses the shared macOS and Windows pasteboard (clipboard) so copying 
text or objects in Affinity or any other application will overwrite whatever was 
previously copied.

To move or duplicate text with menu commands:

You can also use the equivalent keyboard shortcuts or right-click to access the 
same commands in the context menu.

1. Select the text to move or duplicate.

2. Choose Edit > Cut to move it or Edit > Copy to duplicate it.

3. Position the text cursor at the location where the text should appear, or select 
a range of text to replace with the pasted text.

4. Choose Edit > Paste.

To move or duplicate text with the mouse:

1. Select the text to move or duplicate.

2. Drag the selected text to move it or press ⌥ (macOS) or Ctrl (Windows) and 
drag it to duplicate it.

To paste text without formatting:

You can paste the contents of the pasteboard (clipboard) without its formatting 
so that you’re pasting just plain text. This is known on macOS as Paste and Match 
Style and on Windows as Paste Plain Text or Keep Text Only. This feature is 
especially useful when pasting text from another document or application to 
avoid importing its text styles.

1. Cut or copy the text.

2. Position the text cursor at the location where the text should appear, or select 
a range of text to replace with the pasted text.

3. Choose Edit > Paste Without Format.

Tip: Paste Without 
Format will not 
remove anchors, note 
and index marks, or 
pinned objects; to 
remove them, paste 
the text into a text 
editor and then copy it 
from there back to 
Affinity

Tip: Text can be 
dragged within the 
same document or 
from another applica-
tions into an Affinity 
document, but not 
between documents 
or from Affinity to 
another application
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To create a new text frame or object when pasting text:

You can also replace all of the text in a new frame or object when pasting text.

1. Copy text as you normally would.

2. Do one of the following:

• Select the Move  tool and without selecting a text frame or object, 
choose Paste. This will normally create a text frame half the size of the 
page in the centre of the page and paste the text into it, but if you copy 
from Microsoft® Word and some other applications on macOS, this will 
result in separate art text objects for each line of text. Note that if you 
select a text frame or text object before choosing Paste, all of its text will 
be replaced when you paste.

• Select the Frame Text  tool, click once outside of the current text frame 
or object if the cursor is in text, and choose Paste. This will create a text 
frame half the size of the page in the centre of the page and paste the text 
into it.

• Select the Art Text  tool, click once outside of the current text frame or 
object if the cursor is in text, and choose Paste. This will create an art text 
frame in the centre of the page and paste the text into it.

To delete selected text:

1. Press Delete or Choose Edit > Delete. Pressing any character key will also 
delete selected text while typing that character.

To delete unselected text:

1. Position the text cursor at the start or end of the text to select.

2. Press one of the following keyboard shortcuts. You can press all of the keys at 
the same time, or the modifier keys first (⌘, Shift, Ctrl) followed by the action 
key (such as an arrow key).

Action macOS Windows

Delete the previous character Delete Backspace

Delete the next character fn + Delete or ⌦ Delete Delete

Delete to the start of the current word and ⌥ + Delete Ctrl + Backspace
then to subsequent words

Delete to the end of the current word and ⌥ + fn + Delete or ⌥ + ⌦ Delete Ctrl + Delete
then to subsequent words

Delete to start of line ⌘ + Delete n/a

Tip: If you’ve changed 
your shortcuts by 
choosing Apple 
Defaults (macOS only) 
or creating custom 
shortcuts, your actual 
modifiers may vary
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Copying text formatting
Affinity allows you to copy and paste text character and paragraph styles and 
attributes between blocks of text. You can also copy fill and stroke attributes from 
objects to apply to text.

To copy text formatting to unselected text:

1. Ensure that the text cursor is not positioned in text or Affinity will treat the 
word containing it as selected. To remove the text cursor from a text frame, 
click once on a blank area of the page—pressing Esc is not sufficient to cause 
Affinity to forget the cursor’s last position.

2. Choose the Style Picker  tool. The mouse pointer should change to an 
unfilled  pointer to indicate that formatting has not been loaded. If it 
changes to a filled  pointer, press Esc or click the Unload button in the 
Context Toolbar to unload the formatting.

3. Click on the text with the formatting you want to copy or on an object whose 
line or fill attributes you want to copy. The mouse pointer will change direc-
tion to a filled  pointer to indicate that formatting has been loaded.

4. Do one of:

• Click a word to apply the loaded character formatting to a single word.

• Drag select a range of text to apply the loaded character formatting to it.

• Quadruple-click or drag select past the last character of a paragraph to 
apply the loaded character and paragraph formatting to the paragraph. For 
an art text object, press ⌘ (macOS) or Ctrl (Windows) and click on the 
object to easily apply the loaded formatting to the entire object

5. Continue applying the loaded formatting to additional text if desired. To load 
formatting from different text, press ⌥ (macOS) or Alt (Windows) and click 
on that text. The mouse pointer will change to an unfilled  pointer while 
you hold down the key to indicate that formatting can be loaded. If you 
release the key without clicking then the loaded formatting will not be 
changed.

6. When you are done, press Esc or click Unload in the Context toolbar before 
changing tools to unload the formatting to avoid a future mistake.

Tip: To apply loaded 
paragraph formatting 
to the last paragraph 
in a text frame, you 
must press Return 
after it to create a 
blank paragraph

Tip: Unlike Microsoft® 
Word’s Format Painter
tool which loads (picks 
up) formatting when 
the tool is chosen, 
Affinity’s Style Picker
tool does not load 
formatting until you 
first click with it

Tip: You cannot copy 
and paste formatting 
between documents 
with the Style Picker
tool

A paragraph, including the paragraph 
break marker at the end, is selected 
with the filled  pointer to apply 
character and paragraph formatting

Tip: The filled pointer 
will include a T next to 
the eyedropper when 
it is positioned over 
text to indicate that 
clicking will now apply 
formatting to text

Tip: Select Text > 
Show Special Charac-
ters before drag 
selecting a paragraph 
because you must 
select the End of 
Paragraph symbol 
which is difficult when 
it’s not shown

Tip: The Style Picker
tool does not unload 
formatting automati-
cally when you change 
tools
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To copy text formatting to selected text:

1. Using the Frame Text , Artistic Text , or Table  tool, select the text to 
which you want to copy formatting. If you want to apply formatting 
attributes, ensure you select the paragraph break marker at the end of the 
paragraph as shown above.

2. Choose the Style Picker  tool. The mouse pointer should change to an 
unfilled  pointer to indicate that formatting has not been loaded. If it 
changes to a filled  pointer, press Esc or click the Unload button in the 
Context Toolbar to unload the formatting.

3. Click on the text with the formatting you want to copy or on an object whose 
line or fill attributes you want to copy. The loaded formatting will be applied 
to the selected text and the mouse pointer will change direction to a filled
pointer to indicate that formatting has been loaded.

4. Continue applying the loaded formatting to additional text if desired. To load 
formatting from different text, press ⌥ (macOS) or Alt (Windows) and click 
on that text. The mouse pointer will change to an unfilled  pointer while 
you hold down the key to indicate that formatting can be loaded. If you 
release the key without clicking then the loaded formatting will not be 
changed.

5. When you are done, press Esc or click Unload in the Context toolbar before 
changing tools to unload the formatting to avoid a future mistake.

To change which text formatting is loaded:

When you choose the Style Picker  tool, the Context Toolbar will change to 
show options to control its behaviour when applying formatting, not when 
loading formatting. It is recommended not to change these options when copy-
ing and pasting formatting for text but you must select both Character Settings
and Paragraph Settings to properly copy paragraph styles.

1. Choose a combination of options from the Context Toolbar before applying 
loaded formatting to text. Click the All button to select all of the checkboxes 
or None to deselect all of them. Layer Opacity, Layer Effects, and Object 
Settings are not applicable to text and can be ignored.

• Stroke: Apply the loaded stroke attributes to the text’s stroke.

• Fill: Apply the loaded fill attributes to the text’s stroke.

• Character Settings: Apply the loaded character attributes, including 
character style, fill, and stroke.

• Paragraph Settings: Apply the loaded paragraph attributes, including 
paragraph style but not the character attributes of the paragraph style.

Tip: The filled pointer 
will include a T next to 
the eyedropper when 
it is positioned over 
text to indicate that 
clicking will now apply 
formatting to text

Tip: The Style Picker
tool does not unload 
formatting automati-
cally when you change 
tools
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Changing case
Affinity can change the case of text from lowercase to uppercase and vice versa. 
You can format text as uppercase with the All Caps and Small Caps character 
attributes available from Text > Capitalisation and the Typography and Charac-
ter panels, but the Change Case feature permanently changes the characters.

To change the case of text:

1. Click the Change Case button  in the Context Toolbar and choose one of 
the following commands, or choose the equivalent command in the Text > 
Capitalisation menu:

From To

Lower Case A test of capitalisation a test of capitalisation

Upper Case A test of capitalisation A TEST OF CAPITALISATION

Toggle Case A test of capitalisation a TEST OF CAPITALISATION

Title Case A test of capitalisation A Test of Capitalisation

Sentence Case A test of capitalisation A test of capitalisation

Sentence Case capitalises the first word of each sentence while Title Case capi-
talises the first letter of each major word. Title Case relies on a list of exceptions 
to determine which words should not be capitalised. You can edit the list of 
exceptions in Settings. Refer to AutoCorrect, Abbreviations, and Title exceptions
on page 455.

Tip: Toggle Case is 
available only in the 
Text menu
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Finding and replacing text
You can use the Find and Replace panel to search for and replace plain text, 
formatted text, and text formatting in the current document.

You can also search for text formatted with a text style or specific formatting and 
change its text style or formatting. Affinity also allows you to search for fields and 
change their formatting or replace them with other fields.

To find or replace text and/or text formatting:

1. Choose Text > Find… to display the Find and Replace panel. You can also 
choose Window > Text > Find and Replace if the panel isn’t visible but the 
first option also makes the Find field active so you can immediately type the 
text to find, so it’s always better to use the Find… command.

2. Enter the text to find in the Find field and if you want to replace it with 
different text, enter the replacement text in the Replace with field. Leave these 
fields blank if you want to search for or replace text formatting only.

To enter special characters, click the magnifying glass  icon on the left side 
of the Find or Replace with fields and select one from the Special Characters
list. For other special characters, copy and paste them from the main docu-
ment text.

To enter a field, click the magnifying glass  icon on the left side of the Find
or Replace with fields and select one from the Fields list. Replacing with a 
field creates a new one with the current formatting defaults for that field.

3. To find text formatting on its own or in combination with the text you 
entered into the Find or Replace with fields, click the Formatting  icon to 
the right of Find or Replace with. From the popup menu, choose:

Tip: Finding a straight 
apostrophe (') will not 
find a typographic (‘) 
apostrophe or vice 
versa so finding 
contractions such as 
isn’t requires typing 
the apostrophe 
exactly as it appears in 
the document

Tip: Click the Clear
icon to quickly delete 
entered text

Panel menu

Find formatting

Replace formatting

Clear FindFind what

Clear Replace withReplace with

Replace and Replace AllFind (search)

Search results

Scope

Tip: You can search 
only the current 
document and not all 
open documents
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• Format: Select individual text formatting; this window is identical to the 
options for creating and editing text styles and is described in Creating 
text styles on page 211.

• Character Style: Select a character style from the list.

• Paragraph Style: Select a paragraph style from the list.

• Reset Format: Select to clear the above three formatting options.

The selected formatting will be shown below the Find or Replace with fields.

4. To limit the search results by case and whole words, click the Formatting
icon to the right of Find. From the popup menu, choose:

• Match Case: select to find only text that exactly matches the case of the 
text in the Find field; for example, Analog won’t find analog.

• Match Whole Word Only: select to find only text that isn’t part of a longer 
word; for example, log won’t find analog.

5. Select from the Scope popup menu to set the search scope to the current 
Document, Section, Spread, Page, Story (all the text in the text object or a 
series of linked text frames), or Selection. The latter refers to either selected 
text or to the story in a selected text object. If you select multiple text objects 
with different stories, all of their stories will be searched.

6. Click Find to search and display the page containing the first result forward 
in the document from the current position. Click Find again or choose Text > 
Find Next to move to the next search result or choose Text > Find Previous
to move the previous search result. Click a search result in the list to jump to 
that result.

7. If you are replacing text or formatting, click Replace to replace the selected 
search result and move to the next result.

8. Click Replace All to replace all remaining search results.

To reuse previous search strings:

Affinity automatically keeps remembers the last 20 search and replacement 
strings so you can reuse them to save time. It does not save the formatting or 
options that you used with that search.

1. To select a recently-used search or replacement string, click the magnifying 
glass  icon on the left side of the Find field or the caret  icon on the left of 
the Replace with field, and select from the list.

2. Select Clear Recent Finds or Clear Recent Replaces to clear the list.

Tip: Although Affinity 
stores recent searches, 
you cannot save 
search strings for 
future use

Tip: You cannot search 
an entire Affinity Book 
at once so you must 
open each Chapter to 
search it individually

Tip: With Scope set to 
Selection and a text 
frame in a linked series 
of frames selected, 
Affinity will search the 
entire story and not 
just the text in the 
selected frame

Tip: Match Case and 
Match Whole Word 
Only are sticky options 
that will persist for the 
rest of the session, 
including when you 
switch documents

Tip: Choose Reset 
Format from the 
Formatting icon’s 
popup menu to clear 
the selected 
formatting
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Using regular expressions (GREP)
You can use regular expressions to find and replace text patterns. For example, 
you could search for all of the numbers in your document and change their 
numeric formatting.

Learning how to use regular expressions is beyond the scope of this manual but 
some examples are provided further below.

Regular expressions normally use the ANSI C or POSIX locale and ignore the 
text’s language setting so they are limited to the 7-bit ASCII character set. For 
example, entering [a-z] will match any lower- or uppercase letter but not 
accented characters such as åéîøü. With Locale Aware Regular Expression
selected, entering [a-z] will also match the accented characters because they will 
use the full Unicode character set.

To find and replace using regular expressions:

1. Choose Text > Find… to display the Find and Replace panel. 

2. Click the Formatting  icon to the right of Find. From the popup menu, 
choose Regular Expression or Locale Aware Regular Expression.

3. Enter the regular expression to search for in the Find field and if applicable, 
its replacement in the Replace with field.

4. Click Find, Replace, and Replace All to find and replace as you normally 
would.

Examples Find Replace with

Remove spaces at the end of paragraphs \s+$ nothing

Remove blank paragraphs (extra paragraph breaks) (?<!.)\R|\R\Z nothing

Remove duplicate words \b(\w+)\b \1 $1

Change double spaces after periods, exclamation points, and question ([\.\!\?])\s\s+ $1  and a space
marks to single spaces

Change two or more spaces to single spaces \s\s+ space

Add periods at the end of paragraphs without periods ([^.!?:...»])$ $1.

Change paragraphs starting with “1. “, “2. “, etc. to a numbered list ^\d+\. ?(.) $1 and a style
if you also set a replacement paragraph style that is numbered, such
as the default Numbered 1 style

Replace any of a list of words separated by a vertical bar with any text; \b(one|two|three) any text
the words in this example are one, two, three)

Replace comma thousands separators with spaces (?<=\d)[., ](?=\d\d\d) space

Replace space thousands separators with non-breaking spaces  (\d)(space)(\d) non-breaking space

Make 4-digit numbers such as years that aren’t part of longer (?<!\d)\d{4}(?!\d) <Bold>
numbers bold, if you set replacement formatting to Bold

Tip: Regular Expres-
sion is sticky and will 
persist for the rest of 
the session, including 
when you switch 
documents; ensure 
you switch back to 
Normal when you are 
done or it will appear 
that Find and Replace 
doesn’t work
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Replace a hyphen between two numbers with an en dash while (\d)(-)(\d) $1–$3
leaving hyphens between letters unchanged

Change straight quotation marks to typographic quotation marks (")(.+?)(") “$2”

Change straight quotation marks to guillemets (")(.+?)(") «$2»

Examples Find

Find the words color and colour colou?r

Find non-ASCII characters [\x7f-\xff]

Find any “e” character, including uppercase and accented [[=e=]]

Find ordinals (1st, 2nd, 3rd, 4th…), regardless of superscripting (?<=\d)(st|nd|rd|th)

Find fractions, but will also find dates written as 10/21/2023 \d+/\d+

Find most email addresses [-\u\l\d._]+@[-\u\l\d_]+\.[\u\l]{2,4}

Find repeated words \b(\w+)\s+\1\b

Find text between typographic quotation marks, e.g., “abc” (?<=\“)(.*?)(?=\”)

Find text between straight quotation marks, e.g., "abc" (?<=\")(.*?)(?=\")

Find text between parentheses () (?<=\()(.*?)(?=\))

Find text between square brackets [] (?<=\[)(.*?)(?=\])

Find paragraphs starting with specified text (change text to whatever ^text(.*)$
you want)

Find text at the end of words e.g., for father in grandfather, use (?<=prefix)suffix
(?<=grand)father
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Spell checking
Affinity can check spelling as you type or on demand. Spell checking requires 
that you specify the language for text. Refer to Language on page 158 for more 
information and to ensure you have the appropriate dictionaries installed.

Words you add to your custom dictionary will be available to all applications 
(macOS) or just to Affinity (Windows). Affinity does not use the macOS Auto-
matic by Language spelling option which mixes learned words of all languages 
together in one dictionary, so words you learn in other applications may not be 
available to Affinity and vice versa.

To enable or disable spelling as you type:

1. Choose Text > Spelling > Check Spelling While Typing. Misspelled words 
will be underlined in red.

To spell check manually:

1. Choose Text > Spelling > Check Spelling to highlight the next misspelled 
word and then right-click the misspelled word to see a list of spelling 
suggestions.

• Spelling suggestion: Select a suggestion to correct the word.

• Ignore Spelling: Select to ignore all instances of the word in this docu-
ment only. You can also choose Text > Spelling > Ignore Misspelled 
Word.

• Learn Spelling: Select to add this word to your custom spelling dictionary. 
To later remove the word from the dictionary, right-click the word again 
and choose Unlearn Spelling.

2. For a longer document, choose Text > Spelling > Spelling Options… to 
display the Spelling Options window.

Tip: Ignored words are 
saved in the docu-
ment so do not use 
the Ignore Spelling
feature with the 
Affinity Book feature 
because ignored 
words are not synced 
between chapters

Tip: Assign keyboard 
shortcuts to the Check 
Spelling (more 
commonly known as 
Check Document 
Now on macOS) and 
Ignore Misspelled 
Word to make it easy 
to navigate between 
misspelled words
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• Change: Click to change the word highlighted in the document to the 
first word in the list below, or to the one you have selected in the list.

• Find next: Click to skip this word and move to the next misspelled word.

• Ignore: Click to ignore all instances of the word in this document only.

• Learn: Click to add this word to your custom spelling dictionary. To later 
remove the word from the dictionary, right-click the word and choose 
Unlearn Spelling.

• Define: Click to see definitions for the selected word. (macOS only)

• Guess: Shows a list of suggestions for the word highlighted in the 
document.

macOS: To edit the custom dictionary or copy it to another Mac computer:

1. If you have not previously added a word to the dictionary, right-click one 
word in Affinity that you want to add and choose Learn.

2. Quit all of your applications.

3. Using Finder, choose Go > Go to Folder and enter

• macOS 14.4.0 and earlier: ~/Library/Spelling/

• macOS 14.4.1 and later: 
~/Library/Group Containers/group.com.apple.AppleSpell/Library/Spelling/

4. If macOS System Settings > Keyboard > Text Input > Edit > Spelling is set to 
a specific language, the learned words will be stored in a file named xx_XX
(language code and country code), just like standard spelling and hyphen-
ation dictionaries as described on page 464. If you do not see a file in this 
format then you have set this option to Automatic by Language and the 
learned words will be in a file named LocalDictionary.

5. Double-click the file to open it in TextEdit, or right-click it and choose Open 
With to edit it in another text editor.

6. Add, change, and delete words as required.

7. For macOS 14.4.0 and earlier, sort the list alphabetically. This is not important 
for macOS 14.4.1 and later.

8. Save the file and quit the text editor.

9. Restart macOS. This is important because the macOS spell checker caches the 
dictionary.

Tip: On macOS, 
learned words for 
English US will be 
stored in a file named 
en and not en_US
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Windows: To copy the custom dictionary to another Windows computer:

Windows users can copy their custom spelling dictionary between machines but 
there is no way to merge two dictionaries together or edit the dictionary. The file 
is named dictionary.propcol but its location depends on how you installed 
Affinity:

• Affinity Store MSIX installer or Windows Store: 
%USERPROFILE%\.affinity\Common\3.0\user\dictionary.propcol

• Affinity Store EXE installer: 
%appdata%\Affinity\Common\3.0\user\dictionary.propcol

AutoCorrect
Affinity can convert straight quotation marks to typographic ones, convert 
paragraphs to lists, change capitalisation, set superscripts, and correct common 
errors as you type. For example, you can replace teh with the. AutoCorrect can 
also automatically capitalise the first word of a sentence and you can define 
exceptions to automatic capitalisation to avoid capitalising the word after an 
abbreviation, such as the word following vs.

Affinity uses its own lists for each type of text replacement for every language it 
supports and doesn’t rely on the similar text replacement features built into 
macOS and Windows. This is important because while you might want the same 
corrections for basic text some of the corrections you use in Affinity may be 
more typographic and not suitable for your other applications. macOS also lacks 
separate text replacement lists for each language so Affinity’s custom feature is 
important for those who work in multiple languages.

You can customise how AutoCorrect works by setting its options, defining the 
text to correct, and defining the abbreviation exceptions. Refer to AutoCorrect, 
Abbreviations, and Title exceptions on page 455 for information.
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Word count
Affinity can display the count of the words, characters, lines, and paragraphs for 
the selected text, current story, or entire document. The current count is dis-
played in the Status Bar at the bottom of the document window to the right of 
the Preflight status indicator but can be hidden if you find it distracting. The 
count is updated when you pause during typing.

You can customise the count feature to display the count of words, characters, 
characters including spaces, lines, or paragraphs and you can view the other 
counts by clicking the count number.

If there is overset (overflowing) text, the count of overset text will be shown in 
parentheses after the count of visible text.

To show the count:

1. Choose View > Show > Word Count to display the count if it’s not currently 
displayed.

2. Choose what you want to count:

• To display the count for the entire document: deselect all text and text 
objects.

• To display the count for a single story: select a text object or position the 
text cursor in a text object.

• To display the count for a range of text: select the text range.

3. Click the count number to display a popup menu with the other statistics. 
Select a different statistic to change the default count to be displayed. Or press 
Esc or click outside of the popup to close it without selecting a statistic.

Word count Overset text
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Importing (placing) text
Affinity can place (import) text from word processors and text editors into text 
frames and other text objects. It supports the most common file formats but not 
the .odf (OpenDocument) format used by Google Docs™ and LibreOffice or the 
.pages format used by Apple® Pages®. For best results, it is recommended that you 
export from those applications to the .docx format used by Microsoft® Word.

Format Description Notes

.docx Microsoft® Word Supported by most word processors

.rtf Rich Text Format Supported by most word processors and some text
  editors

.txt Plain text format Supported by most word processors and text editors

As with linked images, Affinity allows you to import text and maintain the link 
to the original file so that changes made to it will be updated automatically in 
Affinity. Refer to Linking text files on page 144 for more information.

Imported text retains all of its text styles, formatting attributes, footnotes, and 
endnotes. Embedded images and tables will be imported although shapes are 
limited to rectangles and ellipses.

When you import text, it will be placed into a text frame or other text object in 
an existing document; you are not opening a document or adding its pages to the 
Affinity document. The layout of the placed text and images will differ from the 
original document, especially if the size of the text frame does not match the 
original document’s main text area.

You can also copy and paste text from a word processor or text editor, but unless 
you’re pasting a small block of text, you will lose so much formatting that it’s 
better to place text.

Copy from Results when pasting

Microsoft® Word Will lose images and shapes; tables will be converted to text

Apple® Pages® Will lose text styles, notes, images, and shapes; tables will be
 converted to text

LibreOffice  Will lose text styles, images, and shapes; tables will be converted to
 text

Google Docs™ Will import as plain text; everything else will be lost

Tip: Text imported 
from a word processor 
will likely have differ-
ent leading (line 
spacing) than in the 
original word process-
ing file; refer to 
Leading on page 170 
for a tip on adjusting 
the leading after 
import

Tip: Refer to Importing 
notes from Microsoft® 
Word on page 353 for 
more information on 
importing documents 
that include footnotes 
or endnotes

Tip: If a word proces-
sor document uses 
revision tracking, you 
must accept all 
changes and re-save 
the document from 
the word processor 
before importing it 
into Affinity
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To place text into an empty text frame or text object, or at the cursor 
position in a range of text:

1. Using the Frame Text , Artistic Text , or Table  tool, position the text 
cursor where the imported text should be placed.

2. Choose File > Place…

3. Select a file from the window and click Open.

To append text to the end of the text in a text frame or text object:

1. Deselect any selected object(s) by clicking on a blank area of the page.

2. Choose File > Place…

3. Select a file from the window and click Open. The mouse pointer will change 
to a Place .pointer.

4. Click the text frame or text object in which to append the text. As you move 
the mouse pointer over the frame or object, the text will appear to show you a 
preview of how it will be placed.

To replace all the text (the story) in a text frame or text object:

1. Using the Move  tool, select the text frame or text object. Do not double-
click it or Affinity will position the text cursor in it.

2. Choose File > Place…

3. Select a file from the window and click Open.
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Linking text files
When placing text, you can import the text into the document as regular text or 
you can link to the original .docx, .rtf, or .txt text file.

Unlinked text becomes regular text as if it were typed directly in Affinity. There 
is no connection to the source file, and unlike embedded images, you cannot 
later change your mind and link the text without deleting it and re-importing it.

Linked text becomes editable text but Affinity maintains an absolute link to the 
text file’s location. connection to the source file. The text can also be updated 
automatically when the linked text files are updated. Moving a document with 
linked text to another computer is slightly more complex because Affinity stores 
an absolute link—the full file path—so you will be prompted to find the text files 
when opening a moved document.

Unlike Adobe® InDesign®, Affinity does not need to link an entire story to a text 
file. If you position the text cursor between two paragraphs in the middle of a 
story, Affinity will place the linked text between them. A linked range of text will 
be made up of complete paragraphs—you cannot join linked text to an existing 
paragraph.

Linked text is editable in Affinity but all changes you make to it, including for-
matting, text edits, notes, and pinned objects, will be lost when the linked file is 
updated and the changes are synced to the text in Affinity. The only exceptions is 
changes to text styles will be preserved if Preserve Text Styles on Import is 
selected.

To import text as linked:

1. Choose File > Placement Policy > Import Text Files as Linked. This option is 
also available in the New Document and Document Setup windows. Refer to 
Creating a new document on page 22 and Changing layout options on page 
33 for more information.

To modify the formatting of linked text:

1. Choose File > Placement Policy > Preserve Text Styles on Import. This 
option is also available in the New Document and Document Setup
windows.

2. Changes made to the linked text file’s styles in another application will not be 
synced to this document so you can now edit the imported text styles in 
Affinity.

To update linked text automatically:

Linked text can be updated automatically or manually when it is modified.

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click General in the left pane.

2. Select Automatically update linked resources when modified externally. 
This setting applies to linked text and images.

Tip: Changes made to 
linked text in Affinity 
cannot be synced back 
to the external file

Tip: Store all of the 
linked images for a 
document in a folder 
at the same level as 
the document file to 
make it easier to move 
the document and 
images together
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To find and relink missing text files:

Preflight can warn you when a linked text file is missing but you can also find 
missing linked text files on your own.

1. Choose Document > Resource Manager and select the Text tab.

2. Click the Status column to sort by status. Missing text files will be sorted to 
the top of the list.

3. Select the first missing text file and click Relink. A file open window will 
appear. Navigate to a folder and click Select Folder. If other text files are 
missing and are stored in the same folder, Affinity will relink them automati-
cally.

Or click Replace… to select another text file. A file open window will appear. 
Select a file and click Open.

To manually update linked text that has been modified externally:

If Automatically Update Linked Resources when Modified Externally is not 
selected in Affinity > Settings > General and a linked text file is modified in 
another application, the text file must be updated manually. You will also need to 
manually update a linked text file if you have changed its text or formatting in 
Affinity.

1. Choose Document > Resource Manager and select the Text tab.

2. Click the Status column to sort by status. Modified text files will be sorted 
near the top of the list, below missing text files if any are missing.

3. Select a modified text file and click Update. Repeat for all modified text files. 
You can also press ⌘ (macOS) or Ctrl (Windows) while clicking to select 
multiple text files, or press Shift while clicking to select a range of files before 
clicking Update.

To find linked text in the document:

Affinity does not indicate the start and end of linked text which can make it 
difficult to determine its extent if it is part of a story and not the entire story. But 
you can direct Affinity to select the entirety of a linked text file.

1. Choose the Frame Text  tool.

2. Choose Document > Resource Manager and select the Text tab.

3. Select a text file in the list. If there are multiple copies of the text file in the 
document, click the caret  icon to the left of the text file name so you can 
select one of them.

4. Click Locate in Document. Affinity will select the text in the document.



146 Basic text

To find a linked text file used in the document on your computer:

1. Choose Document > Resource Manager and select the Text tab.

2. Select a text file in the list. If there are multiple copies of the text file in the 
document, click the caret  icon to the left of the text file name so you can 
select one of them.

3. Click Show in Finder (macOS) or Show in Explorer (Windows). Affinity will 
open a file folder window on your computer containing the text file.

To move linked text files to a different folder:

If you move linked text files using macOS Finder or Windows Explorer, the 
images will become missing in Affinity and you will need to relink them. You can 
also move images with Affinity in one step. This is also a convenient way to group 
images from multiple folders into a single location.

1. Choose Document > Resource Manager and select the Text tab.

2. Select the text files(s) to move in the list. You can also press ⌘ (macOS) or Ctrl
(Windows) while clicking to select multiple text files, or press Shift while 
clicking to select a range of files.

3. Click Collect… A file open window will appear. Navigate to the new location 
and click Collect. The selected text files will be moved to this folder.
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Formatting characters
Character attributes are those that can be applied to one or more characters and 
include font family, size, kerning, tracking, and spelling language. While you can 
apply these attributes to an entire paragraph, they are applied to a range of text 
and not to the paragraph. For formatting attributes that can be applied only to 
entire paragraphs, refer to Formatting paragraphs on page 167.

If you regularly use the same combination of character attributes, consider 
creating a character text style to ensure consistency and save time. Refer to 
Creating text styles on page 211 for more information. Character attributes are 
applied over the attributes defined in paragraph and character styles and are 
sometimes referred to as character overrides.

All character attributes can be selected from the Character panel. Some of the 
most common ones are also available from the Context Toolbar and those you 
might want to use with a keyboard shortcut are also available in the Text menu.

To apply character attributes to a range of text:

1. Using the Frame Text , Artistic Text , or Table  tool, select the text to 
which you want to apply formatting, or place the cursor in a word to apply 
the formatting to that word.

2. Select the character attributes as described in the following sections.

To apply character attributes to all the text in one or more text objects:

1. Using the Move Text , select the text frames or other text objects to which 
you want to apply formatting.

2. Select the character attributes as described in the following sections.

Fonts
A font is a set of character glyphs that share a font family (typeface), font size, 
and font style (traits). For example, 12-pt Myriad Pro Semibold Italic is a font.

Affinity supports fonts in the OpenType, TrueType, and Affinity font formats. 
Static digital fonts have one font file per font family and font style combination. 
For example, each of the six styles below is a separate static font file.

Myriad Pro Regular Myriad Pro Italic Myriad Pro Bold
Myriad Pro Semibold Myriad Pro Semibold Italic Myriad Pro Bold Italic

Affinity also supports OpenType Variable fonts which require just one file for an 
entire font family. Refer to Variable fonts on page 151 for more information.

Tip: Affinity does not 
support colour fonts 
or the older Multiple 
Master format

Tip: You must select 
the individual text 
objects inside a group 
to apply attributes to 
them, except for Font 
Colour and Stroke

Tip: Refer to Setting 
default text formatting
on page 192 for 
information on 
changing Affinity’s 
default character 
attributes

Panel menu

Font collection

Font size, Font style, and 
Font variations

Font family

Font colour and Background colour

Character style
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Using the Character panel
To display the Character panel:

1. Click the Character panel  button in the Context Toolbar or choose 
Window > Text > Character.

The top section of the Character panel allows you to set the font and character 
style.

• Font Collection: Select a collection to narrow the number of font families 
listed. macOS: You can create and modify the font collections using the 
FontBook application included with macOS. The list includes some auto-
matic categories as well as:

• Recents: Lists the 10 most recently-used font families.

• Missing Fonts: Lists the fonts used in the document that are not installed 
on this computer.

• Favourites: Lists the font families you have marked as a favourite.

• Font Family: Select a font family (typeface) from the popup menu of those 
installed on your computer, for example, Myriad Pro. Expand a font family to 
see the available font styles and select one without having to select font style 
separately.

Click the Favourite  icon to add the selected font family to your Favourites
collection.

Panel menu

Decorations: Underline, strikethrough, outline 
stroke, and outline colour

Positioning and Transform: Kerning, tracking, 
baseline offset, leading override, no break…

Language: Spelling and hyphenation…

Typography: Ligatures, alternates, variants, 
figures, and capitals…

Font: Font family, size, style, colour, and 
background colour, plus character style

Expand/collapse section

Optical Alignment: 
positioned relative to 

frame edges

Tip: Click the 
Favourite  icon to 
add the font family to 
your Favourites
collection

Tip: You can also select 
Font Family from the 
Context Toolbar
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• Font Size: Select a preset font size or enter a custom size. By default, Affinity 
measures text in points (abbreviated as pt). Points are a traditional measure-
ment system for type but there wasn’t a universal standard for its size until the 
advent of desktop publishing. A point is defined now as 1⁄72 of an inch. You 
can use the document’s measurement system instead of points by choosing 
Affinity > Settings…, clicking User Interface in the left pane, and then dese-
lecting Show Text in points.

Instead of specifying a size you can also choose to make the text larger or 
smaller by a set increment. Choose Text > Size > Bigger, Smaller, Precise 
Bigger, or Precise Smaller, their keyboard shortcuts, or click the Bigger  or 
Smaller  icons in the Context Toolbar.

Command macOS Windows Increment

Bigger ⌘ + > Ctrl + > 1 pt, 0.01 in, 0.1 mm

Smaller ⌘ + < Ctrl + < 1 pt, 0.01 in, 0.1 mm

Precise Bigger ⌘ + ⌥ + > Ctrl + Alt + > 0.1 pt, 0.001 in, 0.01 mm

Precise Smaller ⌘ + ⌥ + < Ctrl + Alt + < 0.1 pt, 0.001 in, 0.01 mm

• Font Style (traits): Select a font style for the selected font family, for example, 
Semibold Italic. Font style is a combination of traits, including weight (thin, 
medium, bold, black…), width (condensed, regular, expanded…) and slope 
(roman, also referred to as regular or plain, and italics). The name of a font 
style may not include all of its traits, for example, a font style named Italic
implies that it is for the roman (regular or plain) weight and is not condensed.

For an OpenType Variable font, Font Style will list its preset style variations. 
If you set a custom combination of axes, Font Style will show as Custom.

Many users refer to font style as the font weight. Font style should not be 

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
font size; refer to 
Keyboard shortcuts on 
page 452

Tip: You can also select 
Font Style from the 
Context Toolbar

* The Filter by Collec-
tion and Type options 
are shown only when 
the font menu is 
opened from the 
Context Toolbar

Number of font styles

Favourited

Not favourited

Filter by type*

Sample text

Expand/collapse 
font family

Selected font style

Filter by collection*

Tip: You can also select 
Font Size from the 
Context Toolbar
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confused with Character Style which is a combination of character attributes 
you create to format text.

Faux bold and italic

Some display fonts used for large headings, titles, and other non-body text 
purposes are available in just one or two font styles. For example, macOS and 
Windows include just the Regular style of the font Impact because it is already 
bold and there is no italic version. The Bold and Italic buttons in the Context 
Toolbar and the equivalent commands in the Text > Character Traits menu 
will be disabled when a bold or italic font style is not available. Some applica-
tions, including Microsoft® Word, will allow you to make it bold and italic 
even if there isn’t a bold or italic font style, a technique known as faux bold
and faux italic. These applications smear the font to make it appear bold and 
slant the characters to make them appear italic. Affinity does not support faux 
bold and italic as they shouldn’t be used in professional typesetting. 

Tip: Be careful when using the Bold button, menu command, or shortcut. If you’re using 
a professional body font with several weights, such as Light, Regular, Medium, Bold, and 
Black, the Bold button will often not make the text the next bolder weight but make it 
Bold. If it’s already Bold or Black, the Bold button may make it Regular.

• Font Colour and Background Colour: Click the colour samples in the Char-
acter panel to set the text fill colour and background or highlight colours, or 
click the Font Colour  or Background Colour  icons in the Context 
Toolbar.

• Font Variations:  Click to specify the font variations. Refer to Variable 
fonts on page 151.

• Character Style: Select the character text style. Any other attributes you select 
in the Character panel will override the character style. Refer to Creating text 
styles on page 211 for more information.

Tip: To set the text 
stroke width and 
colour, use the Stroke
panel or the Outline 
Colour control in the 
Decorations section of 
the Character panel

Tip: You can create 
your own faux italic by 
setting Shear to 
approximately 14°

Tip: You can also select 
the character style 
from the Text Styles 
panel and Context 
Toolbar

Colour
Background colour

Font colour

Tip: You can also click 
the Bold and Italic
buttons in the Context 
Toolbar or choose 
Text > Character 
Traits > Bold and 
Italic; click or choose 
them a second time to 
toggle them off

Tip: Refer to Fill, 
stroke, and colour on 
page 249 for more 
information on 
selecting colours

Tip: You can also select 
Font Colour, but not 
Background Colour, 
from the Context 
Toolbar
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Variable fonts
Affinity supports the OpenType Variable font format which requires just one font 
file for an entire font family. Variable fonts include preset style variations so that 
you can still choose Regular or Semibold as easily as with a static font but they 
also allow you to define your own instances, a combination of style variations 
(axes) for finer control than static fonts can offer.

For example, a font with five weights and five widths would have previously 
required 25 font style files but now all of them can be accessed with a single 
variable font file, an if you want a weight or width somewhere between these 
preset variations, you could define your own instance.

To select a preset style variation, select it from the Font Style list. To define your 
own instance, click the Font Variations button  in the Character Panel or 
Context Toolbar to display a popup window in which you can set the values for 
each available axis.

The available axes vary between fonts but the most common are listed below. You 
may see a four-character code instead of the name for some axes. Some fonts 
may also have more axes than the font designer chose to offer because they are 
controlled by the offered axes. However, you can see the hidden axes by clicking 
Show Hidden Axes.

• Weight: Set the font style from lighter to bolder. Adjusting the weight will 
also adjust spacing and kerning and will affect the width of characters.

Tip: The Show Hidden 
Axes checkbox will be 
visible only if there are 
hidden axes to reveal

M M M M M M M M
Custom weights of 200 and 350 between the presetsPreset weights: Roboto Flex Thin (100), Light 

(300), and Regular (400)

Tip: Press ⌥ (macOS) 
or Alt (Windows) while 
dragging an axis’ slider 
to set a position 
between the preset 
notches

Tip: Variable fonts 
allow users to create 
the exact font style 
required for a design 
and require less space 
when multiple styles 
are used

Axis slider Axis value

M M M M M
M M M M M
M M M M M
M M M M M
M M M M M

Width axis

W
eig

ht
 ax

is
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• Width: Set the font style from narrower to wider. The range of available 
widths varies between fonts and some fonts that offer Width may only offer 
narrowing or widening.

• Slant: Set the font style from regular (upright) to oblique (slanted). Some 
fonts may also offer a reverse oblique (backslant) option. This option is simi-
lar to using the Shear option in the Position and Transform section of the 
Character panel and for some fonts may produce identical results, but Slant is 
preferred if available because it may control hidden axes and thus slant the 
characters in the manner intended by the font designer.

• Italic: Set the font style from roman to italic. Some variable fonts, including 
most fonts from Google Fonts, may offer italic as a separate font file rather 
than as an axis in a single file. For those that offer italic as an axis, Affinity will 
display a slider and allow you to set any value but most fonts offer only on 
and off so setting a value in between the two extremes is unnecessary. The 
Slant axis, if available, and Affinity’s Shear option, slant the characters with-
out changing their shapes but the Italic axis is a true italic and will change the 
shape of certain characters, such as “a” and “g” in this example.

• Optical size: Set the font style from optically sized for body text to display 
type. Optical sizing often adjusts stroke contrast or serif size to improve 
readability at different sizes. Lower values are better for body text and higher 
values for display text.

• Lowercase height (YTLC): Set the x-height of lowercase characters.

• Ascender height (YTAS): Set the height of the ascenders of lowercase 
characters.

Title Title Title
Roboto Flex (12) 30 50

Wag Wag Wag
Archivo Regular Italic Regular with Shear=+10

Wag Wag Wag
Roboto Flex Regular Slant=-10 Affinity’s Shear=+10

look look look
Regular lowered ascenders raised ascenders

M M  M M M M
Custom widths of 50 and 150 on other side of Roboto Flex (100)Preset widths: Roboto Condensed and Flex

Wag Wag Wag
Nunito Sans (500) 440 540
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• Uppercase height (YTUC): Set the height of uppercase characters. In some 
fonts, this option can allow you to make uppercase characters as short as the 
x-height so that the ascenders of lowercase characters are taller.

• Descender depth (YTDE): Set the height of lowercase descenders.

• Figure height (YTFI): Set the height of figures (numbers) to help them stand 
out or blend in with other text.

a500 a500 a500
Regular Height lowered Height raised

quip quip quip
Regular Depth lowered Depth raised

ePUB ePUB ePUB
Regular Height lowered Height raised
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Decorations
The Decorations section of the Character panel allows you to specify underline, 
strikethrough, and the text outline, modifications (decorations) to the character 
appearance.

Underline thickness and positioning are defined in the font and are scaled auto-
matically based on font size. If you format text of varying sizes with underline, 
Affinity will use the thickness and positioning of the largest text in the range of 
underlined text for a seamless stroke thickness and position. If you interrupt the 
underline by not underline one or more characters, Affinity will treat the text as 
separate ranges for purposes of determining the largest character in a range.

• Underline and Colour: Select Single Underline  or Double Underline
to enable one of these or No Underline  to disable underline. Click the 
colour sample to the right of these icons to set the underline colour. Setting to 
None will use the Font Colour and will not make it invisible.

• Strikethrough and Colour: Select Single Strikethrough  or Double 
Strikethrough  to enable one of these or No Strikethrough  to disable 
strikethrough. Click the colour sample to the right of these icons to set the 
strikethrough colour. Setting to None will use the Font Colour and will not 
make it invisible.

• Outline Stroke and Colour: Click the stroke control to set the text outline’s 
thickness, dash pattern, and other properties. Click the colour sample to set 
the text outline colour. Setting to None will cause the text will appear un-
stroked (default).

Tip: You cannot adjust 
Underline and 
Strikethrough thick-
ness or positioning in 
Affinity

Tip: Use the Font 
Colour control in the 
top section of the 
panel to set the text fill 
colour

Tip: You can also set 
Outline Stroke with 
the Stroke panel and 
Outline Colour with 
the Colour panel

Tip: You can also click 
the single Underline
and Strikethrough
buttons in the Context 
Toolbar or choose 
Text > Character 
Traits > Underline and 
Strikethrough; click or 
choose them a second 
time to toggle them 
off

Continuous underline is based on 
largest font size in the selected range

Interrupted underline is based on 
individual font sizes

Underline off, single, 
double, and colour

Strikethrough off, single, double, and colour

Outline stroke and colour

Tip: Refer to Fill, 
stroke, and colour on 
page 249 for more 
information on 
selecting colours
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Position and Transform
The Position and Transform section of the Character panel allows you to change 
how characters are positioned and scaled.

• Kerning: Kerning adds and removes space between specific pairs of charac-
ters to correct visual gaps caused by adjacent characters with overhanging 
shapes. Most quality fonts have kerning values defined for character pairs that 
would produce a gap but at large display sizes you may wish to override the 
value set by the font designer.

• Auto: Select to use the font’s defined kerning values. This field will show 
Auto only when a range of text set to Auto is selected; it will show the 
font’s kerning value in parentheses when the text cursor is between two 
characters. If there is not a kerning pair value defined for the two charac-
ters, then (0‰) will be shown.

• 0‰: Select to disable kerning for a pair of characters or range of text. The 
field will show 0‰ when set to zero or (0‰) when set to Auto.

• Preset or custom value: When the text cursor is between two characters, 
select a preset value or enter a custom value in permilles (thousandths of 
an em space). Positive values will loosen spacing and negative values will 
tighten spacing.

You can also tighten or loosen kerning by a set increment instead of specify-
ing a kerning value. Choose Text > Spacing > Tighten, Loosen, Tighten 
More, or Loosen More or their keyboard shortcuts:

Command macOS Windows Increment

Loosen ⌥ + � Ctrl+ � 10‰

Tighten ⌥ + � Ctrl+ � 10‰

Loosen More ⌘ + ⌥ + � Shift + Alt + � 50‰

Tighten More ⌘ + ⌥ + � Shift + Alt + � 50‰

Tip: Choose Text > 
Spacing > Use None
to set both kerning 
and tracking to 0‰

Tip: Tighten and 
Loosen change 
kerning when the text 
cursor is between two 
characters, or tracking 
when text is selected

Tip: Choose Text > 
Spacing > Use Default
to set kerning and 
tracking back to Auto, 
the font’s default

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
kerning or tracking; 
refer to Keyboard 
shortcuts on page 452

Tip: Affinity does not 
offer an Optical 
Kerning feature to 
automatically kern 
characters based on 
their shapes

Tip: You can’t change 
kerning when a range 
of text is selected, 
except to Auto or 0‰

To Av We To Av We
Auto 0‰

Kerning

Tracking

Baseline Offset

Leading Override

No Break

Shear

Horizontal Scale

Vertical Scale

Super/Subscript
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• Tracking: While kerning is used to add and remove space between specific 
character pairs, tracking adds and removes space between all characters. 
Tracking can be used in conjunction with kerning. For example, you could 
increase tracking to loosen the overall spacing but keep Auto kerning enabled 
to avoid unsightly gaps with overhanging character shapes. Select a preset 
value or enter a custom value in permilles (thousandths of an em space). 
Positive values will loosen spacing and negative values will tighten spacing.

In general, display type should be tracked tightly with a negative value while 
you may not need to adjust tracking at all for body text. White text on a solid 
background may need to be loosened to avoid having the characters seem 
closer than they are.

Instead of specifying a tracking value you can also tighten or loosen tracking 
by a set increment. Choose Text > Spacing > Tighten, Loosen, Tighten More, 
or Loosen More or their keyboard shortcuts:

Command macOS Windows Increment

Loosen ⌥ + � Ctrl+ � 10‰

Tighten ⌥ + � Ctrl+ � 10‰

Loosen More ⌘ + ⌥ + � Shift + Alt + � 50‰

Tighten More ⌘ + ⌥ + � Shift + Alt + � 50‰

• Baseline Offset: Select a preset baseline offset or enter a custom value. Posi-
tive values will raise the character above the baseline and negative values will 
lower the character below the baseline.

Instead of specifying an offset you can also choose to raise and lower the 
baseline by a set increment. Choose Text > Size > Raise Baseline, Lower 
Baseline, Precise Raise Baseline, or Precise Lower Baseline or their keyboard 
shortcuts. You can also choose Use Default to reset the baseline to normal.

Command macOS Windows Increment

Raise Baseline Shift + ⌥ + ↑ Shift + Alt + ↑ 1 pt, 0.01 in, 0.1 mm

Lower Baseline Shift + ⌥ + ↓ Shift + Alt + ↓ 1 pt, 0.01 in, 0.1 mm

Precise Raise ⌘ + Shift + ⌥ + ↑ Ctrl + Shift + Alt + ↑ 0.1 pt, 0.001 in, 0.01 mm

Precise Lower ⌘ + Shift + ⌥ + ↓ Ctrl + Shift + Alt + ↓ 0.1 pt, 0.001 in, 0.01 mm

Tip: Tighten and 
Loosen change 
kerning when the text 
cursor is between two 
characters or tracking 
when text is selected

Definition: The 
baseline is the invisi-
ble line on which the 
bases of characters 
without descenders 
are aligned

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
the baseline; refer to 
Keyboard shortcuts on 
page 452

Tip: If you don’t need 
these shortcuts, you 
can remove them to 
avoid accidentally 
changing kerning or 
tracking; refer to 
Keyboard shortcuts on 
page 452

Tip: Choose Text > 
Spacing > Use None
to set both kerning 
and tracking to 0‰

Tightened Normal Loosened
-50‰ 0‰ 50‰ loose

Tip: Choose Text > 
Spacing > Use Default
to set kerning and 
tracking back to Auto, 
the font’s default

Tip: Use Baseline 
Offset to adjust the 
vertical position of an 
inline image to align it 
with neighbouring 
characters
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• Leading Override: Leading (line spacing) is normally set for an entire para-
graph but you can override it for specific characters. The paragraph leading 
value will be shown in parentheses if you have not overridden it.

• Shear: Enter a value to slant the characters to create the appearance of an 
italicized font. Positive values will slant the characters to the right and nega-
tive values to the left. A faux italic can be created with a shear of approxi-
mately 14% and while it is not a replacement for a true italic font style, it can 
be useful for display type.

• Horizontal Scale: Enter a value to horizontally scale the characters and the 
space between them. Positive values will stretch the text and negative values 
will condense it. Scaling is not a replacement for a true condensed or 
expanded font style, but it can be useful for display type.

• Vertical Scale: Enter a value to scale the characters vertically. Positive values 
will increase the height while negative values will decrease it.

• Super/Subscript: Select Superscript or Subscript to create faux superscripts 
and subscripts by automatically decreasing the font size and changing the 
baseline offset. You cannot adjust the scaling and offsets applied and the 
changed values are not shown in the Font Size and Baseline Offset fields.

If an OpenType font includes true superscript or subscript characters, it is 
preferable to use them rather than this automatic faux option which results in 
thinner strokes than normal characters, but some fonts don’t include true 
super- and subscript characters. Refer to Super/Subscript: on page 163 for 
more information.

• No Break: Select to disable automatic word wrapping inside of a text frame. 
This feature is useful to prevent automatic hyphenation of proper nouns (for 
example, Southampton), breaking at manual hyphens (for example, 
90-degree), or to keep certain words together (for example, 4K TV).

Tip: Refer to Super/
Subscript on page 163 
for more information 
on true superscript 
and subscript

Tip: Setting Leading 
Override to less than 
the paragraph leading 
value will have no 
effect

Tip: You can also click 
the Superscript and 
Subscript icons in the 
Context Toolbar or 
choose Text > Base-
line > Superscript and 
Subscript

Shear Shear Shear
-14° 0‰ 14°

Super¹ Sub₂ Super1 Sub2
Automatic super- and subscriptTrue super- and subscript

Tip: Scaling art text 
with the Move  tool 
will adjust its horizon-
tal scale

Tip: Do not use No 
Break with Justified 
Left, Centre, Right, or 
All because it will 
cause characters to 
overlap

Tip: There is no visual 
indication when text is 
formatted with No 
Break but you can 
search for it with Find 
and Replace
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Language
The Language section of the Character panel allows you to specify the language 
for spelling and hyphenation, as well as the typography script and language.

You can add words to the included spelling dictionaries or the ones you install 
(refer to Installing additional dictionaries on page 463) by right-clicking a mis-
spelled word and choosing Learn from the context menu, but you cannot add 
words to the hyphenation exception dictionary.

• Spelling language: Select the language for the text. Select None to turn off 
automatic spell checking.

• Hyphenation language: Select Auto to allow Affinity to select the most appro-
priate hyphenation dictionary. For most languages, this will exactly match the 
spelling language but some languages such as English (Canada) don’t have 
their own hyphenation dictionary so Auto uses English (US). It is recom-
mended that you select English (United Kingdom) instead of Auto for Cana-
dian and Australian English and even Americans may wish to use UK 
hyphenation. See Improving Hyphenation below for details.

• Typography script and language: The typography script and language deter-
mine how OpenType rules are applied and thus which alternate characters are 
available. You can ignore these controls and leave them set to Auto if you 
don’t need to access certain alternate characters. Typography script specifies 
the way text is written, for example, Arabic, while Typography language
specifies the actual language, for example, Persian. Select Auto to allow Affin-
ity to select the most appropriate option or Default to use the font’s default 
option. The typography scripts and languages available will depend on the 
selected font.

Improving hyphenation

Affinity uses the widely-available Hunspell dictionary format used by many other 
applications including LibreOffice and Apple’s operating systems. Unfortunately, 
Hunspell’s English dictionaries are not equal in strength.

The Hunspell US, Canadian, and Australian English spelling dictionaries are 
equivalent to a pocket dictionary while the UK English dictionary has twice as 
many words and is equivalent to a standard dictionary. The result is that valid 
words can be flagged as incorrect when formatted as US, Canadian, or Australian 
English.

Hunspell offers hyphenation dictionaries only for US and UK English so 

Tip: You cannot 
automatically disable 
hyphenation for 
capitalised words

Tip: There is no reason 
to use the None option 
for Hyphenation; 
insert a soft hyphen 
before a word to 
disable automatic 
hyphenation for a 
word; you can also 
format it with No 
Break

Tip: You cannot 
automatically disable 
spell checking for 
capitalised words

Spelling language

Hyphenation language

Typography script

Typography language
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Canadian and Australian English text with Hyphenation Language set to Auto
will be hyphenated with the US dictionary.

A hyphenation dictionary is not a list of words but a list of hyphenation patterns 
(rules). Because the US English patterns were created based on a smaller set of 
words, Hunspell has difficulty hyphenating some very common words. While 
there are differences in hyphenation between countries, the differences are 
primarily for the hyphens you type, such as pre-trial (UK) vs. pretrial (US). The 
rules for automatic hyphenation are largely identical between the UK and US.

Even though the patterns in the UK hyphenation dictionary were created based 
on a UK spelling dictionary, they work better for Canadian and Australian 
English than the US English hyphenation dictionary. Therefore, Canadian and 
Australian users should set Hyphenation Language to Auto for best results.

American users should also compare results with Hyphenation Language to 
English (United Kingdom) because it will usually result in better hyphenation. 
Doing this will not impact spell checking, only hyphenation.
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Optical Alignment
The Optical Alignment section of the Character panel allows you to specify how 
punctuation and certain characters are positioned relative to the left and right 
edges of the text frame. Optical alignment is off by default but is commonly used 
in magazines, brochures, and books to ensure that a page of text is visually 
aligned. It is generally used for body text and not for headings or tables.

Optical alignment makes the left and right edges of a column of text look more 
uniform to the eye by slightly shifting certain characters and by hanging punctua-
tion (positioning it) outside of the text frame. With a bit of manual adjustment to 
find the right value, you can even hang entire words outside of the text frame.

• Type: Select Font to enable optical alignment and use the font’s values or 
Manual to enter custom values. Select None to disable optical alignment. Very 
few fonts offer optical alignment values so selecting Font will almost always 
use Affinity’s default values.

• Add: Click to add an optical alignment rule to the table below. Click the 
Remove Rule  icon to delete a rule from the table.

• Left/Right: Set how far the character should extend outside of the text frame’s 
left or right edge. This value is specified as a percentage of the character 
width.

• Characters: List the characters (without separators) to which the rule applies. 
For example, CGOQ() characters extend 10% of their width out of the text 
frame because they have curved sides.

Tip: The alignment 
rules are editable even 
if the Type is set to 
Font; changes you 
make will be ignored 
unless you set Type to 
Manual

Product 1
New! Product 2

Product 3

“Hanging
Normal
Optical

Punctuation hung 
outside of column Word hung

outside of columnCurved side of character 
outside of column

Tip: Optical Alignment 
is not recommended 
for use with art text or 
path text because they 
lack a frame

Tip: When you set 
Type to Manual, the 
default Characters for 
Left/Right 50% rule 
will be set to an en 
dash; this is a mistake 
and it should be an em 
dash

Type (on/off)

Set Rule values

Add Rule

Remove Rule
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Typography
The Typography section of the Character panel allows you to access the 
extended characters of some fonts including ligatures, ordinals, super- and 
subscripts, and small caps.

Only the most common typography options are listed in the Character panel. 
You can access the full set of options and view samples with the Typography
panel which you can open by clicking the More  icon, by choosing Window > 
Text > Typography, or by clicking the Show Typography  icon in the Context 
Toolbar. OpenType fonts provide many typographic options so only the most 
common are listed here.

The typography options that are enabled in the Character panel or listed in the 
Typography panel are dependent on the selected font and in some cases are 
impacted by the Typography script and Typography language you have set as 
described in the section on Language on page 158. If an option such as Histori-
cal Ligatures isn’t listed in the Typography panel, it’s because the font doesn’t 
offer that option. Affinity will list all of the features of the font but you can hide 
the ones not relevant to the text cursor position or selected text by selecting Hide 
irrelevant features at the top of the panel.

The most confusing aspect of these font features is that the OpenType font format 
offers font designers multiple ways to accomplish the same thing, so fonts may 
use different font features to offer the same options to users. For example, to use 
slashed zero digits, one font may require you to select Character Variants while 
another might require you to select a separate Slashed Zero option. Or to access 
swash capitals, one font may require you to select the Swash option while 
another might require you to select Historical Forms.

Panel menu

Expand/collapse section

Hide irrelevant features

Two views of the 
Typography panel for 
different fonts

Tip: The Typography
options in the Charac-
ter panel are listed as 
radio buttons but as 
checkboxes in the 
Typography panel; 
the options available 
depend on the 
selected font

Tip: The typography 
options change the 
appearance of charac-
ters but do not change 
the characters you 
have entered; for 
example, lowercase 
letters will still be 
lowercase when 
applying All Caps

Tip: Typography 
options may be 
disabled or hidden for 
some fonts if Spelling 
Language is set to 
None

Option buttons

Option menus More
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• Ligatures: Select Standard Ligatures  to substitute ligature glyphs in place 
of the standard character glyphs for the most common character pairs such as 
the characters fi. This feature is on by default because it is almost always 
better to use these ligatures in place of separate character glyphs.

Select Discretionary Ligatures to use less common glyphs that aren’t suitable 
for all uses or Historical Ligatures to use glyphs that are no longer in 
common use but which may be useful for setting. If a font includes either of 
these ligature sets, they will be off by default.The choice of which ligatures to 
include in which set is up to the font designer so you may find that a ligature 
included in Discretionary Ligatures in one font is in Historical Ligatures in a 
different font as shown below.

Select Contextual Ligatures to use ligature glyphs in the appropriate context, 
such as when preceded by a specific character or followed by a space. This 
feature is on by default because it is almost always better to use these ligatures 
in place of separate character glyphs. The example below shows Contextual 
Ligatures in the context of the following character which the font designer 
could also have achieved by using the Final Forms option.

• Contextual Alternates:  Select to use the alternate or variant form of a 
character glyph depending on the context. They are commonly used to 
improve the joining of specific characters but in this example, the alternate 
form of the colon is raised above its normal position when used with digits to 
express a time. The Contextual Alternates option is on by default if supported 
by a font. Refer to the font’s documentation for a list of the supported 
alternates.

9:15 Time: 9:15 Time:
Contextual Alternates offContextual Alternates on

ct st  ct st
Historical ligatures offHistorical ligatures on (EB Garamond 12)

fi ff fl ffi ffl fi ff fl ffi ffl
Standard ligatures offStandard ligatures on

es est us use es est us use
Contextual ligatures offContextual ligatures on (EB Garamond 12)

Definition: A ligature 
is a single character 
glyph that replaces 
two or more single 
glyphs to improve 
readability and 
aesthetics

ct st sp  ct st sp
Discretionary ligatures offDiscretionary ligatures on (Minion Pro)
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• Ordinals:  Select to format ordinal numbers such as 1st as superscripted 
with characters scaled relative to adjoining characters of the same size. This 
option is off by default because it should be applied only to the ordinal 
number or else you would inadvertently superscript body text. While it may 
be more convenient to use the Superscript ordinals as they are typed feature 
in Settings…, if the font you are using includes true ordinals it is better to use 
them and disable the automatic setting.

• Fractions and Figure Position:  Select to use formatted fractions for 
numbers separated by a forward slash with digits scaled relative to adjoining 
characters of the same size. This option is off by default because it should be 
applied only to the fraction itself. Some fonts support only basic fractions 
such as ½ while others allow you to compose your own complex fractions 
such as 1¼76. For the latter, format the Numerator and Denominator with the 
options of the same names in the Figure Position section of the Typography
panel, and format the forward slash with Fraction.

Some fonts may also offer an Alternate Fraction option to change how the 
fraction is displayed, but this may work only with single-digit fractions.

• Super/Subscript:  Select to raise or lower characters from the baseline 
and scale them relative to adjoining characters of the same size. While it may 
be more convenient to use the similar Super/Subscript feature in the Posi-
tioning and Transform section, it is better to use superscripts as intended by 
the font designer if they are available. Some fonts may also offer Superior and 
Inferior options for scientific notation which can be found in the Figure 
Position section of the Typography panel.

Super¹ Sub₂ Super1 Sub2
Automatic super- and subscriptTrue super- and subscript

�⁄� � 3/8
Fraction Alternate fraction Standard characters

½ ⅜ 1¼76
Basic fractions Composed fraction

1st 2o 3re 1st 2o 3re

Ordinals off and superscript onOrdinals on

Tip: Always precede a 
fraction with a space 
or it will not be 
properly formatted
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• All/Small Caps/Petite Caps and Case-Sensitive Forms: Select All Caps
 or Small Caps to use a font’s style for true all uppercase or small capital 

letters. You can also use the Text > Capitalisation > All Caps and Small Caps
commands to access these features. Some fonts with a small x-height may also 
support Petite Caps and All Petite Caps which are shorter than standard 
Small Caps and work better with neighbouring lowercase text.

You can also choose All Small Caps to use the smaller cap height characters 
of Small Caps, even for uppercase letters, or Caps to Small Caps to use the 
smaller cap height characters just for the uppercase letters.

If the font supports it, selecting All Caps from the Character panel will 
automatically select the Case-Sensitive Forms and Capital Spacing options. 
These options can be accessed individually in the Capitals section of the 
Typography panel. Case-Sensitive Forms shifts characters such as parenthe-
ses up to align better with All Caps characters and lining figures while Capi-
tal Spacing improves the spacing of All Caps characters.

Select Titling to use alternate characters designed specifically for uppercase 
titles. The character glyphs are designed for titling instead of body text, but 
unlike All Caps you must format the characters as uppercase yourself. This 
feature is always available in Typography even for fonts that don’t support it 
but it is off by default and is supported by few fonts.

Select Unicase to use single-case characters designed in which upper- and 
lowercase characters are of uniform height. This feature is always available in 
Typography even for fonts that don’t support it but it is off by default and is 
supported by few fonts.

Unicase offUnicase on (Emigre Filosofia Unicode)

(CAPS 12) (Caps 12)
Standard charactersAll Caps

(CAPS 12) (CAPS 12)
Case-Sensitive Forms+ Capital Spacing offCase-Sensitive Forms+Capital Spacing on

(Caps 12) (Caps 12)
Standard charactersSmall Caps

C��� text C��� text
Petite Caps beside lowercase textSmall Caps beside lowercase text

Titling offTitling on (Missaali by Tommi Syrjänen)

Tip: The Text > Capi-
talisation menu 
includes two types of 
commands; Small 
Caps and All Caps are 
character attributes 
while the other 
commands perma-
nently change the 
characters’ case; refer 
to Changing case on 
page 133

Tip: If you select All 
Caps or Small Caps for 
text set in a font family 
that does not include 
that style, Affinity will 
create faux all or small 
caps by scaling the 
uppercase glyphs
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• Character Variants:  Click to select from a menu of the variants available 
for the font. Applying these options to characters other than those in the 
menu will have no effect so if you want to use certain variants throughout a 
document you can enable them in a text style. Each of the characters in the 
example below is a variant form of the standard character. For example, this 
example has different glyphs for each of these letters and digits.

Some fonts don’t group their variant or alternate characters so that you can 
enable them with the Character Variants option and instead you must select 
the individually from the Alternates section of Typography panel. A font may 
offer a separate option for a Slashed Zero as shown above to distinguish 
between a zero and capital O. Two other alternates are Historical Forms for 
glyphs that are no longer in common use but which may be useful for a 
period effect, such as the italicized long s which was used to replace one or 
both of the letters s in a double s, and a Contextual Swash which will replace 
the standard characters at the start or end of a word for a flourish.

• Stylistic Sets:  Click to select from a menu of the stylistic sets available for 
the font. A stylistic set is a group of character variants or alternates that can 
be applied together. For example, the font used in the example above allows 
selecting the straight-sided six and nine separately as variants to combined as a 
set. Not all of the characters in a set are available separately as character 
variants so refer to the font’s documentation for a list, especially since sets are 
not always clearly named.

• Swash:  Click to select from a menu of the swash style sets available for the 
font in place of the standard characters. Swash characters are often used at the 
start or end of a word for a flourish. Be careful when using them in the 
middle of a word because the swash may collide with another character.

Kick  Kick
Standard charactersSwash characters

Tip: Some fonts may 
offer swash characters 
through a Swash Style 
Set available from the 
Character panel

Queen  Queen
Standard charactersContextual Swash

Congreſs Congress
Standard charactersHistorical Forms

Tip: Some fonts may 
offer swash characters 
through the Contex-
tual Swash option in 
the Typography panel

Galf  Galf
Stylistic set off (standard characters)Stylistic set on

ɑll 4069 all 4069
Standard charactersCharacter variants



166 Basic text

• Figure Style: Select Old Style from the Figure Style section of the Typogra-
phy panel for non-lining figures, also known as lowercase or hanging figures, 
which have varying heights and baseline positions.

• Figure Width: Select Tabular from the Figure Width section of the Typogra-
phy panel when numbers in columns should align.

• Word Position Forms: Select Isolated Forms to use a special version of a 
character outside a word; this is on by default and useful for Arabic but must 
be deselected for some script fonts. Select Initial Forms or Final Forms to use 
a special version of a character at the start or end of a word; these are on by 
default and there is little reason to deselect them.

vane  vane
Initial Forms and Final Forms offInitial Forms and Final Forms on

12345  12345
67890  67890

ProportionalTabular

Isolated Forms offIsolated Forms on

Tip: Use Tabular
figures in conjunction 
with Lining (non-Old 
Style) figures for 
columns of numbers

1234567890 1234567890
Lining figuresOld Style figures
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Formatting paragraphs
Paragraph attributes are those that can be applied only to entire paragraphs and 
include justification, indents, paragraph leading, tab stops, hyphenation, and 
much more. For formatting attributes that can be applied only to any range of 
characters, refer to Formatting characters on page 147.

If you regularly use the same combination of character attributes, consider 
creating a character text style to ensure consistency and save time. Refer to 
Creating text styles on page 211 for more information. Character attributes are 
applied over the attributes defined in paragraph and character styles and are 
sometimes referred to as character overrides.

All paragraph attributes can be selected from the Paragraph panel. Some of the 
most common ones are also available from the Context Toolbar and those you 
might want to use with a keyboard shortcut are also available in the Text menu.

To apply paragraph attributes to a range of text:

1. Using the Frame Text , Artistic Text , or Table  tool, position the text 
cursor in the paragraph to which you want to apply the formatting, or select a 
range of paragraphs.

2. Select the paragraph attributes. These are described in the following sections.

To apply paragraph attributes to all the text in one or more text objects:

1. Using the Move Text , select the text frames or other text objects to which 
you want to apply formatting.

2. Select the paragraph attributes as described in the following sections.

Tip: If you select a 
range of paragraphs it 
is not important to 
select all of the 
paragraphs’ characters 
because Affinity will 
apply the formatting 
to the entire 
paragraphs

Tip: Refer to Setting 
default text formatting
on page 192 for 
information on 
changing Affinity’s 
default paragraph 
attributes
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Using the Paragraph panel
To display the Paragraph panel:

1. Click the Paragraph panel  button in the Context Toolbar or choose 
Window > Text > Paragraph.

Alignment (justification)
The top section of the Paragraph panel allows you to set the alignment of the 
paragraph to the left or right edges of the text frame or text object and the para-
graph style.

•  Left Align (default): Select to left align all lines of text; also known as rag 
right.

• Centre Align: Select to centre align all lines of text.

• Right Align: Select to right align all lines of text; also known as rag left.

•  Justified Left: Select to align text to both the left and right edges and to 
left align the last line of the paragraph (recommended for justified text).

Tip: You can also 
choose all of these 
options from the Text 
> Alignment menu or 
click from the equiva-
lent buttons in the 
Context Toolbar

Tip: Do not use 
Justified Left, Centre,
Right, or All with No 
Break because it will 
cause characters to 
overlap

Panel menu

Justification (from left): Left, Centre, and Right 
Align; Justified Left, Centre, Right, and All; Align 
towards spine, Align away from spine

Paragraph style

Panel menu

Spacing: Leading, left/right indents, first 
line indent, space before/after, 

Justification: minimum, desired, and 
maximum word and letter spacing

Bullets & Numbering: options for unordered 
and ordered lists

Drop Caps

Decorations: borders and fill

Justification and paragraph style

Expand/collapse section

Tab Stops

Hyphenation: auto 
hyphenation rules

Initial Words: format a 
paragraph’s first words

Flow: Start, keep, 
widow, and orphan
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•  Justified Centre: Select to align text to both the left and right edges and to 
centre align the last line of the paragraph.

•  Justified Right: Select to align text to both the left and right edges and to 
right align the last line of the paragraph (not recommended for languages 
written left-to-right).

•  Justified All: Select to align text to both the left and right edges and to 
force justify the last line of the paragraph, even if it’s a single word (not 
recommended).

•  Align Towards Spine: Select to left align text on right pages and right 
align text on left pages.

•  Align Away from Spine: Select to right align text on right pages and left 
align text on left pages.

• Paragraph Style: Select the paragraph text style. Any other attributes you 
select in the Paragraph panel will override the paragraph style. Refer to 
Creating text styles on page 211 for more information.

Tip: Affinity does not 
offer a Flush Space
(variable space) 
character which is 
sometimes used with 
Justified All text

Tip: You can also select 
the paragraph style 
from the Text Styles 
panel and Context 
Toolbar
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Spacing
The Spacing section of the Paragraph panel allows you to set the space between 
paragraphs and lines of text as well as how much text is indented from the left or 
right edges.

• Leading: Paragraph leading controls the space between lines of text and is 
measured from the baseline of a line of text to the line above it. Word proces-
sors usually refer to leading as line spacing. To override leading for a range of 
characters in a paragraph, refer to Leading Override on page 157.

Most professionals use exact leading which traditionally was written as font 
size / leading. For example, 10/12 (pronounced 10 on 12) is 10 point type 
with 12 point exact leading.

Applications such as Affinity offer you multiple ways to specify leading but 
Affinity’s Default, At Least, and Multiple options work differently than 
similar features in other applications such as Adobe® software.

Affinity uses the line spacing selected by the font’s designer while Adobe 
software uses a fixed value of 120% of the font height (which can be changed 
in settings in InDesign®). Unfortunately, even fonts from major type 
foundries have inappropriate default leading values which resulted in very 
tight leading in Affinity versions 1 and 2. Affinity version 3 calculates leading 
in a more modern way based on changes to the OpenType font specification 
which will result in more pleasing line spacing. Selecting Use Modern Lead-
ing Calculation will use the new approach.

Tip: Leading is pro-
nounced ledding
because it refers to the 
metal lead which was 
previously used to set 
type

Definition: The 
baseline is the invisi-
ble line on which the 
bases of characters 
without descenders 
are aligned

Using a larger font size for 
some text on a line will 
increase its leading when 
using Default or % Height

Leading is measured 
between baselines

Left and Right indent

First Line indent and 
Last Line outdent

Sum space before and 
after

Align to Baseline Grid 
(override)

Leading

Space before

Space after

Space between same styles

Use space before

Use version 3+ approach to leading
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Use Modern Leading Calculation will be selected by default for new docu-
ments but off for documents, text, and text styles created with Affinity ver-
sions 1 and 2 to avoid changes to your documents. If you used the Default, At 
Least, and Multiple leading options in your older documents, it is recom-
mended that you reformat them with Use Modern Leading Calculation
selected and review the changes to your text flow.

• Default: Select to use the font’s defined line spacing. The calculated lead-
ing value for the font size will be shown as [value] in square brackets when 
you have selected Default. For example, if the font’s default leading is 120%
and the font size is 12 pt, then Affinity will show [14.4 pt].

• Exactly (recommended): Select to specify an exact leading value and then 
enter the value into the field. You can also choose from a list of preset 
leading values. If the font size is greater than the leading then characters in 
the lines of text may overlap.

• % Height: Select to specify a percentage of the font size. The calculated 
leading value will be shown as (value) in parentheses when you have 
selected % Height. For example, if you enter 120% for a font size of 12 pt
then Affinity will show (14.4 pt). If you click in the Leading field again, the 
percentage you entered will be shown.

• At Least: Select to specify the minimum leading for the font size. This 
option is similar to Exactly and will generally result in a fixed leading 
amount but if you increase the font size then leading may increase. The 
value you enter will be shown as (value) in parentheses when you have 
selected At Least to differentiate it from an exact value. For example, if you 
enter 14 pt then Affinity will show (14 pt).

• Multiple: Select to specify leading as a multiple of the font’s default line 
spacing. Selecting Multiple will initially set leading to 1.5 times the font’s 

Leading set to Default for Adobe® Myriad Pro which has default line spacing of 120%; the 
leading will be suitable and identical whether or not Use Modern Leading Calculation is 
selected

Leading set to Default for Monotype® Arial 
which has default line spacing of just 
103% so lines of text are too tight with 
Use Modern Leading Calculation off

Alice was beginning to get 
very tired of sitting by her sis-
ter on the bank, and of having 
nothing to do: once or twice 
she had peeped into the book

Alice was beginning to get 
very tired of sitting by her sis-
ter on the bank, and of having 
nothing to do: once or twice 
she had peeped into the book

Alice was beginning to 
get very tired of sitting by her 
sister on the bank, and of 
having nothing to do: once or 
twice she had peeped into 
the book her sister was read-

Leading set to Default for Monotype® Arial 
with Use Modern Leading Calculation
selected so lines of text are suitably spaced

Alice was beginning to 
get very tired of sitting by her 
sister on the bank, and of 
having nothing to do: once or 
twice she had peeped into
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default leading. If you click in the Leading field, the multiple will be 
shown but otherwise the field will show the calculated leading value for 
the font size will be shown as [value] in square brackets. For example, if 
the font’s default leading is 120%, the font size is 12 pt, and the multiple is 
set to 1.5, then Affinity will show [21.6 pt].
Tip: Word processors such as Microsoft® Word, Google Docs™, LibreOffice, and 
Apple® Pages® offer Line Spacing options that are multiples of the default single line 
spacing. But 1.0 (Single) or 1.5 times Line Spacing in a word processor is not equiva-
lent to Multiple of 1.0 or 1.5 in Affinity, although that is how the text will be imported 
from these programs. Microsoft Word and LibreOffice use a fixed line spacing of 
120% of the font height, so to match their line spacing in Affinity select Exactly and 
set leading to 120% of the font height multiplied by the line spacing value chosen in 
Word (e.g., 1.0 or 1.5). Google Docs and Pages work similarly to Affinity but calculate 
leading differently so it is recommended that you adjust leading as required after 
importing.

You can set paragraph leading with the Spacing section of the Paragraph 
panel or with the Paragraph Leading  icon in the Context Toolbar. You can 
also increase or decrease leading by a set increment instead of specifying a 
leading value by choosing Text > Paragraph Leading > Increase, Decrease, 
Precise Increase, or Precise Decrease or their keyboard shortcuts:

Command macOS Windows Increment

Increase ⌥ + ↓ Alt + ↓ 2 pt, 0.02 in, 0.2 mm, 21%, 0.21x

Decrease ⌥ + ↑ Alt + ↑ 2 pt, 0.02 in, 0.2 mm, 21%, 0.21x

Precise Increase ⌘ + ⌥ + ↓ Ctrl + Alt + ↓ 0.2 pt, 0.001 in, 0.01 mm, 3.6%, 0.03x

Precise Decrease ⌘ + ⌥ + ↑ Ctrl + Alt + ↑ 0.2 pt, 0.001 in, 0.01 mm, 3.6%, 0.03x

• Left/Right Indent: Enter the amount that the paragraph should be 
indented from the left and right edges of the text frame or object. Entering a 
value for Left Indent will automatically change First Line Indent by the same 
amount, and entering a value for Right Indent will change Last Line Outdent
by the same amount.

• First Line Indent: Enter the amount that the first line should be indented 
from the left edge of the text frame or object. A typical value for a book is one 
or two times the font size. To creating a hanging indent, enter the indent 
value into Left Indent and then set First Line Indent to zero.

Affinity uses the macOS approach to first line indent and doesn’t work the 
same way as Adobe® and Microsoft® applications. To create an indented first 
line, set Left Indent to 0 and First Line Indent to a positive value. To create a 
hanging indent, set Left Indent to a positive value and set First Line Indent
to 0.

• Last Line Outdent: Enter the amount that the last line should be indented 
from the right edge of the text frame or object. This feature is often used with 
tables of contents and menus to hang their page numbers and prices outside 
of the text by setting Right Indent to the value that the paragraph text should 

Tip: Instead of using 
Left and Right Indent, 
You can inset all text in 
a text frame with the 
Insets fields in the 
Text Frame panel

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
leading; refer to 
Keyboard shortcuts on 
page 452

Tip: You can set Left, 
Right, and First Line 
Indent visually with 
the Text Ruler; refer to 
Tab Stops in the 
following section for 
an example
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be indented from the right edge of the text frame and setting Last Line Out-
dent to 0.

•  Space Before/After: Enter the amount of space that should be added 
between paragraphs. You can add space before or after the paragraph, or add 
both. The behaviour of these controls is modified by Space Between Same 
Styles, Sum Space Before and After, and Use Space Before which are 
described below.

• Space Between Same Styles: Select to override the defined Space Before and 
Space After values and enter the amount of space to add between two para-
graphs of the same paragraph style.

• Sum Space Before and After: Select to add both Space Before and Space 
After. When deselected, Affinity will use only the larger value.

• Use Space Before: Select Only Between Paragraphs to avoid adding Space 
Before the first line of text in a column or text frame or select Always to allow 
space to be added at the top of a column or frame. You can also select Only at 
Column Top but there is no reason to use that option.

• Align to Baseline Grid: Select to ignore the baseline grid(s) of the document 
or text frame allowing the paragraph to be positioned according to the text 
formatting. This setting overrides the baseline grid for the paragraph. Refer to 
Baseline grid on page 90 for information on using a baseline grid.

• Use Modern Leading Calculation: Refer to Leading on page 170.

Tip: Always use Space 
Before or Space After
to add space between 
paragraphs instead of 
pressing Return a 
second time so that 
you can control the 
amount of space; use 
the Find and Replace
panel to replace 
double paragraph 
returns with a single 
one

Tip: Use Space 
Between Same Styles
to reduce the space 
between items in a 
bulleted or numbered 
list while continuing 
to add more space 
before and after the 
first and last list 
paragraphs

Misir Wot: Lentil stew in berbere 
sauce .............................................................5
Yekik Alicha: Yellow split peas in mild 
turmeric sauce .........................................12

Misir Wot: Lentil stew in berbere 
sauce .............................................................5
Yekik Alicha: Yellow split peas in 
mild turmeric sauce ...............................12

With Right Indent = 1p6 (18 pt) and Last Line Outdent
= 0, the page numbers will hang to the right of the 
menu items

With Right Indent = 0 and Last Line Outdent = 0, the 
page numbers will be aligned with the menu items
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Tab Stops
The Tab Stops section of the Paragraph panel allows you to indent text with tab 
characters to specific positions relative to the left edge of a text frame or object. 
You can also specify that the tab’s space be filled with a visible character to form a 
dot leader or other type of leader.

Click the More  icon for a tab stop or click a tab stop in the Text Ruler to 
display a popup window and edit additional tab stop settings:

When working with tab stops you may wish to choose use the Text Ruler to 
visually set and modify tab stops. Click the Frame Text Ruler  icon in the 
Context Toolbar or choose View > Show > Text Ruler to toggle its display. The 
Text Ruler will appear above the active text frame or object. You can move the 
ruler closer to the text you are formatting by dragging the handle on the left side 
of the ruler.

Drag an indent or tab stop marker in the Text Ruler to change its position. Click 
a tab stop marker to edit its values in the same popup window above that is 
opened from the Tab Stops section of the Paragraph panel.

• Default tab stops: Set the default spacing for tab stops. Adding tab stops will 
override the default spacing until the last added tab stop at which point the 
default spacing will resume.

• Add tab stop: Click  to create a new tab stop. Its default position will be the 
sum of the last tab stop and the default tab stop spacing. You can also add a 
tab stop by clicking on the Text Ruler.

• Tab stop position: Set the position for the tab stop. You can also change a tab 
stop’s position by dragging its marker in the Text Ruler.

Tip: The Text Ruler is 
not available for art 
text or path text 
objects

Decimal Character

Delete Tab Stop

Alignment

Leader CharacterLeader Type

Measure from right edgeTab Stop Position

Drag to move

First Line Indent Right IndentLeft Indent
Tab Stop Insertion point (text cursor)

Leader Type MoreTab stop alignment

Delete tab stop

Add tab stop

Tab stop value

Tab stop list

Default tab stops

Tip: For text frames or 
objects with curved or 
irregular left edges, 
tab stops are relative 
to the leftmost point; 
for Path Text, the tab 
stops are positioned 
along the path and 
not necessarily in a 
straight line
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Click the More  icon and select From Right to measure the position from 
the right edge of the ruler. You can also change where a tab stop is mea-
sured from by dragging the tab stop between the top and bottom of the text 
ruler. Drag it from the bottom to the top of the text ruler to measure it 
from the right or to the bottom to measure it from the left. Measuring from 
the right is commonly used in conjunction with a leader.

• Tab stop alignment: Select the alignment for the tab stop. You can also 
change a tab stop’s alignment by clicking its marker in the Text Ruler and 
selecting an alignment from the popup window.

• Left: Select to left align text to the tab stop.

• Centre: Select to centre align text to the tab stop.

• Right: Select to right align text to the tab stop.

• Decimal: Select to align the next decimal in the text to the tab stop. 
The default decimal character is a period but you can change it by click-
ing the More  icon and entering a different character into the Decimal
field.

• Leader type (dot leader): Click the More  icon for a tab stop or click a 
tab stop in the Text Ruler and select a dot leader type:

• None: Select to use a normal blank tab.

• Character: Select to fill the tab space with a leader. The default 
period character will create a dot leader but you can enter custom leader 
characters. To create leaders with wider spacing, enter a period followed 
by one or more spaces.

• Underline: Select to fill the tab space with underline characters 
which is useful for creating printed forms.

• Strikethrough: Select to fill the tab space with strikethrough 
characters.

• Delete tab stop: Click the Delete  icon to delete the corresponding tab 
stop. You can also delete a tab stop by dragging it off of the Text Ruler and 
then releasing the mouse button.

Tip: You can also 
double-click a tab stop 
in the Text Ruler to 
cycle through the 
types of tabs until you 
reach the one you 
want

Tip: To create a dot 
leader, you must also 
set the tab stop’s 
Alignment to Right
and its Position to 0, 
and select From Right
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Justification
Justifying text, aligning it to both the left and right edges of the text frame or 
object, requires adding and removing space between words and letters to balance 
lines of text. The Justification section of the Paragraph panel allows you to set 
minimum, desired, and maximum word- and letter-spacing for the Justified 
options in the top section of the panel.

The minimum and maximum options will have no impact on left-, centre-, or 
right-aligned text. For word spacing, you can enter values from 0 to 250% while 
for letter spacing you can enter values from -100 to 250%. However, for both 
word and letter spacing, the Minimum value must be less than the Desired value 
which must be less than the Maximum value.

Affinity will do its best to honour the values you set and will never use less than 
the minimum spacing, but if it is impossible to fit or break a word, Affinity will 
exceed the maximum as required.

• Minimum, Desired, and Maximum word spacing: Set the desired 
space between words and sentences. Change the desired word spacing to 
reduce or increase the width of the space character. Change the minimum 
and maximum word spacing to avoid unsightly rivers of white space in justi-
fied text; minimum and maximum will have no effect on non-justified text. 
The default values of 80, 100, and 133% will work well for most text.

• Minimum, Desired, and Maximum letter spacing: Set the desired 
space between characters, before the application of kerning and tracking. 
These values will be set to zero by default so that space will be added and 
removed only between words. You would not normally set desired spacing to 
more than zero but if your text has unsightly rivers of white space, you might 
consider increasing the maximum. Minimum and maximum will have no 
effect on non-justified text. Changing the desired spacing is similar to chang-
ing tracking for a paragraph.
Tip: Due to a bug with hyphenating justified text, you must set Minimum, Desired, and 
Maximum letter spacing to 0 for hyphenation to work properly. If you set these values 
for justified text with Auto Hyphenation enabled or with words that include soft 
hyphens, Affinity may not break words at the optimal positions leading to undesirable 
white space between words.

To avoid whitespace rivers in justified text:

1. Use the Find and Replace panel to search for double spaces between sen-
tences and replace them with single spaces; double spaces can interfere with 
word spacing in justified text. Enter two spaces into the Find field and one 
space into the Replace field.

Tip: Affinity does not 
also offer Glyph 
Scaling (horizontal 
scaling) for automatic 
justification

Tip: Using two spaces 
between sentences 
will interfere with the 
word spacing settings

Minimum, Desired, and Maximum letter spacing

Minimum, Desired, and 
Maximum word spacing

Tip: If you don’t want 
to change the Justifi-
cation options, review 
your text for incorrect 
hyphenation and 
insert soft hyphens 
where possible
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2. Turn on automatic hyphenation. Refer to Hyphenation on page 185. For text 
written in English US, English Canada, and English Australia, consider using 
the English UK hyphenation dictionary. Even with differences in spelling, 
using the UK dictionary will result in better hyphenation for American 
English.

3. Make small adjustments to the minimum and maximum word and letter 
spacing in paragraphs that have whitespace rivers; see above.

4. Tighten or loosen a line of text by adjusting Tracking. Refer to Position and 
Transform on page 155.

5. If possible, reword the text.

6. As a last resort, manually adjust Horizontal Scale for a line of text. Affinity 
does not have an automatic glyph scaling feature but you can scale glyphs 
manually. Refer to Position and Transform on page 155.
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Flow
The Flow Options section of the Paragraph panel allows you to direct Affinity to 
avoid creating widows and orphans and to set where a paragraph should start.

Incorrect use of these options can lead to unusual text flow with entire para-
graphs moved to the next page.

A widow occurs when the last line of a paragraph can’t fit at the bottom of the 
previous text frame or column and is positioned on its own at the top of a 
column. An orphan occurs when the first line of a paragraph is all that can fit at 
the bottom of a text frame or column. A runt occurs when the last line of a 
paragraph has only a single word.

• Start anywhere: Set where the paragraph will start. This option is often used 
to start certain levels of headings at the top of the next page, text frame, or 
column as an alternative to manually inserting a page, column, or frame 
break.

• Anywhere: Select to allow the paragraph to start anywhere after the previ-
ous paragraph.

• In Next Column: Select to force the paragraph to start in the next column.

• In Next Frame: Select to force the paragraph to start in the next text 
frame.

• On Next Page, Next Odd Page, Next Even Page: Select to force the para-
graph to start on the next page or next odd or even numbered page. Next 
page refers not to the next sequential page but to the next text frame in the 
linked series that is not on the current page.

• Keep with previous paragraph: Select to keep at least the first line of the 
paragraph with the last line of the previous paragraph. Setting this option for 
a paragraph following a heading will avoid the heading being positioned at 
the bottom of a text frame or column without text beneath it.

Widow

Orphan

Runt

Widow

Tip: Don’t set both 
Keep with Previous 
Paragraph and Keep 
Paragraph Together
for all body text

Tip: Affinity does not 
offer an option to 
avoid runts; one way 
to fix a runt is to select 
the runt and the 
preceding word and 
set No Break so that 
the last two words will 
be on a new line; you 
could also replace the 
space between then 
with a non-breaking 
space but the com-
bined word may be 
hyphenated

Keep with previous
Prevent orphans

Keep together
Prevent widows

Start paragraph

Line break mode for non-Latin scripts

Keep with next
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• Prevent orphaned first lines: Select to keep the first two lines of a paragraph 
together to avoid an orphan at the bottom of a text frame or column.

• Keep paragraph together: Select to keep the entire paragraph together. If the 
next text frame or column isn’t large enough to fit the entire paragraph then 
Affinity will be forced to break it.

• Prevent widowed last lines: Select to keep the last two lines of a paragraph 
together to avoid a widow at the top of a text frame or column.

• Keep with next: Enter the number of lines of the next paragraph that the last 
line of a paragraph should be kept with. Always use this option together with 
Prevent widowed last lines to avoid creating widows.

• Line Break Mode: Affinity can break a paragraphs to a new line in two ways. 
Western line breaking breaks text at spaces and hyphens while International
line breaking can break at any character based on dictionary rules. The Auto
option (default) uses the appropriate mode based on the spelling language 
defined for the text, although Affinity will generally break lines correctly even 
if spelling language is set to None. There are two reasons you may need to 
change this setting from Auto:

• Korean text with ragged margins often uses Western line breaking and 
spaces, even for ideographs while justified Korean text usually uses Inter-
national line breaking even for interspersed Latin characters.

• If the spelling language is a Western (Romance) language but lines are not 
breaking as expected at spaces and hyphens, select Western because Auto
defaults to International line breaking unless the spelling language is a 
language identified as Western by Affinity.
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Bullets & Numbering
The Bullets & Numbering section of the Paragraph panel allows you to create 
and set the formatting of bulleted and numbered lists. Affinity allows you to 
create multi-level (hierarchical) lists as well as those spanning an entire 
document.

Each item in a list must be a separate paragraph; entering a line break will not 
create a new item in the list.

To create a bulleted or numbered list:

1. Position the text cursor in a paragraph or select a range of paragraphs.

2. Select the Bulleted List  or Numbered List  icons in the Context Tool-
bar or choose Text > List > Bullet or Number.

3. Set the list formatting options as described below.

4. To add another item to the list, position the text cursor at the end of a list 
paragraph and press Return.

5. To end the list, press Return to start a new paragraph and set List Type to No 
List.

To change a bulleted or numbered list to regular paragraphs:

1. To remove the bullets or numbers entirely, select the paragraph(s) and dese-
lect the Bulleted List  or Numbered List  icon in the Context Toolbar.

You can also deselect the Text > List > Bullet or Number command or set 
Type to No List in the Bullets & Numbering section of the Paragraph panel.

2. To convert the bullets or numbers from a list to editable text, select the para-
graph(s) and choose Text > Expand > Expand List. The visual appearance of 
the paragraphs will be unchanged but you will now be able to format or delete 
the bullets and numbers.

To create a multi-level (hierarchical) list:

1. Create a bulleted or numbered list.

2. Position the text cursor at the start of a list paragraph that should be a child of 
the item before it, or select a range of paragraphs.

3. Press Tab to increase the list level or press Shift + Tab to decrease the list level. 
This will change the List Level and Left Indent values without entering a tab 
character.

4. To include the parent’s number in the list number (for example, 1.1, 1.2…), 
insert the parent’s level number  into the Text field by clicking the caret
icon at its left and selecting from the popup menu. For example, the Text field 
should contain the following for these number formats:

Tip: It is recom-
mended to use 
paragraph styles to 
format bulleted and 
numbered lists to 
ensure consistent 
formatting

Tip: Bullets and 
Numbers are not plain 
text so their characters 
cannot be found with 
Find and Replace and 
are not counted by 
Word Count
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Format Text value Notes

7.1, 7.2, 7.3…  .   refers to the parent level

7.2.1, 7.2.2, 7.2.3… . .   refers to the first parent level and 
  refers to the second parent level

7a, 7b, 7c…  This is the same as the first level but with a
  different number format and without the
  decimal

To format list markers (bullets and numbers):

If you apply character formatting to the first character in a bulleted or numbered 
paragraph, the formatting will also be applied to the list marker, the bullet or 
number.

1. Create a character style for the list marker that specifically defines the 
attribute you do not want changed by the following paragraph text’s format-
ting. For example, if you apply Bold to the following text, define this style as 
Regular.

2. Select the list paragraphs and select the character style from the Character 
Style option in the Bullets & Numbering section of the Paragraph panel.

To create a running list (a named list for global numbering):

In addition to creating a list of consecutively numbered paragraphs, you can 
create a running list and add new items to it anywhere in your document or 
Affinity Book. Named lists are especially useful for numbering figures and 
illustrations.

If you add paragraphs to the same list in multiple text frames on the same page, 
they could be numbered incorrectly depending on the position of the text frames 
in the layer stack. The text frame that should be numbered before another should 
be lower in the layer stack than the other frame.

1. Select a numbering style from the Type field.

2. Enter the text to define the list marker in the Text field. You can include 
Figure or a similar word as a prefix.

Format Text value

Figure 1: some text…  Figure : 

3. Set Tab Stop to 0 if the list marker (Text) includes or will be followed by a 
space and set Marker Alignment to Left.

4. Set Start Numbering At to 1.

5. Set Restart Numbering to Manual Only and deselect Restart Numbering 
Now.

Definition: The term 
Running List refers to 
a list that is inter-
rupted by other 
paragraphs and even 
the end of a story or 
Chapter

Tip: An alternative to 
using a character style 
to avoid the format-
ting of the first charac-
ter changing the list 
marker is to insert a 
Zero-Width Space 
between the marker 
and first character
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6. Enter a Name that is unique to all of the paragraphs in this list. To create a 
hierarchical running list, all levels of the hierarchy must share the same name.

7. Select Global.

8. Optional: Select a character style to apply to the list marker (Text).

9. Optional: To right-align the numbers, set Marker Alignment to Right. Using 
the Spacing section of the panel, set First Line Indent to greater than zero.

10. Create a paragraph style for this list. For all subsequent items in this noncon-
secutive list, you must set every item in the Bullets & Numbering panel 
section exactly the same for the list to continue and be formatted consistently, 
so it is easier to do this using a paragraph style. Refer to Creating text styles
on page 211 for more information.

Using the Bullets & Numbering panel:

• List type: Select Bullet for a bulleted list or select one of the number formats 
for a numbered list to change a regular paragraph to a list. Select No List to 
change a list paragraph back to a regular paragraph.

It is recommended to use this setting only when editing paragraph styles and 
formatting lists and to instead select the Bulleted List  or Numbered List

 icons in the Context Toolbar or choose Text > List > Bullet or Number. 
These options don’t provide the means to select the bullet character or 
number format but they will automatically indent the list paragraph, saving 
you from having to manually format a standard list.

• List level: Set the list level to a value between 1 and 9 for a multi-level (hierar-
chical) list or choose Text > List > Increase Level or Decrease Level or their 
keyboard shortcuts:

Command Shortcut

Increase Level Ctrl + Shift + ] (Alt + Shift + ])

Decrease Level Ctrl + Shift + [ (Alt + Shift + [)

Changing this number will not automatically change the list paragraph’s left 
indent. It is recommended to use this setting only when editing paragraph 

List type

List marker

Marker tab stop

Start numbering at

List name

List character style

List level

Bullet glyph browser

Marker alignment

Restart numbering where

Restart numbering now (override)

Global list

Tip: If a paragraph was 
previously formatted 
as a list, using the 
menu commands or 
Context Toolbar icons 
will restore its prior 
format

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
leading; refer to 
Keyboard shortcuts on 
page 452

Tip: Test with the 
largest number to 
determine the appro-
priate First Line 
Indent value
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styles and to instead position the text cursor at the start of a paragraph or 
select the paragraphs and press Tab or Shift + Tab to change the Left Indent
value at the same as the list level is changed.

• Text (list marker): Enter the text to define the list marker:

Bulleted list: Enter a bullet character followed by a tab . Click the caret 
icon at the left of the field to select from a list of common bullet characters or 
click the more  icon to select a bullet from the Glyph Browser. A bulleted 
list will normally have the same bullet character(s) for each list paragraph but 
it is possible to use a different bullet for each item.

Numbered list: Click the caret  icon at the left of the field to select from a 
list of options including list number levels. The default value of the current 
number level  followed by a tab  is suitable for basic lists. To format a 
number such as 1.2.3, use the parent number levels for the first two levels 
separated by periods, for example, . .

• Tab stop: Enter the amount of space from the list marker (text) to the start of 
the paragraph text because lists don’t use the default or set tab stops but have 
their own tab stop value. Choose a value that is wide enough to fit the largest 
number and the white space before the paragraph text.

• Marker alignment: Select the alignment of the bullet or number Text
(marker). This is normally used only with numbered lists so that the numbers 
can be right aligned, but it can also be used with bulleted lists that have 
glyphs of varying widths.

• Start numbering at: To start numbering at a value other than 1, enter a 
different starting number.

• Restart numbering: Set when numbered should be restarted.

• Any Non List (default): Select to restart numbering after any paragraph 
that isn’t numbered and at the next paragraph with a higher List Level.

• Manual Only: Select to allow numbering to continue throughout a story 
even if there are intervening paragraphs that aren’t numbered.

To right align the numbers, 
set Marker Alignment to 
Right and First Line Indent to 
a value that is greater than 
zero, less than Left Indent
and Tab Stop, but wide 
enough to fit the numbers

Tip: First Line Indent
must be set to greater 
than zero with centre- 
and right-aligned 
markers

Tip: Test with the 
largest number to 
determine the appro-
priate First Line 
Indent value

Tip: Refer to Glyph 
Browser on page 126

Tip: When using Tab to 
indent selected 
paragraphs, you must 
start the selected text 
range at the begin-
ning of a paragraph or 
a tab character will be 
entered, deleting the 
selected text

Example of a multi-level numbered list with Marker 
Alignment set to Left

• for level 1, Tab Stop and Left Indent are set to 2p (24 
pt) and First Line Indent is set to 0

• For level 2, Tab Stop is set to 4p (48 pt) and Left 
Indent and First Line Indent are set to 2p (24 pt)
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• Below Current Level: Select to allow numbering to continue throughout a 
story as with Manual Only but to restart numbering at the next paragraph 
with a higher List Level.

• Below Level #: Same as above but below a specified level number. This 
option is available only when there is already at least a second level.

• Restart numbering now: Select to restart numbering at 1 with the current list 
paragraph and override the Restart numbering setting.

• Name and Global: Enter a name for a list to be continued throughout multi-
ple stories in a document or in the chapters of an Affinity Book. For each list 
in each story, set Restart numbering to Manual Only, enter a list name, and 
select Global. The names you enter must exactly match for list numbering to 
be continued.

• Style: Select a character style to apply to the list marker (Text). Use this option 
if you want the bullets to be a different colour than the text or the numbers to 
be bold.
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Hyphenation
The Hyphenation section of the Paragraph panel allows you to enable automatic 
hyphenation and configure how it functions.

Using hyphenation with the default settings, especially in narrow columns, can 
lead to hyphenation issues.

Customising the default settings will correct most issues but the ideal settings 
depend on the font, column width, language, and content type. Words containing 
a soft hyphen (discretionary hyphen) will never be hyphenated at any other 
position. You can prevent a word such as a name from being hyphenated by 
inserting a soft hyphen before the word; it will never be visible.

• Use auto-hyphenation: Select to enable hyphenation or deselect to disable it. 
It is recommended that hyphenation be disabled for heading styles.
Tip: Due to a bug with hyphenating justified text, you must set Minimum, Desired, and 
Maximum letter spacing to 0 for hyphenation to work properly. If you set these values 
for justified text with Auto Hyphenation enabled or with words that include soft 
hyphens, Affinity may not break words at the optimal positions leading to undesirable 
white space between words.

Tip: Choose Text > 
Insert > Dashes and 
Hyphens > Soft 
Hyphen to insert a 
soft hyphen

Enable hyphenation

Minimum score (0 to 10, whole numbers)

Minimum word length (shortest word to hyphenate)

Minimum prefix (characters before hyphen)

Minimum suffix (characters after hyphen)

Maximum consecutive hyphens

Hyphenation zone

Capital zone

Paragraph end zone

Column end zone

2-character prefix

4 consecutive hyphens

Example of hyphenation 
issues using default settings

Setting Max Consecutive Hyphens, Minimum 
Prefix, and Maximum Prefix to 3 corrects the issues 
except for the hyphenated name which can be 
fixed by inserting a soft hyphen before the name

Hyphenated name Hyphenated name
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• Minimum score (not recommended): Enter a whole number between 0 
(default) and 10 to control how aggressively text is hyphenated. Affinity will 
hyphenate at any point with a score of 0 but only at the most preferable points 
with a score of 10. In practice, scores higher than 5 will lead to no hyphen-
ation. Scores of 0 or 1 are recommended for strong hyphenation or 2 or 3 for 
less hyphenation.

• Minimum word length: Enter the minimum number of characters a word 
must have for it to be hyphenated. The default value of 5 is recommended for 
English text.

• Minimum prefix and suffix: Enter the minimum number of characters before 
the first hyphen in a word and after its last hyphen. For example, changing 
these options from their default of 2 to 3 would cause automatic to be 
hyphenated only as auto-matic instead of as au-tomatic in addition to 
auto-matic. It is recommended to change these options to 3 for English text.

• Max consecutive hyphens: Enter the maximum number of consecutive 
hyphens that should be allowed. The default of 0 will allow unlimited consec-
utive hyphens. Values of 2 or 3 are recommended.

• Hyphenation zone: Enter the amount of space from the right edge allowed at 
the end of a line before hyphenating the next word. The default of 0 will allow 
any hyphenation while increasing the value will result in less hyphenation. 
Commonly-used values are 2–3p, 24–36 pt, 0.3–0.5 in, or 8–12 mm.

• Capital zone: Enter a separate hyphenation zone value for words that are in 
all uppercase. Set a value larger than the width of most uppercase words to 
prevent them from being hyphenated.

• Paragraph end zone: Enter a value to override the paragraph’s Hyphenation 
Zone value for the last full line of the paragraph. Many users set this value to 
about 150% of Hyphenation Zone to avoid hyphenating short words at the 
end of a paragraph. To prevent the last word in a paragraph from being 
hyphenated regardless of length, set this value to at least the width of the 
column.

• Column end zone: Enter a value to override the paragraph’s Hyphenation 
Zone value for the last line of a column that is continued in another column. 
To avoid hyphenating the last word in a column, set this value to the width of 
the column. To allow longer words to be hyphenated at the end of a column, 
set this value to about 150% of Hyphenation Zone.

Tip: Affinity does not 
offer an option to 
prevent capitalised 
words, including 
proper names, from 
being hyphenated; it is 
recommended that 
you review your text 
and address issues by 
inserting a soft 
hyphen before a 
hyphenated name to 
disable automatic 
hyphenation; you can 
also format it with No 
Break
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Drop Caps
The Drop Caps section of the Paragraph panel allows you to scale and position 
the first character or characters of a paragraph so they occupy the space of multi-
ple lines of text. Drop caps are commonly used in books at the start of a chapter.

To create a basic drop cap:

1. Position the text cursor in a paragraph or select a paragraph.

2. Select Enabled in the Drop Caps section of the Paragraph panel.

3. Increase the Distance to text value to add white space to the right of the drop 
cap character to avoid a drop cap with a vertical right stroke encroaching on 
the neighbouring characters.

4. Select Align left edge so that the enlarged drop cap character is better aligned 
with the text below it.

5. To create a drop cap of more than one character, deselect Auto and enter the 
number of characters.

• Enabled: Select to create a drop cap at the start of the paragraph or deselect to 
remove the drop cap.

• Height in lines: Enter the height of the drop cap in lines of text. You may 
enter values of 1 to 20 and the default is 3. A value of 1 will appear as normal 
text.

• Characters: When Auto is deselected, enter the number of characters that 
should be formatted as a drop cap. You can enter up to 20 characters but a 
drop cap should never be longer than the first word.

Enable drop caps

Gap between

Drop cap character style

Drop cap height

Number of characters to format as a drop cap

Align drop cap to frame
Scale if descender present

Example of a 3-line drop cap Example of a 5-character wide drop cap
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• Auto: Select to convert the first alphanumeric character and any preceding 
punctuation to a drop cap. Deselect to specify the number of characters to 
include in the drop cap.

The Auto setting is better than specifying one character manually because if 
the first letter is preceded by a quotation mark, they will be converted 
together into a drop cap together. To hang the quotation mark outside the left 
edge of the text frame, select the quotation mark and set Type to Font in the 
Optical Alignment section of the Character panel.

• Distance to text: Enter a value to add white space to the right of the drop cap 
character to avoid a drop cap with a vertical right stroke encroaching on the 
neighbouring characters.

• Align left edge: Select so that the enlarged drop cap character is better 
aligned with the text below it.

• Scale for descenders: Select if you are converting a lowercase letter with a 
descender to a drop cap to avoid the descender overlapping the text below. 
Affinity will automatically scale the drop cap so that the entire glyph is inside 
the specified number of lines.

• Style: Select a character style to apply to the drop cap. Use this option to 
change the font or colour for the drop cap rather than directly applying 
formatting attributes.

Tip: You cannot 
override an attribute 
of the Drop Caps Style
if it’s defined as part of 
that style; for example, 
if Style is defined as 
Garamond, you cannot 
select the text and 
format it as Times

Example of a drop cap using Auto Example of a drop cap using Auto with 
Optical Alignment enabled



Expert Guide to Affinity by Canva 3.0 189

Initial Words
The Initial Words section of the Paragraph panel allows you to apply different 
formatting to the first few words of a paragraph. This option is used with some 
books that apply formatting such as uppercase letters to the first few words but it 
can also be used to apply formatting such as bold to the text in a bulleted list 
until a punctuation character is encountered.

• Enabled: Select to format the first words with different formatting at the start 
of a paragraph or deselect to remove the Initial Words. There is no default 
formatting for initial words so this setting will have no apparent impact until 
you select a Style.

• Max word count: Enter the number of words to format as initial words, up to 
a maximum of 50 words.

• End characters: To end the Initial Words formatting before the Max Word 
Count limit is reached, enter one or more characters at which to automati-
cally end the formatting. The most common end characters are included in 
the field by default but you can enter any character. Click the caret  icon at 
the left of the field to select from a list of common special characters.

• Style: Select a character style to apply to the initial words. Tip: You cannot 
override an attribute 
of the Initial Words 
Style if it’s defined as 
part of that style; for 
example, if Style is 
defined as Garamond, 
you cannot select the 
text and format it as 
Times

Enable initial words

Number of words to format as Initial Words

End characters for early termination

Initial words character style

Example of initial words using 
default settings with a bold 
character style

Example of initial words using 
default settings with a bold 
character style and Optical 
Alignment enabled
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Decorations (background and borders)
The Decorations section of the Paragraph panel allows you to set the stroke and 
background fill for paragraphs. Strokes on all four sides can be combined to 
create a box around a paragraph while strokes on the top and bottom can be used 
for rules above or below a paragraph.

The background fill for a paragraph extends to its left and right edges and fills the 
space between lines of text while the similar Background Colour option in the 
Character panel only fills behind the individual characters.

A decoration is made up of one or more stroked sides and the background fill. 
You can create multiple decorations for a paragraph which will be automatically 
named Decoration 1, 2, 3… Strokes will be applied in numerical order so if you 
set Decoration 1 to have a 10 pt black stroke and Decoration 2 to have a blue fill, 
the blue fill of Decoration 2 will obscure the inner half of Decoration 1’s stroke.

• Selected decoration: When using more than one decoration, select the deco-
ration to edit or delete.

• Add/Delete decoration: Click Add  to create an additional decoration or 
Delete  to delete the selected decoration. New decorations will be created 
with the same settings as the selected decoration.

• Stroke side and fill: Select the left , top , right , or bottom  side(s) 
to which to add a stroke (border or rule) or fill .

• Indent from: Enter a positive value to indent the fill and stroke, or a negative 
value to outdent the fill and stroke.

Tip: There is no limit 
on the number of 
decorations you can 
add

Tip: To add a fill 
behind the entire text 
frame instead of just 
the paragraph or 
characters, use the 
Text Frame panel

Tip: Affinity does not 
offer separate Rule 
Above/Below and 
Border features but 
instead offers the 
more flexible Decora-
tions feature that 
allows you to create 
any combination of 
rules and borders

Use paragraph decorations 
to create callouts

Example using a background 
fill and left stroke

Selected decoration

Stroke side and Fill

Indent from

Add/Delete decoration

Indent relative to

Stroke colour Stroke

Fill colour Transparency

Combine identical decorations

This text has a 
character 
background

This text has a 
paragraph 
background

Example of character 
background colour

Example of paragraph 
background colour
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• Indent relative to: Select how the fill and stroke are aligned. The left and right 
sides can be aligned to:

• Column: Select to align to the left or right edge of the column.

• Indents: Select to align to the Left Indent and Right Indent values speci-
fied in the Spacing section of the panel.

• Text (default): Select to align to the left or right edge of the longest line of 
text in the paragraph. For text that is left-aligned, setting the left side to 
Text will have the same result as selecting Column while setting the right 
side to Text will usually result in a fill and stroke that are inset from the 
column’s edge.

The top and bottom sides can be aligned to:

• Ascent: Select to align to the highest ascent of all the characters on the first 
(top) or last (bottom) line of text. This option is not recommended for 
bottom because the fill and stroke would be above the line of text.

• Baseline: Select to align to the baseline of the first (top) or last (bottom) 
line of text. This option is not recommended for Top because the fill and 
stroke would be below the line of text, overlapping only the descenders.

• Cap Height (default for Top): Select to align to the highest cap height of 
any character on the first (top) or last (bottom) line of text. This option is 
not recommended for bottom because the fill and stroke would be above 
the line of text.

• Descent (default for Bottom): Select to align to the lowest descent of all 
the characters on the first (top) or last (bottom) line of text. This option is 
not recommended for top because the fill and stroke would be below the 
line of text.

• X Height (not recommended): Select to align to the largest x height of any 
character on the first (top) or last (bottom) line of text.

• Stroke: Click the colour sample to set the colour of the border stroke and 
click the stroke control on its right to set its thickness, dash pattern, and other 
properties.

• Fill colour: Click the colour sample to set the colour of the fill.

• Transparency: Click to set the transparency of the fill and stroke.

• Combine identical decorations: Click to combine overlapping decorations 
from multiple paragraphs. The horizontal strokes will be removed and the fill 
extended to include the space between the paragraph.

Two paragraphs
of text

Two paragraphs
of text

Two paragraphs
of text

Two paragraphs
of text

Combine identical off Combine identical on

Tip: Refer to Fill, 
stroke, and colour on 
page 249 for more 
information on 
selecting colours
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Setting default text formatting
Affinity allows you to change the default values for all character and paragraph 
formatting. You can customise the defaults by setting all of the formatting 
options to what you would like them to be and then saving that group of settings 
as the new defaults. You can also revert to Affinity’s original defaults at any time.

In addition to the default formatting used for new documents, Affinity also has 
session defaults, the formatting that is currently in use. For example, Affinity’s 
factory default formatting is Arial 12 pt and if you choose Garamond 14 pt that 
will be the current session default. Setting the default formatting saves the cur-
rent session defaults.

Affinity has separate default formatting for text frames (standard text frames, 
shape text frames, and tables) and for text objects (art text and path text).
When you save the current formatting as the default, you are saving changes to 
both text frame and text object defaults at the same time.

Setting the default formatting will save character, paragraph, and the names of 
the default character and paragraph text styles, but it will not save the text style 
definitions. If you set the defaults while a paragraph or character style is in use, 
the text style name will be saved in your defaults, but for that to be effective you 
would also need to save that text style as a default style for new documents. Refer 
to Importing and setting default text styles on page 217.

To set the default formatting based on formatted text:

1. Choose the Frame Text  or Table  tool to set the defaults for text frames, 
including shape text frames and tables. Or choose the Artistic Text  or any 
other tool to set the defaults for text objects, including art text and path text.

2. Position the text cursor in the text whose formatting you want to set as the 
default and choose Edit > Defaults > Synchronize from Selection to set 
Affinity’s session defaults to match the text’s formatting.

The defaults for new text frames and/or text objects in this document will 
now be changed. To set the defaults for both text frames and text objects, 
repeat steps 1 and 2 with the other tool selected.

3. To save these session defaults as Affinity’s defaults for new documents, choose 
Edit > Defaults > Save.
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To change Affinity’s defaults for one or more attributes:

1. Create a temporary new document; its settings are unimportant because it 
will be deleted when you’re done.

2. Choose either the Frame Text  or Table  tools to set the defaults for text 
frames, including shape text frames and tables. Or choose the Artistic Text
tool or any other tool to set the defaults for text objects, including art text and 
path text.

3. Change any attributes you wish to change.

4. To set the defaults for both text frames and text objects, you must select the 
attribute separately for both tools. For example, choose the Frame Text
tool and select a font family, and then choose the Artistic Text  tool and 
reselect the same font family, even though the control will show that it’s 
already selected.

• For a list control such as Font Family, select the option from the list a 
second time by clicking it twice—once to open the list and once to select it 
again.

• For a text field control such as Font Size, click in the text field and press 
Return.

• For a checkbox control such as No Break, click it twice to toggle its selec-
tion on and off.

• For a toggle control such as Underline, select another option and then 
select it again.

5. Choose Edit > Defaults > Save to save the session defaults as Affinity’s new 
defaults. You can now close the temporary document.

To revert to the Affinity’s default formatting:

1. Choose Edit > Defaults > Revert. Affinity will revert the document’s defaults 
for frame text, art text, and objects at the same time

To reset to the factory default formatting:

Affinity can reset the defaults to its factory settings for frame text, art text, and 
objects at the same time.

1. Open or create a document.

2. Choose Edit > Defaults > Factory Reset. Affinity will revert the document’s 
defaults for frame text, art text, and objects at the same time.

3. Choose Edit > Defaults > Save.

Tip: It is better to 
create a blank docu-
ment before changing 
your defaults to avoid 
accidentally saving 
attributes already 
selected in an open 
document
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Default font for CJK
If you enter text in Chinese, Japanese, or Korean, you should change the default 
font from Arial to avoid missing characters. You can use any font you want but 
the default fonts included with macOS and Windows are listed below. Follow the 
instructions above for changing the default text formatting.

Language macOS font Windows font

Simplified Chinese PingFang SC Microsoft YaHei UI

Traditional Chinese (Taiwan) PingFang TC Microsoft JhengHei UI

Traditional Chinese (Hong Kong and Macau) PingFang HK Microsoft JhengHei UI

Japanese Hiragino Sans (sans serif) Yu Gothic UI
 Hiragino Mincho (serif)

Korean Apple SD Gothic Neo Malgun Gothic
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Text wrap
Affinity will flow text in text frames without regard to an overlapping object 
unless you specify that text should be wrapped around it. The text wrap feature 
creates an editable and invisible outline around which the text will wrap.

To wrap text around an object:

1. Select one or more objects to modify.

2. Choose Text > Text Wrap > Show Text Wrap Settings to open the Text Wrap
window.

3. Select a Wrap Style:

Wrap Style Description

None (default) Text will not wrap around the object

Jump Text will flow above and below the object

Square Text will flow on all four sides of the object’s bounding box

Tight Text will flow around the object’s invisible wrap outline; the
 outline will match the object’s shape unless you change it

Inside Text will flow inside the object’s invisible wrap outline, as well as
 above and below the object

Edge Text will flow on all sides of the object’s invisible wrap outline

Tip: To ensure a 
wrapped object 
moves with the 
relevant text, pin the 
object and choose 
Float With Text

Tip: Unlike most 
applications, text wrap 
in Affinity also applies 
to text frames above 
the wrapped object; 
you must set Ignore 
Text Wraps for a text 
frame above a 
wrapped object to 
avoid the object 
impacting the frame

Tip: Text in art text and 
path text objects is not 
affected by text wrap
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4. For Square and Tight, select where to Wrap To:

Wrap To Description

Both Sides (default) Text will wrap on both the left and right sides

Largest Side Text will wrap only on the wider side; if the object is
 positioned in the centre of the text frame, text will wrap on
 the left side

5. Set the Distance from Text offsets to adjust the space between the object and 
text. For Square and Tight, the Bottom distance setting defines the minimum 
distance from the wrapped object because the start of the first baseline after 
the wrapped object is impacted by the paragraph spacing.

To customise the wrap outline to wrap text around the subject of an image:

When you select the Tight, Inside, or Edge wrap styles, Affinity flows text around 
the object’s invisible wrap outline rather than its bounding box. For a non-rec-
tangular shape such as an ellipse or path, the wrap outline will match the shape’s 
path until you change it. Text won’t wrap around the subject of an image unless 
it’s on a transparent background.

1. Select the object to modify.

2. Choose Text > Text Wrap > Edit Wrap Outline. Affinity will display node 
handles along the object’s path which you can drag and modify like any other 
path to change the shape of the wrap outline.

3. Deselect the object to end editing of the wrap outline.

To reset the wrap outline to the object’s shape or path:

1. Select the object to modify.

2. Choose Text > Text Wrap > Reset Wrap Outline. Affinity will restore the 
original wrap outline.

To ignore text wrap for a text frame:

1. Select a text frame or position the text cursor in a frame.

2. Choose Text > Text Wraps > Ignore Text Wraps or select Ignore Text Wraps
in the General section of the Text Frame panel. Objects with text wrap 
applied will no longer impact text in the selected text frame.

Tip: Ignore Text Wraps
applies to the text 
frame and not to a 
selected range of text

Tip: To ensure a 
wrapped object 
moves with the 
relevant text, pin the 
object and choose 
Float With Text

Tip: Although Bottom
should define a fixed 
distance from the 
wrapped object with 
the Jump setting, it 
currently works like 
Square and Tight and 
defines the minimum 
distance

Text wrap set to Tight Editing the wrap outline

Tip: If the subject of an 
image is on a non-
transparent back-
ground, you must 
manually trace the 
subject by editing the 
wrap outline

Tip: Affinity does not 
offer options to wrap 
toward or away from 
the document’s spine
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Pinning (anchoring) objects
You can pin an object to a position in text to enable the object to move with the 
text to which it is pinned as you continue to edit the text.

Affinity allows you to pin objects to text so they float relative to a position in the 
text or to position objects inline so that they are treated similar to a character. 
The examples below are a group a images and text frames grouped together and 
pinned inline.

Pinned objects can be scaled, rotated, and deleted like any other object but 
moving them may be limited by the options you select in the Pinning panel.

To pin an object or change its pinning type:

1. Select the object. If there are multiple text objects on the page, move it near to 
where it should be pinned.

2. Do one of the following:

• Click the Float With Text  or Inline In Text  buttons in the Pinning 
panel.

• Choose Layer > Float With Text or Inline In Text.

3. The object will be pinned to text in the nearest text object. A blue pin  icon 
will indicate where the object is pinned.

Float With Text: Example of a columnar 
object with Text Wrap set to Tight

Float With Text: Example of an extra-
columnar object

Inline In Text: Example of a columnar 
object in a paragraph by itself; the 
multiple objects were first grouped 
together

Inline In Text: Example of a columnar 
object positioned between two 
characters; the tool icons in this manual 
are created in this manner

Definition: Extra-
columnar object refers 
to objects outside of 
the column

Tip: Pinning is referred 
to as anchoring in 
some applications

Tip: All of the images 
in this manual are 
pinned inline, includ-
ing both the icons 
placed between words 
and the larger illustra-
tions between 
paragraphs
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4. Drag the pin icon to the position in the text where you want to anchor the 
object. The object will remain in the same position but the horizontal and 
vertical offset values in the Pinning panel will change.

5. If necessary, set the pinning options with the Pinning panel. If the panel is 
not visible, choose Window > Text > Pinning.

To import an image and pin it inline:

1. Position the text cursor in text.

2. Choose File > Place… and select an image to import. Affinity will position it 
inline.

3. If necessary, set the pinning options with the Pinning panel. If the panel is 
not visible, choose Window > Text > Pinning.

To unpin a pinned object:

1. Select the object and do one of the following:

• Click the Unpin  icon in the Pinning panel.

• Choose Layer > Float With Text or Inline In Text to deselect it.

To view pin icons:

Blue pin  icons will indicate where objects are pinned. The pins are always 
visible when a pinned object is selected but hidden when special characters are 
not shown.

1. Choose Text > Show Special Characters to display pins for all pinned objects.

Pinning objects behind text
Affinity always pins objects in front of text. If you want to pin objects behind 
text, you will need to use this workaround:

To pin an object or change its pinning type:

1. If the object is already pinned, un-pin it.

2. Draw another text frame in front of the object, matching the object’s width 
and height.Enter the text that should appear in front of the object.

3. Select the new text frame and the object and choose Layer > Group.

4. Pin the group into the main text frame below and set the pinning options as 
you normally would.
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Using the Pinning panel
To display the Pinning panel:

1. Choose Window > Text > Pinning to display the Pinning panel.

2. Set the pinning options:

• Float with Text: Click to pin the object relative to a position in the text. 
This option is used for extra-columnar objects often placed outside of the 
text frame. It can also be used for objects inside the text frame if text wrap 
is enabled.

• Inline in Text: Click to position objects inline so that they are treated 
similar to a character.

• Unpin: Click to disconnect the object from the text.

• Horizontal align, Of, and Offset: Select how the object should be posi-
tioned horizontally. To float an object in a consistent horizontal position 
outside of a text frame, set Of relative to the Column, Frame, Page Margin, 
or Page Edge.

• Horizontal Align: Outside Left, Inside Left (default), Inside Centre, 
Inside Right, or Outside Right. If Mirror Facing Pages is selected, this 
option will alternate between left and right as the pin is moved 
between facing pages.

• Of (what): Character (default, not recommended), Text (Indented), 
Column, Frame (recommended), Page Margin, or Page Edge.

Tip: Changing the 
Horizontal Align and 
Of options will change 
the Offset to maintain 
the object’s current 
horizontal position

Tip: This tip could 
have been created as a 
floated object but was 
actually created using 
the Sidenotes feature 
for better automatic 
positioning

Float with Text Inline In Text

Unpin
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• Offset: Enter the amount the object should be offset horizontally from 
the selected page element.

• Keep within bounds: Select to prevent the floated object from being 
shifted to the left or right of the text column.

• Vertical align, Of, and Offset: Select how the object should be positioned 
horizontally. To float an object outside of a text frame without it appearing 
above or below the column, select Keep within bounds.

• Vertical Align: Outside Above, Inside Top (default), Inside Centre, Inside 
Bottom, or Outside Below.

• Of (what): Line (default, recommended), Frame, Page Margin, or Page 
Edge.

• Offset: Enter the amount the object should be offset vertically from the 
selected page element.

• Keep within bounds: Select to prevent the floated object from being 
shifted above or below the text column.

• Mirror Facing Pages: Select to automatically alternate Horizontal Align 
between left and right as the pin is moved between facing pages.

• Preserve Manual Position: Select to allow the object to be moved manu-
ally within the limits imposed by the other options. Deselect to prevent 
the object from being moved manually.

• On Overlap: Select what to do if two or more floated objects would over-
lap at their optimal positions. This option must be set for all of the floated 
objects to be of any use.

• Do Nothing (default): Select to allow objects to overlap.

• Pack Horizontally: Select to adjust the object’s horizontal position so 
that more than one object can be positioned at the same vertical posi-
tion. This option is not recommended for large objects because they 
may overlap the adjacent text even if positioned in the page margin.

• Stack Vertically: Select to adjust the object’s vertical position so that 
the objects are spaced vertically, even if they’re not directly aligned to 
the pin position.

• Horizontal/Vertical Gap: Enter the gap between objects when On Over-
lap is set to Pack Horizontally or Stack Vertically.

• Scale to: Select to scale the inline object to match the adjacent text. Select 
No Scale (default) to set the size manually, Point Size to match the font 
size, or Ascent, Cap Height, or X-Height to match these font measurements.

Tip: Changing the 
Vertical Align and Of
options will change 
the Offset to maintain 
the object’s current 
vertical position
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• Scale: When Scale To is set to an option other than No Scale, set how 
much the image should be scaled relative to the selected option. For 
example, if Point Size is selected for 24 pt text then setting Scale to 50% 
would cause the inline object to be scaled to 12 pt tall.

• Base position: Select to align the bottom of the object with the text’s 
Baseline (default) or Descender.

• Offset: Enter the offset of the object from the Base Position.

• Preserve manual scale: Select to allow the object to be scaled manually. 
Scaling an object manually will adjust the Scale value.

• Borders: Enter the gap between the object and adjacent text. Enter nega-
tive values to allow adjacent text to overlap the object.
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Text styles, also known as character and paragraph styles or style 
sheets, are essential for creating a consistently-formatted docu-
ment. You can use text styles in documents of any length but 
they are critical for long publications such as books, magazines, 
and newspapers.

In this chapter
Using text styles ..........................................................................................204
Applying text styles ...................................................................................208
Creating text styles ....................................................................................211
Changing text styles ..................................................................................216
Importing and setting default text styles ..........................................217

Text styles 4
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Using text styles
A text style is a collection of paragraph and character attributes that you can 
apply to text without having to apply the attributes individually to save time and 
ensure consistent formatting.

Affinity offers paragraph and character text styles which are applied to para-
graphs and characters. A paragraph style is a collection of any paragraph and 
character attributes while a character style is limited to character attributes. 
Applying a paragraph style to one or more characters will apply it to the entire 
paragraph while applying a character style will apply it only to the selected 
characters.

You can apply only a single paragraph style to a paragraph and a single character 
style to a range of text. For example, you can’t apply both Heading 1 and Bullet 1
to the same paragraph—if you want Heading 1 to have a bullet you would need to 
edit the style or create a version of it with that formatting. Likewise, you can’t 
apply both the Emphasis and Highlight character styles to the same text.

You can override a paragraph or character style with individual formatting 
attributes. This capability should be used sparingly because if you were to over-
ride the Body style with Bold and then later decided that Semibold was more 
appropriate, you’d have to change all instances of Bold manually. With a character 
style, you could change the style’s definition to update all instances automatically. 
Individual attributes are best reserved for text that already has a character style 
applied or for rare exceptions.

Most users define a paragraph style for each type of paragraph, such as Heading
1, Heading 2, and Body, and apply a style to every paragraph in the main text. 
Most text will not have a character style applied because they are used to modify 
the formatting of selected words and phrases in a paragraph, such as Emphasis to 
make text stand out or Hyperlink to indicate that the text is a clickable link.

Text style and formatting precedence:
If you apply conflicting formatting to the same text, Affinity uses a hierarchy to 
determine which formatting to display. For example, if you defined a paragraph 
style as Helvetica, a character style as Garamond, and then formatted the text as 
Caslon, Affinity would display the text as Caslon regardless of the order you 
applied the paragraph style, character style, and font family.

Formatting precedence (from top to bottom)

Character attributes (style overrides)

Character style

Paragraph attributes (style overrides)

Paragraph style

Application defaults

Tip: Don’t confuse text 
styles with object styles, 
which Affinity refers to 
simply as styles

Tip: Affinity allows you 
to apply paragraph 
styles to characters 
with the Show in both 
panels option but this 
is not recommended 
for beginners

Tip: Affinity allows you 
to apply only a single 
character style to a 
range of text

Tip: Affinity does not 
offer GREP styles or 
nested styles
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Text style example

How text styles affect formatting
Text formatting is a combination of the default text attributes, the paragraph 
style, the character style, and any paragraph or character attributes applied to 
override the styles.

A text style can be based on another text style which results in attributes defined 
in the parent style being inherited by the child style. For example, it is common 
to base Heading 2 on Heading 1. Affinity also offers style groups which aren’t 
applied directly to text but which can be used as the base for other styles and to 
group styles in the Text Styles panel. For example, all of Affinity’s default para-
graph styles are based on the Base style group.

A text style can also be based on [No Style] which means it is not based on 
another style and inherits no attributes.

If you do not define an attribute such as font family or size for a text style that is 
based on another style or style group, it will inherit the parent’s attribute. If you 
do not define an attribute for a text style that is not based on another style or 
style group, applying the text style will not change those attributes. For example:

 Based on Font family Weight Size/Leading Colour

Default attributes n/a Arial – 12/Default Black

“Base” style group [No Style] Garamond – 10/12 –

“Heading 1” Base Myriad Pro Bold 24/28 –

“Heading 2” Heading 1 – – 12/14 –

If you applied Heading 2 to text formatted as Arial 12/Default Green, it would 
become Myriad Pro Bold 12/14 Blue—the Myriad Pro Bold and Blue attributes 
would be inherited from Heading 1 while 12/14 were defined in Heading 2.

If it had not been defined as Blue, applying Heading 2 to the green text would not 
change the colour was not defined in Base, Heading 1, or Heading 2 and you had 
already overridden the default text attributes with Green. However, if Base had 
been defined as Black and Heading 1 did not define the colour, applying Heading 
2 would have made the green text black because Heading 1 and Heading 2 would 
have inherited it from Base.

Lorem ipsum
Dolor sit amet, consectetur adipiscing elit, sed 
do eiusmod tempor.

Incididunt ut labore et ½ aliqua.

Body paragraph style

Body paragraph style +
Strong Emphasis character style + 
a character attribute (Fractions)

Body paragraph style +
Strong Emphasis character style

Heading 1 paragraph style

Tip: 12/Default means 
12 pt type on Default 
leading while 10/12
means 10 pt type on 
12 pt leading

Tip: [No Style] is not a 
text style but just a 
shortcut for the Text > 
Text Styles > Set No 
Paragraph/Character 
Style commands
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Using the Text Styles panel
The formatting applied to text is expressed as paragraph style + character style + 
individual attributes. For example, Body + Strong Emphasis + Font size: 24 pt. The 
Text Styles panel shows 

To display the Text Styles panel:

1. Choose Window > Text > Text Styles to display the Text Styles panel.

2. Click the caret  icon to the left of the Current Formatting field to view 
overflowing information. This field lists the formatting in use at the text 
cursor position or for the first character in a selected range of text. The pre-
sentation format is Paragraph Style + Character Style + individual formatting 
attributes.

3. Choose Show Hierarchical from the panel menu  to toggle between listing 
text styles as children of the styles or groups on which they are based (default) 
and showing styles as a flat list (recommended). Hierarchical makes it easy to 
see at a glance how your styles are structured while a flat list makes it easier to 
find styles by name.

4. Choose Show Samples from the panel menu  to toggle between listing text 
styles with their formatting (default) and as plain text (recommended). 
Samples makes it easy to find certain styles such as Drop Caps at a glance but 
it gives too much weight to lesser-used such as Initial Words compared to 
Body and Heading 1.

Create
Paragraph Style

Create
Character Style

Update
Paragraph Style

Create
Style Group

Update
Character Style

Delete Style

A style group

Current Formatting

No paragraph style

A paragraph style

A character style

No character style

Reapply Text Styles

Panel menu

Style options menu
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5. Choose Sort by Type from the panel menu  to toggle between listing style 
groups first followed by paragraph and then character styles (default, recom-
mended), and listing all styles and groups in alphabetical order regardless of 
type. Styles are listed alphabetically within the three types when sorted by 
type.

6. Click the style options menu  for a text style to see options specific to that 
style. You can also right-click a style name to see the same options.
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Applying text styles
There is more than one way to apply character styles but the most common way 
is to select a range of text or position the text cursor in text and then select a 
paragraph or character style. This option will clear existing formatting. If you 
want to preserve or control the existing formatting when applying text styles, 
refer to the next section.

To apply a text style:

1. Position the text cursor in text or select a range of text.

2. Select a style by doing one of:

• Click the character or paragraph style name in the Text Styles panel.

• Select the style from the Character Style or Paragraph Style popup menus 
in the Context Toolbar.

• Select the style from the Character Style popup menu in the Character 
panel or Paragraph Style popup menu in the Paragraph panel.

• Choose Apply “Style Name” to Paragraphs from the style options menu 
 to the right of the text style’s name in the panel, but there’s no reason to 

use this more cumbersome method. This option is available only for 
paragraph styles.

• Choose Apply “Style Name” to Characters from the style options menu 
to the right of the text style’s name in the panel. Paragraph styles can be 
applied to selected characters with this option—doing so applies only their 
character attributes.

To apply a text style to and preserve or control existing formatting:

1. Position the text cursor in text or select a range of text.

2. Apply a paragraph style by doing one of:

• Choose Apply “Style Name” to Paragraphs and Clear Character Styles
from the style options menu  to the right of the text style’s name in the 
panel to clear existing character styles from a paragraph but not individual 
character attributes. For example, if you applied Body to a paragraph with 
some text formatted with the Emphasis character style and, this option 
would remove Emphasis from the text.

• Choose Apply “Style Name” to Paragraphs and Preserve Character 
Formatting from the style options menu  to the right of the text style’s 
name in the panel to retain existing character styles and character 
attributes that don’t match the new paragraph style as overrides. For 
example, if you applied a style defined as Times 14 to a paragraph 

Tip: Although text 
styles are normally 
applied with a text 
tool, you can apply 
text styles to entire 
text frames selected 
with the Move  tool; 
this can lead to 
unexpected results for 
text in linked frames 
because the styles will 
be applied only to the 
text that was in the 
frame when the style 
was applied, and the 
frame may end up 
containing more or 
less text depending on 
the style’s formatting

Tip: You don’t need to 
select an entire 
paragraph to apply a 
paragraph style; the 
style will be applied 
even to partially 
selected paragraphs
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formatted as Arial 12 with some words formatted as Garamond 16, the 
paragraph would remain Arial 12 and Garamond 16.

• Choose Apply “Style Name” to Paragraphs and Preserve Local Format-
ting from the style options menu  to the right of the text style’s name in 
the panel to retain existing character styles and all character and para-
graph overrides. For example, if you applied a style defined as Times 14 to 
a paragraph formatted as Arial 12 with some words formatted as Gara-
mond 16 in a document with Arial 12 as the default, the paragraph would 
change to Times 14 but the specific words would still be formatted as 
Garamond 16. The Arial 12 text would change to Times 14 because Arial 
12 was not an override of the document’s default.

3. Or apply a paragraph or character style by choosing Apply “Style Name” to 
Characters and Preserve Local Formatting from the style options menu  to 
the right of the text style’s name in the panel to retain all character attributes 
and character styles as overrides. For example, if you applied Emphasis to text 
formatted as Garamond 14, those attributes would override Emphasis.

To apply a text style and its Next Style to successive paragraphs:

If you’ve defined a paragraph style with a Next Style, you can apply the ordered 
styles to successive paragraphs. For example, if Heading 1 has Next Style set to 
Heading 2, and if Heading 2 has Next Style set to Body, then you can select a 
range of paragraphs and with one command apply Heading 1 to the first para-
graph, Heading 2 to the second paragraph, and Body to all of the following 
paragraphs.

1. Select a range of paragraphs.

2. Choose Apply “Style Name” Then Next Styles from the style options menu 
to the right of the paragraph style’s name in the panel. This command will be 
present only if the paragraph style has Next Style set to another paragraph 
style.

To remove a text style from text:

1. Position the text cursor in text formatted with the style.

2. To remove the style and its formatting, click [No Style] in the Text Styles 
panel. There are two [No Style] options in the panel so be sure to click the one 
with the pilcrow (paragraph)  icon to remove the paragraph style or the 
lowercase a  icon to remove the character style.

3. Or to remove the style and retain its formatting, choose Detach Paragraphs 
from “Style Name” or Detach Characters from “Style Name” from the style 
options menu  to the right of the text style’s name in the panel.

Tip: [No Style] is not a 
text style but just a 
shortcut for the Text > 
Text Styles > Set No 
Paragraph/Character 
Style commands
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To override a style:

A style override is any attribute you’ve applied to text formatted with a text style. 
If there are overrides applied to the selected text or text cursor position, a plus 
sign will be shown beside the style name in the Current Formatting field in the 
Text Styles panel as well as in the Context Toolbar, Paragraph panel, or Charac-
ter panel.

1. Position the text cursor in text or select a range of text.

2. Apply any character or paragraph formatting attributes.

To clear text style overrides:

1. Position the text cursor in text or select a range of text.

2. Reapply the style by doing one of:

• Click the style name in the Text Styles panel.

• Click the Reapply Text Styles  icon to the right of the Current Format-
ting field at the top of the Text Styles panel or choose Text > Reapply Text 
Styles. These options will reapply the paragraph and character style and 
remove all paragraph and character overrides.

• Choose Text > Reapply Base Styles. This option will reapply the paragraph 
style but remove character styles in addition to paragraph and character 
overrides.

• Choose Apply “Style Name” to Paragraphs or Apply “Style Name” to 
Characters from the style options menu  to the right of the text style’s 
name in the panel, but there’s no reason to use this more cumbersome 
method.

Tip: The plus sign will 
not be shown next to 
the style name in the 
Text Styles panel list
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Creating text styles
To manually create a new text style:

1. Optional: Position the text cursor in a text frame or other text object. The new 
style will be based on the text style and formatting in use. For example, if you 
place the cursor in text formatted as Body with 14 pt overriding the style, the 
new style will be based on Body and have 14 pt already defined.

2. Choose the type of style to create. You can change the type of style after 
starting but choosing the right type now will pick up the current text style and 
formatting in use.

• Click the Create Paragraph Style  icon or choose Text > Text Styles > 
Create Paragraph Style to create a paragraph style.

• Click the Create Character Style  icon or choose Text > Text Styles > 
Create Character Style to create a character style.

• Click the Create Style Group  icon. There is not a matching menu 
command.

• Or if you want to create a text style based on another style, choose Create 
Style based on “Style Name” from the style options menu  to the right 
of the text style’s name in the panel.

3.  Style name: Enter a unique name for the text style.

Tip: Consider how the 
text style will be 
sorted alphabetically 
when choosing a 
name; for example, 
numbering heading 
styles as 1, 2, 3 makes 
them easier to find 
than naming them 
Title, Heading, and 
Sub-heading
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4.  Based on: Select another text style or style group on which to base this style. 
The new style will inherit all of the base style’s attributes. This is especially 
useful if there are only minimal differences between styles, such as a heading 
that is smaller than the heading on which it is based. Select [No Style] if you 
don’t want to base this style on another.

5.  Next style: Select another text style for the paragraph following one formatted 
with this text style. For example, setting Next style to Body for Heading 1
would automatically set Body for the next paragraph when pressing Return in 
a Heading 1 paragraph. Select [Same Style] if you don’t want the text style to 
change when you press Return; you would use this option for body, num-
bered, and bulleted styles

6.  Next level: Select another style for the next lower text style in a hierarchy of 
styles. For example, you would set Next level to Heading 2 for Heading 1, and 
to Heading 3 for Heading 2. This feature allows you to press Tab or Shift + Tab
at the start of a paragraph to switch to the next lower or higher level of the 
style hierarchy. For example, pressing Tab at the start of a Heading 1 paragraph 
would switch automatically to Heading 2 instead of entering a tab character.

7.  Keyboard shortcut: Assign a custom keyboard shortcut for commonly-used 
text styles by clicking in the text field and pressing the shortcut combination 
you want to use. If that shortcut is already in use a warning  icon will 
appear. Mouse over that icon to learn which shortcut is in conflict.

If you assign a keyboard shortcut to a character style and want to be able to 
turn it off (set it back to [No Style]) turn it off with a shortcut, too, you must 
assign a shortcut to [No Style] because shortcuts can’t be used as toggles.

The keyboard shortcut will be shown in the Text Styles panel as a reminder.

8.  Type: Choose between Paragraph, Character, and Group style types. Regard-
less of which type of style you started to create, you can change this setting to 
create a different type of style. The title of the window will not update to 
reflect the change in the type of text style.

A style group has all of the same options as a paragraph style.

9.  Show in both panels: Select this option if you want to be able to apply the 
character attributes of a paragraph style as a character override to text set in a 
different paragraph style, or to apply a character style as a paragraph style. For 
example, you might choose this option if you wanted to be able to apply the 
font family, weight, and size attributes of Heading 2 to text set as Body.

In the above example both Body and Heading 2 would be listed in the Text 
Styles panel as the selected paragraph style, but Body would be applied to the 
paragraph and Heading 2 to just a range of characters. Look at the Context 
Toolbar or Character and Paragraph panels for clarity.

10.  Reset formatting: Click to remove all attributes defined for the text style.

Shortcut is set to Shift + ⌘ + B

Tip: You can’t edit [No 
Style] with the Text 
Styles panel but you 
can assign a keyboard 
shortcut by choosing 
Affinity > Settings…
(macOS) or Edit > 
Settings… (Windows), 
clicking Shortcuts in 
the left pane, choos-
ing Text from the 
menu list, and then 
selecting Text Styles > 
Set No Character Style

Tip: Consider how the 
text style will be 
sorted alphabetically 
when choosing a 
name; for example, 
numbering heading 
styles as 1, 2, 3 makes 
them easier to find 
than naming them 
Title, Heading, and 
Sub-heading

Tip: Reset formatting
does not change the 
options in the Style
category (Style name, 
Based on, Next style, 
Next level, Keyboard 
shortcut, Type, and 
Show in both panels)

Tip: The both panels
name refers to apply-
ing text styles via the 
Character and Para-
graph panels and also 
via the Context 
Toolbar, not via the 
Text Styles panel
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11.  Style settings: This field displays a summary of the text style definition.

12.  Apply style to selection: Select to apply the new text style to the selected text 
or text cursor position when you click OK; deselect it to create the style 
without applying it to the text. This option is not applicable to style groups.

13.  Category: Click each category of character or paragraph attributes in the left 
pane and define the values you wish to include in the text style. The options 
are the same as those in the Character and Paragraph panels.

Character

Font Set the font family, traits (font style) weight, width, and size

Colour & Decorations Set the fill and highlight colours, underline, etc.

Position & Transform Set the kerning, tracking, baseline offset, leading override,
 superscript, etc.

Language Set the spelling and hyphenation language

Optical Alignment Set how punctuation and certain characters are positioned
 relative to the frame edges

Typography

Alternates Specify ligatures and alternates

Variants Specify stylistic sets, character variants, and position forms

Figures Specify figure (numeral) width, position, and style

Capitals Specify all caps, small caps, titling, and unicase

Paragraph

Spacing Set the alignment, indents, leading, space before, and after

Tab Stops Set tab stops and leaders

Justification Set minimum, desired, and maximum word and letter
 spacing

Flow Options Set start, keep together, widow, and orphan options

Bullets & Numbering Set bulleted and numbered list options

Baseline Grid Set to override a baseline grid

Hyphenation Set hyphenation rules

Drop Caps Set to create automatic drop caps

Initial Words Set formatting for the first words in a paragraph

Decorations Set paragraph borders and fill

Export Tags Set tags (classes) for EPUB or accessible PDF; refer to
Setting text style export tags on page 373

Tip: Weight and Width
will be disabled if you 
select a font style 
because it combines 
the weight, width, and 
slope (italic) traits
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If you don’t want the style to change the existing formatting for an attribute, 
leave the option set to[No change]. If you edit a value and want to restore it to 
[No change], the way you do that depends on the type of control:

• Popup menu: Select [No change] from the list.

• Text field: Delete the value to clear the field and then press Tab.

• Checkbox: Click the checkbox until the mixed-state value appears (a 
horizontal line instead of the usual checked or unchecked appearance).

• Radio button: Click the No Change radio button option.

• Colour sample: Deselect the neighbouring checkbox; the colour will be 
ignored if the checkbox is deselected.

14. Click OK to create the style.

To duplicate a text style to create a new text style:

1. Choose Duplicate “Style Name” from the style options menu  to the right 
of the text style’s name in the panel.

2. The Text Style Editor window will be displayed with the same options as 
creating or editing a text style. Name the new style and change its formatting 
attributes as required. Affinity will show the effect of the changes live as you 
modify the attributes in the window.

3. Click OK to create the style.

To delete text style(s):

1. To delete a single text style, choose Delete “Style Name” from the style 
options menu  to the right of the text style’s name in the panel.

Or select the text style name in the panel list and then click the Delete Style
 icon or choose Text > Text Styles > Delete Paragraph Style or Delete 

Character Style. Note that selecting a style will apply it to the selected text or 
text cursor position so this method is often less convenient.

2. To delete all text styles, choose Detach and Delete All Styles from the panel 
menu  or choose Text > Text Styles > Detach and Delete All Styles. No 
formatting will be lost as the formatting attributes will be detached from the 
text styles and applied directly to any styled text. There is no confirmation for 
this command but you can undo it.

Tip: A white colour 
sample with a red line 
through it means no 
colour
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3. To delete only the text styles that are not in use, choose Delete Unused Styles
from the panel menu  or choose Text > Text Styles > Delete Unused Styles. 
There is no confirmation for this command but you can undo it.

4. To delete a style group or a text style, as well as all the styles based on it, 
choose Delete “Style Name” Group from the panel menu . There is no 
confirmation for this command but you can undo it.
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Changing text styles
You can change text styles at any time using the same options as when you cre-
ated the style.

One of the first things you might do after creating a new document with the 
default text styles is edit the Base style group. With the default text styles, Body, 
Heading 1, Bullet 1, and Numbered 1 are all based on the Base style group so 
instead of changing the font family for each from Arial to your preferred font you 
could edit Base and the styles would be updated automatically.

You can even change a paragraph style to a character style or vice versa. You can 
even change a paragraph or character style to a style group but these types of 
changes can have confusing consequences so it’s best to avoid changing a style’s 
type. For example, if you changed the Body style to a style group then all text 
formatted as that style would appear to be formatted with a style group. You 
would also no longer be able to apply the style directly via the Text Styles panel
without using the group’s style options menu .

To update a text style to match the current formatting:

1. Format text with the text style and then adjust its formatting attributes as 
desired using the Paragraph and Character panels. Position the text cursor 
anywhere in the formatted text. If you leave a range of text selected, Affinity 
will use the formatting at the start of the text range.

2. Update the paragraph or character style by doing one of:

• Click the Update Paragraph Style  icon or the Update Character Style
 icon at the bottom of the Text Styles panel or in the Context Toolbar.

• Choose Text > Text Styles > Update Paragraph Style or Update Character 
Style.

• Choose Update “Style Name” from the style options menu  to the right 
of the text style’s name in the panel.

To manually change a text style’s definition:

1. Choose Edit “<style name>” from the style options menu  to the right of 
the text style’s name in the panel.

Or double-click the style name in the Text Styles panel. Note that double-
clicking a style will apply it to the selected text or text cursor position so this 
method is not recommended unless the cursor is in text of the text style you 
want to edit.

2. The Text Style Editor window will be displayed with the same options as 
creating or editing a text style. Change the style’s formatting attributes as 
required. Affinity will show the effect of the changes live as you modify the 
attributes in the window.

3. Click OK to update the style.

Tip: With this option 
you can update any 
style to match any 
other style as well as 
the current formatting

Tip: If you change a 
paragraph or charac-
ter style to a style 
group, the text style’s 
formatting will be 
removed from any 
paragraphs formatted 
with it
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Importing and setting default text styles
Newly-created documents include Affinity’s default text styles. You can save your 
current collection of text styles for use in future documents or import text styles 
from one document into another.

To save the current text styles as the default:

1. Choose Save Styles as Default from the panel menu  or choose Text > Text 
Styles > Save Styles as Default.

To revert to the factory default text styles:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Miscellaneous in the left pane.

2. Click Reset Text Styles.

3. Click Close.

To import text styles from another document:

1. Choose Import Styles… from the panel menu  and then select the other 
document from the Open window.

2. Select which text styles to import by selecting or deselecting the checkboxes 
to the left of their names. Affinity will display the formatting attributes of the 
selected text style and for a style in the document of the same name at the 
bottom of the window.
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Choose Check All from the popup menu below to select or deselect all text 
styles, or choose Check Paragraphs or Check Characters to select or deselect 
all paragraph or character styles.

3. Affinity will indicate which text styles will replace and overwrite an existing 
style. To import a style but not replace an existing one with the same name, 
enter a new name for the style in the text field to the right of the style name.

4. Click OK to import the selected text styles into the document.

To export text styles to share them with another user:

Affinity doesn’t provide a way to export text styles because you can import styles 
from another document, but if it’s easy to share text styles without sharing the 
contents of your document.

1. Create a new document.

2. Choose Detach and Delete All Styles from the panel menu  or choose Text 
> Text Styles > Detach and Delete All Styles to delete all text styles from the 
document.

3. Choose Import Styles… from the panel menu  and then from the Open
window select a document that contains the text styles you want to share.

4. Click OK in the Imported Text Styles window. The blank document now 
contains just the text styles you want to share.

5. Save the document and send it to the other user.

218 Text styles
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While illustration is not the focus for page layout and publishing, 
it’s important to master the basics of creating and manipulating 
objects in order to lay out books, magazines, and other long 
documents. This chapter introduces the types of objects, 
explores the many shapes, and provides instructions for select-
ing, moving, duplicating, scaling, rotating, aligning, arranging, 
and grouping objects.

Affinity offers many vector illustration features including the Pen 
and Node tools that are beyond the scope of this manual. This 
chapter focuses on the features most relevant to page layout.

In this chapter
About objects and layers .........................................................................220
Creating shapes ..........................................................................................223
Creating lines ...............................................................................................228
Selecting objects ........................................................................................230
Transforming objects ................................................................................235
Fill, stroke, and colour ...............................................................................249

Objects 5
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About objects and layers
Everything you add to a page is an object, whether it is text, an image, a shape, a 
path, or even an embedded document. Objects are layered on top of each other 
in a stack so they are also all referred to as layers.

Most objects are opaque but they can be made translucent by changing their 
opacity which allows the objects beneath them to be partially visible.

Using the Layers panel 
To display and customise the Layers panel:

1. Choose Window > General > Layers to show the Layers panel if it is not 
already open.

Each layer is indicated with a thumbnail and name. The thumbnail images are 
generated automatically from the layer’s contents. The names are also gener-
ated automatically but can be changed.

The layer(s) selected in the document window will be indicated with an 
accent colour in the panel, and the parent layer(s) will be indicated with a 
slightly darker shade of the accent colour.

2. Choose Auto-scroll from the panel menu  to scroll the list of layers when 
you select an object in the window so that it is visible in the panel.

3. Choose Show Group Thumbnails from the panel menu  to represent 
groups with an automatic thumbnail instead of a folder icon.

Layer opacity

Layer type

Panel menu

Delete selected layers

Collapse an expanded parent

Layer thumbnail

Selected layer

Expand a collapsed parent

Lock/Unlock selected layers

Toggle visibility

Toggle lock/unlock

Tip: The accent colour 
can be customised on 
macOS with System 
Settings > Appear-
ance and on Windows 
using with Settings > 
Personalisation > 
Colours
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4. Choose Show Object Type from the panel menu  to display an icon to the 
left of the thumbnail indicating the type of object:

Layout and Vector   Pixel

 Master page  Container layer  Pixel layer

 Frame text  Shape  Adjustment

 Art text  Path  Live filter

 Shape frame text  Picture frame  Mask

 Path text  Image  Fill layer

 Table  Clipping Mask  Pattern layer

 Linked/embedded resource  Compound layer

 Empty group  Compound add

 Symbol  Compound subtract

 Artboard  Compound intersect

 Data merge  Compound xor

5. Choose Thumbnail Background > Checkerboard from the panel menu  to 
toggle on and off a checkerboard background behind the layer thumbnails. A 
checkerboard can be helpful in distinguishing objects in a thumbnail.

6. Choose Thumbnail Background > Light or Dark from the panel menu  to 
change the background shade.

7. Choose No Thumbnails or Small/Medium/Large Thumbnails from the panel 
menu  to change the size of the page thumbnails. While larger thumbnails 
are easier to see, you’ll be able to see fewer layers at once in the list.

To select layers to manipulate:

• Single-click a layer to select it so you can perform actions to it.

• To select a range of layers, select one by single clicking it and then press Shift
and click the last one in the range.

• To select multiple layers that aren’t in a continuous range, press ⌘ (macOS) or 
Ctrl (Windows) and click each layer.

• If a selected object’s layer isn’t visible in the list, choose Layer > Find in 
Layers Panel to scroll the panel list to its position.
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To expand/collapse a parent layer:

• Click the caret  icon to the left of a group, container layer, or clipping object 
to expand it and view its child layers. Click it again to collapse it.

• Or right-click a layer and choose Expand Selection or Collapse Selection.

• If the layer is nested multiple levels deep, you can right-click and choose 
Collapse All Parents to collapse multiple layers at once. Or choose Layer > 
Collapse All in Layers Panel.

To rename layers:

1. Double-click a layer name to rename it and press Return or Enter when you 
are done. Automatic layer names such as Frame Text and Rectangle are shown 
in low contrast while the names you enter yourself are shown in high 
contrast.

2. To rename multiple layers sequentially, press Tab instead of Return or Enter to 
commit the layer’s name and move to the next one in the list. Press Shift + Tab
to move up instead of down.
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Creating shapes
There are two types of vector objects that can be added to a document: shapes 
and paths (curves). The Shape tools let you create commonly-used geometric 
shapes such as rectangles , ellipses , and triangles , while the Pen  tool 
lets you draw open and closed paths made up of connected line and curve 
segments.

You can edit both shapes and paths using the Move  and Node  tools. A 
shape can be converted to a path for asymmetric manipulation.

To draw a shape:

1. Select one of the Shape tools.

2. To create the shape with specific options, select them from the Context 
Toolbar before drawing the shape. Changing the options first will set the 
default for all future shapes of this type that you draw.

You can also click an existing shape to select it which will temporarily copy its 
options without resetting the defaults.

3. Drag from one corner of the shape to the other. Affinity will display the 
shape’s width and height as you drag.

• Hold Shift to constrain the shape to equal width and height

• Hold ⌘ (macOS) or Ctrl (Windows) to draw from the centre

• While drawing, hold Ctrl (macOS) or right mouse button (Windows) to 
rotate the shape about its origin; Affinity will display the rotation angle as 
you drag

• While drawing, hold Space to reposition the shape before it is finished

4. Release the mouse button to create the shape.

5. Optional: Change the shape’s options using the Context Toolbar.

Tip: Lines are not 
shapes in Affinity so to 
create a line you must 
draw one with the Pen
tool

Tip: Select the Keep 
Selected  icon in 
the Context Toolbar
so that the new shape 
will be selected after it 
is created

Tip: Refer to Shape 
options on page 224 
for more information
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To create a shape numerically:

1. Select one of the Shape tools.

2. Hold ⌘ (macOS) or Ctrl (Windows) and click on the page where you want to 
create the shape.

3. Enter the Width, Height, and any other shape-specific values. Click the link 
 icon to change the Width and Height together.

4. By default, the position you clicked will be the centre of the new shape as 
indicated by the selected centre anchor. Select a corner or side anchor to 
change how the shape is positioned.

5. Click OK to finish creating the shape.

Shape options
All shapes have fill and stroke attributes but each has its own options which can 
be set in the Context Toolbar while creating and editing shapes.

Tool Options

 Rectangle N/A

 Ellipse N/A

 Rounded Rectangle Radius for each corner, percentage or absolute size

 Triangle Top Point as a percentage of width

 Diamond Mid Point as a percentage of height (0% forms a
 triangle, 100% an inverted triangle)

 Trapezoid Left and Right Points as a percentage of width

 Polygon Number of Sides
 Curve as a percentage of radius (0% forms a polygon,
 100% forms an ellipse), and Smooth Points when using
 Curve

 Star Number of Points
 Inner Radius
 Inner/Outer Circle
 Curved Edges and Left/Right Curve when using
 Curved Edges

Selected anchor
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Tool Options

 Double Star Number of Points
 Inner Radius and Point Radius for alternating points

 Square Star Number of Sides (points)
 Cutout as a percentage of radius (0% forms a polygon)

 Arrow Thickness as a percentage of height
 Left/Right End Style
 Proportional so ends remain fixed when scaled instead
 of scaling with the shape
 End Length/Size
 Inner Offset/Indent Size, depending on the End Style

 Donut Hole radius as a percentage of shape radius
 Start/End/Total Angle to define a cut out

 Pie Hole radius as a percentage of shape radius
 Start/End/Total Angle to define a cut out

 Segment Starting Angle
 Lower/Upper Line as a percentage of height (setting
 Lower to 0% and Upper to 100% forms an ellipse)

 Crescent Left/Right Curve as a percentage of width (setting
 Left to -100% and Right to 100% forms an ellipse)

 Cog Number of Teeth
 Inner Radius (length of teeth)
 Hole Radius
 Tooth Size (point width)
 Notch Size
 Curvature

 Cloud Number of Bubbles
 Inner Radius

 Callout Rounded Rectangle Same as Rounded Rectangle plus Tail Width/Height
 as a percentage of the shape
 Tail Start (root)/End (point) as a percentage of width

 Callout Ellipse Same as Ellipse plus Tail Height
 Tail End (point) and Tail Angle as a percentage of width

 Tear Curve
 Tail Position offset from centre
 Bend
 Fixed Ball Size so the ball remains fixed when scaled
 instead of scaling with the tear
 Ball Size when not a fixed size
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Tool Options

 Heart Spread (lobe height)

 Spiral Refer to Help for options

 QR Code Refer to Help for options

 Cat N/A

Modifying shapes
To change a shape’s options numerically:

1. Select the shape with the Move  tool, Node  tools, or any of the Shape
tools. Size handles to scale the shape will be shown around its selection box.

If you select multiple objects, switch to any Shape tool because otherwise the 
Context Toolbar will show options for multiple objects of any type rather 
than the specific type you have selected.

2. Change the options in the Context Toolbar.

To change a shape’s options visually:

1. Select the shape with the Node  tools, or with a Shape tool. One or more 
red control handles will appear to change the shape’s options.

When you move the mouse pointer over a red control handle, a red guide will 
indicate the directions you can drag.

2. Drag the red control handles to set the shape’s options. Double-click a handle 
to restore it to its original position.
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Creating a grid of shapes (quick grids)
To create a grid of the same shape:

1. Select one of the Shape tools.

2. Drag from one corner of the shape to the other.

• Hold Shift to constrain the shapes to equal width and height

• Hold ⌘ (macOS) or Ctrl (Windows) to draw from the centre

• While drawing, hold Ctrl (macOS) or right mouse button (Windows) to 
rotate the shapes about the origin

• While drawing, hold Space to reposition the shapes before they are 
finished

3. While the mouse button is still held down, press → to create another column 
of the shape or ↓ to create another row. Repeat as many times as necessary. 
Press ← or ↑ to reduce the number of columns or rows.

4. Press and hold → to increase space between the columns of shapes or ↓ to 
increase space between rows. Press and hold ← or ↑ to reduce space. Hold 
Shift while holding an arrow key to increase or decrease by 10 times the 
normal amount.

5. Release the mouse button to create the grid of shapes. Each shape will be a 
separate object.



228 Objects

Creating lines
Affinity doesn’t have a shape tool for drawing lines but you can draw a straight 
line as a single segment of a path using the Pen  tool.

To draw a line:

1. Select the Pen  tool. The mouse pointer will change to the new path
pointer to indicate that you can start a new path.

2. Optional: Select the Line Mode  icon from the mode selector in the Con-
text Toolbar. This mode constrains drawing to straight lines to avoid creating 
accidental curves. You can also draw straight lines without selecting this 
mode by holding Ctrl while dragging.

3. Click once to create a node (point) where the line should start. The mouse 
pointer will change to the add segment  pointer to indicate that you can 
add another node.

4. Move the mouse to where the line should end and click to create a second 
node and end the path segment.

Affinity will snap the nodes to the nearest snapping points if Enable Snapping
is selected in View > Snapping, but you can also:

• Hold ⌥ (macOS) or Alt (Windows) to not snap to snapping points

• Hold Shift to constrain drawing to orthogonal (horizontal/vertical) and 
45º lines

While moving the mouse to create the second node, Affinity will show a 
measurement line to indicate its length but only if the mouse pointer is close 
to horizontal or vertical and you are not holding a modifier.

5. The line is now completed but the mouse pointer will remain as the add 
segment  pointer to indicate that you can add another node to it.

To start another line, press the Esc key which will deselect the line’s second 
node and change the mouse pointer to the new path  pointer to indicate 
that you can now start a new path.

6. Switch to the Move  tool when you are done drawing lines.

Definition: Affinity 
uses the term Curve
for what other applica-
tions refer to as a Path
and Node for a Point; 
the terms are inter-
changeable but this 
manual uses the term 
Path because referring 
to a straight line as a 
curve is confusing

Tip: The full features of 
the Pen tool are 
beyond the scope of 
this manual

Tip: If you select the 
Line Mode icon, you 
can also draw a 
straight line by 
clicking and dragging 
rather than clicking 
twice
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Modifying lines
Paths can be transformed just like any other object with the Move  tool but you 
can edit their nodes with the Node  tool.

To modify a line:

1. Select the Node  tool. The mouse pointer will change to the node  pointer.

2. Select the line by clicking on it once. Node handles will appear at its ends.

3. Mouse over the node you want to move. The mouse pointer will change to the 
edit node  pointer.

4. Select the node by clicking it once and change its X and Y coordinates in the 
Transform panel.

Or drag the node to its new position. Affinity will snap the node to the near-
est snapping point if Enable Snapping is selected in View > Snapping, but 
you can also:

• Hold ⌥ (macOS) or Alt (Windows) to not snap to snapping points

• Hold Shift to constrain moving the node to orthogonal (horizontal/verti-
cal) and 45º lines from the original position

5. Press the Esc key to deselect the node or switch to the Move  tool when you 
are done editing lines.
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Selecting objects
To select an object by clicking:

1. Using the Move  tool, click once on the object’s stroke. You can click any-
where on an object if it’s filled.

Or select the object layer in the Layers panel. Refer to Using the Layers panel 
on page 220.

A selection box with size handles and a rotation handle will appear around 
the object to indicate that it is selected.

2. Optional:

• Hold Shift while clicking to add or remove objects to those already selected

• Hold ⌘ (macOS) or Ctrl (Windows) while clicking to select objects inside 
a group, container layer, or clipping object rather than the parent layer

• Hold ⌥ (macOS) or Alt (Windows) while clicking to select the object 
behind the object you clicked on; repeat to select the object below it in the 
layer stack

To select an object by dragging:

1. Using the Move  tool, drag a marquee around the objects. By default, 
objects that intersect with the marquee will be selected. You can change this 
behaviour by choosing Affinity > Settings… (macOS) or Edit > Settings…
(Windows), clicking Tools in the left pane, and selecting from Marquee 
selection behaviour.

A selection box with size handles and a rotation handle will appear around 
the object(s) to indicate that they are selected.

2. Optional:

• Hold ⌥ (macOS) or Alt (Windows) before starting to drag to force drag 
select even if an object is below the mouse pointer

• Hold Shift while dragging to add or remove objects to those already 
selected

• Hold ⌘ (macOS) or Ctrl (Windows) while dragging to select objects inside 
a group rather than the group itself

• Hold Ctrl while dragging to temporarily reverse the Marquee selection 
behaviour set in Settings

Tip: You can click 
anywhere on filled 
objects to select them, 
but to select unfilled 
objects you must click 
on its path (stroke)

Tip: Marquee selection 
simply means drag-
ging a selection box 
around objects
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To constrain object selection:

Affinity offers options to make it easier to select the desired object in a complex 
or busy page.

• Deselect Auto-Select in the Context Toolbar to prevent selecting objects in 
the document window. You will only be able to select layers using the Layers
panel.

• Select Default to be able to click to select any type of object, Objects to be 
able to select only individual objects, or Groups to be able to select only 
groups.

• If you use container layers , you can deselect the Edit Within Container
icon in the Layers panel to restrict object selection to objects in the selected 
container layer.

To select or deselect all objects:

1. Choose Edit > Select All to select all objects on the current spread.

2. Choose Edit > Deselect or click on an empty area of the spread to deselect all 
objects.

To select a different layer:

1. Choose Layer > Next Layer or Previous Layer to select the layer above or 
below the current layer within the same container layer, group, or the layer 
stack. When the top or bottom is reached then it will cycle to the other end of 
the stack.

2. Choose Layer > Top Layer or Bottom Layer to select the first or last layer in 
the same container layer, group, or the layer stack.

3. Choose Layer > Parent Layer to select the parent group, container layer, or 
clipping object of the current layer.

Tip: Container layers
were known simply as 
Layers in Affinity 2

Tip: You cannot select 
objects on multiple 
spreads at the same 
time

GroupsDefault Objects
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Duplicating Objects
To make one copy of an object:

1. Select the object(s) using the Move  tool.

2. Choose Edit > Duplicate > Selection.

Or hold ⌘ (macOS) or Ctrl (Windows) while dragging the object to duplicate 
it to a specific position on the page. You can even drag the duplicate to 
another page if both pages are visible in the window at the same time.

Or right-click the layer in the Layers panel and choose Duplicate.

Or hold ⌥ (macOS) or Alt (Windows) while dragging a layer in the Layers
panel to duplicate it to a specific position in the layer stack.

To copy and paste an object, including to another page:

You can also use the equivalent keyboard shortcuts or right-click to access the 
same commands in the context menu.

1. Select the object(s) using the Move  tool.

2. Choose Edit > Cut to move it or Edit > Copy to make a copy of it.

3. Optional: Switch to the page you want to move or duplicate the object to.

4. Choose Edit > Paste.

Affinity will paste the object at the same coordinates relative to the spread 
origin as the copied objects unless the new object would be completely out-
side of the visible portion of the spread.

If you paste an object while the text cursor is positioned inside of text, the 
object will be pinned inline. Refer to Pinning (anchoring) objects on page 197 
for more information.

If you copy and paste a text frame, the frame will be pasted with all of the text 
in the story (including the text in the frames it is linked to).

To make copies of an object with the same transformation as the last copy:

1. Select the object(s) using the Move  tool.

2. Choose Edit > Duplicate > Selection.

3. Move, scale, rotate, or shear the object.

4. Choose Edit > Duplicate > Selection again. This duplicate will be cumula-
tively transformed. Repeat as required.
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To make multiple copies of an object:

1. Select the object(s) using the Move  tool.

2. Press Return or Enter to open the Move / Duplicate window.

•  Previous Settings: Select to restore the last-used settings, if applicable.

•  Duplicate: Select to specify that the object should be duplicated. Deselect 
to specify that the object should be moved.

• Number of copies: Enter the number of duplicates to make.

• Insertion mode: Select whether duplicates should be created in front 
or behind the selected object.

•  Offset: Enter how much to move the object and each duplicate by entering 
either Horizontal and Vertical amounts or Distance and Angle. Changing 
either set of fields will adjust the other fields.

•  Rotation: Enter how much the object and each duplicate will be rotated.

•  Scale: Enter how much the object and each duplicate will be scaled.

3. Click OK to duplicate the object.

To specify where duplicates should be created:

1. Select an object on the page or a layer using the Layers panel.

2. Select an insertion mode from the main toolbar to choose where the copy will 
be inserted in the layer stack. These icons are not available by default in the 
Layout studio so you must either switch temporarily to the Vector studio or 
choose View > Customise Toolbar… to add the icon group to the toolbar.

• Deselect all three Insertion  icons to insert the copy above the 
selected object or layer.
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• Select the Insert behind the selection  icon to insert the copy below the 
selected object or layer.

• Select the Insert at the top of the layer  icon to insert the copy at the top 
of the layer. If the layer is inside a Container Layer, the object will be 
inserted at its top; otherwise, the object will be inserted at the top of the 
layer stack.

• Select the Insert inside the selection  icon to insert the copy clipped 
inside the selected object or layer.
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Transforming objects
You can move, scale, and rotate objects visually by dragging them or their han-
dles or precisely by changing coordinates in the Transform panel. You can also 
specify offsets and make duplicates with the Move/Duplicate window.

Text in text frames and images in picture frames can also be moved and scaled 
with their frames. Refer to Moving and scaling text frames on page 103 Scaling 
and rotating images on page 269.

To move, scale, or rotate an object visually:

1. Select the object(s) using the Move  tool.

2. Drag anywhere on or inside the object’s selection box to move it.

• Hold Shift while dragging to constrain movement to horizontal, vertical, 
or 45°.

• Select Hide Selection while Dragging from the Settings  icon in the 
Context Toolbar to temporarily hide selection boxes and handles when 
transforming objects.

• Select Show Alignment Handles from the Settings  icon in the Context 
Toolbar to display blue alignment handles . Hover over a handle to 
display a temporary guide and drag a handle to align it with other objects.

3. Drag a size handle to scale the object.

• Hold Shift while dragging to reverse whether or not the object’s aspect 
ratio will be maintained while scaling. By default, scaling groups, 
unframed images, and documents will constrain their aspect ratio while 
all other object types will not be constrained.

• Hold ⌘ (macOS) or Ctrl (Windows) to scale from the object’s centre

• Hold Ctrl (macOS) or right mouse button (Windows) to rotate the object 
about its origin while scaling

4. Drag the rotation handle to rotate the object about its origin. Hold Shift while 
dragging to constrain rotation to 15° increments.

• Select Enable Transform Origin from the Settings  icon in the Context 
Toolbar to display the object’s origin  (rotation point). Drag the origin 
from the object’s centre to the position about which you want to rotate the 
object.

• Hold Shift while dragging to constrain movement to 45º directions.

• The origin  icon will be bolded when it’s not positioned in the centre.

• Double-click the origin to reset it to the object’s centre.
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To move, scale, or rotate an object precisely:

1. Select the object(s) using the Move  tool.

2. Choose Window > General > Transform to show the Transform panel if it is 
not already open.

3. Change the X (horizontal) and Y (vertical) coordinates for the selected 
object(s) to move them to a new location. If multiple objects are selected, the 
coordinates shown will be for the combined objects.

4. Change the W (width) and H (height) coordinates for the selected object(s) 
to scale them. If multiple objects are selected, the coordinates shown will be 
for the combined objects.

Optional: Click the Link  icon to change Width and Height together and 
maintain the object’s aspect ratio.

5. Change the R (rotation) and S (shear) angles to rotate the object

To rotate objects by 90º or to flip objects:

1. Select the object(s) using the Move  tool.

2. Click the Transform  icon in the main Toolbar and select Flip Horizontal, 
Flip Vertical, Rotate Counter-clockwise, or Rotate Clockwise from the 
popup. Or choose the equivalent command from the Layer > Arrange menu.

Tip: Rather than 
calculating the new 
coordinates, use an 
expression such as +2
to add 2 to the current 
value; refer to Appen-
dix B – Using field 
input expressions on 
page 470
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To move, scale, or rotate with Move/Duplicate:

1. Select the object(s) using the Move  tool.

2. Press Return or Enter to open the Move / Duplicate window.

•  Previous Settings: Select to restore the last-used settings, if applicable.

•  Offset: Enter how much to move the object and each duplicate by entering 
either Horizontal and Vertical amounts or Distance and Angle. Changing 
either set of fields will adjust the other fields.

•  Rotation: Enter how much the object and each duplicate will be rotated.

•  Scale: Enter how much the object and each duplicate will be scaled.

•  Duplicate: Select to specify that the object should be duplicated. Deselect 
to specify that the object should be moved.

Affinity will display a live preview of the effects of this window while you 
adjust the options. The changes will not be applied to your document until 
you click OK.

3. Optional: While the Move/Duplicate window is open, select Enable Trans-
form Origin from the Settings  icon in the Context Toolbar to display the 
original object’s origin . Drag the origin to the position about which you 
want to rotate the object.

4. Click OK to move, scale, rotate, or duplicate the object.

To move, scale, or rotate multiple objects:

When multiple objects are selected, you can move, scale, and rotate them inde-
pendently or together.

1. Select multiple objects using the Move  tool.

2. Deselect the Transform Objects Separately  icon in the Context Toolbar. 
Size handles and a rotation handle will appear around the objects’ selection 

12 copies of the original shape 
will each be shifted 0p4 horizon-
tally and vertically and rotated 
10º about their origin point 
which is above and to their left
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box. The Transform panel will show the objects’ combined coordinates and 
width and height. Any changes you make will be made relative to the objects’ 
selection box and origin.

3. Select the Transform Objects Separately  icon in the Context Toolbar. Size 
handles and a rotation handle will appear around just the first selected object 
and the Transform panel will show its coordinates and width and height. Any 
changes you make will be made relative to the individual object selection 
boxes and origins.

To nudge an object a short distance:

You can customise how much Affinity moves objects when you nudge them with 
an arrow key by choosing Affinity > Settings… (macOS) or Edit > Settings…
(Windows), clicking Tools in the left pane, and setting Nudge Distance and 
Nudge Distance Modifier (when Shift is pressed).

1. Select the object(s) using the Move  tool.

2. Press an arrow key to nudge the object in the key’s direction. Hold Shift while 
pressing the arrow key to move the object 10 times the distance.

Using the Transform panel
The Transform panel is an important one to keep open when working on a 
layout document because it allows you to view and change the coordinates of 
selected objects.

To display and customise the Transform panel:

1. Choose Window > General > Transform to show the Transform panel if it is 
not already open.

2. Select one or more objects to transform using the Move  tool and the panel 
will display the object’s coordinates. If multiple objects are selected, the 
coordinates shown will be for the combined objects.

3. Select the Link  icon to change the width and height in tandem to maintain 
the object’s current aspect ratio.

4. Select the Scale Override  icon to scale the object’s stroke width, corner 
radius, layer effects radius, or the text in a text frame when you change its 
width and height. Or click the caret beside Scale Override to select which 
attributes should be scaled with the object.

Tip: Scale Override is 
intended for use when 
the Link icon is 
selected to maintain 
the object’s aspect 
ratio

Tip: Affinity 3.0 
defaults to nudging in 
pixels which isn’t 
appropriate for Layout 
work so it is recom-
mended you change it 
to points

Tip: You can change 
which object is shown 
as selected by select-
ing the one you want 
first and then Shift
clicking or dragging to 
select the others

Selected anchor

Rotation/Shear

Constrain aspect ratio

Scale Override

Width/HeightAnchor position
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Using Scale Override
Only the size of an object changes when you scale it with normal settings but you 
can set an object so that its stroke, corner radius, layer effects, and text contents 
scale with it:

• Stroke: Select Scale with Object in the Stroke panel to scale the stroke with 
an object.

• Corner radius: Deselect Absolute Sizes in the Context Toolbar to scale corner 
radius with an object.

• Layer effects radius: Select Scale with Object in the Layer Effects window to 
scale the stroke with an object.

• Text frames: Drag the content-scaling handle to scale text with its frame.

You can override these object-specific settings by selecting the Scale Override
icon in the Transform panel. Scale Override can be used visually and precisely:

• Visually: Use Scale Override while dragging a size handle and holding a 
modifier key such as Shift.

• Precisely: Use Scale Override while setting the object’s width or height using 
the Transform panel while the Link icon selected to maintain the object’s 
aspect ratio.

To customise how Scale Override functions:

1. Click the caret beside the Scale Override  icon in the Transform panel.

2. Deselect a checkbox to not override the object’s scaling behaviour for that 
attribute.

3. Select a checkbox to override the object’s scaling behaviour for that attribute 
and select:

• Scale with object to scale the attribute with the object.

• Locked to ignore object-specific scaling settings.

Tip: Scale Override
has no impact on the 
Move / Duplicate
window which can 
create multiple copies 
of objects with 
incremental scaling
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Snapping objects
Objects can be snapped to the guides, grid, baseline grid, page spread, and even 
other objects to help you position and align text and objects. When you draw or 
move an object within range of one of these visual aids, referred to as snapping 
candidates, the object will be aligned to it rather than exactly where you were 
drawing or dragging.

To help illustrate what the object is snapping to, Affinity will display a temporary 
red alignment guide when snapping horizontally and a green alignment guide 
when snapping vertically. A measurement in the same colour will be displayed to 
notify you how close the object is in the other axis.

Most page layout and design applications have relatively limited snapping fea-
tures but Affinity offers extensive control over how snapping functions. You don’t 
have to learn all of these features but it is important to understand that by 
default, Affinity will snap to the last 6 selected objects and not to any other 
objects in the document. You can change this setting with the Candidates option 
but if Affinity won’t snap to the object you want to snap to, simply select that 
object before drawing or move another object.

To enable snapping:

1. If snapping is off, click the Snapping  icon in the Toolbar to toggle snap-
ping on.

To temporarily disable snapping while drawing or moving an object:

• Press ⌥ (macOS) or Alt (Windows) while drawing or moving an object. 
Release the mouse button to enable snapping again.

To disable snapping for a specific object:

• Right-click the object’s layer in the Layers panel and choose Exclude from 
Snapping. An icon  will appear below the layer name to indicate that snap-
ping is disabled for this layer.

To specify how close an object must be before it snaps:

1. Choose View > Snapping… to display the Snapping window or click the 
dropdown menu control to the right of the Snapping  icon in the Toolbar
to temporarily display the Snapping options.

2. Set Screen Tolerance to a value between 3 and 50. The default is 8 which is 
suitable for most purposes. The units are a screen measurement and not 
document units so snapping is relative to the current magnification level. On 

Tip: The snapping 
options are global 
settings and are not 
specific to the current 
document

Tip: Refer to Guides on 
page 78, Grids on 
page 85, and Baseline 
grid on page 90 for 
more information

A red alignment guide indicates that the 
selected shape is snapping vertically to 
the bottom of the right shape, and the 
horizontal distance from the right shape 
is displayed between them
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macOS with the default display magnification set in System Settings, a value 
of 8 corresponds to 8 pixels on a non-Retina screen and 16 pixels on a Retina 
screen.

To customise what to snap to:

1. Choose View > Snapping… to display the Snapping window or click the 
dropdown menu control to the right of the Snapping  icon in the Toolbar
to temporarily display the Snapping options.

2. Select a snapping Preset to switch to a saved combination of options. Affinity 
includes presets for popular workflows and you can create your own.

3. Select one or more options:

Snapping presets Preset options menu

Snap to Grid and Guides

Snap to objects

Screen tolerance (snapping strength)

Snapping on/off

Which snapping candidates

Tip: The snapping 
options are global 
settings and are not 
specific to the current 
document
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•  Candidates: Select how to limit the number of objects to snap to when 
working with a complex page.

Candidate List Snap to only the most recently-selected objects up to the value specified
 in Maximum; enter a Maximum value from 1 to 20 to limit how many
 recently-selected objects to use as candidates; select Show Snapping
 Candidates to highlight the objects that will be used for snapping

Immediate Layers Snap only to objects on the current Layer

Immediate Layers and Children Snap only to objects on the current Layer and its child Layers

All Layers Snap to all objects on all Layers

•  Snap to grid: Select to snap to the page’s grid.

•  Snap to baseline grid: Select to snap to the grid of horizontal baseline 
guides spaced equally from the top to the bottom of the page.

•  Snap to guides: Select to snap to ruler and column guides.

•  Snap to spreads: Select to snap to the page spread edges and to the bleed 
zone guides. Select Include spread mid-points to also snap to the middle 
of the spread pages.

•  Snap to margin: Select to snap to margin guides. Select Include margin 
mid-points to also snap to the middle of each margin guide.

•  Only snap to visible objects: Select to ignore hidden objects.

•  Snap to object bounds: Select to snap to the bounding boxes of other 
objects on the page. Select Include bounding box mid-points to also snap 
to the middle of each object. When selected, you can also customise object 
snapping further with these options:

•  Snap to gaps and sizes: Select to snap when the gap between the object 
and the nearest snapping candidate matches the gap between other 
objects in the same horizontal or vertical direction, or when the 
object’s size matches the size of any other snapping candidate. When 
the object is snapped to a gap or size, measurements will appear beside 
the snapping candidates to clarify why the object is snapping.

The green measurement guides 
between the three shapes indicate that 
the selected shape is snapping to match 
the gap between the other two shapes

Tip: You must also 
select Use Baseline 
Grid in View > Base-
line Grid…

The red and green measurement guides 
indicate that the selected shape is 
snapping to the horizontal and vertical 
sizes of the other object, even though 
they’re not aligned

Tip: If Candidate List
is selected and the 
most recently-selected 
objects are on another 
spread, the object will 
not snap to objects on 
the current spread
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•  Snap to shape key points: Select to snap to the key points of an object, 
such as its centre, when moving a path’s node, drawing a shape, or scaling 
a shape. This feature does not apply to moving shapes.

•  Snap to object geometry: Select to snap to an object’s path and nodes or 
vertices (where the lines meet) when moving a path’s node, drawing a 
shape, or scaling a shape. This feature does not apply to moving shapes.

To create a snapping preset:

1. Choose View > Snapping… to display the Snapping window or click the 
dropdown menu control to the right of the Snapping  icon in the Toolbar
to temporarily display the Snapping options.

2. Select the desired options.

3. Click the menu  icon beside the Preset list and choose Create Preset…
from the popup menu.

4. Enter a Preset name.

5. Click Create.

To change a snapping preset’s name:

1. Choose View > Snapping… to display the Snapping window or click the 
dropdown menu control to the right of the Snapping  icon in the Toolbar
to temporarily display the Snapping options.

2. Select the preset name from the Preset list.

3. Click the menu  icon beside the Preset list and choose Rename Preset…
from the popup menu. Enter a new name in the Rename Preset window and 
click Replace.

To delete a snapping preset:

1. Choose View > Snapping… to display the Snapping window or click the 
dropdown menu control to the right of the Snapping  icon in the Toolbar
to temporarily display the Snapping options.

2. Select the preset name from the Preset list.

3. Click the menu  icon beside the Preset list and choose Delete Preset…
from the popup menu. Enter a new name in the Rename Preset window and 
click Replace.

Tip: Snapping presets 
include all options in 
the Snapping window 
except for Enable 
Snapping and Screen 
Tolerance
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Aligning and distributing objects
To align objects to each other, to the spread, or to the spread’s margins:

1. Select multiple objects using the Move  tool.

2. Optional: Using the Layers panel, click the Toggle Lock  icon for the one or 
more of the objects so that they are not moved.

3. Click the Alignment icon in the main Toolbar.

4. To align the objects, select one of the horizontal alignment icons (Align Left, 
Align Centre, or Align Right) and/or one of the vertical alignment icons 
(Align Top, Align Middle, or Align Bottom).

5. Optional: Set Align To:

• Selection Bounds: Align to the objects’ selection box.

• Spread: Align to the edge of the spread.

• Margin: Align to the margin.

• First Selected: Align to the edge of the first object selected.

• Last Selected: Align to the edge of the last object selected.

6. Click Apply.
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To distribute objects within their selection box or to equally space them:

1. Select multiple objects using the Move  tool.

2. Click the Alignment icon in the main Toolbar.

3. To distribute or space the objects, select the Space Horizontally and/or Space 
Vertically icons.

4. Select Auto Distribute to distribute the objects within their selection box. 
Deselect it to enter a Spacing value to specify how far apart they should be 
spaced.

5. Click Apply.

Arranging objects
Objects are layered on the page starting from the bottom of the layer stack which 
determines how overlapping objects are displayed.

To arrange an object in the layer stack:

1. Select one or more objects using the Move  tool.

2. Click the Arrange  icon in the main Toolbar and select one of:

• Move to Front

• Forward One

• Back One

• Send to Back

Or choose the equivalent command from the Layer > Arrange > Move menu.

Tip: Locked objects 
will be moved when 
you distribute them

Tip: Objects are always 
spaced from the top 
and left edges of the 
selection box
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Grouping objects
Combining objects into a group allows you to manipulate the group as a single 
object. A group can be selected, transformed, and edited just like an individual 
object. You can even group objects and groups into another group in a nested 
hierarchy.

Objects in a group are identical in appearance to ungrouped objects. Groups can 
be dissolved at any time with changing their objects.

To create a group from selected objects:

1. Select the objects using the Move  tool or select the object layers in the 
Layers panel.

2. Click the Group  button in the Context Toolbar, click the Group
icon in the Layers panel, or choose Layer > Group. The selection boxes 
around the individual objects will disappear.

To dissolve a group:

1. Select the group using the Move  tool.

2. Click the Ungroup  button in the Context Toolbar or choose Layer > 
Ungroup. Selection boxes will appear around the individual objects.

3. Choose Layer > Ungroup All to dissolve all nested groups in a group.

To select an object in a group:

1. Using the Move  tool, do one of the following:

• Hold ⌘ (macOS) or Ctrl (Windows) while clicking to select objects inside 
a group, container layer, or clipping object rather than the parent layer

• Or double-click the object in the group to select it

• Or select the object’s layer in the Layers panel

• Or select the Select Objects  icon in the Context Toolbar and then click 
the object.

• Or hold ⌘ (macOS) or Ctrl (Windows) while right-clicking the group and 
select an object from the menu. This is useful only if you have recognisable 
layer names.

To add an object to an existing group:

1. Select the object to add in the Layers panel.

2. Drag the object’s layer and release it with the mouse pointer is over the group. 
The group will be highlighted when the mouse is over it.

Tip: Any object can be 
added to a group 
except for objects 
pinned into text or 
objects on a page’s 
master page layer
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To add the object to a specific position within the group, expand the group by 
clicking its caret  and then drag the layer between two layers. Release the 
mouse with a highlight line appears between the two layers.

Or choose Edit > Cut, select the layer above which you want to move the 
object, and choose Edit > Paste.

To remove an object from a group:

1. Select the group using the Move  tool.

2. Right click the object’s layer in the Layers panel and choose Release.

To create an empty group to which you can add other objects:

1. Deselect all objects using the Move  tool or by choosing Edit > Deselect.

2. Click the Group  icon in the Layers panel or choose Layer > New Group.

Hiding objects
You can hide objects so that they’re not visible on screen or when printed and 
exported which is useful for storing alternate versions of an object or text.

To hide an object:

1. Select the object(s) using the Move  tool.

2. Choose Layer > Hide > Hide. To hide all objects on the spread except for the 
selected object(s), choose Layer > Hide > Others. You can also click the 
Toggle Visibility  icon for individual layers in the Layers panel.

To unhide (show) an object:

1. Select the object(s) using the Move  tool.

2. Choose Layer > Hide > Show. To show all objects on the spread, choose 
Layer > Hide > Show All. To show all objects on the spread except for the 
selected object(s), choose Layer > Hide > Others. You can also click the 
Toggle Visibility  icon for individual layers in the Layers panel.
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Locking objects
You can lock objects to avoid accidentally moving or changing them. Locked 
objects cannot be selected by clicking on them but can still be selected and 
deleted in the Layers panel.

To lock an object:

1. Select the object(s) using the Move  tool.

2. Click the Lock  icon in the Layers panel or choose Layer > Lock. Note that 
you can toggle the lock by clicking the icon at the top right of the panel or by 
mousing over the right edge of the layer. The lock icon for an unlocked layer 
will appear when you mouse over its location.

To unlock an object:

1. Select the object(s) using the Move  tool.

2. Click the Lock  icon in the Layers panel or choose Layer > Unlock. You can 
also unlock a layer by clicking the icon at the right edge of the layer in the 
Layers panel.

3. Choose Layer > Unlock All to unlock all objects nested in a group.

Tip: If you group a 
locked object, you will 
not be prevented from 
selecting or transform-
ing the group
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Fill, stroke, and colour
All objects in Affinity have fill, stroke, and colour attributes, including shapes, 
open and closed paths, picture frames, images, and text objects.

Each character in a text object has its own fill, stroke, and colour attributes, as 
does the image inside a picture frame or other objects inside clipping objects.

Setting fill
Fill refers to the fill colour and opacity. In addition to a solid fill colour, you can 
specify a gradient between two or more colours. Affinity also offers hatch pat-
terns for CAD drawings.

To set an object’s fill:

1. Using the Move  tool, click an object to select it.

2. Click the Fill Colour  sample in the Context Toolbar. The Colour popup 
window will appear displaying the last-used tab.

3. Click the None  icon to remove the fill, the Black  icon to set the fill to 
solid black, or the Colour Picker  icon to select the colour at the pointer 
location.

Tip: Refer to Font 
Colour and Back-
ground Colour on 
page 150

Tip: Hatch patterns are 
not described in this 
manual

Tip: Also see Setting 
fill and stroke for 
images on page 277

Tip: The Black icon 
sets a rich black (C72, 
M68, Y67, K88) not 
pure black (K100)

TEXT

Shape

Fill Stroke

Open path Closed path Picture frame

Text
Text objectImage
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4. Select the Colour tab to define a fill colour.

• Colour model: Select the colour model and selectors:

RGB Sliders Set the colour’s Red, Green, and Blue component values
 from 0 to 255

RGB Hex Sliders Set the colour’s Red, Green, and Blue component values in
 hexadecimal from 00 to FF; or enter the colour’s hex value

HSL Sliders Set the colour’s Hue from 0 to 360 and Saturation and
 Lightness values from 0 to 100

CMYK Sliders Set the colour’s Cyan, Magenta, Yellow, and Black
 component values from 0 to 100

LAB Sliders Set the colour’s Lightness from 0 (Black) to 100 (white) and
 green-red and blue-yellow axes from –128 to 127

HSL Colour Wheel Set the colour’s Hue, Saturation, and Lightness using a
 wheel interface instead of sliders; ; or enter the colour’s hex
 value

Hue Set the colour’s Hue using a slider and use a pad to set the
 Saturation (horizontal axis) and Lightness (vertical axis)

Saturation Set the colour’s Saturation using a slider and use a pad to
 set the Hue (horizontal axis and Lightness (vertical axis)

Lightness Set the colour’s Lightness using a slider and use a pad to
 set the Hue (horizontal axis and Saturation (vertical axis)

Greyness Set the colour’s grey level from 0 to 100% using a slider or
 pad

Tint Set a tint of the current colour using a slider; you must
 set the colour to tint before selecting Tint

• Opacity/Noise: Click the Opacity/Noise  icon to toggle between 
setting these options:

Opacity Set the opacity level from 0 to 100%

Noise Set the noise level from 0 to 100%
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5. Select the Gradient tab to define a gradient fill with two or more colours.

• Type: Select Linear, Elliptical, Radial, or Conical.

• Gradient pad: By default, a gradient will have two stops, one on the left 
and one of the right, and a mid point between them.

• Click a gradient stop to select it and edit its colour and other values. 
The stop will be larger when selected.

• Position: Drag the selected stop to a new position or enter a value into 
the field below. You cannot move the default left and right stops.

• Mid Point: Drag the mid point to the desired position or enter a value 
into the field below.

• When the left stop is selected, click Insert to add another stop and then 
drag the stop to the desired position. Or simply double-click where you 
want to add a stop.

• Click Copy to duplicate the selected stop.

• Click Delete to delete the selected stop; you cannot delete the default 
left and right stops.

• Colour: Click the colour sample to set the colour for the selected stop.

• Opacity: Click the colour sample to set the opacity for the selected 
stop.

Linear gradient Elliptical gradient

Tip: A full description 
of gradients is not 
included in this 
manual
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6. Select the Swatches tab to select a pre-defined colour swatch. Affinity includes 
several palettes of swatches, including Pantone® colours but you can also 
create your own palettes and swatches with the Swatches panel.

• Recent: Select a recently-used colour swatch, if applicable.

• Palette: Select a palette to display its swatches as colour tiles.

• Swatch: Click a colour tile to select a swatch.

• Default swatch tiles: Click the None, Black, Medium Grey (58%), or White
swatch tiles in the upper-right of the window. These swatches are available 
regardless of the selected palette.

• Stroke: Click the colour sample to set the colour of the text object’s stroke 
(outline) and click the stroke control on its right to set its thickness, dash 
pattern, and other properties.

Tip: A full description 
of creating swatches 
and palettes is not 
included in this 
manual

Tip: Unlike the Black
icon at the top-right 
corner of the window 
which sets a rich black, 
the Black swatch tile 
sets pure black for 
both CMYK and RGB 
documents
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Setting stroke
Stroke refers to the stroke colour, width, dash pattern, alignment, end cap, and 
corner join. In addition to a solid stroke colour, you can specify a gradient 
between two or more colours. Affinity also offers brush strokes which aren’t 
frequently used in page layout.

To set an object’s stroke:

1. Using the Move  tool, click an object to select it.

2. Click the Stroke Colour  sample in the Context Toolbar. The Colour
popup window will appear displaying the last-used tab. Refer to setting the 
Fill above for more information.

3. Enter the Stroke Width  in the Context Toolbar or click its popup 
arrow to set the width using a slider.

4. Click the Stroke Settings icon  in the Context Toolbar to customise the 
stroke.

• Line Style: Select the No Line Style , Solid Line Style , or Dash Line 
Style  icon.

• Width: Enter the stroke’s width. This can also be set separately in the 
Context Toolbar.

• Cap: Select the Round, Butt, or Square icon to set how the ends of a line 
should appear. This option also applies to each individual dash in a dashed 
line.

• Join: Select the Round, Bevel, or Mitre icon to set how two segments of a 
path or shape should be joined at a node. When the Mitre icon is selected, 
set the Mitre units—the number of line widths the segments should be 
extended at the node—to dynamically bevel the join.

• Align: Select the Centre, Inside, or Outside icon to set how the stroke 
should be drawn on the path.

Tip: The Path Brush is 
not described in this 
manual

Tip: Brush strokes are 
not described in this 
manual
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• Order: Select the Draw Stroke Behind or In Front icon to set whether the 
stroke is drawn on top of or behind the object’s fill.

• Scale with object: Select to scale the object’s stroke with the object. By 
default, the stroke width remains fixed when scaling objects but this 
setting allows you to maintain proportions when objects are scaled with 
their aspect ratio constrained.

• Start and End: Select an arrowhead or other style for the ends of the path. 
While these options are normally used with open paths such as straight 
lines, they can be applied to closed paths and shapes, too. 

• Scale: Enter the scale of the start or end style as a percentage of the 
stroke width.

• Placement: Select the icon for whether the end style should be drawn 
inside or outside the object’s path.

• Swap: Click to swap the start and end styles.

• Delete: Click to clear the start and end styles; this option is equivalent 
to setting start and end to None.

• Dash pattern (dashed lines only): You can set the dashed line pattern by 
defining a series of six alternating dashed and gap segments. The values 
are whole units and it is common to enter 0, 1, 2, or 3 but you can enter 
values up to 100. The first gap segment cannot be set to 0.

• Select the Butt Cap icon for a dashed line with square ends.

• Define only the first pair of dashed and gap segments for uniform 
dashed lines.

• Balanced Dash Pattern: Select to balance the dashed line at a 
shape’s corners and so that a line starts and ends with a dash.

• Phase: When Balanced Dash Pattern is deselected, enter the number of 
units to offset the dash pattern at the start of the path.

1 1 0 0 0 0 with Butt cap

2 1 0 0 0 0 with Butt cap

1 2 0 0 0 0 with Round cap

1 2 0 2 0 0 with Round cap

1 1 2 1 0 0 with Butt cap

1 1 2 1 3 1 with Butt cap

254 Objects
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Images and even other documents can be imported from a vari-
ety of applications to illustrate your document and enhance its 
design. Images and documents can be placed directly on a page 
or into picture frames which are used to crop and frame their 
content.

Images can be embedded directly into the document or left 
external to keep the document size small. Affinity can even 
update your document automatically when a linked image is 
changed.

In this chapter
Types of images ..........................................................................................256
Picture frames ..............................................................................................258
Placing images ............................................................................................261
Modifying images ......................................................................................267
Linking and embedding ..........................................................................274
Setting fill and stroke for images ..........................................................277
Image captions ............................................................................................279

Images 6
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Types of images
You can add three types of images to your Affinity documents:

• Raster (bitmapped) images are made up of a grid of pixels (square dots) and 
are commonly used for photos. Scaling a raster image larger will enlarge the 
pixels which can make it appear jagged. Text in raster images is converted to 
pixels. The .png, .jpg/jpeg, .tif/tiff, and .heic/heif formats are the most popular 
for raster, along with Affinity’s own .af format and the older .afphoto.

• Vector images are made up of lines and curves drawn between points and are 
commonly used for illustrations. Scaling a vector image larger will not result 
in any loss in quality. Text in vector images is often retained as editable text. 
The .svg and .eps formats are the most popular for vector, along with Affinity’s 
own .af format and the older .afdesign.

• Documents can be placed into an Affinity document in the same manner as 
an image. Documents can combine raster and vector images and text remains 
editable. The most popular document formats are .pdf, .psd, and .dwg/dxf, 
along with Affinity’s own .af format and the older .afpub.

The lines between the image types have blurred because many vector formats can 
include rasters and some raster formats can store editable text and vectors.

Before applications such as Affinity, users flattened and exported their raster 
images before placing them into a publishing application. This step is no longer 
necessary and you can place complex documents into Affinity, streamlining your 
workflow. You may still want to export final, flattened images for use in Affinity 
to avoid accidentally updating a linked image when you merely show and hide 
layers and then resave it.

Definition: The term 
image is used to refer 
to all types of graph-
ics, including raster 
and vector images and 
documents
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Image resolution
Most images define the resolution of the image in dots per inch. If you place an 
unframed image without dragging to define its size, Affinity will use the image’s 
resolution to set its initial size. For example, if a raster image is 1920×1080 pixels 
and its resolution is 300 dpi, the image will be 6.4×3.6 inches (162.69×1.4 mm) 
when placed on the page.

If you place an unframed image but drag to define its size, you will be effectively 
changing the image’s resolution. That size example image at 3.2×1.8 inches would 
be 600 dpi. It’s important to ensure that the resulting actual resolution will be 
sufficient when printing or exporting the document. For example, if your printer 
has asked for images to be 300 dpi but you scale a 300 dpi image to be larger on 
the page, the image’s actual resolution will be less than 300.

You don’t need to calculate the resolution yourself because Affinity will display its 
actual resolution in the Context Toolbar when you select an image.

Replace Image Frame Properties Fill colour Stroke colour Stroke Settings

Layer name Image size and actual resolution Size Picture Frame to Content Stroke WidthShow/Hide Fill with Content

Definition: The term 
resolution refers to the 
image’s level of detail 
and is expressed as 
the number of pixels 
wide by the number of 
pixels tall, not in 
megapixels which is a 
pixel count
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Picture frames
You can place images directly onto the page or into a frame that will crop the 
image to the size and shape of the frame and allow the image to be moved and 
scaled within the frame. Picture frames are ideal for professional layouts because 
you can define the space for images prior to placing them and without regard to 
the picture’s size and aspect ratio. Empty picture frames will be shown with an X
as a placeholder to help with laying out the document.

Unframed or frameless images are similar to art text which also lacks a frame. 
Scaling an unframed image scales the image directly while scaling a framed 
image scales the frame without scaling the image. Unframed images are com-
monly used for images that don’t need to be cropped, although you can still crop 
them with the Vector Crop  tool.

To create a picture frame by drawing:

1. Select the Picture Frame Rectangle  tool or Picture Frame Ellipse  tool.

2. Draw the frame as you would any other shape by dragging from one corner of 
the shape to the other. Release the mouse button to create the frame.

• Hold Shift to constrain the picture frame to a square or circle

• Hold ⌘ (macOS) or Ctrl (Windows) to draw from the centre

• While drawing, hold Ctrl (macOS) or right mouse button (Windows) to 
rotate the picture frame about its origin

• While drawing, hold Space to move the picture frame while drawing

Empty picture frame Image in picture frame

Unframed image Cropped unframed image

Definition: The term 
picture frame is used to 
refer to a frame that 
can contain any time 
of image, not just 
photos; the name 
image frame would be 
more accurate but 
picture frame is the 
traditional name for 
this feature in page 
layout applications

Tip: Select the Keep 
Selected  icon in 
the Context Toolbar
so that the new shape 
will be selected after 
it’s created
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To create a picture frame numerically:

1. Select the Picture Frame Rectangle  tool or Picture Frame Ellipse  tool.

2. Hold ⌘ (macOS) or Ctrl (Windows) and click on the page where you would 
like the frame to be created.

3. Enter the Width and Height.

4. By default, the position you clicked will be the centre of the new frame. Select 
a corner or side anchor to change how the frame is positioned.

5. Click OK to finish creating the picture frame.

Shape picture frames
Affinity provides tools to create picture frames in the shape of rectangles and 
ellipses but you can convert any shape to a picture frame.

To convert a shape to a picture frame:

1. Select a shape.

2. Choose Layer > Convert to Picture Frame.

To create a picture frame made up of multiple shapes:

1. Draw the shapes and then select them with the Move  tool.

2. Choose Layer > Geometry > Add to create a compound shape.

3. Choose Layer > Convert to Picture Frame. An image placed into this frame 
would fill the two ellipses but not the space between them.

Tip: You can place an 
image directly inside a 
shape without con-
verting it to a frame; 
this will crop the 
image inside the 
shape but it is not 
recommended 
because the shape will 
lack the other features 
of a picture frame such 
as the Scaling slider

Tip: If you convert an 
open path, the frame’s 
content will be 
cropped at a straight 
line from the path’s 
endpoints
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To fill text with an image:

1. Create and format an art text object as desired.

2. Select the art text object with the Move  tool.

3. Choose Layer > Convert to Curves to convert the text to paths.

4. Choose Layer > Ungroup because the characters will have been grouped.

5. Choose Layer > Geometry > Add to create a compound shape.

6. Choose Layer > Convert to Picture Frame. An image placed into this frame 
would fill the two ellipses but not the space between them. An image placed 
into this frame would fill the characters but not the space between them.

To convert an unframed image to be in a picture frame:

If you place an image directly on the page as unframed, you can convert it to be 
in a picture frame at any time.

1. Choose Layer > Convert to Picture Frame or right-click the image and 
choose Convert to Picture Frame from the context menu. Affinity will create 
a frame at the same size of the image and move the image inside it.

To convert a framed image to an unframed image:

1. Using the Move  tool, double-click the picture frame to select the image 
inside it.

2. Using the Layers panel, drag the image layer out of the picture frame so that it 
is above or below the frame.

3. Delete the empty picture frame.
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Placing images
Placing images is similar to drawing shapes but you can place multiple images at 
once and even multiple copies of each image.

To place a single image:

1. Optional: Select a picture frame.

2. Choose File > Place… or choose the Place  tool. A file open window will 
appear to select the file to open. Or if a picture frame is selected, click Replace 
Image in the Context Toolbar. Select the image and click Open.

You can also drag an image file’s icon from your computer into Affinity, or to 
place a pixel selection from the pasteboard (clipboard), right-click the picture 
frame and choose Paste as Content from the context menu.

If a picture frame was selected the image will be placed into the frame and no 
further action is required; otherwise, the mouse pointer will change to a Place

.pointer.

3. Position the image in a frame on the page:

• To place an image into a picture frame: Click on a picture frame.

• To place an unframed image at its native size and resolution: Click 
anywhere on the page.

• To place an unframed image at a custom size: Drag on the page to define 
the size.

To place multiple copies of a single image:

1. Start placing an image as you normally would but before clicking on a picture 
frame or clicking or dragging on the page to position the image, set Repeat in 
the Context Toolbar to a number greater than 1. Select Replace Existing if 
you want the existing images in picture frames to be replaced by copies made 
by the Repeat feature.

2. Position the image in a frame or on the page:

• To place images into picture frames: Click on a picture frame. Affinity 
will place one copy in this frame (regardless of whether Replace Existing
is selected) and the other copies into other unlocked frames above this 
frame in the layer stack. Frames lower than the frame will not be used. If 
there are not enough frames on the current page, Affinity will create 
additional frames for them at the same size and position on the following 
pages, mirrored for facing pages, and will create pages if necessary.

Tip: While you can 
copy and paste an 
image file’s icon from 
the macOS Finder into 
Affinity, this is not 
recommended 
because Affinity will 
not know the image’s 
name and location 
and an unnamed copy 
will be embedded

Tip: If you select 
multiple picture 
frames before choos-
ing Place, the image 
will be placed into all 
of them

Tip: If there is already 
a picture in the first 
frame it will be 
replaced by the new 
image even if Replace 
Existing is deselected 
because that option 
applies only to copies

Tip: Ensure picture 
frames are stacked in 
the correct order, from 
bottom to top, before 
placing multiple 
images into them

Tip: If there is already 
a picture in the frame 
it will be replaced by 
the new image

Definition: The term 
place is used instead 
of import images 
because you position 
an image on the page 
at the same time as 
you import it
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• To place an unframed image: Click or drag anywhere on the page as you 
normally would when placing an image. If Repeat is set to greater than 1, 
Affinity will place the copies at the same size and position on the following 
pages, mirrored for facing pages, and will create additional pages if 
necessary.

To place multiple images:

1. Choose File > Place… or choose the Place  tool. A file open window will 
appear to select the file to open. Or if a picture frame is selected, click Replace 
Image in the Context Toolbar. Select multiple images by pressing ⌘ (macOS) 
or Ctrl (Windows) while clicking or press Shift while clicking to select a range 
of images. Click Open.

You can also drag the images’ icons from your computer into Affinity.

2. The Place panel will open allowing you to select which image to paste next. 
Select one or more images to place—the first image will be selected automati-
cally. Click a different image to select it, press ⌘ (macOS) or Ctrl (Windows) 
while clicking to select multiple images, or press Shift while clicking to select a 
range of images.

3. Position the first image in a frame or on the page:

• To place images into picture frames: Click on a picture frame. Affinity 
will place the first image in that frame and place the next image into other 
unlocked frames above the frame in the layer stack. Frames lower than the 
frame will not be used. If there are not enough frames on the current page, 
Affinity will create additional frames for them at the same size and posi-
tion on the following pages, mirrored for facing pages, and will create 
pages if necessary.

• To place unframed images: Click or drag anywhere on the page as you 
normally would when placing an image. Affinity will place the copies at 
the same size and position on the following pages, mirrored for facing 
pages, and will create additional pages if necessary.

4. The image you just placed will be removed from the Place panel and if there 
is at least one remaining image, the next one will be selected automatically. 
Position the next image in a frame or on the page.

Tip: The Place panel 
will close automati-
cally when there are 
no more images, you 
change tools, or press 
Esc

Tip: The Place panel 
cannot be opened 
from the Window
menu like other panels 
but its position can be 
saved in a panel preset 
while it is open

Tip: If there is already 
a picture in the first 
frame it will be 
replaced by the new 
image even if Replace 
Existing is deselected 
because that option 
applies only to copies

Tip: Ensure picture 
frames are stacked in 
the correct order, from 
bottom to top, before 
placing multiple 
images into them

Tip: If you place 
multiple copies of 
multiple images, 
Affinity will place all 
the copies of each 
image before placing 
the next image
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5. To stop placing images while there are still images in the Place panel, press 
Esc.

To replace the image in a picture frame:

1. Select a picture frame.

2. Click Replace Image in the Context Toolbar. Select the image and click 
Open.

Or using the Layers panel, drag an unframed image’s layer over the picture 
frame’s layer and release the mouse button when the layer name is high-
lighted.

To move or duplicate an image between frames:

1. Using the Move  tool, double-click the picture frame or hold ⌘ (macOS) or 
Ctrl (Windows) and single click the picture frame. 

2. Choose Edit > Cut to move the image or Edit > Copy to duplicate the image 
to the other frame.

3. Click the frame to which you want to add the image.

4. Choose Edit > Paste Inside.
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Placing documents
You can place PDF and CAD documents as well as documents created with 
Affinity. The process for placing documents is similar to images but there are 
several additional options that you can set before and after placing a document. 
Documents can have many pages or artboards so when placing one on a page in 
Affinity you must also select which will be displayed. To display more than one 
page or artboard, place the document a second time and select a different page or 
artboard.

To place a PDF or Affinity document:

1. Place the document as you would any other image.

2. If a PDF file is password protected, you will be prompted to enter the pass-
word to place the file. Click the Show Password  icon to show the password 
characters or the Paste  icon to paste a copied password.

3. If the document contains more than one page or artboard and you did not 
select a picture frame before choosing Place, the Place panel will open to 
prompt you to select which page or artboard to display.

4. From the panel list, select a page or artboard, or click the caret  icon to the 
left of the filename to view thumbnails of all the pages or artboards.

5. Place the document into a picture frame or directly on the page as you would 
any other image. You can change which page of the document is displayed by 
double-clicking the frame to select the document within the frame and then 
selecting a page in the Context Toolbar.

6. PDF Passthrough (optional, PDF only): In the Context Toolbar, select 
Passthrough for Affinity to make no changes to the placed PDF file, allowing it 
to be printed or exported as part of the page even if you don’t have its fonts 
installed, or Interpret to allow Affinity to interpret its contents. This option 
will default to Passthrough unless the contents of the PDF file require that 
Affinity interpret it.

Tip: You may need to 
reselect the PDF file in 
the panel if it is 
deselected
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To place a CAD (DWG/DXF) document:

1. Place the document as you would any other image.

2. Set the CAD import options:

• Selection: Select:

All Pages To import all paper space layouts, if present

Single Page To select one paper space layout from the Selected Page list

Model To import only the model space

• Insertion Units (Model only): Select what one unit in the CAD drawing 
corresponds to in the CAD document.

• DPI: Set the resolution for the imported document. Select Use host docu-
ment DPI to use the parent document’s resolution instead.

• Background colour: Set a background colour for the CAD document.

• Colour override: Select a colour to override all stroke colours in the 
document

• Remove hidden items: Select to exclude hidden and frozen layers from 
import.

• Display entity handles: Select to append a handle suffix to each named 
entity to assist with troubleshooting.

• Override line weights (Model only): Select to set all strokes to 0.1 pt.

• Sanitize model (Model only): Select to clean the model to remove unnec-
essary detail and correct common map errors.

• Convert hatches to curves: Select to import all hatch patterns as curves 
(paths) rather than as editable patterns.

3. Click OK.
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To change which page or artboard of a document is displayed:

1. Select the placed document with the Move  tool.

2. Select the page from the Spread list or the artboard from the Artboard list in 
the Context Toolbar.

To change how much of a document’s page is displayed:

1. Select the placed document with the Move  tool.

2. From the Page Box list in the Context Toolbar, choose:

TrimBox (default) Displays all content inside the page

BleedBox Also displays content extending into the bleed zone

MediaBox (PDF only) Also displays the printers marks and bleed zone

ArtBox (PDF only) Few documents have ArtBox defined; rarely used

CropBox (PDF only) Normally the same as TrimBox because it is the size to
 be displayed in a PDF viewing application

Minimum Content Crops to the bounding box of the content, including
 content outside of the page edges that would be
 cropped by the other options; used to trim whitespace
 from around a page

Minimum Visible Content Same as Minimum Content but excludes hidden
 objects

Maximum Content Same as Minimum Content but includes invisible
 control handles for paths outside of visible objects

Maximum Visible Content Same as Maximum Content but excludes hidden
 objects

To change which layers of a CAD, PDF or Affinity document are displayed:

1. Select the placed image or document with the Move  tool.

2. Select one or more layers from the Layers list in the Context Toolbar.

Or select Show All or Hide All from the Layers list to show or hide all layers. 
Objects that are not on a layer will be displayed even when all layers are 
hidden.
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Modifying images

Selecting images
It’s important to know whether the picture frame or the image within it is 
selected before scaling a picture frame or image.

Picture frame: Size handles to scale the frame will be shown at the frame’s cor-
ners and the Scaling slider will be shown below the frame to scale the image 
inside the frame. The Pan  control will be shown in the frame’s centre when 
the mouse pointer is over the frame. The Context Toolbar will show (Picture 
Frame) after the layer name and the frame will be selected in the Layers panel.

Image inside a picture frame: Size handles to scale the image will be shown at 
the image’s corners and the Scaling slider will not be shown. The Context Tool-
bar will show (Image) after the layer name and the image will be selected in the 
Layers panel.

To select a picture frame or an unframed image:

1. Using the Move  tool, click the picture frame once. A bounding box and 
size handles will appear around the picture frame or unframed image to 
indicate that it is selected.

To select the image inside a picture frame:

1. Using the Move  tool, double-click the picture frame or hold ⌘ (macOS) or 
Ctrl (Windows) and single click the picture frame. A bounding box and size 
handles will appear around the image to indicate that it is selected.

To select the picture frame of an image:

1. Using the Move  tool, right-click the image inside a picture frame and 
choose Select Parent from the context menu.

Tip: The name for an 
image layer defaults to 
its filename

Tip: The Scaling slider 
and Pan control won’t 
be shown if the frame 
is too small—zoom in 
to see these controls if 
they’re not visible

Picture frame selected Mouse over frame Image inside frame selected
Tip: The name for a 
picture frame layer 
defaults to Picture 
frame which is why the 
it shows Picture frame 
(Picture Frame) for 
picture frame layers 
that haven’t been 
renamed
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Moving images
To move both the picture frame and the image inside it:

1. Using the Move  tool, click the picture frame once to select it.

2. Drag anywhere on or inside the bounding box but do not drag on the Pan
control or you will move the image inside of the frame. Hold Shift while 
dragging to constrain movement to horizontal, vertical, or 45°.

Or, with the picture frame selected, press Return or Enter to move the picture 
frame and image by entering the horizontal and vertical offset in the Move / 
Duplicate window.

To move the image inside a picture frame:

1. Using the Move  tool, click the picture frame once to select it.

2. Drag on the Pan  control to move the image within the frame.

3. Or, using the Move  tool, double-click the picture frame to select the image 
inside it and drag anywhere on or inside the bounding box. Hold Shift while 
dragging to constrain movement to horizontal, vertical, or 45°.

Or, with the image selected, press Return or Enter to move the image by enter-
ing the horizontal and vertical offset in the Move / Duplicate window.

To move an unframed image:

1. Using the Move  tool, click the image once to select it.

2. Drag anywhere on or inside the bounding box. Hold Shift while dragging to 
constrain movement to horizontal, vertical, or 45°.

Or, with the image selected, press Return or Enter to move the image by enter-
ing the horizontal and vertical offset in the Move / Duplicate window.
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Scaling and rotating images
To set how an image is scaled inside a picture frame:

1. Using the Move  tool, click the picture frame once to select it.

2. Click Properties  in the Context Toolbar to display the Image 
Properties popup window.

3. Select how the image will be scaled in the picture frame. The image will be 
scaled with the frame if Scale to Max Fit, Scale to Min Fit, or Stretch to Fit is 
selected, but if you scale or transform the image inside the frame then None
will be selected automatically.

• Scale to Max Fit (default, recommended): The image will be scaled to fill 
the frame without changing its aspect ratio. The image will be cropped to 
fit if the frame has a different aspect ratio. The image will be scaled with 
the frame.

• Scale to Min Fit: The image will be scaled to fill the frame without chang-
ing its aspect ratio. There will be empty space at the top and bottom or left 
and right of the frame if the frame and image have different aspect ratios. 
The image will be scaled with the frame.

Tip: You can also right-
click a picture frame 
and choose the 
equivalent command 
from Frame 
Properties
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• Stretch to Fit (not recommended): The image will be scaled to exactly fill 
the frame without regard to its aspect ratio, matching the frame’s aspect 
ratio. The image will be scaled with the frame.

• None: The image will not be scaled as the frame is scaled. This option will 
be selected automatically if you scale or transform the image inside the 
frame.

The None option will add a content-scaling handle at the bottom-corner of 
the picture frame. Dragging this handle will scale the image with the 
frame rather than scaling only the frame.

4. Set the anchor position to determine the point from which the image is 
scaled.

To visually scale or rotate a picture frame and the image inside it:

Select Scale to Max Fit, Scale to Min Fit, or Stretch to Fit in Image Properties
before scaling the picture frame.

1. Using the Move  tool, click the picture frame once to select it.

2. Drag a size handle to scale the frame and image.

• Hold Shift while dragging to constrain the frame to the current aspect 
ratio.

• Hold ⌘ (macOS) or Ctrl (Windows) to scale from the frame’s centre

• Hold Ctrl (macOS) or right mouse button (Windows) to rotate the frame 
about its origin while scaling

Tip: You can also right-
click a picture frame 
and choose Frame 
Properties > Anchor 
to Centre but for the 
other anchor points 
you must click Proper-
ties in the Context 
Toolbar

Picture frame with scaling set 
to None

Content-scaling handle

Tip: You can also select 
Lock Children from 
the Context Toolbar
to prevent a picture 
frame’s image from 
scaling with the frame
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3. Drag the rotation handle to rotate the frame and the image inside it. Hold 
Shift while dragging to constrain rotation to 15° increments.

To precisely scale or rotate a picture frame and the image inside it:

Select Scale to Max Fit, Scale to Min Fit, or Stretch to Fit in Image Properties
before scaling the picture frame.

1. Using the Move  tool, click the picture frame once to select it.

2. Using the Transform panel, change the W (width) and H (height) coordinates 
for the selected frame.

3. Using the Transform panel, enter the Rotation and Shear angles.

To visually scale or rotate the image inside a picture frame:

1. Using the Move  tool, click the picture frame once to select it.

2. Drag the Scaling slider control left or right to decrease or increase the scale of 
the image inside the picture frame. Affinity will show the current scale per-
centage as you drag the slider’s thumb.

3. Drag the rotation handle to rotate the image. Hold Shift while dragging to 
constrain rotation to 15° increments.

To precisely scale or rotate the image inside a picture frame:

1. Using the Move  tool, click the picture frame once to select it.

2. Click the Image Size and Actual Resolution in the Context Toolbar to edit 
this information. Enter the Scale percentage or Image DPI (resolution); 
changing one will change the other. Click Original Size to revert to the 
image’s native size and resolution. Select the Link  icon to change the width 
and height in tandem to maintain the image’s current aspect ratio.

Or using the Transform panel, change the image’s width or height. Select the 
Link  icon to change the width and height in tandem to maintain the 
frame’s current aspect ratio.

3. Using the Transform panel, enter the Rotation and Shear angles.

Image size and actual resolution

Tip: Scaling the image 
inside a picture frame 
will automatically set 
the scaling method in 
Image Properties to 
none

Tip: Scaling the image 
inside a picture frame 
will automatically set 
the scaling method in 
Image Properties to 
none

Tip: Rather than 
calculating the new 
coordinates, use an 
expression such as +2
to add 2 to the current 
value; refer to Appen-
dix B – Using field 
input expressions on 
page 470
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To visually scale or rotate an unframed image:

1. Using the Move  tool, click the image once to select it.

2. Drag a size handle to scale the image. Hold Shift while dragging to constrain 
the image to its current aspect ratio.

3. Drag the rotation handle to rotate the image. Hold Shift while dragging to 
constrain rotation to 15° increments.

To precisely scale rotate an unframed image:

1. Using the Move  tool, click the picture frame once to select it.

2. Using the Transform panel, change the image’s width or height. Select the 
Link  icon to change the width and height in tandem to maintain the 
image’s current aspect ratio.

3. Using the Transform panel, enter the Rotation and Shear angles.

To restore a picture frame’s original aspect ratio:

1. Using the Move  tool, click the picture frame once to select it.

2. Double-click any edge size handle (left, right, top, or bottom).

To restore an image’s original aspect ratio:

1. Using the Move  tool, double-click the picture frame to select the image 
inside it.

2. Double-click any edge size handle (left, right, top, or bottom)

To scale a picture frame to the size of its image:

1. Using the Move  tool, right-click the picture frame and click the Size Pic-
ture Frame to Content  icon in the Context Toolbar or choose Frame 
Properties > Size Frame to Content from the context menu.

Cropping unframed images
To crop an unframed image:

1. Using the Vector Crop  tool, click to select an unframed image.

2. Drag a crop handle to scale the cropping rectangle. While cropping:

• Hold Shift to constrain the cropping rectangle to its current aspect ratio.

• Hold Ctrl to rotate the cropping rectangle around the opposite handle.

• Hold ⌥ to disable global snapping.

• Hold ⌘ (macOS) or right mouse button (Windows) to crop from the 
centre.

3. Drag on the cropping rectangle to move the image within the cropping rec-
tangle or drag on the cropping rectangle’s borders to move it while the image 
remains fixed in place.
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Using multiple images in a picture frame
Occasionally you might want to add more than one image into a single picture 
frame. For example, you might want to add an icon or watermark that needs to 
be cropped by the frame, too.

Every object in Affinity can act as a parent clipping object for multiple child 
objects so you can add secondary images to a picture frame. In fact, you could 
use rectangles to frame pictures instead of using picture frames, but rectangles 
lack a frame’s content scaling options, Scaling slider, and Pan control.

The primary image of a picture frame is considered its framed content and 
subject to the scaling and panning features. This layer is indicated by the Framed 
Content  icon in the Layers panel. Other secondary images of a picture frame 
will scale like normal child objects.

To add a secondary image to a picture frame:

1. Using the Layers panel, drag an image layer beneath the picture frame’s layer 
and release the mouse button when a highlight line appears between the 
picture frame layer and the existing framed content layer.

Or using the Move  tool, select the unframed image and choose Edit > Cut
to move the image or Edit > Copy to duplicate the image to the other frame. 
Double-click the picture frame that already has an image and then choose 
Edit > Paste.

Framed content icon
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Linking and embedding
When placing images, you can either embed the image into the document or link 
to the original image file.

Linking stores only a low-resolution preview of the image in the Affinity docu-
ment along with an absolute link to the image file’s location. This approach keeps 
the file size small and uses less memory. The images in the document can also be 
updated automatically when the linked images are updated. The disadvantage is 
that if you lose the image files, the document will only have the low-resolution 
preview. Moving a document with linked images to another computer is slightly 
more complex because Affinity stores an absolute link—the full file path—so you 
will be prompted to find the images when opening a moved document.

Embedding stores an exact copy of the image inside the Affinity document 
which avoids losing data if the images are later moved or lost. This approach 
comes at the cost of memory and file size—embedding multiple images can 
create huge Affinity files and consume a lot of memory so it is best to use embed-
ding only for small documents with few images.

The Placement Policy allows you to select whether images should be placed as 
embedded or linked. Refer to Creating a new document on page 22 and Chang-
ing layout options on page 33 for more information. If you select Prefer Embed-
ded but attempt to embed more than about 25 MB of images, you will be 
prompted to switch to Prefer Linked. You can also mix linked and embedded 
images in the same document.

To update linked images automatically:

Linked images can be updated automatically or manually when they are 
modified.

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click General in the left pane.

2. Select Automatically update linked resources when modified externally. 
This setting applies to linked text and images.

Tip: Store all of the 
linked images for a 
document in a folder 
at the same level as 
the document file to 
make it easier to move 
the document and 
images together
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To change an embedded file to linked or vice versa:

1. Choose Document > Resource Manager and select the Images tab.

2. Select the image in the list. If you select an image on a page, it will be selected 
automatically in the list. You can also press ⌘ (macOS) or Ctrl (Windows) 
while clicking to select multiple images, or press Shift while clicking to select a 
range of images.

3. Click Make Linked to link it or Embed to embed it. When making a file 
linked and the original file no longer exists, Affinity will prompt you to 
choose a location where it will create a new linked copy of the image. If the 
original file exists but has been modified since you embedded a copy of it, you 
will be prompted to choose which version to use. Choosing Yes will overwrite 
the original external file with the embedded copy and No will replace the 
embedded copy with the external file.

To find and relink missing images:

Preflight can warn you when an image is missing but you can also find missing 
images on your own.

1. Choose Document > Resource Manager and select the Images tab.

2. Click the Status column to sort by status. Missing images will be sorted to the 
top of the list.

3. Select the first missing image and click Relink. A file open window will 
appear. Navigate to a folder and click Select Folder. If other images are miss-
ing and are stored in the same folder, Affinity will relink them automatically.

Or click Replace… to select another image file. A file open window will 
appear. Select an image and click Open.

To manually update linked images that have been modified externally:

If Automatically Update Linked Resources when Modified Externally is not 
selected in Affinity > Settings > General and a linked image is modified in 
another application, then the images must be updated manually.

Tip: If you edit an 
embedded PDF, SVG, 
PSD, or EPS document 
within Affinity then it 
will be converted to an 
Affinity document and 
you will no longer be 
able to make it linked; 
you can use the 
Resource Manager to 
find the original file 
should you want to 
revert to it
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1. Choose Document > Resource Manager and select the Images tab.

2. Click the Status column to sort by status. Modified images will be sorted near 
the top of the list, below missing images if any are missing.

3. Select the first modified image and click Update. Repeat for all modified 
images. You can also press ⌘ (macOS) or Ctrl (Windows) while clicking to 
select multiple images, or press Shift while clicking to select a range of images 
before clicking Update.

To find an image in the document:

1. Choose Document > Resource Manager and select the Images tab.

2. Select the image in the list. If there are multiple copies of the image in the 
document, click the caret  icon to the left of the image thumbnail so you 
can select one of them.

3. Click Locate in Document.

To find a linked image used in the document on your computer:

1. Choose Document > Resource Manager and select the Images tab.

2. Select the image in the list. If there are multiple copies of the image in the 
document, click the caret  icon to the left of the image thumbnail so you 
can select one of them.

3. Click Show in Finder (macOS) or Show in Explorer (Windows). Affinity will 
open a file folder window on your computer containing the image file.

To move linked images to a different folder:

If you move linked images using macOS Finder or Windows Explorer, the images 
will become missing in Affinity and you will need to relink them. You can also 
move images with Affinity in one step. This is also a convenient way to group 
images from multiple folders into a single location.

1. Choose Document > Resource Manager and select the Images tab.

2. Select the image(s) to move in the list. You can also press ⌘ (macOS) or Ctrl
(Windows) while clicking to select multiple images, or press Shift while 
clicking to select a range of images.

3. Click Collect… A file open window will appear. Navigate to the new location 
and click Collect. The selected images will be moved to this folder.

To open a stock photo’s web page:

Stock photos have a link to the vendor’s website.

1. Choose Document > Resource Manager and select the Images tab.

2. Select an image in the list.

3. Click Open Stock URL to open the stock photo’s web page in your default 
browser.



Expert Guide to Affinity by Canva 3.0 277

Setting fill and stroke for images
Affinity allows you to apply fill and stroke properties to unframed images and 
picture frames. The fill will only be visible if the Show/Hide Fill with Content
option is chosen and the image doesn’t fill the entire frame or it has transparent 
areas.

You can also apply fill and stroke properties to the image inside a picture frame. 
Filling an image will tint the image similar to using Layer > New Adjustment > 
Recolour. The stroke for an image inside a picture frame will be visible only if the 
image does not fill the frame. If the stroke is set for both the frame and the image 
inside it, the frame’s stroke will be layered above the image’s stroke.

To add a border (stroke) to an image:

1. Using the Move  tool, click the picture frame or unframed image once to 
select it, or double-click a picture frame to select the image inside it.

2. Enter the Stroke Width  in the Context Toolbar or click its popup 
arrow to set the width using a slider.

3. Click the Stroke Colour  sample in the Context Toolbar and select a colour.

4. Click the Stroke Settings icon  in the Context Toolbar to customise the 
stroke.

To add a fill (tint) to an image:

1. Using the Move  tool, click an unframed image once to select it, or double-
click a picture frame to select the image inside it.

2. Click the Fill Colour  sample in the Context Toolbar and select a colour.

To add a fill to the background of a picture frame:

1. Using the Move  tool, click the picture frame once to select it.

2. Click the Fill Colour  sample in the Context Toolbar and select a colour.

Fill and stroke not set Image fill colour set Frame and image stroke set 
and frame fill colour set

Fill and stroke off Frame stroke set Frame fill set to a colour for an image that 
doesn’t fill the entire frame with Show/Hide 
Fill with Content selected

Tip: Refer to Fill, 
stroke, and colour on 
page 249 for more 
information on 
selecting colours and 
customising strokes
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3. Select the Show/Hide Fill with Content  icon in the Context Toolbar.
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Image captions
Affinity does not include a feature to automatically add captions to images but 
you can easily add your own captions that flow with a story’s text.

For captions above or below an image pinned inline:

1. Enter the caption text as a paragraph and apply a caption paragraph style to it.

2. To avoid the image and caption being separated on different pages, set Para-
graph > Flow Options > Keep With Next to 1 line in the style for captions 
above an image, and select Paragraph > Flow Options > Keep With Previous 
Paragraph in the style for captions below an image.

For captions to the left or right of an image pinned inline, and for images 
pinned floating:

1. Unpin the image.

2. Enter the caption text into a separate text frame or art text object.

3. Select the image and caption text object and choose Layer > Group.

4. Choose Edit > Cut.

5. Place the text cursor where the image and caption should be pinned and 
choose Edit > Paste. If the image and caption is now pinned inline when it 
should be floating or vice versa, click the Float With Text  or Inline In Text

 buttons in the Pinning panel.

To number figures or illustrations throughout a document:

You can create a running list name a list and add new items to it anywhere in 
your document or Affinity Book.

1. Select a numbering style from the Type field.

2. Enter the text to define the list marker in the Text field. You can include 
Figure or a similar word as a prefix.

Format Text value

Figure 1: some text…  Figure : 

3. Set Tab Stop to 0 if the list marker (Text) includes or will be followed by a 
space and set Marker Alignment to Left.

4. Set Start Numbering At to 1.

5. Select Restart Numbering to Manual Only and deselect Restart Numbering 
Now.

6. Enter a unique list Name and select Global.

7. Optional: Select a character style to apply to the list marker (Text).

Tip: Pasting the cut 
group will ensure that 
it is pinned in the right 
location but Affinity 
will default to inline or 
floating depending on 
which feature was last 
used

Tip: For images that 
aren’t pinned to text, 
simply create a text 
frame or art text 
object for the cap-
tion—group the 
image and caption if 
desired

Definition: The term 
Running List refers to 
a list that is inter-
rupted by other 
paragraphs and even 
the end of a story or 
Chapter
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8. Optional: To right-align the numbers, set Marker Alignment to Right. Using 
the Spacing section of the panel, set First Line Indent to greater than zero.

9. Create a paragraph style for this list. Refer to Creating text styles on page 211 
for more information.

Tip: Test with the 
largest number to 
determine the appro-
priate First Line 
Indent value

280 Images
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There are many different ways to create a book with Affinity, 
including creating it as individual chapter documents combined 
together as an Affinity Book file. The best approach to use for 
your book project will depend on the type of book you plan to 
publish, its design, and your preferred workflow.

In this chapter
Parts of a book .............................................................................................282
Static layouts vs. automatic text flow ..................................................282
Sections and stories in books ................................................................284
Splitting a book into chapter documents .........................................286

Books 7
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Parts of a book
Books are typically divided into front matter, body pages, and end matter, also 
known as back matter. Below is a list of the most common parts of a book but 
not all books will have every part or have them in the same order:

Front Matter Body End Matter

Accolades Prologue or Introduction Appendices
Half title Chapters Endnotes
Frontispiece Epilogue Bibliography
Title page Afterword/Conclusion Glossary
Copyright/Colophon Postscript Index
Also by the author  Acknowledgements
Dedication  Author bio
Table of contents  Accolades
Epigraph  Colophon
List of figures
Preface
Foreword

Static layouts vs. automatic text flow
Many books have text that flows automatically from page to page like a word 
processor. The text and images pinned into it will flow as you add and edit text as 
long as the text frames are linked together. To change the order of pages you 
would cut and paste the text from one page to another, just as you would with a 
word processor.

Other books use a static layout with text that does not flow automatically from 
page to page. To move a page to another position in the document you would 
change the order of the pages. These books are sometimes designed around 
complex illustrations with text edited to fit the available space.

Static layout: text frames 
are not linked, each 
frame contains its own 
story

Automatic Text Flow:
text frames are linked 
from page to page into 
one story

Definition: The term 
story refers to all the 
text in a text object or 
in a series of linked 
text frames
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A novel or textbook will almost always use automatic text flow while a photo 
book or children’s story book will almost always use a static layout. This manual 
uses automatic text flow with inline images that are pinned to the text, as well as 
page breaks to interrupt the flow where required.

Some books can be laid out either way and the choice is a personal preference. 
For example, a cookbook could be created as a static layout if you want to posi-
tion each page element manually and be able to change the order of recipes 
easily. But you could also use automatic text flow and pin each recipe’s sidebars 
and photos.

Using static layouts with automatic text flow
If a chapter’s body text skips a page or spread due to the use of a full-page or full-
spread photo or illustration, you can insert a page break before the photo or 
illustration and pin the full-page image followed by another break. Be careful 
using this approach with images that span a facing-page spread because if you 
add or remove text before the image it could shift to the right side and not fit 
onto the page. You can avoid this by inserting an even page break before the 
image but that could lead to a preceding blank page.

Alternatively, you can also place the images on static pages and link the previous 
and following text frames to skip over them. If you add or remove a substantial 
amount of text before the static page or spread you may need to rearrange the 
pages because the static page or spread may become distant from the text that 
describes it.

Automatic text flow with a pinned 
spread: a page break is inserted before 
the pinned full-spread image, followed 
by two page breaks

Automatic text flow with a static page: 
the story is linked from the frame before 
the static page to the frame after it, 
jumping over the image

Automatic text flow with a pinned 
image: a page break is inserted before 
the pinned full-page image, followed by 
another page break

Definition: A spread is 
a pair of left and right 
pages in a facing-
pages document

Tip: You can pin 
images with the 
Pinning panel so they 
move with the associ-
ated text; refer to 

Tip: Refer to Interrupt-
ing text flow on page 
118 for information on 
page breaks

Automatic text flow with a static 
spread: the story is linked from the 
frame before the static spread to the 
frame after it, jumping over the image
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Sections and stories in books
Affinity uses the term section to refer to a range of pages but sections don’t have 
to correspond to your book’s chapters. You might use sections even if your book 
doesn’t have chapters because most books have front matter, pages before the first 
body page. Using a section for your front matter and one or more sections for the 
body of the book will allow you to restart page numbering at the first body page 
and to change the page numbering style.

A book with a static layout might not use linked frames so each frame would 
contain a separate story, or it might have frames on the left and right side of each 
facing-page spread that are linked together as pairs, but not linked to frames on 
other spreads.

For a book with automatic text flow there would be many pages of linked frames 
containing one story. You must choose whether to use a single story for all of the 
text in the body of your book or whether to use a separate story for each chapter. 
And you must also choose whether to create a section for each chapter.

Single vs. multiple stories
Use a single story for simplicity. With a single story, all of the text in the body of 
the book in a single series of linked frames. You can start a new chapter by 
inserting a page break. You can move a chapter by cutting and pasting all of its 
text as you would in a word processor. You may need to add or remove pages at 
the end of the book as you add and remove text.

Use multiple stories in a single document, one for each chapter, to simplify 
reordering chapters, add endnotes at the end of each chapter, and improve per-
formance. You can move a chapter by dragging all of its pages to a new position 
with the Pages panel. You may need to add or remove pages at the end of each 
chapter as you add and remove text.

Using multiple stories reduces the load on your computer because Affinity only 
has to reflow a single chapter instead of the entire book when you add or delete a 
line of text. Although modern computer hardware makes this less of a concern, 
performance can still be an important factor in a document with many inline 
images.

Regardless of which approach you select, adding pages and linking their text 
frames is easy with AutoFlow. Refer to AutoFlow text on page 117 for more 
information.

654
B

321
A Single story: the last text frame of chapter A 

on page 3 is linked to the first text frame of 
chapter B on page 4 so there is only a single 
story

Tip: Use the Section 
Manager to create 
sections; refer to 
Sections on page 66 
for more information

654
B

321
A Multiple stories: the text frames in chapter A 

are linked from pages 1–3 and the frames in 
chapter B are linked from 4–6 but there is no 
link between the chapters

Definition: Front 
Matter refers to the 
pages before the body 
of a book, including 
the title page, copy-
right page, table of 
contents, and preface
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Single vs. multiple sections
Use a separate section for each chapter if you want chapter-specific page number-
ing or to easily change the chapter name shown in the header or footer. But if 
your chapters require master page objects unique to each chapter, such as tabs 
that bleed off the right edge of pages, sections will be of little value because 
master pages must be applied manually to pages. You could apply a master page 
manually to all of the pages in a section but if you do that you might as well place 
the chapter name on the master page.

If you use separate sections for each chapter then you should use a separate story 
for each chapter, too. Unlike word processors such as Microsoft® Word which 
allow you to insert a section break at any point in your text, sections in Affinity 
are a grouping of pages. If you had a section starting on page 50 but the chapter 
heading on that page re-flowed to page 51 when you added more text, your 
chapter headings would be off by one page. If you used separate stories, the story 
for the previous chapter would be overset (overflowing) when you added more 
text. Affinity will warn of this you through Preflight so that you could add 
another page with AutoFlow.

Tip: Use the Fields 
panel to insert a 
Section Name into a 
header or footer
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Splitting a book into chapter documents
You can create a book as a single file or as separate files for each chapter joined 
together into a book. Many people used to create separate files for chapters due 
to limited computer hardware but today’s computers are more than sufficient to 
create a long, complex document with hundreds of images without needing to 
use separate files. But if you do need or prefer to work this way, the Books panel
allows you to create an Affinity Book comprised of multiple Chapter documents. 
A Chapter document is just a regular Affinity document that has been added to 
an Affinity Book. Working on a single chapter at once lowers the demands on 
your system’s memory and it’s much easier to reorder chapters with the Books 
panel.

The disadvantage of using the Affinity Book feature is increased complexity and 
the inability to package a Book for publication—the Save As Package command 
packages only individual documents. Affinity simplifies most of the complexity 
for you by synchronizing text styles, page numbers, and more across your Book 
but you may need to add or remove pages to the end of chapters to achieve the 
layout you desire.

Undo and Affinity Books
When you undo an action in Affinity it is added to the undo history which you 
can view with the History panel. Each document has its own undo history so the 
list of actions in the History panel will change when you switch documents.

An Affinity Book does not have its own undo history so the actions you perform 
on a Book cannot be undone.

Tip: Books is capi-
talised in this manual 
when referring to an 
Affinity Book, and 
uncapitalised when 
referring to a book 
created as a single 
document

Tip: Do not add a 
chapter document to 
more than one Affinity 
Book because it will 
impact synchroniza-
tion

an Affinity Book is stored as a .afbook file which combines the pages of separate document .af files 
together when you export or print the Book

Tip: You can use an 
Affinity Book even if 
your project doesn’t 
have chapters because 
you can divide your 
Book into arbitrary 
groups of pages

Tip: Do not duplicate 
an Affinity Book and 
its chapters, other 
than for archiving, 
because Books use 
absolute links to their 
chapters so opening 
the duplicate Book will 
modify the original 
chapters
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Using the Books panel
To display the Books panel:

1. Choose Window > Layout > Books to display the Books panel.

The first icon to the right of each Chapter’s name and page number indicates its 
Chapter file status:

Chapter file
Status Description

 The Chapter is open for editing

 The Chapter is closed and there are no issues

 The Chapter is closed and was edited while the Affinity Book was closed—
 open it to update the Book

 The Chapter is locked or could not be found—if locked, unlock the file; close
 and reopen the Book and locate the Chapter when prompted to resolve it

The second icon to the right of each chapter’s name and page number indicates 
its Preflight status:

Preflight
Status Description

 Preflight not completed because Check is set to Never

 All Preflight tests passed

 One or more Preflight warnings

 One or more Preflight errors and possibly one or more warnings

Add chapterSynchronize chapters Remove chapter(s)

Panel menu

Switch between open books

Selected chapter is highlighted

Chapter file status

Preflight status

Style source chapter

Book name and 
modification status

Update numbers 
now
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Managing stray pages
Most books use facing pages to mirror headers and footers on the left and right 
side or to allow for different inner and outer margins, so pages are paired into 
spreads. The term stray page refers to a single page at the start or end of a chap-
ter document that isn’t part of a facing-page spread in that chapter. Stray pages 
from adjoining chapter documents need to be joined together into a spread and 
sometimes a blank page needs to be added to maintain the proper order of pages.

An Affinity Book cannot support books with Chapters that can start on the left 
side of a facing-page spread to avoid blank pages. Novels, biographies, and some 
other text-focused books often start chapters on either side of the spread depend-
ing on where the previous chapter ended. If you were to use an Affinity Book for 
this type of project and chapter 1 ended on a right page but you created the 
chapter 2 document with its first page on the right, as a new document is nor-
mally created, Affinity would have to change the side for every page in chapter 2. 
This would result in unsatisfactory results so it’s best to avoid this issue.

If your chapters always start on the same side of a spread you will have to add 
and remove blank pages manually to avoid two successive blank pages.

The Books panel’s menu offers two Stray Pages commands:

• Merge Where Possible: If a chapter ends on a left page and the following 
chapter starts on a right page this command will merge those two stray pages 
into a single spread when printing or exporting the Affinity Book.

• Pad: If a chapter ends on a right page and the following chapter starts on a 
right page this command will add a blank page to maintain the facing pages.

By default, Merge Where Possible is enabled and Pad is disabled but this is not 
an optimal combination. Leaving Pad off will result in a single-page spread when 
a chapter document ends with a right page which must be avoided.

Definition: Facing-
page spread refers to a 
pair of left and right 
pages in a facing-
pages document

Chapter ends on a blank right page: 
The Pad command will insert a blank 
page before page 7 but Merge Where 
Possible won’t merge the two blank 
pages

Chapter ends on right: The 
Pad command can insert a 
blank page before page 7 to 
maintain facing pages

Chapter ends on left: The 
Merge Where Possible 
command can merge pages 4 
and 5 into a single facing-page 
spread

98

7

4

32

1

98

7

4 5

32

1

76

5

4

32

1
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When Pad is used, as is shown in the middle and right scenarios above, a com-
pletely blank page will be added; you cannot choose a master page to be applied 
to it. If you want your blank pages to display a chapter name or page number 
then you must add your own blank pages.

The right scenario above shows how a chapter document ending with a blank 
right page can result in two successive blank pages. The blank page at the end of 
the first chapter document would not be completely blank–it would typically be 
based on a master that displays the page number and perhaps the chapter name, 
but from a book design perspective it’s effectively blank. Because you would have 
Pad enabled to avoid single-page spreads, Affinity will add a blank page before 
page 7. Merge Where Possible merges only stray pages as shown in the left sce-
nario and Pad will have created two spreads, albeit ones with two blank pages.

If you want to avoid two successive blank pages you must first delete the blank 
right pages from the end of your chapter documents. If you later need another 
page in that chapter, you must manually add a new page—do not use AutoFlow 
because it always inserts an even number of pages, and in this case that would 
leave you with a blank left page.

If you don’t want to deal with the complexity of adding and removing pages in 
your chapter documents then you may wish to refrain from using an Affinity 
Book.
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Creating an Affinity Book
Create at least one of the Chapter documents before you create an Affinity Book. 
Although you can update the design and formatting of chapters later, it’s a best 
practice to finalize the document size, margins, colour profile, master pages, 
notes formatting, and other basics before creating additional chapter documents. 
Some information can be synced across chapters, but other options such as 
endnote placement would have to be changed manually in each chapter.

To create an Affinity Book:

1. Choose File > New Book to show the Books panel if it is not already open. 
You can also open the Books panel with Window > Layout > Books and then 
click its Create new book button or choose New Book from the panel menu 

.

2. Choose Stray Pages > Pad from the panel menu  to avoid single-page 
spreads.

3. Choose Save Book from the panel menu  and give your project a name.

Tip: You can only save 
an Affinity Book from 
the panel menu ; it 
doesn’t allow for the 
use of keyboard 
shortcuts like the File 
menu
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To add chapters to an Affinity Book:

1. Click the Add Chapter icon  or choose Add Chapter… from the panel 
menu .

2. Select one or more Affinity document files to add.

3. If your chapters aren’t in the right order, you can drag them to the correct 
order in the panel.

To remove chapters from a Book:

1. Select the chapter name(s) in the Books panel; press Shift and click to select a 
range of chapters, or press ⌘ (macOS) or Ctrl (Windows) and click to select 
multiple discontinuous chapters.

2. Click the Remove Chapter  icon or choose Remove Chapter from the panel 
menu .

3. Choose Replace Chapter from the panel menu  to remove one selected 
chapter document and replace it with another of your choosing in a single 
step.

To open an Affinity Book:

You can open more than one Affinity Book simultaneously. Only one Book is 
active at a time, similar to how only one document is active.

1. You can open an Affinity Book with the same File > Open… command used 
to open a document. The Books panel will be shown if it is not already open. 
When no Book is open, the Books panel will display an Open book… button 
and you can also open a Book by choosing Open Book… from the panel 
menu .

2. To change which Book is active, click the current Book’s name at the top of 
the Books panel to choose from the list of open Books.

Tip: Recently-used 
books can be opened 
by choosing them 
from the File > Open 
Recent menu or the 
Recent pane of the 
New Document
window

Tip: It is a best practice 
to add separate 
chapters for front 
matter and end matter

Tip: All chapter 
documents must be 
the same resolution 
(DPI) to ensure they 
are all scaled the same 
when printed or 
exported
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To save an Affinity Book:

1. Choose Save Open Chapters from the Books panel menu  to save any 
modified (un-saved) Chapters you have open, or choose File > Save for each 
of them.

2. Choose Save Book or Save Book As… from the Books panel menu . These 
commands are not in the File menu and a keyboard shortcut cannot be 
assigned; however, if you quit Affinity with a modified Book open then 
Affinity will prompt you to save it.

To close an Affinity Book:

1. To close the active Book, choose Close from the Books panel menu . You 
can close only one Book at a time. If you quit Affinity with an open Book, it 
will be closed automatically and you will be prompted to save it if it was 
modified.

To duplicate an Affinity Book:

1. Using macOS Finder or Windows File Explorer, duplicate the folder contain-
ing the Book and its chapter documents; for example, name this folder 
Project-Copy.

2. Temporarily rename the original folder; for example, rename it to Project-
Temp.

3. Open the duplicate Book’s .afbook file in Affinity.

4. Affinity won’t be able to locate its chapter documents because a Book uses 
absolute paths to its chapters and you renamed the original folder. Click Yes
and in the file window that appears select the chapter document in the 
Project-Copy folder. Ensure you don’t select the same chapter in the original 
folder.

5. Affinity will relink all the remaining chapter documents if they’re in the same 
folder. Save the Book now by choosing Save Book from the Books panel 
menu .

6. Using macOS Finder or Windows File Explorer, rename the original folder 
back to its original name.

Tip: Saving an Affinity 
Book will not save its 
Chapter documents
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Syncing styles, formats, and masters in an Affinity Book
Each chapter document has its own master pages, text styles, table formats, and 
swatches but Affinity can sync this information across an Affinity Book. By 
default, the first chapter you add is designated the Book’s Style Source Chapter, 
the master copy for this information.

You can synchronize formatting to other chapters even while those chapters are 
closed. Affinity will open the chapter documents in the background, update 
them, save changes, and close them. Note that chapters that are currently open 
will be updated but changes will not be saved; you should save those chapters 
when you’re done with your other edits.

Syncing text styles and table formats

If a text style or format one with the same name doesn’t exist in the target chap-
ter, it will be copied from the Style Source Chapter. You can add a new text style 
or table format in the Style Source Chapter and sync it to all other chapters.

If a text style or format with the same name exists in the target chapter, it will be 
updated to have the same attributes. You can update a text style or table format in 
the Style Source Chapter and sync the change to all other chapters.

If you rename a text style or table format in the Style Source Chapter, syncing 
will create a new one in the target chapters because the names won’t match. Text 
formatted with that text style won’t be formatted with the renamed style. For 
example, consider the case of renaming the Body style in the Style Source Chap-
ter to Body Text and then syncing to another chapter. The text formatted as Body
in the target chapter will still be formatted as Body and a new Body Text style will 
be created. You would need to use Find and Replace to search for all instances of 
Body to replace format them as Body Text.

Syncing swatches

Syncing swatches is identical to syncing text styles and table formats with the 
addition of synching document palette categories.

Syncing master pages

Syncing master pages is more complex. If a master page with the same name 
doesn’t exist in the target chapter, it will be copied from the Style Source Chapter.

If a master page with the same name exists in the target chapter but anything 
about that master is different, it will not be updated and instead a new master 
page will be created and copied from the Style Source Chapter. Making any 
change to a master page in the Style Source Chapter can result in duplicate 
master pages in the target chapters.

If you rename a master page in the Style Source Chapter, syncing will create a 
new master page in the target chapters because the names don’t match.

If you must adjust your master pages—for example, adjusting page size, margins, 

Tip: Note that custom 
variables are not 
synced across chap-
ters and are available 
only in the chapter 
document in which 
they were created

Tip: It is important to 
finalize your text style 
names before creating 
additional chapters or 
your chapters will end 
up with multiple 
copies of your styles 
with different names

Tip: It is important to 
finalize your master 
pages before creating 
additional chapters or 
your chapters will 
have multiple copies 
of your master pages
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or bleed, or adding an object—it is best to make the changes manually to each 
chapter and disable the synchronization of master pages in Synchronize Settings.

To synchronize chapter documents:

1. If necessary, select a chapter in the Books panel and choose Set Style Source 
Chapter from the panel menu . Or click in the blank well area to the left of 
the chapter name in the Books panel—a tooltip will be displayed when the 
pointer is over the well. This action cannot be undone.

2. Select the chapters you want synchronized. To synchronize only specific 
chapters, select just those chapters in the panel list. To synchronize all chap-
ters, deselect any selected chapters by clicking in a blank area of the chapter 
list or by holding ⌘ (macOS) or Ctrl (Windows) while clicking the selected 
chapter.

3. If desired, you can customise which information is synced by choosing Syn-
chronize Settings from the panel menu . The settings you select will be 
saved with the Book.

4. Choose Synchronize from the panel menu , Synchronize Now from this 
window, or click the Synchronize Chapters  icon to sync the information 
from the Style Source Chapter to the selected chapters.

Tip: Be careful when 
clicking near the Style 
Source Chapter well
because there is no 
visual cue that clicking 
in the well will do 
anything, nor is there a 
confirmation alert to 
avoid accidental 
changes

Tip: As with other 
Affinity Book actions, 
synchronizing chap-
ters cannot be undone
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Number pages, notes, and lists in an Affinity Book
Affinity can number pages, notes, and global list items automatically across 
chapters even while chapters are closed. Affinity will open the chapter documents 
in the background, update them, save changes, and close them. Note that docu-
ments that are currently open will be updated but changes to them will not be 
saved.

Page numbers are updated automatically and there is no need to manually 
update them unless you turn off automatic numbering. Note and list item num-
bers are updated only when you choose to update them. All numbers can be 
updated automatically when you print or export a Book.

Notes will be numbered across chapters only if Restart Every > Book is chosen 
from the Notes panel for all of the chapter documents.

List items will be numbered across chapters only if the lists at the start and end 
of each chapter are the same level and if the following options are chosen from 
the Bullet and Numbering section of the Paragraph panel:

• Restart numbering > Manual Only

• Restart Numbering Now set to Off

• Global set to On.

To update page numbers automatically across chapters:

If you turn off automatic page numbering for a Book, Affinity will change the 
Start page number at setting in the Section Manager for the first section of each 
chapter document to a fixed number.

1. Choose Update Numbers > Update Page Numbers Automatically from the 
Books panel menu  to enable or disable automatic page numbering. This is 
on by default.

To modify the page numbering for a chapter:

Many books have front matter with pages numbered in Roman numerals (i, ii, iii, 
iv…) followed by body pages numbered in Arabic numerals (1, 2, 3, 4…) To 
create this common numbering approach in an Affinity Book:

1. Ensure Update Numbers > Update Page Numbers Automatically is selected 
from the Books panel menu .

2. Open the front matter chapter and choose Document > Section Manager or 
click the Section Manager  icon in the Pages panel.

3. Set the Number style to i, ii, iii, iv…

4. If there are no other sections in this chapter, open the next chapter. Other-
wise, select the next section in this chapter.

Tip: Do not try to use 
the Section Manager
to adjust the page 
numbering for a 
Chapter; the options 
are not disabled but 
will have no effect

Tip: Do not try to use 
the Section Manager
to adjust the page 
numbering for a 
Chapter; the options 
are not disabled but 
will have no effect
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5. Set the Number style to 1, 2, 3, 4… in the Section Manager. The remaining 
chapters will continue this numbering style automatically unless you wish to 
change it again.

6. To restart page numbering at the start of a chapter, select that chapter in the 
Books panel and choose Page Number Options from the panel menu .

To number notes across chapters:

1. Choose Numbering > Restart Every > Book from the Notes panel.

2. Create or edit an endnote and then choose Update Document Settings from 
Selected Endnotes from the panel menu . If you’ve already created multiple 
chapter documents you will need to repeat these steps for each chapter.

To update page, note, and list numbers before printing or exporting:

1. Choose Update Numbers > Update Numbers Before Output from the panel 
menu . This is on by default. Note that this affects only the Export… and 
Print… commands in the panel menu . Choosing the same commands 
from the File menu will not update numbers because those export only the 
current chapter and not the whole Book.

To manually update page, note, and list numbers:

1. Select the chapter(s) to update in the Books panel.

2. To update just one type of number, select Update Numbers > Page Numbers, 
List Numbers, or Note Numbers from the panel menu .

3. To update all numbers at the same time, choose Update Numbers > All 
Numbers or click the Update Numbers button at the bottom of the panel.

Tip: Although this 
command is named 
Update Numbers it 
will also update the 
text of endnotes so 
there is no need to use 
the similarly-named 
command for 
endnotes
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Positioning endnotes at the end of an Affinity Book
Many books include endnotes at the end of chapters which Affinity does by 
default. If you want to consolidate all of your endnotes at the end of a Book, 
Affinity can do this automatically but you should learn how it works to avoid 
confusion.

To position endnotes at the end of an Affinity Book:

1. Choose Positioning > Note position > End of Book from the Notes panel.

2. Create or edit an endnote and then choose Update Document Settings from 
Selected Endnotes from the panel menu . If you’ve already created multiple 
chapter documents, you will need to repeat these steps for each chapter.

3. When the End of Book option is chosen, Affinity will create a non-printing 
section named #Booknotes at the end of each chapter to make it convenient to 
edit its endnotes without having to keep switching between the current 
chapter and the endnotes at the end of the Book.

4. Create an End Matter document for your endnotes and index to avoid adding 
a printing section for them after the non-printing #Booknotes section in your 
last actual chapter.

5. Add the End Matter document to the Book as a chapter.

6. Place the cursor in a text frame in the End Matter chapter and choose End-
notes > Insert Endnotes from the Books panel menu . All of the Book’s 
endnotes will be added to that text frame. These endnotes are not editable so 
they are similar to an inserted index or table of contents.

Definition: End Matter
is also known as Back 
Matter and includes 
the appendices, 
endnotes, glossary, 
index, and bibliogra-
phy

Tip: The endnotes title 
of the first chapter 
with endnotes will be 
used as the title of an 
Affinity Book’s consoli-
dated endnotes

Tip: If you are left with 
blank pages where the 
endnotes were located 
before the new non-
printing section, you 
will have to delete 
those pages manually

Tip: The #Booknotes
section will have 
Include on Export
deselected which 
prevents it from being 
printed or exported
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Adding references to an Affinity Book
Affinity can create the table of contents and index for an entire Book and cross-
reference text across its chapters but the features function slightly differently in a 
Book.

To add a table of contents to an Affinity Book:

Refer to Creating a table of contents on page 310 for general information on 
tables of contents.

1. With the Book open, place the cursor in a text frame in your front matter 
chapter and click the Insert  icon in the Table of Contents panel.

2. No entries will be shown for the inserted table of contents unless your front 
matter chapter has applicable headings. Click Scope > Book in the panel to 
include all chapters in this table of contents.

3. Click the Update  icon in the Table of Contents panel to reflect the table’s 
expanded scope.

4. To update tables of contents automatically before printing or exporting, 
choose Update Numbers > Update Tables of Contents Before Output.

To add an index to an Affinity Book:

Refer to Creating an index on page 326 for general information on indices.

1. With the Book open, place the cursor in a text frame in your End Matter 
chapter and click the Insert Index  icon in the Index panel. Unlike the table 
of contents feature, the scope for a Book’s index is always the entire Book so 
there is nothing else you need to do. Affinity will automatically sync index 
topics across chapters, even if you rename them.

2. To update the index automatically before printing or exporting, choose 
Update Numbers > Update Index Before Output.

To add cross-references to an Affinity Book:

Refer to Creating cross-references on page 302 for general information on cross-
references. The Book and the chapters to target (add a cross-reference to) must 
be open when you add or remove a cross-reference. You can edit a cross-refer-
ence without the Book and target chapter being open as long as you don’t need to 
change the target paragraph, anchor, or index mark.

1. Open the Book and the chapter(s) you want to target.

2. Follow the steps for creating a cross-reference. A Target Chapter option will 
appear in the Insert Cross-Reference window to select a chapter for the target 
paragraph, anchor, or index mark. The remainder of the options are the same 
as for standard documents.

3. To update all cross-references in a Book, choose Cross-References > Update 
Cross-References from the Books panel menu .
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4. To update cross-references automatically before printing or exporting, choose 
Cross-References > Update Cross-References Before Output.

Printing and exporting an Affinity Book
The Print and Export commands in the File menu will print and export the 
current document, not an entire Affinity Book—you must use the equivalent 
commands in the Books panel menu . Likewise, the Preflight panel will check 
for errors in the current document, not an entire Book, and you must use the 
equivalent command in the panel menu.

To preflight an Affinity Book:

1. Select one or more open chapter documents in the Books panel to preflight 
the selected chapter(s), or deselect all chapter documents to preflight all open 
chapters.

2. Choose Preflight from the panel menu . The Preflight panel will not be 
displayed and no window will open; instead, the Preflight status icons for the 
chapter(s) will update to reflect the results of the Preflight check:

Status Description

 Preflight not completed because Check is set to Never

 All Preflight tests passed

 One or more Preflight warnings

 One or more Preflight errors and possibly one or more warnings

3. Click the Preflight status icon to open a chapter and display the Preflight 
panel to see the list of warnings or errors.

To print or export an Affinity Book:

1. To export specific chapters, select the chapters in the Books panel.

2. Choose Print… or Export… from the panel menu . The Print and Export 
windows will include a Range option (for Print) and an Area option (for 
Export) to let you choose whether to export the entire Book or the chapters 
selected in the panel.

3. Set the print or export options. Refer to Publishing on page 393 for more 
information.

4. Click Print or Export.

Tip: You can only 
preflight chapters that 
are currently open

Tip: Refer to Preflight-
ing documents on 
page 394 for more 
information on 
Preflight

Tip: All chapter 
documents must be 
the same resolution 
(DPI) to ensure they 
are all scaled the same 
when printed or 
exported
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The features described in this chapter are critical to creating 
books, newspapers, magazines, academic papers, reports, and 
other long documents.

Cross-references are used to refer readers to another place in the 
same publication and can be updated automatically as the docu-
ment changes. A table of contents is used to list the topics for 
the publication or one of its chapters in page number order. The 
index is used to list topics and keywords in alphabetical order, 
typically at the end of a publication.

Notes, including footnotes, sidenotes, and endnotes, are used to 
cite other works or to provide comments on the main text.

Anchors and hyperlinks are used to link to other places in the 
publication or to another document or website URL.

Fields are used to insert information about the document, such 
as the page number or section name, and can be updated auto-
matically as the document changes.

Together these features simplify the effort required to create a 
long and complex publication. Mastering these features will save 
you time as you prepare a document for publication and help 
ensure a more consistent publication with fewer errors.

In this chapter
Creating cross-references ........................................................................302
Creating a table of contents ...................................................................310
Creating an index .......................................................................................326
Creating notes .............................................................................................339
Using fields ...................................................................................................354
Using anchors ..............................................................................................362
Using hyperlinks .........................................................................................366

References 8
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Creating cross-references
A cross-reference refers the reader to another place in the same publication, 
whether through a page or chapter reference or a hyperlink in a PDF or eBook.

A cross-reference in Affinity is a field that refers to the position of an anchor 
elsewhere in your publication. The cross-reference field will update automatically 
when its target changes pages and you can choose to update cross-references 
when the paragraph text changes.

Affinity can generate many complex types of cross-references by combining 
subfields including the paragraph text following the anchor position. You can 
save combinations of subfields and text as presets to make it easy to add cross-
references.

You can format cross-references automatically with a character style but the style 
can be applied only to the entire cross-reference. If you want to format only part 
of a cross-reference or format two parts of it separately, you would need to com-
bine it with plain text or a second cross-reference to the same target.

Cross-reference targets

You can choose to target a cross-reference to an anchor, paragraph, or index 
mark, but targeting a paragraph or index mark will generate a new anchor auto-
matically. Anchors generated automatically by cross-references will not be 
exported as PDF bookmarks unless you modify them.

The choice of which to target depends on your work style:

• If you cross-reference a heading and target the paragraph, Affinity will insert 
an anchor at its start. If you later insert a table of contents, Affinity will insert 
a second anchor because the table of contents feature also relies on anchors.

• If you insert the table of contents first and update it as you edit your docu-
ment, Affinity can reuse the table of content’s anchor when adding a cross-
reference.

• If you cross-reference an index mark, Affinity will create an anchor using the 
index mark’s name rather than the paragraph text.

refer to “Aperture” on page 192

refer to “Depth of field” above

see Understanding Exposure on page 87 of chapter 2

See Depth of Field

See Depth of field for more information

See Depth of field on page 73 for more information

See Depth of field on page 73 for more information

The boxed text in these 
examples can be inserted 
automatically as a cross-
reference
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Using the Cross-References panel
To display the Cross-References panel:

1. Choose Window > References > Cross-References to display the 
Cross-References panel.

2. Choose Edit Strings… from the panel menu  to change the Above/Below
text used for certain cross-references.

3. Drag the column dividers to see more of a particular column.

Go to target

Update AllUpdate

EditInsert

Filter list by page or spread

Go to cross-reference

Selected cross-reference

Panel menu

Text inserted on the page

Column dividers—drag to resize

Status icon

Delete

Page number of
a cross-reference
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Adding a cross-reference
To insert a cross-reference:

1. Using the Frame Text  tool, position the text cursor where you want the 
cross-reference to be inserted.

2. Click the Insert Cross-Reference  icon in the Cross-References panel or 
choose Text > Cross-References > Insert Cross-Reference, and select the 
target.

• Link to: Select Paragraph (default), Anchor, or Index Mark. You must have 
previously defined anchors or index marks to use the latter options.

• Filter style (Optional): Select a text style name to filter the list by style.

• Search (Optional): Enter a search phrase to filter the list by text. Affinity 
will search anywhere in the paragraph, anchor name, or index mark name. 
To search only from the start, click the dropdown caret on the right side of 
the field and choose Search from Start.

• List: Select one of the listed paragraphs, anchors, or index marks.

3. Format the cross-reference:

• Preset: Choose one of the default cross-reference presets. You can create a 
custom format with the Text option below and create your own presets.

Tip: Presets are 
language specific
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• Language: If the cross-reference’s language doesn’t match the language of 
the surrounding text, click the menu  icon beside the Preset list, choose 
Language from the popup menu, and then select the language to use.

• Text: Create a custom format for the cross-reference. Click the caret 
icon on the left side of the field to select from a list of relevant special 
characters and cross-reference components (building blocks). You can also 
enter plain text into the field.

Component Text Result

Page Number on page PageNumber on page 192

Section Name in chapter SectionName in chapter 3

Chapter Name in the ChapterName chapter in the Exposure chapter

Object Description see figure ObjectDescription see figure 46

Anchor Name see AnchorName see Depth of field

Above/Below continued AboveBelow continued below

Numbered Paragraph see NumberedParagraph see 3. Aperture

Paragraph Body see ParagraphBody see Aperture

List Number see ListNumber see 3

Note Number in footnote NoteNumber in footnote 17

• Combine components together to create complex cross-references:

Text  Result

refer to “ParagraphName” on page PageNumber refer to “Aperture” on page 192

refer to “ParagraphName” AboveBelow refer to “Depth of field” above

see AnchorName on page PageNumber of chapter SectionNumber see Understanding exposure on page
   87 of chapter 2

on page SectionName.PageNumber on page 12.10

• For Above/Below, you can change the text that will be inserted by choos-
ing Edit Strings… from the panel menu .

Tip: Note Number
inserts the number of 
a footnote, endnote, 
or sidenote; use 
Paragraph Body to 
insert its text

Tip: Object Descrip-
tion inserts the layer’s 
name which you can 
use as a way to insert 
text that doesn’t 
appear in the 
document

Tip: You could type 
text such as “refer to” 
and “on page” directly 
in the text frame but 
including this text in 
the cross-reference 
format helps ensure 
consistency through-
out a long publication

Tip: Do not use a 
component with a 
paragraph that doesn’t 
make sense, such as 
List Number for a 
paragraph that isn’t 
numbered because 
the cross-reference 
will be shown as out-
of-date until you 
remove the 
component
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4. Optional: To create a preset for your custom cross-reference format, click the 
menu  icon beside the Preset list and choose Create Preset… from the 
popup menu. Enter a preset name and then click OK. If you later modify the 
preset, choose Save Preset from the menu  icon to update it. Choose 
Rename Preset… or Delete Preset… to rename or delete the selected preset.

5. Optional: To apply a character style to the cross-reference, choose one from 
Style override. Choose what the style is applied to with For.

• Everything: Select to apply the character style to the entire cross-reference

• All Fields: Select to apply the style to just the fields and not the plain text 
you enter. For example, for a cross-reference of “ParagraphBody on page 
PageNumber”, the style would be applied to ParagraphBody and 
PageNumber but not to the words in between.

• Text Fields: Select to apply the style just to text fields such as 
ParagraphBody.

• Number Fields: Select to apply the style to just the number fields such as 
PageNumber.

6. Optional: Deselect Generate hyperlinks if you don’t want cross-references to 
be clickable in an exported PDF file. It is recommended to leave this on 
because you can control whether hyperlinks are included when exporting. 
Hyperlinks added for cross-references will not appear in the Hyperlinks 
panel because they are not editable. Ensure Include Hyperlinks is selected 
when exporting to PDF if you want them included.

7. Optional: If you cross-reference short paragraphs such as headings, you’ll 
likely want to include the full heading name in the cross-reference but if you 
cross-reference a full paragraph or a long section name then you may wish to 
truncate the inserted text. Select Limit subfields to choose from two options 
to shorten the text:

• Enter the Max word count to limit the text by number of words. Select 
Add ellipsis to add an ellipsis to truncated text. For example, setting Max 
word count to 3 and adding an ellipsis to “Introduction to digital photog-
raphy” would result in “Introduction to digital…” being inserted.

• Enter one or more characters into End characters to choose which charac-
ters mark the end of the text to include—if an end character is not 
encountered the full paragraph will be inserted. Select Include end char-
acter if you want it included in the inserted cross-reference. For example, 
setting End characters to a colon would insert “Chapter 6” for a paragraph 
with the text “Chapter 6: Exposure”.

8. Click OK to insert the cross-reference.

9. Optional: If you created a cross-reference to a Paragraph or Index Mark you 
can rename the generated anchor with the Anchors panel. Refer to Using the 
Anchors panel on page 362.

Generate hyperlinks
does not apply 
formatting automati-
cally; it’s up to you to 
apply an appropriate 
character style with 
Style override
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To edit a cross-reference:

1. To edit one cross-reference, position the text cursor before or after its field in 
the document text and choose Text > Cross-References > Edit Cross-Refer-
ence… You can also double-click its name in the Cross-References panel or 
select the cross-reference in the panel and click the Edit Cross-References
icon.

2. To edit the format of multiple cross-references at once, press Shift and click to 
select a range of cross-references, or press ⌘ (macOS) or Ctrl (Windows) and 
click to select multiple discontinuous cross-references, before clicking the 
Edit Cross-References  icon. You can’t set the target for multiple cross-ref-
erences and the formatting options of the first one will be shown in the Edit 
Cross-Reference Format window

3. All of the options for editing a cross-reference are the same as for creating a 
new one. When editing a single cross-reference, you can change its target to a 
different paragraph, anchor, or index mark.

To find a cross-reference in the document:

1. Select a cross-reference in the Cross-References panel and click the Go to 
Cross-Reference  icon.

To view the target of a cross-reference:

1. Select a cross-reference in the Cross-References panel and click the Go to 
Target  icon.

To delete cross-references:

1. Select one or more cross-references in the Cross-References panel and click 
the Remove Cross-References  icon. The cross-reference field in the docu-
ment text will be expanded to become regular text which you can then edit. 
You can also simply delete the cross-reference field directly in the document’s 
text.
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To convert a cross-reference to regular text:

1. Right-click a cross-reference field and choose Expand Field from the context 
menu. The cross-reference field will be expanded to become regular text 
which you can then edit and the cross-reference will be removed from the 
panel. Deleting a cross-reference with the panel will also convert a cross-ref-
erence to regular text.

2. If the text in a cross-reference was hyphenated by automatic hyphenation, the 
hyphen will be included in the expanded field. Fields are expanded automati-
cally when copying text from Affinity to a word processor such as Microsoft® 
Word so it is a good practice to scan expanded fields for misplaced hyphens. 
Spell checking text copied to Word will usually find these hyphens.

To share a cross-reference preset with another computer or user:

Presets are not saved in your user settings but there is a way to share them with 
another computer or Affinity user.

1. Click the Insert Cross-Reference  icon in the Cross-References panel.

2. Choose the preset you want to copy.

3. Click in the Text field and press ⌘ + A (macOS) or Ctrl + A (Windows) to 
copy the cross-reference format to the pasteboard (clipboard). Click Cancel. 
To close the Insert Cross-Reference window.

4. Create a new document and draw a text frame.

5. Paste the pasteboard (clipboard) into the text frame. It will appear empty 
because you have pasted invisible control codes that don’t have associated 
special character symbols.

6. Save this document and transfer it to the other computer.

7. Open the document on the other computer.

8. Click in the text frame and press ⌘ + A (macOS) or Ctrl + A (Windows) to 
copy the cross-reference control codes to the pasteboard (clipboard).

9. Click the Insert Cross-Reference  icon in the Cross-References panel.

10. Paste the pasteboard (clipboard) into the Text field.

11. Click the menu  icon beside the Preset list and choose Create Preset…
from the popup menu. Enter a preset name and then click OK. 
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Updating cross-references
Cross-references aren’t updated automatically when you edit your document and 
the target of a cross-reference changes. It’s up to you to update the cross-refer-
ences before printing or exporting.

The Cross-References panel shows a status icon for each cross-reference:

Status Description

 OK – there are no issues with the cross-reference

 The cross-reference target is missing because the paragraph, anchor, or index
 mark was deleted; copying and pasting text that includes a target anchor will
 result in a missing target

 The cross-reference is out-of-date because the target has been edited or the
 anchor or index mark is no longer on the same page; click the Update  or

Update All  icon

To update cross-references:

1. Click the Update All Cross-References  icon in the Cross-References panel
to update all in the document. This is the right of the two Update icons and is 
always available, regardless of what part of the document you are viewing or 
which tool you have selected.

2. To update one or more specific cross-references, select the cross-references in 
the Cross-References panel. Click the Update Cross-Reference  icon to 
update the selected items.

Affinity can also warn you of an outdated cross-reference through the Preflight 
panel which offers a convenient Fix button to update it, but each outdated cross-
reference will have its own Fix button so it’s usually faster to update cross-refer-
ences with the Cross-References panel.
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Creating a table of contents
Affinity can generate one or more table of contents for your publication based on 
the selected paragraph styles. While most publications will have just one table of 
contents near the front of the document, some may have a second table of con-
tents to list figures, illustrations, or photo credits. Some textbooks also have a 
table of contents at the start of each chapter to list its topics.

A table of contents is a block of special text that you can modify but when you 
update the table of contents any edits you made to it will be lost. You should 
avoid making any edits until the last stage before publishing. The table of con-
tents can be updated at any time and can be generated from a single document or 
from all of the chapter documents in an Affinity Book.

Sort order

A table of contents is sorted in the order the headings are used in your publica-
tion, from the first to last page and from the bottom to top of the layer stack on 
each page.

The layer stack order is important only if you use more than one text frame for 
your headings. Most long documents have just one main text frame per page for 
all of the page’s text, with separate frames only for the header and footer. If your 
document uses a separate text frame for each heading then your table of contents 
entries could be in the wrong order unless you pay attention to the layer stack 
order. Ensure the heading at the top of the page is on the bottom of the layer 
stack with additional headings on top.

Parts of a table of contents
A table of contents is a list of entries that are made up of a heading and a page 
number. You can select how many levels of headings to include and you can 
modify the formatting, including the separator between the heading and page 
number and whether the page number is shown before or after the heading. You 
can even hide the page number entirely.

Sample table of contents

Tip: If you number 
chapter pages using a 
combination of 
section name and 
page number (for 
example, 1.1, 1.2, 
1.3…), the section 
prefixes will not be 
included in the table 
of contents because 
they are not part of 
the page number

Tip: Master page text 
frames will be on the 
bottom of the layer 
stack unless you have 
edited the master 
layer detached

Exposure .................................................................5
Aperture ......................................................... 12
Shutter speed ............................................... 15
ISO ..................................................................... 17
Light meter .................................................... 21

Focusing modes .................................................27
Manual focus ................................................. 28
Auto focus ...................................................... 39
Continuous focus ........................................ 42

White balance .....................................................44
Types of lenses ...................................................58

a TOC 1: Heading 1 Number¶ TOC 1: Heading 1

a TOC 1: Heading 2 Number¶ TOC 1: Heading 2

Tip: You cannot sort a 
table of contents 
alphabetically
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Using the Table of Contents panel
To display the Table of Contents panel:

1. Choose Window > References > Table of Contents to display the Table of 
Contents panel.

Set indent level and page number 
visibility

Update All DeleteUpdate

Limit scope to current section (chapter)

Include in TOC

Omit from TOC

Panel menu

Rename TOC

Ignore text in unlinked text frames

Include front matter before the TOC

Include images pinned in text

Separator between headings and page 
numbers

Display page numbers to the left of 
headings

TOC Style menu

Table of contents name

Insert

Limit scope automatically

Type (for EPUB)

Generate PDF bookmarks

Share styles among 
multiple TOCs

Replace line breaks with 
spaces

Limit scope automatically



312 References

Generating a table of contents
You must use paragraph styles for the text to include in a table of contents. You 
can use any styles that you want but for the main table of contents there are some 
advantages to using the standard Heading 1, 2, 3… naming convention, or 
Affinity’s equivalent for the user interface language in use.

It’s difficult to see the start and end of a table of contents because Affinity doesn’t 
display it with any shading as in other applications. Until you’re experienced with 
working near the table of contents text block, it is recommended that you insert 
the table of contents into a separate text frame without any other text to avoid 
losing text when the table of contents is updated.

The table of contents inserted by Affinity does not include the title Table of 
Contents and you might consider placing even the title in a separate frame so that 
updating the table of contents can replace all the text in the frame(s).

It doesn’t matter whether you create text frames for the table of contents on a 
master page or whether you create them directly on a document page.

To insert a table of contents:

1. Using the Frame Text  tool, create a text frame for the table of contents and 
position the text cursor in it.

2. Click the Insert Table of Contents  icon in the Table of Contents panel or 
choose Text > Table of Contents > Insert Table of Contents. Affinity will 
insert the table into the frame.

3. Review the list of paragraph styles in the panel. Select any additional styles 
you want to include in the table and deselect any selected ones that you want 
to exclude.

4. If the table of contents’ text frame has an overflowing Text Flow Out
control near the frame’s bottom-right corner, you will need to create addi-
tional pages.

• If none of the pages following the table of contents have text frames inher-
ited from a master page, press Shift and click the Text Flow Out control. 
The AutoFlow feature will create as many pages of text frames as required 
to contain the table of contents.

• If any of the pages following the table of contents have text frames inher-
ited from a master page, you must manually add page(s) for the rest of the 
table of contents and create and link the text frames. Using AutoFlow 
would result in text frames being layered over the master page frames on 
the following pages.

5. Set Type to General unless you will export the document to EPUB. Refer to 
Using tables of contents in EPUB on page 387.

6. Refer to Formatting a table of contents on page 314 for information on the 
formatting options and instructions for editing the TOC text styles.

Tip: For information 
on generating a table 
of contents for an 
Affinity Book made up 
of separate Chapter 
documents, refer to 
Adding references to 
an Affinity Book on 
page 298

Tip: When a TOC is first 
created, an anchor is 
added for each style 
that matches the 
standard Heading 1, 2, 
3 naming convention, 
so if you don’t want 
anchors generated for 
one of them, rename it 
temporarily, insert the 
table of contents, and 
then rename it back

Tip: You cannot 
choose the text styles 
to include in the table 
of contents before 
generating it



Expert Guide to Affinity by Canva 3.0 313

To delete a table of contents:

1. To delete a table of contents, select the table name from TOC popup menu 
and click the Delete  icon.

To update a table of contents:

The table of contents isn’t updated automatically when you add, edit, and delete 
headings. It’s up to you to update the table of contents before printing or 
exporting.

1. Click the Update All Tables of Contents  icon in the Table of Contents 
panel to update all the tables in the document. This is the right of the two 
Update icons and is always available, regardless of what part of the document 
you are viewing or which tool you have selected.

2. To update a specific table of contents, position the text cursor in the table of 
contents frame or choose the table name from the TOC popup menu in the 
Table of Contents panel. Click the Update Table of Contents  icon to 
update the selected table. Affinity can also warn you that a table of contents is 
outdated through the Preflight panel which also offers a convenient Fix
button to update it.

To set the scope for a table of contents:

If your publication has only one table of contents, Affinity will automatically add 
all headings that are after the table of contents. You can also choose to include 
headings in the publication before the table of contents.

If you wish to limit the table’s scope or are working with multiple tables of con-
tents, you can choose from these options.

1. To include front matter headings used on pages before the table of contents, 
select Include entries before TOC in the Table of Contents panel.

2. To limit the scope until the next table of contents is found, select Stop at next 
TOC in the Table of Contents panel.

Or to limit the scope to the current section, change Scope from Document to 
Section in the Table of Contents panel.

3. To omit headings used in unlinked text frames, change Look In from All Text 
Frames to Text Flows.

Tip: For tips on 
formatting and setting 
the scope of multiple 
tables of contents, 
refer to Pinning 
(anchoring) objects on 
page 197
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Formatting a table of contents
Affinity provides several formatting options in the Table of Contents panel to 
modify the table text that will be inserted.

Because a document can have more than one table of contents, the formatting 
options are saved as a TOC style. A TOC style is not a text style but a group of 
text styles used to format a table of contents. You can use the same TOC style for 
multiple tables of contents or a different style for each table, but you’ll need to 
use separate styles if you want modify formatting or the included heading levels.

To set the table of contents options:

1. To choose a different TOC style, select from the TOC Style popup menu in 
the Table of Contents panel.

2.  TOC Style formatting options: Use these options to customise the text 
inserted into the table of contents.

Item Purpose

Numbers before headings Position page numbers to the left of headings

Remove line breaks Replace manual line breaks in headings with spaces

Include inline pins Include images pinned in headings

Separator Inserted between the heading and page number;
 click the caret  icon on its left side to easily enter
 relevant special characters

Style Name Select which paragraph styles to include in the
 table of contents; click the menu  icon to the
 right of a selected style to Include Page Number
 (default) or change the Indent Level

Include page number Deselect to not display page numbers for this level
 of the table of contents; this is useful when you want
 to summarize the contents of a major topic

Indent level Set the hierarchy level for TOC anchors so book-
 marks are organized correctly in exported PDF files;
 Affinity will do this automatically if you use the
 standard Heading 1, 2, 3… text styles or Affinity’s
 equivalent for the user interface language in use;
 indent levels are numbered from 1

3. To rename a TOC style, click the menu  icon to the right of the TOC Style
popup menu and choose Rename… from the context menu.

Tip: Add punctuation 
when using Remove 
line breaks by adding 
punctuation before 
the line break and 
setting its Fill to None

Tip: Changes you 
make to a TOC style’s 
text styles or to the 
options in the Table of 
Contents panel are 
made immediately to 
the TOC style–there is 
not a command to 
save changes to the 
TOC style

Tip: Indent level does 
not indent the text; 
edit the associated 
TOC text style to 
change the left indent 
value

Tip: Table of contents 
text styles are based 
on the document’s 
Base text style but you 
cannot change 
Affinity’s default 
formatting for a table 
of contents so refer to 
To import TOC styles 
from another docu-
ment on page 320 for 
more information
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4. To delete a TOC style, click the menu  icon to the right of the TOC Style
popup menu and choose Delete from the context menu.

5. You can also create a new TOC style with the Create New… command but it’s 
unnecessary unless you deleted the automatic style created for an additional 
table of contents.

Using numbered headings in a table of contents:

If you create a table of contents for numbered headings the numbers cannot be 
removed automatically when the table is created; editing the TOC heading style 
will have no effect because the numbers are included as text.

When you insert the table of contents, the numbered headings will be poorly 
formatted because the number and heading are separated by a tab but the table of 
contents text styles have only one tab stop for between the heading text and page 
number. To fix this:

1. Position the text cursor in the table of contents heading you want to correct.

2. Using the Text Styles panel, click the menu  icon to the right of the heading 
text style and choose Edit “TOC #: Heading #”, where TOC # is the name of 
the table and Heading # is the name of the heading style.

3. Click Tab Stops in the left pane.

4. Click the Add New Tab Stop  icon and adjust the value for the new tab stop.

5. Click OK.
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To reformat the table of contents by editing its text styles:

When you insert a table of contents in a document for the first time, Affinity will 
create a number of additional text styles to control the table formatting. You can 
modify the attributes of these styles as required for your publication. These text 
styles are grouped into a table of contents style, referred to as a TOC style.

Each TOC style has its own set of text styles numbered in the order you create 
them so you can format each one separately. Because this can result in many text 
styles, table of contents styles are displayed in the Text Styles panel only when 
the text cursor is placed in a table of contents.

The styles are:

Style Purpose

¶ TOC 1: Entry Base style, not applied directly to the TOC; the TOC
  style for the first TOC you insert is named TOC 1 and
  additional ones are numbered sequentially

¶ TOC 1: Heading 1 For all TOC entries, numbered by level; if you use
  custom heading style names, they will be prefixed with
  the TOC name

a TOC 1: Number Base style, not applied directly to the TOC

a TOC 1: Heading 1 Number For the page number

To add a dot leader:

The default formatting for tables of contents doesn’t include a dot leader but you 
can add one.

1. Ensure Separator in the Table of Contents panel is set to  (tab), the 
default value.

2. Using the Frame Text  tool, position the text cursor in the table of contents.

3. Double-click the TOC 1: Entry style in the Text Styles panel to edit it, where 
TOC 1 is the name of the TOC style.

4. Select Tab Stops from the left pane. There will already be a right-aligned tab 
stop set to 0 from right.

5. Select (.) Glyph or one of the other leader characters from the list. You can 
also click the More  icon to chose a custom character.

Tip: TOC 1: Entry will 
be based on whatever 
style your level 1 
heading is based on; it 
is not advisable to 
change this

Tip: Affinity creates 
the table of contents 
text styles for you; 
while you can redefine 
the character and 
paragraph attributes 
of these styles, do not 
rename them because 
the modified name 
will not be shown
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6. Click OK.

To hang page numbers to the right of table of contents entries:

If your table of contents has long headings you may wish to hang its page num-
bers to the right of the entries.

1. Set Right Indent to the value that the table of contents’ entries should be 
indented from the right edge of the text frame.

2. Set Last Line Outdent to 0.

To create clickable bookmarks for an exported PDF:

1. Select Include as PDF bookmarks in the Table of Contents panel. This 
option is specific to each table of contents so if you have more than one you 
can choose whether to select it for each table.

2. When exporting to PDF, you must also select Include bookmarks in the 
Export window.

Lorem ipsum dolor sit amet, 
consectetur adipiscing elit ....................5
Aliquam nec turpis quis lacus porta 
tincidunt ....................................................12

Lorem ipsum dolor sit amet, 
consectetur adipiscing elit ....................5
Aliquam nec turpis quis lacus 
porta tincidunt ........................................12

With Right Indent = 1p6 (18 pt) and Last Line Outdent
= 0, the page numbers will hang to the right of the 
table of contents’ entries

With Right Indent = 0 and Last Line Outdent = 0, the 
page numbers will be aligned with the table of 
contents’ entries
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To exclude specific headings from a table of contents:

Sometimes you might want to exclude a specific heading from a table of contents 
yet wish to use the same heading style for that paragraph. There is more than one 
way to do this but the best option is:

1. Using the Frame Text  tool, position the text cursor in the heading to 
exclude.

2. Click the menu  icon beside the heading style name in the Text Styles panel
and choose Create Style Based On “Heading <#>” from the popup menu.

3. Name the new style Heading # Copy, where # is the number of the original 
heading.

4. Click OK. Formatting changes you make to the original heading style will be 
made to the duplicate style.

If the table of contents already exists, paragraphs formatted with this new 
style won’t be included in the table of contents. If you haven’t yet created the 
table of contents, you will need to deselect this style in the Table of Contents
panel’s list of styles.

To include headings that do not appear in a publication:

Sometimes you might want to include headings that do not appear in a publica-
tion, such as list of advertisers, or perhaps the actual headings are images but you 
need plain text equivalents to appear in the table of contents.

In this manual, the chapter headings are written as “References 3” but as 
“3. References” in the table of contents. This was achieved by formatting the 
actual chapter headings with a paragraph style not used by the table of contents 
and then following the steps below to add a hidden layer for the heading used by 
the table of contents.

1. Using the Frame Text  tool, create a separate text frame for a heading that 
should be invisible. The frame does not need to be in the exact position 
because it will not be printed or exported to PDF.

2. Enter the heading text and apply the heading style to it.

3. Choose Window > Text > Pinning to display the Pinning panel.

4. If the heading should move with the text on page, select the heading’s text 
frame and click the Float With Text  icon in the Pinning panel to pin the 
heading’s frame into the main text frame.

5. Choose Layer > Hide to make the heading’s frame invisible. The heading will 
still be included in the table of contents but it will not be printed on the page. 
You can also click the Toggle Visibility  icon next to the heading’s text 
frame’s layer in the Layers panel to show and hide the frame but you might 
have to expand the master page layer and the main text frame’s layer to find it.
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To include a chapter number prefix in the table of contents:

If you number chapter pages using a combination of section name and page 
number (for example, 1.1, 1.2, 1.3…), the section prefixes will not be included in 
the table of contents because they are not part of the page number. You must use 
a workaround to include the chapter’s section name prefix.

1. After each heading that will be included in the table of contents, type a tab 
character, insert a SectionName field, and type a period. An entry will look 
like this for a chapter with a section name of “7”:

White balance  7.

2. Select the tab and field and using either the Context Toolbar or Character 
Panel, set their text fill colour to none  to make them invisible. Repeat this 
for each heading.

3. Generate the table of contents but remove the tab from the Separator field in 
the Table of Contents panel because you already inserted a tab manually into 
each heading. The resulting entry will look like this:

White balance ................................................. 7.44

To switch between print and digital table of contents formatting:

If you want to be able to export your document with hyperlink style formatting 
for digital but plain text for print, you can do this with two TOC styles.

1. After generating the table of contents and adjusting the TOC text styles for 
print (or digital), click the menu  icon to the right of the TOC Style popup 
menu and choose Rename… from the context menu. Name it Print (or 
Digital, as appropriate) or another name of your choosing.

2. Click the menu  icon again and choose Create New… from the context 
menu. Name this style Digital (or Print, as appropriate) or another name of 
your choosing.

3. Adjust this TOC style’s text styles for digital (or print).

4. To switch between the two styles, select the Print or Digital style name from 
the TOC Style popup menu and your table of contents will be reformatted 
automatically.
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To import TOC styles from another document:

TOC styles cannot be exported independently but you can import a TOC style 
by adding a page from another document.

1. In the document from which you want to import a TOC style, rename the 
desired TOC style to something unique by clicking the menu  icon to the 
right of the TOC Style popup menu and choosing Rename… from the con-
text menu. For example, My TOC Style

2. Save that document and switch to the document in which you want to import 
the TOC style.

3. Using the Pages panel, note the absolute page number of the last page.

4. Choose Document > Add Pages from File… and select the first document.

• Page Numbers: There is no need to import all of the document’s pages 
since you just want the TOC style so enter the number of a single page to 
import.

• Pages: Enter the absolute page number of the last page you noted above to 
ensure the imported page is placed at the end of the document so it won’t 
disrupt an existing facing-page spread.

Click OK.

5. Affinity will display a window listing the source (incoming) document’s text 
styles and noting any conflicts. Assuming you named the TOC style with a 
unique name, those styles will not have any conflicts.

Tip: The Pages panel 
will only show abso-
lute page numbers 
unless you use a 
section to restart page 
numbering, and then 
it will show the 
absolute page number 
followed by the 
relative number in 
parentheses, for 
example, Pages 60,61 
(54,55)
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• Deselect all text styles except for those that are part of the TOC style 
group that you named to avoid replacing an existing text style such as 
Body or Heading 1.

Click OK.

6. The page you chose will be added to the document. Select that page in the 
Pages panel and click its Delete  icon to remove it.

7. Using the Table of Contents panel, select the table of contents you want to 
style from the TOC popup menu near the top of the panel. If there is only one 
table of contents and you haven’t renamed it, it will be named TOC 1.

8. Choose the name of the TOC style you imported from the TOC Style popup 
menu in the panel. The table of contents will be reformatted using the 
imported TOC style.
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Working with multiple tables of contents
Most books have a single table of contents. If a book has more than one table of 
contents they can share a single TOC style as long as they have identical format-
ting, but if their formatting or settings differ you will need at least a second TOC 
style.

For demonstration purposes, this book also has chapter-specific tables of con-
tents at the start of each chapter, listing only the topics in that chapter. While 
Affinity provides the tools to do this, it takes some effort to format the tables 
consistently. The steps below instruct you to match the approach used for this 
book.

1. Follow the instructions in Using sections for chapters on page 71 to create a 
section for each chapter in the book.

2. Follow the instructions in Generating a table of contents on page 312 to insert 
the main table of contents. This first table will be named TOC 1 in the TOC
popup menu near the top of the Table of Contents panel. To rename this 
table of contents for your own convenience, click the Rename  icon, but this 
will not change its appearance.

3. Follow the instructions in Formatting a table of contents on page 314 to 
format this first table of contents. The first table will have a TOC style named 
TOC 1. To rename this TOC style for your own convenience, click the menu

 icon to the right of the TOC Style popup menu and choose Rename…
from the context menu, but this will not change its appearance.

4. Sometimes you might need to customise a heading. For example, if your 
chapter headings are numbered and you use the same heading style for 
Introduction, it would be left aligned with the “1” for the following chapter 
name as shown in this example. One solution is to insert a tab before the 
word Introduction in that heading but to make it invisible. To do this, a tab 
stop can be created at 0.0001 pt for that heading. This invisible tab would 
become visible in the table of contents because its tab stop was set to match 
the other chapter headings.

5. Insert the second table of contents at the start of the first chapter. The second 
table and its TOC style will be named TOC 2.

6. Deselect Heading 1 from the Style Name popup menu because the chapter 
headings are formatted as Heading 1 and are not included in the chapter-spe-
cific tables.

7. Deselect Include as PDF bookmarks because you want bookmarks generated 
only from the main table of contents. Leaving this selected will generate 

Tip: Affinity doesn’t 
allow tab stops at 0 pt 
so 0.0001 pt was used 
as an approximation 
of 0 pt without adding 
so many decimal 
places that Affinity 
rounded it to zero
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duplicate PDF bookmarks and break their hierarchy because you deselected 
Heading 1 for this table.

8. By default, the scope for these chapter tables will be the same as for the main 
table. Ensure Include entries before TOC is not selected so the second table 
will start with subsequent headings. You could choose Stop at next TOC to 
prevent this table from including entries in the next chapter’s table but in this 
book the Appendices chapter heading needed to be excluded from the last 
chapter’s table. It’s possible to do that with a table of contents in a hidden layer 
just before the Appendices page but the better approach is to create sections, 
as you did in step 1, and to limit the scope of this table of contents to the 
current section by changing Scope from Document to Section.

9. Repeat steps 5 to 8 for each of the chapter-specific table of contents. 

10. The panel’s controls act on the table selected in TOC list. To switch between 
tables of contents, select the table name from TOC popup menu or click in 
the table of contents’ text frame. All of the chapter-specific tables of contents 
share the same formatting but as each table was inserted, Affinity created 
TOC styles for each chapter. Only two TOC styles are needed, TOC 1 for the 
main table and TOC 2 for the chapters, so the excess TOC styles were deleted 
to avoid later confusion. To delete a TOC style, select the table name from 
TOC list, click the menu  icon to the right of the TOC Style list, and 
choose Delete from the context menu. Ensure you choose TOC 2 from TOC 
Style for each of the chapter tables.

11. The left indent for the new chapter-specific tables is different than the main 
table because Heading 1 is not included. Unfortunately, it’s not possible to 
base one TOC style on another nor is it possible to make a copy of a TOC 
style and customise it. The TOC 2 style created by Affinity has none of the 
formatting that was set for the main table so all of the formatting would 
normally have to be repeated but there is a workaround. To do this, go to a 
chapter-specific table of contents and:

• Change TOC 2: Entry to be based on TOC 1: Entry instead of Base

• Change TOC 2: Heading 2 to be based on TOC 1: Heading 2 instead of 
TOC 2: Entry

• Change TOC 2: Heading 3 to be based on TOC 1: Heading 3 instead of 
TOC 2: Entry

The TOC 2: Heading 1 style was skipped because Heading 1 is not included in 
this table. There is no need to change the number styles.

12. Adjust the left indent for the TOC 2: Heading 2 and 3 text styles to complete 
the formatting of the chapter-specific tables of contents.
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Creating a pictorial table of contents
Images pinned to headings can be included to create a pictorial table of contents 
for catalogues and other special cases. The images can be used with or without 
accompanying text. For example, the sample below was created with inline 
images in Heading 1 paragraphs that did not include any text. The Numbers 
Before Headings option was used to position the numbers before the images and 
the leading zero was achieved by changing the page number format with the 
Section Manager.

Sample pictorial table of contents

The generated table of contents will include the pinned image at the same size it 
was pinned so you will likely need to make a second copy of the image on the 
page on which it is used at the size required for the table of contents. Use linked 
images instead of embedded ones to avoid increasing the size of your document 
when duplicating images.

To create a pictorial table of contents:

1. Select an image to include in the table of contents. Choose Edit > Copy to 
copy the image to the pasteboard (clipboard).

2. Using the Frame Text  tool, draw a text frame. Don’t worry about its posi-
tion because this frame will be hidden and won’t be visible to readers, but 
make it larger than the image you copied.

3. Select Heading 1 or whichever heading style you want to use for the table of 
contents from the Text Styles panel, Context Toolbar, or Paragraph panel.

4. Optional: Enter heading text if you want text to accompany the image in the 
table of contents.

5. Choose Edit > Paste to paste inline the copied image; if you entered text, you 
can paste the image anywhere in the heading.

6. Using the Move  tool, select the pasted image.

7. Using the Transform panel with the Link  icon selected, change the image’s 
width (or height) to the size you want the image to appear in the table of 
contents. Optional: Make the text frame smaller.

8. Select the text frame and hide it by choosing Layer > Hide or by deselecting 
the Toggle Visibility  icon in the Layers panel.

¶ TOC 1: Heading 1a TOC 1: Heading 1 Number
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9. Repeat the above steps for each image you want to include in the table of 
contents.

10. Using the Frame Text  tool, create a text frame for the table of contents and 
position the text cursor in it.

11. Click the Insert Table of Contents  icon in the Table of Contents panel.

12. In the list of paragraph styles at the bottom of the panel, select only the style 
used for the images in the hidden text frames.

13. Select Include Inline Pins in the panel. Optional: Select Numbers Before 
Headings to match the sample.

14. Optional: Edit the TOC 1: Heading 1 Number text style to change the page 
number size, or the equivalent style if your heading uses a different style.

15. Optional: Edit the TOC 1: Heading 1 text style to change the leading and tab 
stop. To position the numbers to the right of the images, you must deselect 
the From Right option for the tab stop.
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Creating an index
Affinity can generate an index for your publication based on index marks that 
you add into your text. The index is normally placed at the end of the document 
and there can be only one index per document so you can’t create multiple 
specialized indices unless you use a workaround such as the one described in 
Creating multiple indices on page 337.

Affinity sorts index entries alphabetically with punctuation and symbols first, 
followed by numbers, A–Z, and then non-Roman language characters. You 
cannot customise the order of these categories but you can manually change the 
sort order of individual index entries.

An index is a block of special text that you can modify but when you update the 
index any changes you made to it will be lost. You should avoid making any edits 
to the generated text until the last stage before publishing. The index can be 
updated at any time and can be generated from a single document or from all of 
the chapter documents in an Affinity Book.

Affinity offers two approaches for creating an index. You can create its topics and 
then find the topics in the document to reference them or you can add index 
marks to create topics and references at the same time. Both approaches will 
create the same results but which approach is best for you depends on the publi-
cation and your working style. You can also use a combination of both 
approaches,

Parts of an index
The key parts of an index are the index topics, the words you have indexed, and 
the references which can be either the page numbers or cross-references to other 
index topics. A topic and reference are together referred to as an index entry. 
Some topics may not have a reference because they may list only subtopics.

Sample index

A
Aperture, 17, 192, 223
Aspect ratio, 33
Auto focus, 24

B
Bokeh, 67. See also Focus

D
Depth of field, 69
Dynamic range, 82

E
Exposure, 31–34, 79

F
Film speed, 54, 86
Focal length, 16, 81
Focus
 Auto focus, 29
 Manual focus, 25–27

H
Hot shoe, 29

I
Image stabilization, 18, 30
ISO. See Film speed

Index entry (index topic and index reference)

Index entry with a sub-topic

Style override for a primary reference

Cross-reference

Grouped page range

Index topic without a reference

Section heading

Tip: If you number 
chapter pages using a 
combination of 
section name and 
page number (for 
example, 1.1, 1.2, 
1.3…), the section 
prefixes will not be 
included in the index 
because they are not 
part of the page 
number
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Using the Index panel
To display the Index panel:

1. Choose Window > References > Index to display the Index panel.

2. Choose Show Topics from the panel menu  to view topics without refer-
ences. This view saves space and allows you to focus on the topics. Choose 
Show Topics and References to restore the default view.

Insert Index Show/Hide Index Marks toggleInsert Reference Mark Update Index

Panel menu

Add Topic Delete

Index language

Text between multiple page numbers

Text between pages in a range

Text before a cross-reference

Text for a cross-reference

Text for a cross-reference with a page number

Text after the cross-reference text

Text after the last cross-reference

Text between the topic and page number

Include section headings (A, B, C…)
Group page ranges (e.g., 17-19)
Expand cross-references to include reference’s 
page number

Filter the topic list

Expand/collapse a topic

Index topic
Index subtopic

Index reference

Index formatting options
(click to collapse)

Index cross-reference
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Adding index topics
You don’t have to create index topics manually because Affinity will create them 
automatically when you insert an index mark. These instructions are for those 
who prefer to create topics on their own before they add index references.

To create a topic list (optional):

If you want to create topics before reviewing where they are mentioned, you can 
add a list of topics to have available during indexing. Creating topics in advance 
is optional because you can create a topic at the same time as you insert an index 
mark. Topics without references added to them will not be listed in the index.

Affinity does not provide an option to import a topic list so you must do it manu-
ally. Once you’ve added all of the topics, use the Find in document feature to 
quickly index all of the added topics.

1. Create a temporary text frame and paste the copied word list into it

2. Position the cursor before the first word and choose Text > Index > Insert 
Index Mark. Press Return to index the word and then the ↓ key to move to 
the next word in the list.

3. Repeat step 2 3 until you have indexed all the words.

4. Delete the text frame which will delete the index references (marks) but keep 
the index topics.

To add an index topic:

1. Click the Add Topic  icon. This feature does not have a matching menu 
command so you can’t assign a keyboard shortcut to it.

2. Enter the Topic Name, for example, Auto focus.

3. Optional: To create a subtopic, select a Parent Topic from the list of existing 
topics. For example, select Focus to add Auto focus as a subtopic of Focus.

4. Optional: To override the automatic sorting of the topic, enter text for a 
custom sort order. For example, to sort van der Linden as Linden you would 
enter Linden for Sort By.

5. Optional: To create a cross-reference to another index topic, select the other 
topic from the list of existing topics under See. For example, select Focus to 

Tip: You can create 
sub-subtopics to as 
many levels as 
required by selecting a 
subtopic as the Parent 
Topic

Tip: The Find in 
Document feature 
searches only the 
current document, not 
an Affinity Book 
comprised of multiple 
Chapter documents

Tip: Assign a simple 
keyboard shortcut to 
Insert Index Mark so 
that you can press its 
shortcut, Return, and 
↓ in rapid sequence
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append See also Focus to the Bokeh topic. Refer to adding cross-references 
below for more information on See vs. See Also.

6. Click OK. The index topic will appear in the Index panel list.

To add a subtopic:

1. Right-click an index topic title in the Index panel and choose Edit topic…
from the context menu.

2. The features of the Add Index Topic window are the same for adding topics 
and subtopics.

To rename or edit an index topic:

1. To rename it, select an index topic title in the Index panel and then click it a 
second time—do not double-click. Enter a new name and press Return.

2. Or right-click an index topic title in the Index panel and choose Edit topic…
from the context menu. The features of the Edit Index Topic window are the 
same for adding topics.

To change the index topic for an index reference:

1. Using the Index panel, drag the index reference below another index topic.

To change the index parent topic for an index topic:

1. Using the Index panel, drag the index topic below another index topic.

To delete an index topic:

1. Select an index topic in the Index panel and then click the Delete  icon. The 
topic and all of its references will be deleted.

To import index topics from another document:

Affinity doesn’t provide a way to import or export index topics but it’s relatively 
easy to copy index topics, but only for those that have at least one reference 
(index mark).

1. Open the document containing the index topics to be copied.

2. Using the Frame Text  tool, select and copy the text containing the index 
references. If the references are in more than one story you will need to repeat 
this for each story.

3. Open the document to which the topics should be copied.

4. Using the Frame Text  tool, create a temporary text frame.

5. Paste the copied text into the frame using Edit > Paste or Paste Without 
Format. The latter will paste the text and index marks without importing any 
text styles.

6. Delete the pasted text. The text and its index references will be deleted but the 
index topics will remain.
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Adding index entries
An index entry is made up of an index topic and a reference which is either a 
page number or a cross-reference to another topic. When you insert an index 
mark in your text, you can create a new topic or choose an existing topic to 
associate it with.

When you insert an index mark a special character is inserted at the text cursor 
position or at the start of the selected word.

Affinity does not allow you to enter multiple references simultaneously so if you 
want to insert marks for multiple topics you will need to repeat the steps below.

To add a new reference to an index topic:

1. Using the Frame Text  tool, position the text cursor before, in, or after a 
word, or select a word.

2. Double-click the desired index topic or subtopic in the Index panel. Affinity 
will insert an index mark for the topic before the text cursor or selected text.

To add an index entry:

1. Using the Frame Text  tool, position the text cursor before, in, or after a 
word, or select a word. To index a phrase, select the range of text to index.

2. Click the Insert Mark  icon in the Index panel or choose Text > Index > 
Insert Index Mark.

3. The Topic field will be pre-filled with the word you clicked in or the words 
you selected. If the pre-filled text matches any topics in the list they will be 
suggested. If you select a subtopic from the list, it will also pre-fill the Parent 
Topic field. Alternatively, you can delete the pre-filled text and select from the 
full Topic list.

4. Optional: To make the topic a subtopic of another topic, select the Parent 
Topic or enter a new one. For example, to index Auto Focus as a subtopic of 
Focus, you would enter Auto Focus as the Topic and Focus as the Parent Topic. 
If the text pre-filled for Topic should be the Parent Topic, click the Move to 
Parent  icon to the right of the two fields.

5. Optional: To indicate the primary reference for a topic, choose a character 
style from Style Override. This is typically used to bolden or italicize the page 
number of the most important page for an index topic.

Tip: Click the Show/
Hide Index Marks
toggle  icon in the 
Index panel or Choose 
Text > Index > Show 
Index Marks to see the 
invisible index markers 
and avoid accidentally 
deleting them
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6. Click OK. Affinity will insert an index mark before the text cursor or selected 
text. If the Topic or Parent Topic fields contains a topic that is not already in 
the list, Affinity will create it when inserting the index mark.

To quickly index many occurrences of a topic:

1. Right-click an index topic in the Index panel and choose Find in docu-
ment… from the context menu. The panel will list all occurrences of the topic 
title in the document with a checkbox beside them. The checkboxes for the 
existing reference(s) will be selected.

2. Click a list item to view it in context in the document window. Select its 
checkbox if you want to add an index mark for that occurrence.

3. Click the Done button after you have selected the desired occurrences of the 
topic.

To view an index mark in the document:

1. Double-click an index reference in the Index panel. Affinity will change the 
page displayed in the document window so that the index mark is visible.

2. Click the Show/Hide Index Marks toggle  icon in the Index panel or 
Choose Text > Index > Show Index Marks to see the invisible markers.

Tip: The Find in 
Document feature 
searches only the 
current document, not 
an Affinity Book 
comprised of multiple 
Chapter documents

Tip: Instead of using 
Find in Document, 
you can copy an index 
reference mark and 
then use Find and 
Replace; enter the 
same text into both 
fields and paste the 
copied index mark 
before or after the 
Replace text

An index mark between two characters

Tip: The Find in 
Document feature will 
also find words with 
the same first letters, 
so finding Generate
will find Generator
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Adding index cross-references (See or See Also)
A cross-reference is an index reference that points to a related index topic rather 
than a page number in the document. For a topic that has a page number refer-
ence, a cross-reference will insert See also in the index entry. In the Sample index
on page 326, Bokeh has another page number reference so the cross-reference to 
Focus creates an index entry of:

Bokeh, 67. See also Focus

For a topic that has no page number references of its own, a cross-reference will 
insert See in the index entry. In the sample index, ISO doesn’t have a page 
number reference so the cross-reference to Film speed creates an index entry of:

ISO. See Film speed

To add a cross-reference to another index topic:

1. Right-click an index topic in the Index panel and choose Add cross-refer-
ence… from the context menu.

2. Select a topic from the See topic list.

3. Click OK. Affinity will add the cross-reference. If you later delete the cross-
referenced topic, the broken cross-reference will be displayed in red in the 
panel list.

4. To customise the See and See also text that Affinity adds to the index, refer to 
Formatting an index on page 334.

To delete an index entry:

1. To delete the entire index entry, include the topic and its references, select an 
index topic in the Index panel and then click the Delete  icon.

2. To delete only the reference to a page number or a cross-reference, select the 
reference in the Index panel and click the Delete  icon.

Index cross-reference Broken index cross-reference

Tip: Index cross-refer-
ences are unrelated to 
the general Creating 
cross-references
feature described on 
page 302
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Generating an index
It’s difficult to see the start and end of an index because Affinity doesn’t display it 
with any shading as in other applications. Until you’re experienced with working 
near the index text block, it is recommended that you insert the index into a 
separate text frame without any other text to avoid losing text when the index is 
updated.

The index inserted by Affinity does not include the title Index and you might 
consider placing even the title in a separate frame so that updating the index can 
replace all the text in the frame(s).

It doesn’t matter whether you create text frames for the index on a master page or 
whether you create them directly on a document page.

To insert the index:

1. Using the Frame Text  tool, create a text frame for the index and position 
the text cursor in it.

2. Click the Insert Index  icon in the Index panel or choose Text > Index > 
Insert Index. Affinity will insert the index into the frame.

3. If the index’s text frame has an overflowing Text Flow Out  control near 
the frame’s bottom-right corner, press Shift and click the control. Affinity will 
create as many pages of text frames as required to contain the index.

To update the index:

The index isn’t updated automatically when you add and delete index marks. It’s 
up to you to update the index before printing or exporting.

1. Click the Update Index  icon in the Index panel. The Preflight panel can 
also warn you when the index needs to be updated and offers a convenient 
Fix button that to update it.

To delete the index:

1. There isn’t a command or button to delete the index, so using the Frame Text
 tool, select all the text in the index text block and press Backspace or Delete.

Tip: For information 
on generating an 
index for an Affinity 
Book made up of 
separate Chapter 
documents, refer to 
Adding references to 
an Affinity Book on 
page 298
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Formatting an index
Affinity provides several layout options in the Index panel to modify the index 
text that will be inserted. The options you select and the text you enter in this 
panel will be saved in your user defaults for future documents.

1.  Language: Use this to specify the language used to sort the index. Select Auto
to use the spelling language of the index.

2.  Include section headings: Use this to add heading characters before all of the 
indexed words starting with A, B, C, etc. Affinity will add a letter for each 
character, including non-Roman alphabets, but not for the punctuation and 
numbers section. For example, 6-pack starts with a number so it would be 
sorted into the punctuation and numbers section but would not have a sec-
tion heading.

3.  Group page ranges: Use this to group references on sequential pages rather 
than listing each of them separately. For example, 7–9 instead of 7, 8, 9.

4.  Expand cross-references: Use this to replace the See cross-reference for a 
topic that has no page number references of its own with the page number(s) 
of the cross-referenced topic. With this setting off, the Sample index on page 
326 inserted these entries in their respective sections:

Film speed, 54, 86
ISO. See Film speed

But with this setting on, it would insert:

Film speed, 54, 86
ISO, 54, 86

5.  Labels and separators: Use these options to customise the text inserted into 
the various parts of the index. Click the caret  icon on their left side to 
easily enter relevant special characters.

Item Purpose

After Topic Inserted after the topic name, default is comma + en space

Between Items Inserted between references, default is comma + space

Between Ranges Inserted between grouped page ranges, default is en dash

Before References Inserted before cross-references, not page numbers, default is
 period + space

See Inserted as part of a cross-reference, default is See

See Also Inserted as part of a cross-reference, default is See Also

After See (Also) Inserted after the See or See Also text, default is space

After References Inserted after the last cross-reference, default is space

Tip: Page ranges will 
be grouped within 
sections, so a new 
range will be started 
for each section even 
if they’re consecutive 
pages

Tip: To insert empty 
space between letters 
instead of section 
headings, edit the 
Index Section Heading
style and change the 
text fill colour to white
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To reformat the index by editing its text styles:

When you insert an index in a document for the first time, Affinity will add a 
number of additional text styles to your document to control the index format-
ting. You can modify the attributes of these styles as required for your publica-
tion. The styles are:

Style Purpose

¶ Index Base style, not applied directly to the index

¶ Index Entry Base style, not applied directly to the index

¶ Index Entry 1 For topics

¶ Index Entry 2 For subtopics, if they exist

¶ Index Section Heading For section headings (there is not an option to
  insert a section heading for a character that
  lacks matching entries)

a Index Cross-reference Base style, not applied directly to the index

a Index Cross-reference Label For the words See and See Also

a Index Cross-reference Topic For the cross-reference topic name

a Index Entry Number Separator For the characters between multiple index entry
  page numbers; for example, 7–9, or 14, 22, 36

a Index Entry Page Number For the page numbers

To right align index page numbers or add a dot leader:

Affinity left aligns index page numbers but you can change this with text styles.

Aperture, 17, 192, 223
Aspect ratio, 33

 Auto focus, 24

Follow the steps below to format an index with this formatting:

Aperture ................................... 17, 192, 223
 Aspect ratio ................................................ 33
 Auto focus ................................................... 24

1. Delete all of the characters from the After Topic field of the Index panel.

2. Choose Tab from the field’s menu (click the caret  icon on its left side).

3. Double-click the Index Entry style in the Text Styles panel to edit it.

4. Select Tab Stops from the left pane and click the Add New Tab Stop  icon.

Tip: Affinity creates 
the index text styles 
for you; while you can 
redefine the character 
and paragraph 
attributes of these 
styles, do not rename 
them or Affinity will 
generate a new 
version when you 
update the index
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5. Click the More  icon to display the popup settings window. Choose right 
alignment, select (.), select From Right, and set Position to 0.

6. Click OK.

To capitalise index entries:

1. Create a character style and with Typography selected in the left pane, select 
All Caps.

2. Edit the Index Entry 1 paragraph style and with Drop Caps selected in the left 
pane, set Height in Lines to 1 and Characters to 1. Set Style to the name of 
the character style you created in step 1. Although the Drop Cap feature is 
used, this combination of options will do nothing other than capitalise the 
first character of the index entry.

3. To capitalise level 2 or other index entries, repeat step 2 for the corresponding 
paragraph style.
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Creating multiple indices
While you can create only one index with Affinity, there is a workaround but it 
involves manual work that must be repeated each time you update the index.

Index topics for a secondary index can be created as subtopics for a dummy
parent topic that you will later delete. After updating the index, you would simply 
cut the secondary index from the main index, paste it elsewhere, and reformat it 
to correct the indentation level.

The dummy topic can be named anything but it’s easiest to choose a name that 
will be sorted to the top of the index. If you chose one that sorted to the end of 
the index, the secondary index text might be overflowed from the main index’s 
text frame, making it difficult to select.

Affinity sorts punctuation before numbers and letters so it’s recommended to 
prefix the dummy topic name with an underscore. In the example below, the 
dummy topic is named _Film brands. When the index is generated, all of the 
subtopics of the dummy topic are sorted below it before the first entry of the 
main index.

Sample multiple indices

To add an index entry for a secondary index:

1. Index the term as you normally would but enter the dummy topic name into 
the Parent Topic field.

_Film brands
Austria

Lomography, 322
Belgium

Dan-Di, 306
Germany

ADOX, 324
AGFA, 338
Rollei, 306

Hungary
Forte

Italy
Ferrania, 314

Japan
Fujifilm, 307
Konica, 316

…truncated example

A
Aperture, 17, 192, 223
Aspect ratio, 33
Auto focus, 24

B

First section heading

Punctuation and 
numbers section
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To generate and format a secondary index:

1. Using the Frame Text  tool, create a text frame for the secondary index just 
as you did for the main index.

2. Insert or update the main index as you normally would.

3. Select all the text from the start of the dummy topic name up to and including 
the paragraph break  at the end of the last secondary index entry.

4. Choose Edit > Cut.

5. Position the text cursor in the secondary index’s text frame and choose Edit > 
Paste.

6. Select the dummy topic name, including its paragraph break , and press 
Delete.

7. The secondary index entries are indented one level more than they should be 
since they were created as children of the dummy parent topic. If they are all 
the same indent level, you can simply choose Edit > Select All and then use 
the Paragraph panel, change the Left Indent and First Line Indent to match 
the main index’s first level index entry. If the secondary index has subtopics of 
its own, you must adjust the indent values for each entry manually because 
Affinity can’t change varying indent values by a relative amount.

To update a secondary index:

1. Each time you update the main index, the secondary index’s entries will be 
added to it. Repeat the steps for generating and formatting a secondary index 
each time you update the main index.
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Creating notes
A note is text positioned at the bottom or side of a page or at the end of the 
chapter or publication and is used to cite other works or to provide comments on 
the main text. A note is made up of two parts: the note reference marker in the 
text and the note body.

Affinity offers three types of notes which you can use together in the same docu-
ment. For each you can control the formatting of the note reference marker and 
the note body as well how the body is positioned. You can choose whether long 
notes can be split and continued in the next column or frame. Affinity will keep 
footnote and sidenote references and bodies on the same page, where possible.

• Footnotes are positioned at the bottom of the column or frame and can be 
positioned inside or below the frame. If a frame has more than one column 
you can choose whether they should span columns. They can be separated 
from the main text by a horizontal rule.

• Sidenotes are positioned to the left and/or right side of frames and are verti-
cally aligned with the marker, although multiple or long sidenotes may cause 
the vertical position to change.

• Endnotes are positioned at the end of the story, chapter, or document and 
don’t affect the layout of the main text but readers must navigate to the end of 
the text to find the corresponding endnote. Affinity can also insert a title for 
the endnotes.

Tip: Note reference 
markers are not plain 
text so their characters 
cannot be found with 
Find and Replace and 
are not counted by 
Word Count

Tip: Choose Text > 
Notes > Show Note 
Marks when working 
with notes to see their 
markers more easily, 
and never edit end-
notes without this 
selected
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Using the Notes panel
To display the Notes panel:

1. Choose Window > References > Notes to display the Notes panel.

Go to note reference

Panel menu

Insert note

Type of note

Go to note body

Number format and options

Note position

Note number format for marker (main text) 
and note (note body) and note

Scope of settings

Expand/collapse section

Separator rules (footnotes only)
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Adding notes
To insert a note into text:

1. Using the Frame Text  tool, position the text cursor where you want the 
note reference marker to be inserted.

2. Choose one of Text > Notes > Insert Footnote, Insert Sidenote, or Insert 
Endnote. Notes inserted via the menu will always use Document-wide
settings.

Or to insert a note using the Notes panel, set Type to Footnotes, Sidenotes, 
or Endnotes and choose Document-wide or Custom. Click the Insert Note

 icon.

Affinity will insert the note reference marker and for a footnote or sidenote 
will adjust the text flow to accommodate the note body. The text cursor will 
move automatically to the note body to allow you to type the note.

3. When you have finished typing the note body, click the Go to Reference
icon to return to the main text.

To view the note body for a note reference marker:

1. Click the Go to Body  icon to move the text cursor from the note reference 
marker to the note body.

To view the note reference marker for a note body:

1. Click the Go to Reference  icon to move the text cursor from the note body 
to the note reference marker.

To edit a note:

1. Edit a note body as you would any other text. Choose Select All to select all 
the text in the note without selecting text outside of the note.

2. For endnotes, you must first select Text > Notes > Show Note Marks to see 
their enclosing brackets. Be very careful when placing the text cursor at the 
start or end of an endnote. If you start typing and notice that the text is 
outside of the endnote brackets you must undo what you have typed and 
move the cursor inside of the brackets.

3. If you copy and paste a range of story text that includes a note marker, the 
note will be pasted along with the text.

To delete a note:

1. You can delete the note reference marker with Backspace or Delete as you 
would any other character. Deleting the note reference marker will delete the 
note body.

Tip: For information 
on using notes in an 
Affinity Book made up 
of separate Chapter 
documents, refer to 
Adding references to 
an Affinity Book on 
page 298

Tip: A field is treated 
as a single character 
so you need only press 
the Backspace or 
Delete once to delete 
a note reference 
marker

Tip: You cannot 
navigate from one 
note to the next so 
position the text 
cursor in a different 
note using the mouse

The text cursor may look like it 
is to the left of this end bracket 
but it is actually to its right

Tip: You can include 
inline and floating 
images in the note 
body; text wrap for 
floating images will 
apply only to the note 
body and not to the 
story text
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Separating multiple note references
If you insert two or more note reference markers at the same position in your 
document, you should separate their numbers with a comma or space. Affinity 
cannot do this automatically. Typing a comma and superscripting it will result in 
a comma that is larger and heavier than it should be and that is misaligned to the 
surrounding numbers because the Superscript feature in the Notes panel doesn’t 
use the font’s automatic superscript capability. In some fonts, a comma can’t even 
be superscripted.

To separate multiple reference numbers with commas:

1. Type a comma between two note reference markers and then select it.

2. If you are using an OpenType font that offers superscripted numerals and 
commas, select the comma and use the Character panel to select Typography
> Superscript.

If you are using a font that does not offer OpenType superscripted numerals 
and commas:

1. Change the font size to 60% of the current value. You can do this easily 
by entering *60% or *.6 into the Font Size field and pressing Return.

2. Use the Character panel to change Positioning and Transform > Base-
line Offset to 33% of the font size. You can do this easily by combining 
the font size with 33%. For example, if the original font size was 11 pt, 
enter 11*33% and press Return.

3. The comma will now be formatted correctly. Create a character style so that 
you can easily apply the same formatting to other commas or spaces to sepa-
rate note reference markers. Using the Text Styles panel, click the Create 
Character Style  icon or choose Text > Text Styles > Create Character 
Style. Enter a unique Style Name and then click OK.

Adding multiple references to the same note
Affinity doesn’t allow you to insert multiple instances of the same note reference 
number that point to the same footnote or endnote, but you can accomplish this 
with cross-references.

To add an additional reference to an existing note:

1. Using the Frame Text  tool, position the text cursor where you want the 
additional reference to be inserted.

2. Click the Insert Cross-Reference  icon in the Cross-References panel or 
choose Text > Cross-References > Insert Cross-Reference.

Note references1,2,3 Comma is superscripted
Note references1,2,3 Properly scaled and aligned



Expert Guide to Affinity by Canva 3.0 343

3. Select Paragraph from Link To and type the first few words of the footnote or 
endnote text to find the note in the list. Select the note.

4. Delete the contents of the Text field. Click the caret  icon on the left side of 
the field and choose Note Number which will insert a  cross-refer-
ence component.

5. If the actual note reference (note number) is formatted with a character style, 
select that same character style from the Style Override list.

6. Select Generate Hyperlinks if the document will be distributed digitally.

7. Click OK. Affinity will insert a cross-reference field at the text cursor position 
with a value that matches the note’s reference number.

8. If you did not select a character style from Style Override, select the field and 
then Text > Baseline > Superscript. You can also select Superscript from the 
Super/Subscript list in the Character panel’s Positioning and Transform
section.
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Converting one type of note to another
You can convert footnotes, sidenotes, and endnotes to either of the other types. 
You can convert all the notes in your document at once or just those in a 
selection.

To convert notes from one type to another:

1. Choose Convert Notes… from the Notes panel menu .

2. Choose the types of note you want to convert from and to.

3. Set Scope to Entire Document to convert all notes or to Current Selection to 
modify only the notes in the selected text.

To convert notes in selected text only:

1. Choose Convert Selection to Footnotes/Sidenotes/Endnotes, as applicable, 
from the Notes panel menu . This has the same effect as choosing Convert 
Notes… and setting the scope to Current Selection.
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Note settings
Note settings includes all of the numbering, formatting, and positioning options 
in the Notes panel. When you create a new note you can choose whether to 
create it with the document-wide settings or with custom settings for a specific 
note. The document-wide settings for a new document will be based on Affinity’s 
default settings which you can change to match those of the current document.

It is important to understand that the settings used to create a note depend on 
the Document-wide / Custom toggle. Once the note is created the toggle will 
have no further effect on the note and there is no user interface feedback as to 
which settings were used to create the note. Clicking in a note will not change the 
toggle to reflect whether it uses document-wide or custom settings.

You can revert the document-wide settings for a document back to Affinity’s 
default settings, and revert the default settings back to the original factory 
defaults. Changes are saved and reverted to all three types of notes at once.

Changing the document-wide settings will update the settings for all notes 
created using those settings but will have no impact on custom notes which each 
have their own individual settings. To change custom notes to the document 
settings you must use Revert Selected/All Notes to Document Settings.

You can’t create custom presets nor can you copy custom settings from one note 
to another, but you can copy a note reference marker, paste it at the desired 
location, and then change its note body text.

To set the document-wide note settings:

1. If the text cursor is positioned in text, click on a blank area of the page or 
change to the Move  tool.

2. Choose one of Footnotes, Sidenotes, or Endnotes in the Notes panel.

3. Choose Document-wide.

4. Set any note options to update the document-wide settings.

To convert custom-formatted notes to the document-wide settings:

1. Using the Frame Text  tool, position the text cursor in a note with custom 
settings or select a range of text containing one or more note reference 
markers.

2. Choose Revert Selected Footnotes/Sidenotes/Endnotes to Document Set-
tings, as applicable, from the Notes panel menu . The command you choose 
will have no impact on the other two types of notes. Or choose Revert All 
Footnotes/Sidenotes/Endnotes to Document Settings to change all custom 
notes of the chosen type at once.

Tip: After using 
Custom to format a 
specific note, change 
the toggle back to 
Document-wide or 
the next note you 
insert with the panel 
will use custom 
settings

Tip: You can set 
document-wide 
settings only when the 
text cursor is not 
placed in a text frame 
or when the cursor is 
placed in a note of the 
same type that was 
created with docu-
ment-wide settings

Tip: The only way to 
know if a note uses 
document-wide or 
custom settings is to 
look in the panel 
menu  if the Revert 
Selected Notes to 
Document Settings
command is disabled 
then the note uses 
document-wide 
settings and if it is 
enabled then it uses 
custom settings
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To convert notes using document-wide settings to custom settings:

1. Using the Frame Text  tool, position the text cursor in a note with docu-
ment-wide settings or select a range of text containing one or more note 
reference markers with document-wide settings.

2. Choose Custom from the Notes panel and define the settings for the selected 
notes.

To save the current document’s document-wide note settings as Affinity’s 
defaults:

1. Choose Save Document Settings as New Defaults from the Notes panel
menu .

To revert the current document’s note settings to Affinity’s defaults:

1. Choose Reset Document Settings to Factory defaults from the Notes panel
menu .

2. This will change only the current document’s settings, not Affinity’s current 
defaults. To change the defaults to the factory defaults, now choose Save 
Document Settings as New Defaults.

To change the current document’s note settings to match those of the 
current custom-formatted note:

1. Using the Frame Text  tool, position the text cursor in a note with custom 
settings.

2. Choose Update Document Settings from Selected Footnotes/Sidenotes/
Endnotes, as applicable, from the Notes panel menu . The command you 
choose will have no impact on the other two types of notes.
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Numbering notes
Notes are numbered automatically within a document, from the first to last page 
and from the bottom to top of the layer stack on each page, but you can restart 
numbering for each frame, page, story, or section. In the case of an Affinity Book, 
you can also restart numbering every chapter.

There is one significant exception to the numbering of endnotes. Note reference 
markers that are in text frames or tables pinned in another text frame will be 
numbered after the end of the story. If the story spans dozens of pages and you 
pin a text frame containing a note reference marker on the first page, it will be 
numbered after the last note on the last page of the story. If you must use notes in 
a pinned text frame then you should consider using footnotes in that frame and 
numbering them separately.

You can choose whether to restart note numbering every frame, page, story, 
section, document, or Affinity Book. 

To change note numbering:

1. Set Type to Footnotes, Sidenotes, or Endnotes in the Notes panel. Each type 
of note can be numbered separately.

2. Choose Document-wide to change the document’s settings or Custom to 
change the selected note(s) or the next one you insert. It is generally best to 
maintain a consistent numbering system within a document but you are able 
to use 1, 2, 3… for the document and A, B, C… for a custom note. However, 
if you restart numbering in a custom note it will impact subsequent docu-
ment-wide notes.

3. In the Numbering section, choose a Number format from the list. In addi-
tion to the standard number and letter options, you can choose symbols 
which numbers notes as *†‡§¶#, duplicating each symbol when the pattern 
repeats.

4. Choose the Start number and set Restart Every to direct Affinity when to 
restart numbers at 1. By default, Affinity will restart numbering footnotes for 
each frame which you may want to change to story, section, or document. 
Numbering for sidenotes and endnotes restarts by default for each story 
which you may want to change to section or document.

5. For Custom-formatted notes you can also choose to Restart numbering now.

Tip: When using 
symbols for number-
ing, restart numbering 
every frame for best 
results due to the 
limited range of 
symbols

Tip: You cannot 
change Document-
wide settings while a 
Custom-formatted 
note is selected
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Formatting notes
Before changing note formatting:

1. Set Type to Footnotes, Sidenotes, or Endnotes in the Notes panel. Each type 
of note can be formatted separately.

2. Choose Document-wide to change the document’s settings or Custom to 
change the selected note(s) or the next one you insert. Refer to Note settings
on page 345 for more information.

To format the note reference marker:

In the Format section of the Notes panel, use the settings under In main text:

1. By default, the Number text will appear as a pound sign or hashtag  which 
inserts an automatic note number. You can enter additional character(s) such 
as enclosing brackets [ ]or click the caret  icon on its left side to easily 
enter relevant special characters.

2. Choose a character style from Number style to format the note reference 
marker. Ignore this if you are satisfied with the default reference marker’s 
appearance.

3. The reference marker is superscripted by default but you can deselect Super-
script for formats such as [#].

To format the note body text:

In the Format section of the Notes panel, use the settings under In note body:

1. The Number text, Number style, and Superscript options apply to the note 
number in the note body and are identical to those for the reference in the 
main text so refer to the above description. Number text in the note body 
defaults to  plus a space to provide a separator before the note text.

2. Choose a paragraph style from Note body style to format the text of the note’s 
text. The default is the Body style but you may want to create a unique style.

3. You can apply character styles and attributes directly to the note body text. If 
you apply formatting to the first character of the note body, the note body’s 
number will be formatted, too. To avoid this, position the text cursor before 
the first character, choose Text > Insert > Spaces and Tabs > Zero-Width 
Space. Then while pressing Shift, use → (Right Arrow) to select the text you 
want to format. As long as you don’t select the Zero-Width Space and apply 
formatting to it, the note number will be unaffected.

To left align the first word of each footnote:

The text in footnotes is aligned to the footnote number so the first words of 
footnotes may not be aligned. In the Format section of the Notes panel, use the 
settings under In note body:

1. Using the Frame Text  tool, click on a blank area of the page to remove the 
text cursor from any text objects.

Tip: The Superscript
option scales the font 
size so the character 
strokes will be thinner 
than normal text; 
disable this feature 
and apply a character 
style with Typography 
> Superscript enabled 
to take advantage of a 
font’s true superscript 
characters, if available

Tip: You can also avoid 
this by selecting a 
character style from In 
Note Body > Number 
Style but it must have 
the same type of 
character attributes 
defined; for example, if 
the first word of the 
note body is italicized 
and you don’t want 
the Number Text to be 
italicized, select a 
character style that 
has Italics set to off

Tip: You cannot 
change Document-
wide settings while a 
Custom-formatted 
note is selected
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2. Choose Document-wide in the Notes panel.

3. Add a Tab after the footnote number by setting Format > In Note Body > 
Number Text to . To enter a Tab, click the caret  icon on the left side 
of the field.

4. Create a paragraph style for the footnote text if you have not already done so. 
Set Format > In Note Body > Note Body Style to this style.

5. Edit the footnote paragraph style and add a tab stop set to where you want to 
align the first words. Set Left Indent to the same value and then set First Line 
Indent to 0. Click OK.

To link note reference markers to note bodies:

1. Choose Generate hyperlinks so that note reference markers are linked to and 
from the note bodies in an exported PDF file. This is useful mainly for end-
notes that are separated from the note reference markers. Hyperlinks added 
for notes will not appear in the Hyperlinks panel as they are not editable.

2. Ensure Include Hyperlinks is selected when exporting to PDF.

To format note numbers with true superscripts rather than faux 
superscripts:

Affinity automatically formats note reference markers in the main body text and 
in the note text with faux superscripts because only some OpenType fonts offer 
true superscripted numerals. It is better to use true superscripted numerals if you 
are using an OpenType that offers them.

1. Using the Text Styles panel, click the Create Character Style  icon or 
choose Text > Text Styles > Create Character Style to create a character style.

2. The Text Style Editor window will be displayed. Click Figures in the left pane.

3. Select Figure Position > Superscript.

4. Click Style in the left pane.

5. Enter a unique Style Name such as Superscript and then click OK.

6. Using the Notes panel, choose Document-wide to change the document’s 
settings.

7. Set Format > In Main Text > Number Style and Format > In Note Body > 
Number Style to the character style you created above.

8. Deselect Format > In Main Text > Superscript and Format > In Note Body > 
Superscript.

The note reference markers will now be true superscripts if the font offers them.

Tip: You cannot 
change Document-
wide settings while a 
Custom-formatted 
note is selected

Tip: You cannot 
change Document-
wide settings while a 
Custom-formatted 
note is selected
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Positioning notes
These controls determine how notes are positioned.

Before changing note positioning:

1. Set Type to Footnotes, Sidenotes, or Endnotes in the Notes panel. Each type 
of note can be formatted separately.

2. Choose Document-wide to change the document’s settings or Custom to 
change the selected note(s) or the next one you insert. Refer to Note settings
on page 345 for more information.

To position footnotes:

1. In the Positioning section of the Notes panel, choose a Note position option 
from the list.

• Below Text: Notes appear below the last line of story text in the text frame 
or column.

• Bottom of Column (default): Notes appear inside the bottom of the frame, 
spanning only one column if there are multiple columns. This is the most 
common setting for books.

• Bottom of Frame: Notes appear inside the bottom of the frame and span 
the width of the frame if there are multiple columns.

• Below Frame (not recommended): Notes appear below the text frame in 
an adjacent note frame. You can specify their Max Total Height to ensure 
they don’t flow off the bottom of the page.

2. Set Min gap before to define the desired whitespace between the story text 
and the start of the first footnote and set Gap between to define the vertical 
space between each footnote. You can also set Initial advance and Min 
advance to define the position of the footnote’s first baseline; refer to Initial 
Advance on page 122.

3. Set Allow split notes to allow footnotes to be continued in the next column or 
frame to reduce undesired whitespace.

4. Set Pack short notes to start footnotes on the same line as the previous foot-
note’s body, and Short note gap to define the horizontal distance between 
them.

Tip: Unlike in Adobe®
InDesign®, the Keep 
Together paragraph 
flow setting does not 
override Allow split 
notes

Tip: Choose Text > 
Insert > Breaks > 
Column Break to split 
a footnote earlier than 
Allow split notes will 
do

Tip: You cannot 
change Document-
wide settings while a 
Custom-formatted 
note is selected
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5. In the Rules section, select First Note from Rule before to define the rule 
above a footnote, or Continued Note to define the rule above a note split 
from the previous column or text frame with Allow split notes.

6. Select Draw rule if you want a rule (line) to separate the first or continued 
footnote and then select the Stroke style including colour, width, and other 
options. Set Left indent and Length to define the width of the rule and Verti-
cal offset to define the rule’s position relative to the start of the first note.

To position sidenotes:

1. In the Positioning section of the Notes panel, choose a Note position option 
from the list.

• Left of Frame: Notes appear to the left of the text frame, even if the note 
reference marker is not in the leftmost column of the frame.

• Right of Frame: Notes appear to the right of the text frame, even if the 
note reference marker is not in the rightmost column of the frame.

• Away From Spine (recommended): In a facing-pages document, in the 
outer margin. In a non-facing-pages document, this is the same as Left of 
Frame.

• Towards Spine: In a facing-pages document, in the inner margin. In a 
non-facing-pages document, this is the same as Right of Frame.

• Alternate Sides: The first note in the frame will be on the outer (or left) 
side, the next on the inner (or right) side, etc.

• Closest Side (default): Notes appear on the side that is closest to the note 
reference marker. Adding and removing text will cause the notes to change 
sides.

2. Set Width and Distance from frame to define the size and position of the 
sidenote.

3. Set Min gap between to define the vertical space between each sidenote. You 
can also set Initial advance and Min advance to define the position of the 
sidenote’s first baseline; refer to Initial Advance on page 122.

4. Set Allow split notes to allow sidenotes to be continued on the side of the 
next text frame for the main story. Split sidenotes are less common than split 
footnotes.

Tip: To change the 
space before the rule, 
use Min gap before in 
the Positioning 
section
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To position endnotes:

1. In the Positioning section of the Notes panel, choose a Note position option 
from the list.

• End of Story: Notes appear below the last line of text in the story in the 
same text frame.

• Separate Frame: Notes appear in a new text frame after the story’s last text 
frame to create separate endnotes for each story.

• Shared Section Frame: Notes appear in a new text frame after the section’s 
last page to create separate endnotes for each section.

• Shared Document Frame (default): Notes appear in a new text frame after 
the document’s last page to create endnotes for the entire document. This 
is the most common setting for books.

• End of Book: Refer to Adding references to an Affinity Book on page 298.

2. Set Min gap before to define the desired whitespace between the story text 
and the start of the first endnote and set Gap between to define the vertical 
space between each footnote. You can also set Initial advance and Min 
advance to define the position of the footnote’s first baseline; refer to Initial 
Advance on page 122.

3. In the Title section of the Notes panel, enter the Title text and select a para-
graph style from Title style to create an automatic heading for endnotes 
displayed in a separate frame than the story text. To create your own heading, 
leave the Title text field blank.

How notes work:

Footnotes and sidenotes, as well as endnotes positioned at the end of a story, are 
stored in individual text frames associated with a note reference marker. These 
frames are similar to a pinned text frame so if you expand the main text frame’s 
layer in the Layers panel you’ll see that the note frames are child layers.

Affinity will display X‐handles at the corners and midpoints of a selected note to 
indicate that you cannot move or scale the layer. The width of the text frame for 
footnotes and endnotes is determined by the column or frame they are associated 
with while the width of the frame for sidenotes is set in the Notes panel. The 
height is always determined by the note’s content.
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Importing notes from Microsoft® Word
Footnotes imported from a Microsoft® Word .docx file will all use custom set-
tings because they won’t match the document’s Document-wide settings. They 
will likely all have a paragraph style named Footnote Text which you could rede-
fine in Affinity but footnotes aren’t properly formatted after importing from 
Word so it is recommended you reformat them in Affinity.

1. After importing the .docx file, choose Revert all Footnotes to Document 
Settings from the Notes panel menu .

2. The footnotes will now be formatted with the document-wide settings (which 
default to Body as the Note body style) and likely the Footnote Reference
character style imported from Word. Footnote Reference was intended for the 
note reference marker and the number in the note body and not the rest of 
the note body, so you should remove it from the note bodies. First, define a 
new character style for the note bodies named Note Body and base it on the 
Body paragraph style, you can change the attributes for it later as desired. The 
choice of name is unimportant.

3. Using the Find and Replace panel, click the Find formatting  icon for Find
and select Footnote Reference from the Character Style menu and Body from 
Paragraph Style. Click the Find formatting  icon for Replace and select the 
new Note Body style you created above. Do not enter text in the Find or 
Replace fields. This step assumes that the document-wide settings for foot-
notes uses Body as the Note body style and that the body text imported from 
Word is not formatted with Body.

4. Click Find and then click Replace All.
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Using fields
A field is variable text that you insert into your document and which Affinity can 
update. Fields are used to insert information such as page numbers, section 
names, dates, and metadata. If you insert them on a master page the information 
displayed on a document page will be relative to that page and its section.

Affinity offers three types of fields:

• Metadata: These fields store information about the document such as title, 
author, and keywords and you can edit their values. All fields can be inserted 
into document text but these fields are commonly used for PDF metadata.

• Variables: These fields display dynamic values such as page number, section 
name, and saved date. Their values cannot be edited.

• Custom variables: You can also create your own fields and edit their names 
and values.

Using the Fields panel
To display the Fields panel:

1. Choose Window > References > Fields to display the Fields panel.

2. Collapse and expand the panel’s sections by clicking the caret  icons to the 
left of their titles.

Panel menu
Section name

Field name Metadata field value

Edit format or set format default

Variable field value’s placeholder

Tip: A field is not plain 
text so its value 
cannot be found with 
Find and Replace and 
is counted as one 
character and one 
word by the Word 
Count feature regard-
less of how many 
characters or words it 
displays

Tip: Fields are specific 
to a document and 
cannot be synced 
across Chapters of an 
Affinity Book or 
imported into another 
document
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Inserting fields
Some of the common fields are available from the Text > Insert > Fields menu 
but you must use the Fields panel to access most of them.

To insert a field:

1. Using the Frame Text  tool, position the text cursor where you want the 
field to be inserted.

2. Insert the desired field by double-clicking its name in the Fields panel or by 
choosing it from Text > Insert > Fields.

3. Choose Text > Highlight Fields to add shading behind fields such as page 
numbers to make them easier to see while editing your document. This 
shading will not be printed.

To edit the value of a metadata field:

1. Click a field value in the Fields panel and then click it a second time—do not 
double-click. Enter a new value and press Return.

To delete a field:

1. Delete a field as you would any other character with Backspace or Delete. A 
field is treated as a single character so you need only press the key once.

To expand a field and convert it to regular text:

1. Using the Frame Text  tool, right-click the field in the document text and 
choose Expand Field from the context menu.

Field types
All page number fields display page numbers in the numbering format defined 
for the field’s section and are relative to the section’s starting page number. If you 
haven’t used sections in the document, page numbers will be numbered 1, 2, 3…

Section Field Displays

Document Information Author User who created the document; you can change the name

 Tags Keywords, used for PDF export; use commas to separate them

 Comments Freeform text for your own use, this isn’t displayed elsewhere or
  exported to PDF

 Title Freeform text for a PDF file’s title

 Subject Freeform text for a PDF file’s subject

 Revision For your own use, this isn’t displayed elsewhere or exported to PDF

 Publisher Freeform text for the name of the publisher of the PDF file

 Illustrator Freeform text for the name of the illustrator of the PDF file

 ISBN-10 Freeform text for a PDF file’s 10-digit ISBN identifier

Tip: To set the default 
value for Author, edit 
this field when no 
documents are open

Tip: You can also 
double-click the value 
to insert non-editable 
fields such as dates 
but it’s better to 
always double-click 
the field names 
because some fields 
can be edited in the 
panel by clicking them
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Section Field Displays

 ISBN-13 Freeform text for a PDF file’s 13-digit ISBN identifier

Document Statistics Last edited by User who last saved the document; you can change the name

 Created Date the document was created or last use of Save As

 Saved Date the document was last saved

 Printed/Exported Date the document was last printed or exported

 Save Count Number of times the document has been saved since creation or
  last use of Save As

 Filename Name of the .af file on your computer

 Path Path to the .af file on your computer

 Total Pages Number of pages in the document

Document Sections Name Name of the section in which the field is inserted

 Running header First or last use of styled text on a page; refer to Running headers on
page 72

 Page Number Page number on which the field is inserted; refer to Page numbering
  on page 67

 Last Page Page number of the last page in the section in which the field is
  inserted

 Run Last Page Page number of the last page before which page numbering is
  restarted

Continuation Previous Frame Page number of the page for the previous text frame the field’s frame
  is linked to; if there isn’t a previous frame then it will be blank

 Next Frame Page number of the page for the next text frame the field’s frame
  is linked to; if there isn’t a previous frame then it will be blank

General Information Date & Time Date and time when the field was inserted or last updated

Data Merge Source Filename of the external data source

 Merge Index Numerical order of the merged record from the filtered index

 Unfiltered Index Numerical order of the merged record from the unfiltered index

Data Merge - filename <dynamic> Fields are generated from the external data source

Custom <user defined> Fields are defined by the user
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Formatting fields
The date and Running Header fields allow you to customise their formatting.

To format a field:

1. Using the Frame Text  tool, right-click the field in the document text and 
choose Edit Field… from the context menu. You can also select the field or 
position the text cursor before or after it and then click the respective Edit
icon beside the field in the Fields panel.

2. Format the field. Refer to Running headers on page 72 for information on 
formatting a running header. For dates, select a Language if the field’s lan-
guage doesn’t match the language of the surrounding text. Choose one of the 
preset date and/or time formats or click Custom and enter a custom format 
into the Pattern field. Refer to the table on the following page for more 
information.

3. Click Close.
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To set the default formatting for a field:

1. Position the text cursor away from date or Running Header fields and click 
the respective Edit  icon beside the field in the Fields panel.

2. Format the field and click Close. The formatting options are the same as for 
formatting a specific field.

Date and time formatting options:

Combine the following symbols in the Pattern field. Note that many are case 
sensitive. Plain text such as Today’s date: must be enclosed in apostrophes and its 
apostrophe repeated as ‘Today’’ date: ’. Non-alphabetic characters such as dashes, 
commas, periods and colons do not need to be enclosed in apostrophes.

Symbol Meaning Pattern Date examples (for September 3, 2025)

G Era G AD
  GGGG Anno Domini
  GGGGG A

y Year y 2025
  yy 25

Q Quarter Q, QQ 2 Use QQ to prefix single digits with 0
  QQQ Q2
  QQQQ 2nd quarter

M Month in year M, MM 9, 09 Use MM to prefix single digits with 0
  MMM Sep
  MMMM September
  MMMMM S

L Standalone month in year L, LL 9, 09 Use LL to prefix single digits with 0
  LLL Sep
  LLLL September
  LLLLL S

w Week of year w, ww 36, 36 Use ww to prefix single digits with 0

W Week of month W, WW 4, 04 Use WW to prefix single digits with 0

d Day in month d, dd 3, 03 Use dd to prefix single digits with 0

D Day of year D, DD, DDD 246, 246, 246 Use DD to prefix single digits with 0 or DDD to
    prefix single digits with 00

F Day of week in month F, FF 1, 01 Example is first Sunday in September
    Use FF to prefix single digits with 0

E Day of week E Sun Example is Sunday
  EEEE Sunday
  EEEEE S
  EEEEEE Su

Tip: Use Standalone 
month in year for 
languages that spell 
the month differently 
in a full date versus 
standalone; for 
example, September 
22 in Polish is 22 
września but Septem-
ber 2023 is wrzesień 
2023
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e Local day of week e, ee 1, 01 Varies by language
  eee Sun
  eeee Sunday
  eeeee S
  eeeeee Su

Symbol Meaning Pattern Time examples (for 6:07:05 p.m. EDT)

a AM or PM a varies PM (US), pm (UK, Australia), or p.m. (Canada)
  aaaaa varies p (US, UK), pm (Canada, Australia)

B Flexible day periods B varies Possible values are “in the morning”, “noon”,
    “in the afternoon”, “in the evening”, and “at
    night” (US, UK, Canada) or “morning”,
    “midday”, “afternoon”, “evening”, and “night”
    (Australia)

h Hour in day (1-12) h, hh 6, 06 Use hh to prefix single digit with 0

H Hour (0-23) H, HH 18, 18 Use HH to prefix single digit with 0

k Hour number in day (1-24) k, kk 19, 19 Use kk to prefix single digit with 0

K Hour in AM/PM (0-11) K, KK 7, 07 Use KK to prefix single digit with 0

m Minute in hour (0-59) m, mm 7, 07 Use mm to prefix single digit with 0

s Second in minute (0-59) s, ss 5, 05 Use ss to prefix single digit with 0

z Time Zone z EDT 
  zzzz Eastern Daylight Saving Time

O Time zone: localized 0 GMT-4 “O” is a letter, not a zero
  0000 GMT-04:00

V Time zone: ID V usnyc Example is New York city
  VV America/New_York
 Time zone: exemplar city VVV New York
 Time zone: generic location VVVV New York Time 

x Time zone: ISO8601 basic x -04
 Time zone: ISO8601 basic xx -0400
 Time zone: ISO8601 extended xxx -04:00

Tip: Sunday is the 1st 
day of the week for 
English US and some 
other languages but 
the 7th day of the week 
for others such as 
English UK
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Creating custom variables
Custom variables are fields that you create for use in your document. For exam-
ple, you might use a custom variable as a placeholder for a product or company 
name that will be finalized or revealed at a later date. Custom variables are also 
useful for customising previously-created documents for individual clients.

To manually create a custom variable:

1. Expand the Custom section of the Fields panel.

2. Click the Create Custom Field  icon.

3. Enter a unique Name for the field and its initial Value.

4. Click Close.

To create a custom variable based on existing text:

1. If the existing text is longer than a single word, select the text.

2. Right-click the text and choose Convert Text to Field… The custom variable 
will be created immediately using the selected text or the word you right-
clicked for both the field name and value. The Custom Field Properties
window will appear to allow you to rename the field.

To change the value of a custom variable:

1. Click the field’s value in the Fields panel and then click it a second time—do 
not double-click. Enter a new value and press Return. You can also right-click 
the field in the text frame and choose Edit Field from the context menu.

To rename a custom variable:

1. Click the Edit  icon to the right of the field in the Fields panel. You can also 
right-click the field in the text frame and choose Edit Field from the context 
menu.

2. The options are the same as for creating a custom field.

To delete a custom variable:

1. Click the Edit  icon to the right of the field in the Fields panel. Click the 
Delete  icon in the popup window.

Tip: The field will be 
formatted using the 
attributes of the first 
character, so if you 
converted two words 
to a field and the 
second word was bold, 
the bold formatting 
would be removed
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To import custom variables into another document:

Custom variables are specific to a document and cannot be synced across Chap-
ters of an Affinity Book or directly imported into another document. However, 
you can copy and paste custom variables to another document.

1. Using the Frame Text  tool, select a custom variable field and choose Copy 
from the context menu. You can also copy a range of text containing one or 
more custom variables or select its text frame.

2. Switch to the target document and choose Edit > Paste. The custom variables 
will be imported into the new document.
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Using anchors
An anchor is a position in a document that you can link to with a hyperlink or 
cross-reference or which you can use as a bookmark in an exported PDF file.

Anchors can be inserted between two characters of text or added to an object 
such as a shape or text frame. Text anchors will move with the text as you add 
and remove text before them in the story while object anchors will remain 
attached to the object.

It’s very easy to delete text anchors by mistake because they are non-printing 
characters. It’s recommended that you enable Show Anchors when working with 
text anchors. Object anchors are never visible and can be found only with the 
Anchors panel.

You can create text and object anchors manually and Affinity will create text 
anchors automatically when a table of contents is generated or when a cross-ref-
erence is added. The table of contents feature uses anchors to link its page num-
bers to pages while the cross-references feature uses anchors as the targets for its 
references.

Using the Anchors panel
To display the Anchors panel:

1. Choose Window > References > Anchors to display the Anchors panel.

2. Collapse or expand parent anchors by clicking the caret  icons to the left of 
their names—they won’t stay collapsed but it may help

3. Filter the list of anchors to just those on a specific page by choosing a specific 
page from the Area popup menu that defaults to All Spreads. If the document 
is a Chapter of an open Affinity Book, All Spreads will be renamed to Current 
Chapter and an All Chapters option will be added. Choosing All Chapters will 
show anchors in all of the Book’s chapters, allowing you to go to any of them 
even if the chapter is not open. Anchors not in the current chapter are listed 
with a Chapter  icon beside them.

Definition: An anchor
is a marker in your 
document

Tip: While Affinity 
doesn’t allow anchors 
to be applied to a 
page like bookmarks 
in Adobe® InDesign®, 
they can be applied to 
an object for more 
flexibility

Tip: Anchors are not 
displayed in the order 
they appear in the 
document or in the 
order bookmarks will 
appear in an exported 
PDF

Go to anchor Add new anchor

Panel menu

Filter by area

Selected anchor

Parent anchor

Child anchor

Export as PDF bookmark

Delete
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Inserting anchors
You can add anchors manually but Affinity will also create them automatically if 
you insert a table of contents or target paragraphs or index marks with cross-ref-
erences. If you plan to add a table of contents, it is recommended that you not 
add anchors for any headings because the table of contents feature will generate 
them automatically. You might instead consider adding the table of contents to 
your publication earlier than you need to and updating it as you work so that the 
anchors are available to you for other purposes.

If you plan to cross-reference your publication by targeting paragraphs or index 
marks, the cross-references feature will automatically insert anchors for the 
targets. But you might prefer to add anchors manually and use them as targets 
when you cross-reference your publication.

To view text anchors:

1. Choose Text > Interactive > Show Anchors to view the non-printing anchor 
symbols. These are not turned on with Text > Show Special Characters.

To insert an anchor:

1. Using the Frame Text  tool, select a word or words or position the text 
cursor before or after a word. Selected text will be used as the anchor’s default 
name.

Or to add an anchor to an object, select an object using the Move  tool.

2. Click the New Anchor  icon in the Anchors panel or choose Text > Inter-
active > Insert Anchor…

3. The Name field will be pre-filled if you selected text. If you placed the text 
cursor or selected an object, the anchor name will default to Anchor # where # 
is the next unused default anchor number. It is recommended that you enter a 
useful name if you intend to export this anchor as a PDF bookmark. A 
unique name will also avoid later confusion over the purpose of an anchor.

4. Select Export as PDF Bookmark (default) to include this anchor as a book-
mark in an exported PDF file.

An anchor symbol between two characters
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5.  From Data Merge and Field are used only for data merging which is beyond 
the scope of this manual.

To delete an anchor:

1. Select an anchor in the Anchors panel and then click the Remove Anchor
icon.

Or position the text cursor before or after a text anchor or select an object 
with an anchor and choose Text > Interactive > Delete Anchor.

You can also delete a text anchor reference as you would any other character 
with Backspace or Delete.

To rename an anchor:

1. Select an anchor in the Anchors panel and then click it a second time—do 
not double-click. Enter a new name and press Return.

Or position the text cursor before or after a text anchor or select an object 
with an anchor and choose Text > Interactive > Anchor Properties… The 
options are the same as for inserting an anchor.

To convert an anchor to a PDF bookmark:

1. Click the Bookmark  icon to the right of the anchor name in the Anchors 
panel.

Or position the text cursor before or after a text anchor or select an object 
with an anchor, choose Text > Interactive > Anchor Properties…, and select 
Export as PDF bookmark.

To move a text anchor:

You can cut and paste anchors just like any other character except that they have 
no width and can be difficult to select.

1. If text anchors are not already visible, choose Text > Interactive > Show 
Anchors to view the non-printing anchor symbols.

2. Using the Frame Text  tool, position the text cursor before or after the 
anchor. Press Shift + � or �, depending on where you placed the text cursor.

If you’re unsure if the text cursor is to the left or right of the anchor, press ←
or → (Left Arrow or Right Arrow) and if the text cursor doesn’t move, you 
just moved past it in that direction.

3. If the anchor was the target of a cross-reference you will need to reselect the 
cross-reference target with the Cross-References panel.

To make an anchor a child of another anchor:

1. Drag an anchor’s name in the panel over the desired parent anchor and then 
release the mouse button when the parent anchor becomes blue. You can also 
drag the anchor between two other anchors to make it a child of those 
anchors’ parent but you can’t specify the exact position.

Tip: Don’t cut and 
paste anchors gener-
ated by the Table of 
Contents feature 
because duplicate 
anchors will be 
created when you 
update the table of 
contents

Tip: Don’t change the 
hierarchy of anchors 
generated by the 
Table of Contents
feature because they 
will return to their 
original position when 
you update the table 
of contents

Tip: Don’t rename 
anchors generated by 
the Table of Contents
feature because 
duplicate anchors will 
be created when you 
update the table of 
contents
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To export a document to PDF and include PDF bookmarks:

1. Choose File > Export…

2. Select PDF from the popup menu of file types.

3. Select a preset such as PDF (for digital - high quality).

4. If Advanced > Include bookmarks is not selected for the preset you chose, 
select it now

You may need to enable bookmarks if they are not visible in your PDF viewer 
software. Adobe® Acrobat® Reader displays PDF bookmarks by default but if 
they’re not visible choose View > Show/Hide > Navigation Panes > Bookmarks. 
Apple Preview does not display PDF bookmarks by default so choose View > 
Table of Contents.
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Using hyperlinks
A hyperlink allows the reader of a PDF or eBook to jump to another location in 
the same publication, another file, a website, or to start an email with their 
device’s default mail application. A hyperlink can be applied to a range of text or 
to an object.

Using the Hyperlinks panel
To display the Hyperlinks panel:

1. Choose Window > References > Hyperlinks to display the Hyperlinks panel.

2. Filter the list of hyperlinks to just those on a specific page by choosing a 
specific page from the Area popup menu that defaults to All Spreads.

3. Filter the list of hyperlinks by choosing a single type of hyperlink from the 
Type popup menu that defaults to All Types.

Inserting hyperlinks
Page and Section are most useful for objects since you can’t CR an object

File is just for relative links, the file isn’t incorporated

To insert a hyperlink:

1. Using the Frame Text  tool, select a range of text. The selected text will be 
used as the default URL if you choose the URL type.

Or to add a hyperlink to an object, select an object using the Move  tool.

2. Click the Add Hyperlink  icon in the Hyperlinks panel or choose Text > 
Interactive > Insert Hyperlink…

Tip: The table of 
contents, index, and 
cross-references can 
be hyperlinked 
automatically but their 
links are not listed in 
this panel

Go to Source Go to Target Edit Hyperlink Add Hyperlink

Panel menu

Hyperlink type

Filter by area

Filter by type

Toggle sort

Child anchor

Selected hyperlink

Delete hyperlink

Tip: Unlike the 
Anchors panel, the 
Hyperlinks panel
cannot list hyperlinks 
in other chapters for 
an Affinity Book

Tip: While you could 
use a hyperlink and an 
anchor to create a 
cross-reference, it’s 
easier to do this with 
the cross-references 
feature which can also 
automatically update 
a page number or the 
link text
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3. Choose the Type of the hyperlink:

• Anchor: Select a text or object anchor from the Anchor list. If the 
document is a Chapter in an open Affinity Book, the Chapter popup 
menu will allow you to select an anchor in a different chapter. Refer to 
Using anchors on page 362 for information on creating anchors.

• Email: Enter an email address so that when the reader clicks the hyper-
link, a new email will be started using the reader’s default mail application. 
Do not include mailto: in the field but you can use the standard ?subject=
syntax, as long as you escape the spaces in the subject with %20.

• File: Click the More  icon to browse to a PDF file on your computer, 
which if you select the additional option to Include file on export will be 
linked with a relative URL in the exported PDF file so they can be 
uploaded together. If you don’t select Include file on export then an 
absolute URL to the file on your computer will be used.

• Page: Select a page number in the current document—the target is to a 
page number so if you add or remove pages the content of the target page 
number might be different. This option is not recommended because if 
you add or remove a page before the hyperlink’s target then the link will be 
to the wrong page. Use Anchor if you want the target to move as pages are 
added and removed.

• Section: Select a section in the current document.

• URL: Enter an absolute URL for a website page or file. Use File if you 
need a relative URL; inclusion of http/https is optional.

4.  From Data Merge and Field are available for all but Page and Section and are 
used only for data merging which is beyond the scope of this manual.

5.  Character Style: Select a character style to apply to the hyperlink. Affinity will 
create a default style named Hyperlink if you select Hyperlink from the list for 
a document that lacks this style.

6. Click OK.

Tip: Although you can 
select any type of file, 
the File feature works 
reliably only with PDF 
files; you may get an 
error when attempting 
to export a document 
that includes a link to 
a different type of file
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To delete a hyperlink:

1. Select a hyperlink in the Hyperlinks panel and then click the Delete Hyper-
link  icon.

Or position the text cursor before or after a hyperlink or select an object to 
which a hyperlink is applied and choose Text > Interactive > Delete Hyper-
link. Or select a range of text that includes the hyperlink or the object to 
which a hyperlink is applied and delete it.

To edit a hyperlink:

1. Position the text cursor in, before, or after a hyperlink or select an object with 
a hyperlink and choose Text > Interactive > Edit Hyperlink…, or double-
click the hyperlink in the Hyperlinks panel. The options are the same as for 
inserting a hyperlink.

To rename a hyperlink:

1. Select a hyperlink in the Hyperlinks panel and then click it a second time—
do not double-click. Enter a new name and press Return. The name has no 
impact on the hyperlink but is helpful for keeping track of the hyperlinks in a 
document

To find a hyperlink in the document:

1. Select a hyperlink in the Hyperlinks panel and click the Go to Source  icon.

To view the target of a hyperlink:

1. Select a hyperlink in the Hyperlinks panel and click the Go to Target  icon.

Or position the text cursor before or after a hyperlink or select an object to 
which a hyperlink is applied and choose Text > Interactive > Go to Hyper-
link Target.

To fix a broken hyperlink:

1. If you delete the target of an Anchor, Page, or Section hyperlink, Affinity will 
display a Broken Hyperlink  icon in the Hyperlinks panel. Delete the 
hyperlink or edit it to select a new target.

368 References
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Affinity allows you to export your documents to EPUB, the most 
popular e-book file format. EPUB files can be read with Apple® 
Books®, Google® Play™ Books, Overdrive® Libby™, and Rakuten® 
Kobo® devices. Amazon® Kindle® devices do not directly support 
EPUB but the files can be converted to Kindle’s format using the 
Send to Kindle option.

Affinity supports both types of EPUB files: Fixed-Layout and 
Reflowable. Fixed-Layout, as the name suggests, mirrors the 
design of a print book so conversion to EPUB is relatively 
straightforward. Fixed-Layout is used primarily for technical 
manuals, cookbooks, graphic novels, and magazines.

Reflowable is used for text-centric books. Converting a print 
book project to a reflowable EPUB requires an investment of 
time for best results.

Affinity also lets you create accessible PDF files for use with 
screen readers and other assistive technologies. PDF/UA is not a 
distinct form of PDF but a standard for accessible PDFs.

In this chapter
About EPUB and PDF/UA .........................................................................370
Before you begin ........................................................................................372
Setting text style export tags .................................................................373
Adding an EPUB cover page (image) ..................................................376
Using custom CSS in a Reflowable EPUB ...........................................377
Setting the reading order for PDF and Reflowable EPUB ............379
Tagging images and objects ..................................................................382
Setting document metadata ..................................................................384
Using tables of contents in EPUB ..........................................................387
Using an index in EPUB ............................................................................390
Other considerations ................................................................................391
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About EPUB and PDF/UA
EPUB and PDF/UA are unrelated formats but creating documents for export to 
them use some of the same features and techniques so they are described here 
together.

About EPUB
Affinity allows you to export your documents to an EPUB file, the most popular 
e-book file format, and it supports both Fixed-Layout and Reflowable EPUB files 
which can be viewed with an EPUB reader.

Fixed-Layout EPUB mirrors the design of a print book so conversion to EPUB is 
relatively straightforward. Fixed-Layout is used when it is important that the 
images and text are laid out in a specific format. It is primarily used for technical 
manuals, cookbooks, graphic novels, illustrated children’s books, and coffee table 
books.

Reflowable EPUB is used for text-centric books and allows text to reflow to fit 
the reader’s window or screen. Text and images will appear on different pages 
than in a print book. Reflowable is used for almost all commercial fiction and 
non-fiction books.

The Affinity user interface is designed for creating fixed-layout documents such 
as print and PDF, so you must direct Affinity how you would like text and images 
to be formatted before exporting to reflowable EPUB. Even if you use fixed-lay-
out EPUB, there are additional steps you should take to avoid errors and to make 
it easier for users to navigate your document.

Fixed-Layout EPUB Reflowable EPUB

Tip: Refer to Exporting 
to EPUB on page 419 
for instructions on 
exporting to EPUB

Definition: An EPUB 
reader is a device or 
application that allows 
users to read EPUB 
documents; examples 
include Amazon® 
Kindle®, Rakuten® 
Kobo®, Apple® Books®, 
Google® Play™ Books, 
and Overdrive® Libby™
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About PDF/UA
Accessible PDF is a general term for PDF documents that are usable by read by 
screen readers used by those with visual impairments while PDF/UA is a specific 
term for the ISO standard. PDF/UA is not a separate format of PDF but a set of 
rules that you must comply with to create a compliant document. Affinity pro-
vides the necessary features to create a compliant document but it is up to you to 
use the features appropriately.

Note that a PDF/UA compliant document must include the PDF/UA Identifier 
which Affinity does not set. It is your responsibility as a document creator to 
verify that the exported PDF is compliant and to set the metadata using a third-
party application.

The PDF/UA standard requires that you tag meaningful content (not decorative 
content) in the logical reading order to represent the document’s structure. 
Headings, lists, and tables must have export tags and images must have alterna-
tive text descriptions. Fonts must also be embedded. You must also avoid using 
colour and contrast to convey information and name links in a meaningful way 
(i.e., avoid “click here”).

A screen reader describes the document’s structure as it reads the document’s 
text to the user. For example, for a paragraph consisting of the phrase “Introduc-
tion to photography” formatted as Heading 1, a screen reader might say “Head-
ing level 1 Introduction to photography”. Tagging headings and the rest of a 
document’s structure allows users to understand the structure of your document 
without seeing it.

Lorem ipsum dolor sit 
amet metus quam, ultrices 
in, sagittis tincidunt

Introduction to photography
Suspendisse leo. Praesent turpis justo, aliquet ac, accumsan vel, 
posuere quis, pede. Morbi pretium lacus. Cras non metus. Donec 
laoreet sem at elit. Cum sociis natoque penatibus et magnis dis 
parturient montes, nascetur ridiculus mus. Vivamus iaculis dolor 
id felis. Phasellus cursus nulla non odio. Nulla a lectus sed nisi 
luctus pretium. Sed egestas rutrum odio. Nunc ornare arcu. 
Quisque at augue ac magna sollicitudin sodales. Donec nulla 
justo, adipiscing sit amet, feugiat ac, facilisis euismod, risus.

Exposure
Pellentesque tincidunt, dolor eu dignissim mollis, justo sapien 
iaculis pede, vel tincidunt lacus nisl sit amet metus. Fusce ac est 
vitae purus varius tristique. Phasellus mattis ornare ligula. Donec 
id nibh. Vestibulum metus quam, ultrices in, sagittis tincidunt, 
gravida et, sapien. Sed bibendum, lectus vitae tincidunt dapibus, 
sem felis posuere est, id ornare augue lorem in purus. 
Suspendisse ligula. Sed mollis tristique mauris. Nullam nunc 
nunc, aliquet et, tristique nec, porttitor quis, urna. Etiam eu erat. 
Morbi ut nisl. Curabitur semper sem. Nulla turpis nibh, tempor 
nec, aliquet vitae, elementum ac, mauris.

Quisque pellentesque metus ac quam. Donec magna nulla, 
aliquet vitae, congue ac, faucibus ut, erat. Donec sit amet neque. 
Donec posuere tempus massa. Duis vulputate mauris sit amet 
purus. Duis vestibulum. Fusce ac erat. Curabitur sagittis. 
Pellentesque ultricies, ante id lobortis feugiat, ipsum magna 
congue risus, pulvinar euismod arcu nunc ac turpis.

Cum sociis natoque penatibus et magnis dis parturient montes, 
nascetur ridiculus mus. Aliquam vel quam ut tellus gravida 
faucibus. Vivamus justo est, elementum vitae, malesuada eu, 
fermentum in, sapien. Donec sit amet justo. In velit. Vivamus 
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turpis pede, dignissim sed, scelerisque nec, pretium sit amet, dui. 
Nam nec felis non turpis hendrerit varius. In ultrices ornare lorem. 
Quisque bibendum, massa sed venenatis malesuada, diam ipsum 
blandit 

Suspendisse leo. Praesent turpis justo, aliquet ac, accumsan vel, 
posuere quis, pede. Morbi pretium lacus. Cras non metus. Donec 
laoreet sem at elit. Cum sociis natoque penatibus et magnis dis 
parturient montes, nascetur ridiculus mus. Vivamus iaculis dolor 
id felis. Phasellus cursus nulla non odio. Nulla a lectus sed nisi 
luctus pretium. Sed egestas rutrum odio. Nunc ornare arcu. 
Quisque at augue ac magna sollicitudin sodales. Donec nulla 
justo, adipiscing sit amet, feugiat ac, facilisis euismod, risus.

Pellentesque tincidunt, dolor eu dignissim mollis, justo sapien 
iaculis pede, vel tincidunt lacus nisl sit amet metus. Fusce ac est 
vitae purus varius tristique. Phasellus mattis ornare ligula. Donec 
id nibh. Vestibulum metus quam, ultrices in, sagittis tincidunt, 
gravida et, sapien.

Sed bibendum, lectus vitae tincidunt dapibus, sem felis posuere 
est, id ornare augue lorem in purus. Suspendisse ligula. Sed 
mollis tristique mauris. Nullam nunc nunc, aliquet et, tristique 
nec, porttitor quis, urna. Etiam eu erat. Morbi ut nisl. Curabitur 
semper sem. Nulla turpis nibh, tempor nec, aliquet vitae, 
elementum ac, mauris.

Definition: A screen 
reader is a program 
that converts written 
documents to spoken 
words or braille for 
those with impaired 
vision
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Before you begin

Customising Preflight
The Preflight feature of Affinity is invaluable for avoiding issues when exporting 
but the EPUB checks are disabled by default. It is advisable to set the Warning 
Level for EPUB (Reflowable) to Warning or Error. Refer to EPUB Reflowable on 
page 396 for a description of each option.

Choosing fonts
Affinity embeds your document’s fonts in EPUB files and allows you to select 
whether to embed them in PDF files. EPUB users may override your font choices 
with their application and device settings, and even if an embedded font works in 
a reader such as Apple Books, it will likely be ignored on a Kindle.

Check your font’s license agreement or contact your font vendor because usage in 
EPUB may be prohibited or an additional EPUB license may be required. 
Embedded fonts are encrypted so that they cannot be used outside of the 
document.

One document or two?
If your project will be printed and reflowable EPUB, the most important decision 
is whether to use a single master document or a separate document for each 
medium.

Affinity makes it possible to use a single document for both formats but only for 
books without cross-references or an index. Most projects have inevitable last-
minute edits which can make it difficult to keep two documents in sync so con-
version to EPUB is often done after the print version is completed.

Tip: Affinity doesn’t 
currently offer Pre-
flight warnings 
specifically for fixed-
layout EPUB but many 
of the warnings apply 
to both and you can 
select the options 
relevant to your 
document

Tip: It is recom-
mended to use a 
single document if it 
will be exported to 
fixed-layout EPUB 
because less customi-
sation is required than 
for reflowable EPUB
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Setting text style export tags
Documents designed for print offer visual cues such as font size and the position 
of elements on the page to help readers understand the document structure. 
EPUB and accessible PDF documents require help to understand the document 
structure or reading order.

Setting export tags for paragraph and character styles allows you to define their 
level in the semantic structure to the reader.

Affinity provides the standard export tags for heading, body text, and emphasis 
styles. For example, Heading 1 will be exported as <h1> which EPUB readers and 
PDF viewers will understand is a first-level heading. The following are the export 
tags defined for Affinity’s default styles:

PDF export tags (paragraph styles only)

P For all body text paragraph styles

H1 to H6 For heading paragraph styles

EPUB export tags for paragraph styles

p For all body text paragraph styles

h1 to h6 For heading paragraph styles

EPUB export tags for character styles

em For emphasis (most readers will format as italic)

strong For emphasis (most readers will format as bold)

Affinity also allows you to assign your own export tags to text styles. You don’t 
need to assign custom tags to the following types of styles:

• Other body text styles because Affinity exports all paragraphs as <p> unless 
you assign another tag

• Bulleted and numbered lists because Affinity exports them automatically with 
<ol> (ordered), <ul> (unordered), and <li> (list item).

• Footnotes and sidenotes for reflowable EPUB because Affinity exports them 
automatically using <aside> which most EPUB readers will display in a popup 
when the note number is tapped—footnotes and sidenotes appear identically 
in reflowable EPUB. Endnotes will be treated as regular hyperlinks to anchors 
at their position in the document. You could assign a custom export tag for 
fixed-layout EPUB but it wouldn’t have a semantic meaning to the EPUB 
reader.

Tip: Refer to Exporting 
to EPUB on page 419 
for instructions on 
exporting to EPUB

Tip: Affinity does not 
have support for 
Figures so you cannot 
wrap a figure in a 
<figure> tag and its 
caption in a 
<figcaption> tag

Tip: Unlike a printed 
document in which 
the visual result is all 
that matters, it is 
vitally important to 
use text styles consis-
tently for all format-
ting when exporting 
to EPUB; avoid using 
local formatting 
except where abso-
lutely necessary, or 
where it would have 
no impact on EPUB

Tip: If you convert a 
project from Affinity 
Publisher 2 or if you 
create your own text 
styles from scratch 
without using Affinity 
3’s default styles, your 
styles will lack export 
tags and you must 
assign them manually.
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You may wish to assign these export tags to paragraph styles used for quotations 
and citations:

blockquote For block quotations; most EPUB readers will indent the paragraph by
 1–2 em

cite For citations; most EPUB readers will not automatically apply different
 formatting

To define export tags:

1. Create or edit a text style.

2. Select Export Tags in the left pane.

3. Set PDF > Export Tag and EPUB > Export Tag. Refer to the table on the 
previous page. If you enter a custom tag name, select Include class in HTML.

4. Select Include class in HTML if you entered a custom tag name or want to 
use a custom CSS class defined in a CSS file added to the document.

5. If Include class in HTML is selected, set Class Name to the name of the 
custom class and select Emit CSS to define the class using this style’s 
attributes.

6. Click OK.

Tip: Custom CSS 
classes can be defined 
in a CSS file added to 
the document with 
the EPUB panel
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To set two styles to the same Class Name:

Sometimes you may have two styles that are visually distinct but which should be 
identical in EPUB. For example, Body and Body Indented might appear differ-
ently in print but identical in EPUB. Setting both styles to the same class name 
and selecting Emit CSS for both would trigger a Preflight warning. To avoid this:

1. Base one style on the other.

2. In the first style, select Include class in HTML, set the Class Name to the 
desired name, and select Emit CSS.

3. In the second style, select Include class in HTML, set the Class Name to [No 
change], and set Emit CSS to No Change [-]. This will set the first style to be 
emitted (generated) in the EPUB CSS while the second shares the style 
definition.

Tip: Be careful that 
only one of two styles 
has Emit CSS selected 
when one of the styles 
is based on the other; 
if the checkbox is set 
to No Change (-), the 
child style will inherit 
the setting of its 
parent
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Adding an EPUB cover page (image)
If you are preparing a printed book for export to EPUB, it is likely that you 
created its cover as separate file because of the requirements from your print 
partner.

If you have a separate EPUB version of your document, you can add the cover 
image as its first page. There are two options for adding a cover image if you want 
to use the same copy of the document for both print and EPUB:

• Store the cover as an image file and attach during export: Create the cover as 
a raster (bitmapped) image. In the Export window for EPUB, set Cover Page
to Use image file in the Export window and then click Choose image file… to 
select the image.

This approach is the easier one but you must remember to re-attach the cover 
image file each time you export because this export setting will not be saved, 
even if you create an export preset.

• Place the cover in a non-printable section: Add two pages before the first 
page of the book and create a new section that starts on page 3, the original 
first page. Refer to Sections on page 66 for more information on creating 
sections. Design the cover on the first of the added pages.

• To print or export for print: Before printing or exporting, deselect 
Include on Export for the first section in the Section Manager.

• To export for EPUB: Before exporting, select Include on Export for the 
first section in the Section Manager. In the Export window for EPUB, set 
Cover Page to Rasterise First Page.

Tip: Kindle’s recom-
mended cover image 
size is 1600×2560 px

Tip: Kindle requires 
that EPUB files have a 
cover image so if you 
do not have a cover 
design then set Cover 
Image to Rasterise First 
Page when exporting
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Using custom CSS in a Reflowable EPUB
You can direct Affinity to include one or more custom CSS files to control how 
text will appear in a Reflowable EPUB document. For example, you may wish to 
use one font family for the print document but a different one for EPUB, or you 
may wish to format block quotations or emphasis in a different manner.

There is no point to including custom CSS files for a Fixed-Layout document 
because those should match the print design.

To add custom CSS code to your document:

1. Choose Window > Layout > EPUB to display the EPUB panel.

2. Select Embed on Add to embed the CSS file’s code in the document or dese-
lect it to link the CSS file as you would link an image or text file. Affinity will 
include the latest version of linked CSS files when exporting to EPUB so it is 
helpful while tweaking your CSS code.

3. Click the Add CSS File  icon to embed or link the CSS file. The filename 
will be shown for embedded files while the path and filename will be shown 
for linked files.

To delete custom CSS code from your document:

1. Click the Delete  icon to the right of a CSS file in the EPUB panel.

To use custom CSS code in your document:

1. Using the Text Styles panel, edit a paragraph style.

2. Select Export Tags in the left pane.

3. Select Include class in HTML.

4. Enter the name of a class from an embedded or linked CSS file.

5. Select Emit CSS to define the class specified in Class Name using this style’s 
attributes.

6. Click OK.

Tip: Affinity will not 
validate your CSS code

Tip: Be careful that 
only one of two styles 
has Emit CSS selected 
when one of the styles 
is based on the other; 
if the checkbox is set 
to No Change (-), the 
child style will inherit 
the setting of its 
parent
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To inspect the HTML and CSS code in an exported EPUB:

It is useful to examine the EPUB files exported by Affinity when developing 
custom CSS code. An EPUB file is actually ZIP file containing XHTML, CSS, 
image, and font files, so it can be uncompressed and its contents reviewed.

You can rename the EPUB file from .epub to .zip, uncompress it, and then view 
or edit the files in a text editor. You can also open the EPUB file directly without 
renaming it in a compatible text editor such as BBEdit for macOS.
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Setting the reading order for PDF and 
Reflowable EPUB
EPUB readers and PDF screen readers interpret documents based on the speci-
fied structure and not visually from the top to the bottom of the page.

Linking text frames so that all of the text in a chapter or article is a single story is 
an important step for structuring a document for an accessible PDF or a Reflow-
able EPUB. Including headings in the same text frames as the body text will also 
avoid issues with the order of layers.

While the initial document structure is derived from how text frames are linked 
and the order of layers in the Layers panel, you can specify a specific structure 
with the Reading Order panel.

The Reading Order panel lists all PDF articles in your document in the order 
that they should be read by an EPUB or screen reader. Affinity will automatically 
create an article for every story in your document and orders them in the order 
they appear in your document, but a PDF article is not the same as a story. You 
can combine multiple articles into a single article which will change the order 
they are read.

You can also add objects to articles for a screen reader to describe to users; 
ensure you have tagged the objects using the Tags panel so that the screen reader 
can read out an object description.

Refer to Starting chapters on new pages on page 381 for more information on the 
effective use of articles.

To display the Reading Order panel:

1. Choose Window > Layout > Reading Order to display the Reading Order 
panel.

Add selected 
object to Article

Create new 
Article

Panel menu

Child article

Story selected in an 
article

Article selected in list

Omit Article tag when exporting

Include Article tag when exporting

Delete ArticleGo to Article

Expand/collapse a 
parent article



380 EPUB

To exclude an article from the reading order:

You can exclude the articles for headers, footers, the table of contents, index, and 
any other stories that you don’t want added to the reading order.

• Click the checkmark icon next to an article to change it to an X to omit its 
article tag when exporting.

To create a new article:

1. Click the Add Article  icon. Affinity will add an empty article to the list.

2. Optional: Click the selected article name to rename it.

To add articles to another article:

You can add other articles and objects to an article to group them for your own 
convenience. For example, you could create an article named Front Matter and 
add your title, copyright, and introduction articles to it. Grouping articles does 
not change the order articles are read but makes them easier to work with.

• Drag an article over another article—the article below the pointer will turn 
blue to indicate that you can drop the article onto it to make it a child article.

To change the order of articles:

• Drag an article between other articles—a blue line will appear to indicate 
where the article will be moved.

• Drag a child article out from under its parent to move it up a level.

To delete an article:

You can only delete the articles that you have added manually.

1. Select an article in the panel list.

2. Click the Remove Article  icon. Affinity will delete the article from the list.

To find an article in the document:

1. Select an article in the panel list.

2. Click the Go to Article  icon or double-click the article in the panel list. 
Affinity will select the article’s object in the document and if required, change 
to its page.

Tip: You can only 
rename the articles 
you have created 
manually ; the names 
are not important 
because they are not 
exported
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Starting chapters on new pages
One of the most confusing issues users encounter when preparing a 
printed book for export to EPUB is starting chapters on new pages. It is 
important that you test your EPUB with multiple reader apps and devices 
to ensure page breaks appear where you want them. Manually inserted 
page breaks and breaks set with Flow Options may be ignored by some or 
all apps and devices.

Using articles in the Reading Order panel will allow you to create page 
breaks at the appropriate locations but it requires breaking the text of 
your book into multiple stories rather than linking every frame together.

It is recommended to make each type of front matter into a separate story. 
Group the cover page and the first front matter story as an article and 
then create a separate article for all other front matter stories.

If the chapters of your book are separate stores, create one article for each 
chapter. If they are a single story, you can put it in an article by itself.

Follow the same approach for end matter as you did for front matter, with 
a separate article for each type of end matter.

Images and reading order
Images pinned as inline or floated will be correctly positioned in text in a 
reflowable EPUB. Pinning images is unnecessary for a fixed-layout EPUB.

Unpinned images in a document exported to a Reflowable EPUB will be omitted 
from the file unless they are added to the document’s Reading Order.

Unpinned images should also be added to the Reading Order for an accessible 
PDF so that their Alt Text will be read in the correct order. Objects added as an 
article without Alt Text will be excluded from the reading order when exported 
to PDF.

To add an image or other object as an article:

1. Select an object.

2. Click the Add Selected Object  icon. Affinity will add the selected object as 
an article to the list.

3. Optional: Drag the article to the appropriate location in the reading order or 
add it to another article.

Example of the article structure for a 
simple novel; the stories are named 
Frame Text/1 or /2 rather than showing 
the text in them because these frames 
are on the master page layer



382 EPUB

Tagging images and objects
Any object can be tagged with alt text (alternative text) to convey its meaning for 
screen readers, and decorative elements should be tagged as such so they can be 
ignored. You can enter your own alt text or select XMP metadata present in an 
image using the Tags panel.

Only one alt text tag can be set per object in a PDF document so if an image and 
a picture frame have their own alt text, the following rules are followed:

• If you place an image with alt text inside a picture frame without alt text or 
vice versa, the alt text will be used for the framed image

• If you place an image with alt text inside a picture frame with its own alt text, 
the image’s alt text will be ignored

• If you change the alt text for a picture frame or the image inside it when they 
both have their own alt text, the new alt text will be applied to the picture 
frame and the image’s alt text will be cleared

Images in EPUB documents can be assigned a Summary and an Extended 
Description to improve accessibility. The display of these fields varies between 
EPUB readers but the Summary is usually displayed below the image and when 
clicked or tapped, the Extended Description is shown below the Summary.

Example of an Extended Description 
collapsed and expanded

Extended 
Description Text

Mark as 
Decoration

Extended 
Description Length

Alt Text

EPUB CSS Class

Alt Text Length

Panel menu
Alt Text Source
Alt Text Language

Extended Description Source
Extended Description Language

Summary of Extended Description
EPUB CSS Class
Summary Paragraph Style
Extended Description Paragraph Style
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To tag an object:

1. Choose Window > Layout > Tags to show the Tags panel if it is not already 
open.

2. Select an object using the Move  or Node  tools.

3.  Alt Text Source: Select Custom to enter your own alt text, or if XMP metadata 
is present, select XMP:Title, Description, Headline, Alt Text, or Extended 
Description as appropriate. Note that Extended Description is typically used 
with the Ext. Description Source option.

•  Language: Select a language if you selected XMP:Alt Text or Extended 
Description.

•  Text: If you selected Custom, enter a description. Press Return or click 
elsewhere in the document to finish editing the text.

4.  Ext. Description Source: An extended hidden description can also be added 
for exporting to EPUB but this option is not supported by all EPUB readers. 
See Summary Text below for more information. Select Custom to enter your 
own description, or if XMP metadata is present, select XMP:Extended 
Description.

•  Language: Select a language if you selected XMP:Extended Description.

•  Text: If you selected Custom, enter a description. Press Return or click 
elsewhere in the document to finish editing the text.

5.  Extended Description Style: Select a paragraph style for Extended Descrip-
tion Text.

6.  Summary Text: You should enter a summary if you enter an extended 
description. Affinity will use the word “Description” as the summary if you 
leave this field blank. EPUB readers usually display the summary text below 
the tagged object and when the user clicks or taps the summary the reader 
expands it to show the extended description.

7.  Summary Style: Select a paragraph style for Summary Text.

8.  EPUB Class: Enter a custom CSS class name to position the object. The class 
must be defined in a CSS file using the EPUB panel.

9.  Mark as Decoration: Select to indicate that it is a non-readable object which 
should be ignored by a screen reader and omitted from an EPUB document.

Tip: The extended 
description uses the 
aria-describedby tag

Tip: You cannot tag a 
text frame or other 
text object; to exclude 
decorative text from a 
screen reader, con-
sider converting it to 
curves and then 
tagging the path as 
decorative
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Setting document metadata

Setting metadata for a document
It is important to set metadata to improve document accessibility. Affinity offers 
basic metadata in the Fields panel and accessibility metadata in the Document 
Metadata window.

To set metadata for a document:

1. Choose Window > References > Fields to show the Fields panel if it is not 
already open.

2. Enter at least the document’s Author, Title, and Subject. Optionally, also 
enter the Publisher, Illustrator, ISBN-13 number, and Copyright informa-
tion.

3. Optional: Choose File > Document Metadata to set accessibility information.



Expert Guide to Affinity by Canva 3.0 385

Select or enter at least one option in the first four sections. Refer to the W3C’s 
Accessibility Properties for Discoverability Vocabulary for more information 
on all of these options. The audio and video metadata don’t apply to docu-
ments created with Affinity but they are included for completeness and for 
those who may hand edit their EPUB files to include audio or video features.

Section Metadata Description

Accessibility Features Annotations Select if annotations are used
 ARIA Select because all Affinity documents include at
  least some ARIA roles
 Index Select if an index is used
 Page-break Markers Select if any text frames are linked
 Page Navigation Select if exported as Fixed-Layout
 Reading Order Select if the order has been manually defined in
  the Reading Order panel
 Structural Navigation Select if headings are hierarchical and have
  EPUB export tags
 Table of Contents Select if a table of contents is used
 Alternative Text Select if all images have alt text or are tagged as
  decorative
 Described Maths Select if equations are described in alt text or
  body text
 Long Description Select if all complex images have extended
  descriptions
 Display Transformability Select if there is all text is real text (not image
  text)
 Unlocked Select if the document is free from Digital Rights
  Management (DRM) or other content restriction
  protocols
 Horizontal Writing Select if text is left-to-right (or right-to-left)
 Vertical Writing Select if text is written vertically
 With/Without Additional Select for CJK text
 Word Segmentation

https://www.w3.org/community/reports/a11y-discov-vocab/CG-FINAL-vocabulary-20241209/#accessibilityAPI-vocabulary
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Accessibility Hazards None Recommended because the audio and video
  options don’t apply to Affinity documents

Access Modes Textual Select if text is used
 Visual Select if images are used
 Chart on Visual Select if charts are used
 Diagram on Visual Select if diagrams are used
 Math on Visual Select if equations are used
 Music on Visual Select if music scores are used
 Text on Visual Select if image text is used

Access Modes Sufficient Textual Select if text is used
 Visual Select if images are used

Accessibility (General) Accessibility Summary Enter a brief, human-readable summary
 Conformance Select the level of conformance as specified by
  The DAISY Consortium
 Certified By Enter the name of the person or organisation
  responsible for compliance testing and
  certification
 Certifier Credentials Enter their credentials or the URL of the web
  page describing the certification
 Certifier Report Link Enter the URL of the certification report

4. Click OK.

Tip: Almost all books 
will select Textual and 
those with images will 
select Visual

Tip: Most books will 
omit the Accessibility 
(General) section

Tip: Almost all books 
will select Textual and 
those with images will 
select Visual

Tip: Select None
because Affinity 
doesn’t have audio or 
video options
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Using tables of contents in EPUB
A table of contents (TOC) helps users and screen readers navigate a long docu-
ment. TOCs in EPUBs are different than print because an EPUB app or device 
can interpret a TOC designed for EPUB to provide navigation controls to users.

Affinity offers four types of TOCs for EPUB documents. All EPUB documents 
must have at least one TOC for navigation purposes and compliance with the 
EPUB specification. If you don’t add one, Affinity will add one for you to avoid 
issues with certain reader apps and devices.

If you add a TOC, it or your main one should have its Type set to EPUB: Primary
so that the EPUB reader can interpret it semantically for navigation.

TOC Type Description

General Use for TOCs in a printed document and chapter TOCs in an EPUB,
 or to style a visible TOC while hiding the EPUB TOC

EPUB: Primary Use for the main TOC in a document to be exported to EPUB

EPUB: Images Use for a TOC of images (not supported by most EPUB readers)

EPUB: Tables Use for a TOC of tables (not supported by most EPUB readers)

A General TOC will display correctly on the EPUB page but will not allow read-
ers to navigate your document using the navigation features of their app or 
device. For example, Apple Books allows readers to tap the Contents icon to view 
the list of chapters or sections included in the document’s TOC. Most EPUB 
readers offer a similar feature although some don’t display page numbers.

It is important that you identify one TOC as the primary before exporting to 

Example of how a TOC would appear 
when the user taps the Contents icon 
in Apple Books for an EPUB with an 
EPUB: Primary TOC

Example of how a TOC would appear 
when the user taps the Contents icon 
in Apple Books for an EPUB with a 
General TOC

Tip: Although Affinity 
will not prevent you 
from setting multiple 
TOCs to EPUB: Primary. 
Images, or Tables, it is 
generally advisable to 
have only one of each 
of these TOC types in a 
document because 
the additional ones 
will be exported as if 
they were set to 
General

Tip: If you are prepar-
ing a book that should 
not have a visible TOC, 
don’t include a TOC in 
your document and 
Affinity will create a 
basic TOC with a link 
to the start of content

Tip: If the only TOC is 
set to General, the 
reader app or device 
navigation will not 
function correctly
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EPUB. This will have not change the TOC’s visual appearance in print, PDF, or 
EPUB.

To format your TOC for use in an EPUB document:

1. Using the Table of Contents panel, select the main TOC from the TOC list or 
navigate to its page and click in the TOC. In most documents, it will be 
named TOC 1.

2. Set Type to EPUB: Primary. The TOC’s appearance will not change but when 
you export the document to EPUB, it will be in the correct format for 
navigation.

3. For a reflowable EPUB, you must select Hide TOC page numbers when 
exporting to avoid the page numbers from a print edition’s TOC from appear-
ing in the EPUB.

To display a General TOC while hiding the EPUB TOC from the text flow:

For certain book designs, you may wish to set different options for the TOC 
visible on the EPUB page than the TOC used by the EPUB for navigation. For 
example, you might want to include second-level headings in the visible TOC but 
not in the EPUB navigation to keep the list short.

1. Using the Table of Contents panel, select the main TOC that you want to be 
visible on the page from the TOC list or navigate to its page and click in the 
TOC. In most documents, it will be named TOC 1.

2. Set Type to General.

3. Set this TOC’s options as desired.

4. Choose Document > New to add a new page at the end of the document.

5. Choose Document > Section Manager.

6. Click the Add Section  icon to create a new section.

7. Deselect Include on Export so that the page(s) in this section will not be 
included when printed or exported.

8. Close the Section Manager.

9. If the page is not based on a master page with a suitable text frame, use the 
Frame Text  tool to draw a new text frame on this page.

10. Using the Table of Contents panel, click the Insert  icon to add another 
TOC.

11. Set Type to EPUB: Primary.

12. Set this TOC’s options as desired.
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To create a TOC for images or tables:

If you include separate TOCs for images and tables with TOC Type set to EPUB: 
Images or EPUB: Tables, a few EPUB readers will be able to interpret them and 
allow users to navigate as they would a regular EPUB: Primary TOC. Unfortu-
nately, the only mainstream EPUB reader that supports this feature is Thorium. It 
doesn’t hurt to set up these TOCs properly because it will have no impact on 
their visual appearance.

1. Using the Table of Contents panel, select the images or tables TOC from the 
TOC list or navigate to its page and click in the TOC.

2. Set Type to EPUB: Images or EPUB: Tables. The TOC’s appearance will not 
change but when you export the document to EPUB, it will be in the correct 
format for navigation.

Thorium’s Navigation window 
allows users to navigate by 
Landmarks, including the Table of 
Contents (EPUB: Primary), Start of 
Content (after the TOC), List of 
Illustrations (EPUB: Images), and 
List of Tables (EPUB: Tables)
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Using an index in EPUB

Page numbers
The index in a reflowable EPUB created with Affinity will include the print 
version’s page numbers linked to the text at the top of that print page. This 
approach is aligned to current industry practices. Major publishers often include 
explanatory text above an EPUB index such as:

The page numbers in this index are for the printed version of the book and their links 
point to the start of the corresponding print pages. Depending on your e-reader screen 
and font sizes, you may need to scroll forward to find the indexed reference on a 
following page.

You cannot add explanatory text such as this automatically when exporting to 
EPUB which may necessitate creating a second version of the document.

Some users prefer to create the index manually using cross-references. The 
advantages of this approach are that cross-references created with anchors can 
link directly to the referenced word and the page numbers can be replaced with 
linked text. For example:

Print: Aperture, 17, 24

EPUB: Aperture, link 1, link 2, link 3

This approach takes considerably more effort and isn’t used by major publishers.

Page ranges
Page ranges in index entries will be exported with two linked page numbers. 
Users can navigate directly to the first or last page in a range. Some users prefer 
to deselect Group page ranges in the Index panel to expand page ranges which 
would allow users to navigate directly to any page in the range.

Grouped: Cameras, 173–175

Expanded: Cameras, 173, 174, 175

Tip: There isn’t a 
corresponding issue 
with TOCs because 
Affinity can remove a 
TOC’s page numbers 
when you export to 
reflowable EPUB

Tip: If you are using a 
single document for 
print and reflowable 
EPUB, consider adding 
the explanatory text as 
a custom field which 
can be easily inserted 
when required
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Other considerations

Converting cross-references
Cross-references that include a page number should be changed before exporting 
to reflowable EPUB. For example:

Print: Refer to Exposure on page 63

EPUB: Refer to Exposure

Cross-references in Affinity are a combination of static text and page number 
variables. Their format is defined from a preset and not a style and there isn’t a 
feature to change all cross-references to another format without editing each one 
manually. It is recommended that for a book that will be printed and exported to 
reflowable EPUB, that you use a format that will work for both mediums.

Using footnotes and sidenotes
Footnotes and sidenotes appear identically in reflowable EPUB . They are 
exported using the <aside> tag which in most EPUB readers displays the note 
reference number in the same manner as print or PDF. The actual footnote is 
displayed in a popup when the note reference number is tapped.

Links and cross-references in footnotes are not universally supported by reader 
apps and devices in reflowable EPUB and should be avoided.

Formatting hyperlinks
Hyperlinks exported to PDF or fixed-layout EPUB will appear exactly as you 
formatted them. If you want hyperlinks to be black and not underlined in the 
print version but blue and underlined in a PDF, it is up to you to reformat them 
before export. Using a character style for hyperlinks makes it easier to reformat 
them.

Hyperlinks exported to reflowable EPUB will be converted automatically to blue 
by EPUB readers. You can override the link colour by formatting them with a 
specific colour if desired. Underlining is generally not used for EPUB links.

Tip: Page numbers can 
be used in ross-refer-
ences in a fixed-layout 
EPUB

Tip: Kindle also offers 
users a Go to Footnotes
link which jumps to a 
footnotes section at 
the end of the book
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Although you can use Affinity for almost any print project, most 
Affinity users print directly to a local printer or export to PDF for 
a print-on-demand service, digital printing press, or conversion 
to film for printing on a commercial press.

Printing a document on a commercial press used to mean print-
ing colour separations to a PostScript file for delivery to a print 
partner, also referred to as a service bureau or service provider. 
The commercial operator would send the PostScript file to an 
Imagesetter for conversion to film. All of the work was done up 
front on your computer so you had complete control of the final 
product, but also the responsibility to get it right. This some-
times led to poor colour because the publishing application 
wasn’t optimized for the specific printing press and paper.

With newer applications such as Affinity, documents are 
exported to a PDF file and the print partner handles the colour 
separations to ensure colour fidelity with the printing press and 
paper.

Affinity also allows you to export to a PDF file suitable for digital 
distribution or for printing through a print-on-demand service, 
and to export to EPUB for generating ebooks that can be viewed 
on a reader app or device.

In this chapter
Preflighting documents ...........................................................................394
Printing directly to a printer ...................................................................402
Creating export presets ...........................................................................406
Printing on a commercial press .............................................................408
Exporting to PDF for digital distribution ...........................................412
Exporting to PDF for print-on-demand ..............................................416
Exporting to EPUB ......................................................................................419
Quick Export .................................................................................................423
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Preflighting documents
Preflight helps you avoid mistakes before printing and exporting. It can alert you 
to errors including spelling, overset text, broken cross-references, out-of-date 
indices and tables of contents, missing fonts and images, and much more.

Affinity can preflight a document live as you work and on demand before you 
print or export. Affinity defaults to live checking for all layout documents and to 
never for vector and photo documents.

The Preflight settings can be individually disabled or configured as a warning or 
error to indicate its severity to you and saved as a profile preset to use for differ-
ent types of documents. The profile preset includes when the Preflight check 
should be completed and is saved with a document for consistent preflight 
checking. You can also add a Preflight comment to any object to remind you to 
review it before printing or exporting. 

You can Preflight an entire Affinity Book at once but only if the Book and all of 
its Chapters are open. Refer to Preflight a Book on page 299 for more informa-
tion.

Using the Preflight panel
To display the Preflight panel:

1. Choose Window > Layout > Preflight or click the Preflight icon at the 
bottom of the document window to the right of the page navigation icons. 
The icon’s appearance will depend on whether there are errors, warnings, or 
no issues.

Status Description

 Preflight not completed because Check is set to Never

 All Preflight tests passed

 One or more Preflight warnings

 One or more Preflight errors and possibly one or more warnings

Tip: The profile preset 
selection is saved with 
the document but the 
profile is not embed-
ded in the document 
so if you send the 
document to some-
body else for review or 
open it on another 
device and you want 
the same Preflight 
settings, export your 
presets to a file that 
can be imported

Definition: Preflight
refers to the automatic 
comparison of a 
document to a check-
list and is named after 
the preflight checks 
that pilots do before 
take off
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2. The issues are sorted by page number by default but you can change that by 
choosing Sort by error type from the panel menu .

3. Select the profile preset to use from the Profile popup menu and choose when 
to Check from the three options. Click Check Now to perform a check if Live
is not selected.

Changing Preflight settings
To change Preflight settings:

1. Create or open a document—you cannot change Preflight settings without an 
open document.

2. Click the menu  icon to the right of the Profile popup menu and choose 
Edit profile… from the popup menu.

3. Choose an issue type from the left pane and configure its options.

4. You can select a Warning Level for each issue type. Select Disabled to ignore 
this issue type, Warning for it to be flagged with the yellow icon, and Error for 
it to be flagged with the Red icon. With the default settings, Error is reserved 

Tip: Preflight does not 
check for issues on 
hidden layers because 
they don’t affect 
printing or exporting

Tip: Preflight cannot 
be restricted to a page 
range and you cannot 
limit how many of 
each issue are 
reported

Panel menu

Preset menu

Page number of issue (M if master page)

Check now

Selected profile

Check when

Error

Warning

Fix issue
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for issues that will impact the successful printing or exporting of the docu-
ment but you can change them as you see fit.

5. You can select Look inside placed documents for some issue types to check 
for that type of Preflight issue in a linked or embedded document

6. The specific options for each issue type vary:

• Alt Text: Alerts you if alt text is missing for placed images and documents, 
and for vector (path) objects.

• Anchors: No specific options, alerts you if an anchor is unnamed which is 
useful for anchors generated by the Table of Contents feature for para-
graphs that are formatted as headings but lack any text.

• Bleed Hazard: If Bleed is set in Document Setup, select the Safe Zone 
Edge for which you want to be alerted. Mirror Bleed (default) will set the 
safe zone to the inverse of the bleed which is a useful amount, Trim Box
will set the safe zone to the edges of the page, and Custom allows you to 
define your own safe zone boundaries.

• Colours and Inks: Set to be alerted if any part of the document would 
exceed the specified Maximum Ink or Maximum Rich Black thresholds. 
Your print partner will tell you the values you should use for their printing 
press.

• Cross-References: Alerts you for invalid cross-references. Select Check for 
empty values to report if a cross-reference targets a blank paragraph.

• Dash Pattern Length: No specific options, alerts you if a pattern has more 
than 12 entries which would only be possible with imported content.

• Data Merge Fields: No specific options, alerts you if there are mismatched 
text field and picture frame links.

• Data Merge Update: No specific options, alerts you if a data merge source 
has been updated.

• Data Merge Validation: No specific options, alerts you if the data merge 
criteria defined in the Process section of the Data Merge Data Viewer 
trigger a warning.

• EPUB Reflowable: Checks for compatibility issues, alerts you if the follow-
ing are selected:

Check Description

Kerning Alerts you if manual kerning has been used

Important text and objects should be fully 
within the Safe Zone to avoid being trimmed

The Trim Box is enclosed by the page edges 
and approximates where trimming will occur

Objects must extend to the edge of the Bleed 
Zone when Bleed is set in Document Setup

Tip: It is recom-
mended that the 
option for Vector 
Objects be disabled 
because it will gener-
ate a Preflight warning 
or error for every line 
drawn with the Pen
tool
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Check Description

Scaling and shearing Alerts you if any characters have been sheared or
 horizontally or vertically scaled

Leading Alerts you if any paragraphs have leading set to
Exactly or % Height

Fills and strokes Alerts you if unsupported fill and stroke settings
 are used

Transparency Alerts you if transparency has been applied to text

Optical alignment Alerts you if characters are optically aligned more
 than 100%

Tab stops Alerts you if tab stops or spacing have been set

Hyphenation settings Alerts you if any hyphenation settings have been set
 other than enable auto hyphenation

Word and letter spacing Alerts you if the word and letter spacing options for
 Justified text have been changed

Paragraph spacing Warns you if Last Line Outdent has been used which
 is unsupported by EPUB

Paragraph flow Alerts you if Flow Options have been set

Decorations Alerts you if any paragraph Decorations in use are
 unsupported by EPUB

Filler text Alerts you if filler text is present in the document

Reading order Alerts you if no articles (text) are specified in the
 Reading Order

Image tags Alerts you if an untagged image has been added to
 the Reading Order

CSS files Alerts you if a linked CSS file is missing; it does not
 validate the CSS code

Style classes Alert if two text styles use the same Class name in
 Export Tags

Optional metadata Alerts you if the Author, Copyright, Publisher,
 Subject, and Comments fields are not set in the

Fields panel

Accessibility metadata Alerts you if at least one option in each section of
 the Document Metadata window is not selected

Unpinned objects Alerts you if any objects which are not tagged as
 Decorative in the Tags panel are not pinned in a
 story; unpinned objects will not be exported
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• Frame Text Scaling: Alerts you if you have linked two or more text frames 
that have different content scaling values which would cause text to 
change size when flowing from frame to frame.

• Hidden Objects: Set to be alerted to a hidden layer. This option is useful in 
case you hide layers while working and forgot to un-hide them.

• Hyperlinks: No specific options, alerts you if a link is invalid.

• Image Colour: Set to be alerted if the colour space (format) or colour 
profile of a placed image or document doesn’t match this document.

• Image Resolution: Set the minimum and maximum thresholds below and 
above which you want to be alerted to avoid low-resolution images that 
won’t print well or images that have such high resolution that it might 
affect performance.

• Index: No specific options, alerts you if outdated.

• Linked Resources: No specific options, alerts you if a linked resource is 
missing or the version in the document needs to be updated.

• Minimum Stroke Width: Because thin lines don’t print well—white lines 
disappear when neighbouring ink bleeds into them and colour lines can 
have multiple component strokes if the CMYK plates are misaligned—you 
can set the minimum widths for white, single ink, and multiple ink lines.

• Missing Fonts: No specific options, alerts you if a font is missing.

• Missing Glyphs: No specific options, alerts you if a font lacks a character 
you used set in that font.

• Overflowing Text: No specific options, alerts you if text is overflowing.

• PDF Passthrough: Set the PDF compatibility level for PDF files placed in 
the document below which you will be alerted. For example, placing a 
PDF 1.4 file with a signature into a document with this option set to 
PDF/X-1a:2003 would alert you of the incompatibility.

• PDF/X ICC Profile Check: No specific options, alerts you if the document 
cannot be exported as a valid PDF/X file.

• Proportional Scaling: Alerts you if images or embedded resources are 
distorted by having different horizontal and vertical scales. Set the thresh-
old value above which you want to be alerted for a distorted image.

• QR Code: Alerts you if QR code shapes are distorted by having different 
horizontal and vertical scales.

• Sections: No specific options, alerts you if all sections have Include on 
export disabled.

• Spelling: No specific options, alerts you of spelling mistakes and if a 
dictionary is missing for the language used.
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• TOC: No specific options, alerts you if outdated.

• Text Patterns: Set to be alerted for common issues such as multiple spaces, 
consecutive breaks, straight quotes, and more; you can set each option 
independently.

• User Comment: No specific options, alerts you if you entered a user 
comment for any object.

Refer to Affinity’s Preflight help page for a complete list of the warning and error 
messages that are associated with the above settings.

https://www.affinity.studio/help/sharing-preflight/
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To save a Preflight profile preset:

1. Click the menu  icon to the right of the Profile list and choose Create 
preset… from the popup menu.

2. Enter a preset name and click OK.

To update a Preflight profile preset:

1. Click the menu  icon to the right of the Profile list and choose Create 
preset… from the popup menu.

2. Enter the preset’s exact name and click OK. Affinity will prompt you to 
confirm that the existing preset should be replaced.

To organize, import/export, or rename or delete a Preflight profile preset:

1. Click the menu  icon to the right of the Profile list and choose Manage 
presets… from the popup menu.

2. To rename or delete a preset, select a preset and click Rename or Delete.

3. To organize presets into categories, click Create Category…, enter a category 
name, and then click OK. Then drag presets into the category—a blue line 
will appear to indicate where the preset will be moved. If you have many 
presets, you can collapse and expand the categories by clicking their caret 
icon.

4. To rename a category, click the menu  icon to the right of the category list 
and choose Rename Category… from the popup menu. To delete a category, 

Tip: The Preset 
Manager is shared 
with other parts of 
Affinity and includes 
linked categories, 
linking to the other 
applications in the 
suite, which don’t 
apply to Preflight 
because it is specific to 
Affinity
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delete all of its presets or move them to another category and then click the 
menu  icon to the right of the category name and choose Delete Cate-
gory… from the popup menu.

5. To export profile presets to share them with another user or device, click 
Export User Presets… to export all presets, or to export just those in one 
category, click the menu  icon to the right of the category name and choose 
Export User Presets… from the popup menu. Both options will create an 
.afpreflightpresets file.

6. To import profile presets from an .afpreflightpresets file, click Import Pre-
sets… to import them exactly as they were exported. To import profile pre-
sets directly into a category, click the menu  icon to the right of the category 
name and choose Import Presets to Category… from the popup menu.

Viewing and resolving Preflight issues
To enable or disable live Preflighting:

1. Click Live to enable live Preflighting, Never to disable Preflight entirely, or 
Export to Preflight only before printing or exporting a document. Although 
the button is labeled Export it works for printing, too.

This feature is saved with a profile preset and with the document.

2. Click Check Now to perform a check if Live is not selected.

To change profile presets:

1. Select the profile preset to use from the Profile list.

To review Preflight issues:

1. Hover the mouse pointer over an issue to see more information in a popup 
tip.

2. Double-click an issue to view the page with the issue; the object or text will be 
selected as appropriate.

3. If the issue has a Fix button, such as an outdated index, click it to resolve the 
issue. For certain types of issues such as missing fonts, the Fix button will 
open another window for you to resolve the issue.

Tip: Preflight reports 
can be viewed only 
within the panel and 
cannot be exported
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Printing directly to a printer
You can print directly from Affinity to any printer connected to your printer or 
network.

To print directly to a printer:

1. Choose File > Print. The options are laid out slightly differently for macOS 
and Windows due to the differences between the operating systems.

2. Adjust the printing options:

• Printer: Select a printer if you have more than one available.

• Presets (macOS) / Profile (Windows): If you’ve created a preset or profile, 
you can select it from the list.

• Copies: Enter the number of copies.

• Paper size: Select a paper size.

• Range and Scale:

• Range: Choose from Entire document, Odd pages, Even pages, Current 
page, or Selection (selected object).

• Pages: Enter a custom page range to print; for example, 10-25.

• Fit type and Scale: Select Scale and enter a scale percentage, the default 
is 100% (actual size), or select Fit to Printable or Shrink to Printable to 
enlarge or shrink the document page to match the printable area of the 
paper.

• Orientation: Select Portrait or Landscape to change the Automatic
orientation of the page on the paper.

macOS Windows
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• Document Layout:

• Model: Choose from:

Model Description

Single prints one page per sheet

Tiled prints each page over multiple sheets when the page is larger
 than the paper; you can specify the amount of overlap to
 make it easier to join sheets together

N-Up prints multiple pages or copies in rows and/or columns; for
 example, a sheet of address labels

Book facing-pages are printed side-by-side on each sheet as they
 are shown on screen

Booklet facing-pages are imposed (flipped and reordered) so they can
 be folded into a booklet

• Bleed and Marks:

• Include bleed: Select if your document has images or text that bleed off 
the page and you defined a bleed when creating the document or 
changing its layout. Always select Include printers marks when includ-
ing bleed.

• Include printers marks: Select if you want to crop a printed document 
with a paper cutter.

Printers marks Description

Include crop marks Places trim lines to indicate the trim box
 borders and fold lines to indicate where to fold
 multi-page spreads

Include registration marks Places target symbols at the corners and mid-
 points outside of the crop area

Include colour bars Places greyscale and colour bars below crop
 area to help adjust ink density during printing

Include page information Places the document name, page number, date,
 and time above the crop area

• The remainder of the options will vary depending on your version of 
macOS and the selected printer.

3. Click Print.

Tip: Refer to Book and 
booklet printing on 
page 405

Tip: Refer to N-Up 
printing on page 404
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N-Up printing
The N-Up option in the Print window allows you to print multiple pages or 
copies of the same page in rows and columns on a single sheet to save paper. This 
is useful for printing address labels, business cards, and archival records. You 
would print labels and cards at actual size but archival records might be printed 
pages at a reduced size.

Additional options are shown when you choose the N-Up model:

• Across/Down: Enter how many pages should be printed across a sheet 
(columns) and down a sheet (rows).

• Repeat: Enter how many copies should be made. While you can make 
additional copies with the normal Copies setting, this option makes copies 
of a page on a sheet before the next page.

• Skip: Enter how many pages to leave blank at the start of the N-Up impo-
sition. If Across and Down were both set to 3 for a 3x3 grid, setting Skip
to 3 would leave the first row on the first sheet blank.

• Left/Top: Enter the offset from the left and top edges of the sheet. N-Up
printing aligns the pages to the left and top of sheets.

• HGap/VGap: Enter the horizontal and vertical gaps between the pages on 
a sheet. Use these options with Left/Top to align pages or copies to a grid, 
such as on a sheet of labels.

A 6-page document 
printed N-Up with 
landscape orientation 
and Across set to 5, 
Down set to 4, Repeat
set to 3, Skip set to 0, 
and Fill last page
selected

1 1 1 1 1
2 3 3 3 4
1 1 1 2 2

4 4 5 5 5
6 6 6 1 1
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• Fill last page: Select this option to avoid wasting paper at the end of the 
document. If the number of pages and copies would result in blank col-
umns or rows, this option will repeat the start of the document until the 
last page is filled.

Book and booklet printing
The Book and Booklet options in the Print window don’t refer to printing an 
Affinity Book but to the printing layout. These options are generally used to print 
pages onto sheets twice as large, such as two US Letter pages on a Ledger sheet or 
two A4 pages on an A3 sheet. It is recommended that you use multiples of four 
pages for best results.

Pages are normally printed individually in sequence, one page per sheet, but the 
Book option prints single-sheet signatures. When printed double-sided, a single-
sheet signature would have four pages that could be folded for binding into a 
book or for side stapling, screw binding, or bound in another manner on the 
side.

The Booklet option imposes pages so the sheets of paper can be folded together 
into a booklet that could be stapled at the centre. Thick booklets will have uneven 
outer edges unless they are trimmed.

Tip: Books are typically 
made up of signatures 
of more than one 
sheet but the Book
printing layout is 
limited to single 
sheets

Definition: Imposition
refers to the flipping 
and reordering of 
pages on a sheet to 
simplify binding

54367218
An 8-page document 
printed using Booklet
would be printed on 2 
sheets folded together

Sheet Sheet

Definition: A signature
is a group of sheets 
folded in half that are 
bound into a book

76583214
An 8-page document 
printed using Book would 
be printed on 2 signatures, 
folded separately

Signature Signature



406 Publishing

Creating export presets
It is useful to create custom presets for export settings to avoid having to select 
them each time you want to export a document. Affinity includes several default 
presets for each file format but these are just starting points.

To create an Export preset:

1. Choose File > Export.

2.  File format: Select PDF from the list of formats on the left of the window.

3.  Preset: Select the preset closest to the one you want to create.

4. Change the export settings as required. When you change an option that 
overrides the preset, the preset name will disappear from above the list of 
export settings.

5. Click the menu  icon in the top-right corner of the window and choose 
Create Preset… from the popup menu.

6. Enter a name and click OK. The new preset will be listed on the left of the 
Export window below the default presets for the selected format.

Tip: One of the most 
important export 
settings is Area and it 
is not included in 
Export presets. Ensure 
you set Area to the 
correct setting every 
time you export.
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To update an Export preset:

1. In the Export window, select the preset.

2. Change the export settings as required.

3. Click the menu  icon in the top-right corner of the window and choose 
Create Preset… from the popup menu.

4. Enter the preset’s exact name and click OK. Affinity will prompt you to 
confirm that the existing preset should be replaced.

To rename an Export preset:

1. In the Export window, select the preset.

2. Click the menu  icon in the top-right corner of the window and choose 
Rename Preset… from the popup menu.

3. Enter a name and click OK.

To delete an Export preset:

1. In the Export window, select the preset.

2. Click the menu  icon in the top-right corner of the window and choose 
Delete Preset from the popup menu.

3. Click Yes to confirm the deletion of the preset.
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Printing on a commercial press
To send a publication to a printer for printing on a commercial press, you need 
to convert your Affinity document and all of its resources and fonts to a PDF file.

To export a publication for commercial printing:

1. Preflight your document and resolve any issues. Refer to Preflighting docu-
ments on page 394. Exporting your document will run preflight automatically 
unless you’ve disabled it, but it’s a best practice to resolve any issues and 
resave the document before exporting.

2. Choose File > Export.

The preview of the first page and the estimated size of the exported PDF file 
may take some time to appear, especially for long documents, and it’s not 
necessary to wait. The preview and file size will also be recalculated as you 
change options in the window.

3.  File format: Select PDF from the list of formats on the left of the window.

4.  Preset: Select a preset from the list that appears based on your print partner’s 
requirements.

Preset Description

PDF/X-4 can be used by a wide range of presses; includes device-
 independent colour spaces (formats) and live transparency

PDF/X-3:2003 similar to PDF/X-4 but does not support live transparency

PDF/X-1a:2003 colours are separated into CMYK and spot colours in the file

PDF (press ready) exports to PDF 1.7 (Acrobat 8) unlike PDF/X which is based on
 PDF 1.6; use if the document has PDF Passthrough files based
 on PDF 1.7

Tip: Click on the 
preview and press ⌘
(macOS) or Ctrl
(Windows) and + or - 
to zoom in or out on 
the Preview

Press ⌘ or Ctrl with 0
to zoom to fit, or with 
1, 2, 3, or 4 to zoom to 
100%, 200%, 400%, or 
800%, respectively

Use pinch-to-zoom on 
a trackpad or hold ⌥
(macOS) or Ctrl 
(Windows) while using 
a mouse scroll wheel 
to zoom

Use two-finger drag 
on a trackpad to pan 
in any direction; use a 
mouse scroll wheel to 
pan vertically or hold 
Shift while scrolling to 
pan horizontally
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5. Set the export settings

• Area: Select All Pages unless your document is a single page in which case 
you would select Whole Document.

• Pages (Optional): Enter a page range to limit the pages that will be 
exported. For example, 7 or 10-25.

• Preview export when complete: Select to open the PDF in your com-
puter’s default PDF viewing application.

• Rasterise: Select Unsupported properties (default, recommended) to ras-
terise only the objects that aren’t compatible with the selected PDF format. 
Select Everything to rasterise all objects or Nothing to omit objects that 
aren’t compatible with the PDF format.

• Use document resolution: Select to export the document at its native 
resolution, or deselect and enter the Raster DPI (resolution) at which 
effects and unsupported properties are rasterised. Leave this unchanged if 
you’re unsure which to use.

• Downsample images: Select and enter a resolution Above which raster 
images will be downsampled to that resolution to reduce file size.

• Resample: Select the resampling method to use if an image is up- or 
downsampled on export.

Resample options Description

Nearest Neighbour Fast but lower quality; use for hard-edge images

Bilinear Use when scaling images smaller (default)

Bicubic Use when scaling images larger

Lanczos 3 (separable) Very high quality but slower than the above
 options

Lanczos 3 (non-separable) Marginally-higher quality than Lanczos 3
 (separable) but slightly slower

• Allow JPEG compression: Select to compress raster elements to reduce file 
size but some quality may be lost (default, recommended). Deselect to 
export uncompressed. Enter a JPEG Quality level to specify the level of 
compression (default is 98 for high quality, 85 for small size).

• Compatibility: Select the version of PDF to export. This will be set appro-
priately by the preset and there is no need to change this unless you are 
creating a custom preset.

• Colour space: Select As document to use the document’s defined colour 
space (format) or select a different colour space. For PDF/X the only other 
option will be CMYK.

Tip: Don’t select All 
Spreads for a facing-
pages document 
because your com-
mercial printer will 
need the pages 
exported as individual 
pages and not as 
reader spreads (layout 
spreads)

Tip: The export 
settings are not saved 
for future use unless 
you create a preset; 
refer to Creating 
export presets on 
page 406

Tip: The All Pages
setting is not sticky so 
you must ensure that 
you select it each type 
you export
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• ICC profile: Select Use document profile to use the document’s defined 
colour profile, or select a different colour profile.

• Embed ICC profiles: Select to embed the colour profiles in the PDF file; 
this cannot be disabled for PDF/X.

• Convert image colour spaces: Select to convert all images to the colour 
space of the exported file or deselect to allow images to use a different 
colour space. For example, an RGB image in a CMYK document would be 
converted to CMYK when this option is selected. This cannot be disabled 
for PDF/X-1a:2003.

• Honour spot colours: Select to export spot colours as spot colours instead 
of converting them to an equivalent colour in the colour space. Select only 
if your printer will print a separate plate for each spot colour.

• Overprint black: Select to print black over CMYK elements instead of 
knocking out the CMYK colour below to avoid registration issues.

• Include hyperlinks: Hyperlinks serve no purpose when printing on a 
press and this option cannot be selected for PDF/X although it’s available 
for PDF (press ready).

• Include bookmarks: PDF bookmarks serve no purpose when printing on 
a press but you can select this option so the file can also be used for other 
purposes.

• Include layers: Select to not flatten the document. Select Include invisible 
layers to also include hidden layers that have non-hidden child layers.

• Include bleed: Select if your document has images or text that bleed off 
the page and you defined a bleed when creating the document or changing 
its layout. Always select Include printers marks when including bleed.

• Include printers marks: Select to include printers marks around the page 
edges to aid in trimming the pages. You can select each type of printers 
marks independently.

Printers marks Description

Crop marks Places trim lines to indicate the trim box borders and fold
 lines to indicate where to fold multi-page spreads

Registration marks Places target symbols at the corners and mid-points
 outside of the crop area to help align the colour plates

Colour bars Places greyscale and colour bars below crop area to help
 adjust ink density during printing

Page information Places the document name, page number, date, and time
 above the crop area

• Embed fonts: Select All Fonts to ensure the document will print correctly. 
For PDF (press ready), you can also select Uncommon Fonts to reduce the 

Tip: This option does 
not change the 
appearance of hyper-
links; it is up to you to 
remove hyperlink 
formatting that you 
may have applied for 
an online version of 
the document

Tip: Refer to Colour on 
page 447 for a descrip-
tion of colour formats 
(spaces) and profiles
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file size by not embedding the basic PostScript fonts or No Fonts. Do not 
select Text as Curves for a long publication because it will convert all text 
to paths and increase the file size.

• Subset fonts: Select to include only the glyphs (characters) used in the 
document rather than the entire font.

• Allow advanced features: Select to use advanced PDF features supported 
by the selected PDF format but which might not be supported by all PDF 
viewers, including stretched art text, stroked text, linear and radial gradi-
ents, and non-solid transparencies. Select this option for printing to a 
commercial press or deselect it if the PDF will also be distributed digitally 
and you aren’t sure of the viewers that will be used.

• Tagged: This option isn’t relevant when printing on a press so leave it 
deselected.

• Password protection: These options aren’t relevant when printing on a 
press.

• Location: Select Ask for Location to select the export location after click-
ing Export. Select Alongside Document to save the exported PDF in the 
same folder as the document itself.

• Show in Finder (macOS) / Explorer (Windows): Select to open a file 
window to access the file after export.

6. Click Export and then enter a filename to export the document.

Tip: Don’t use Subset 
fonts if you think you 
might ever need to 
directly edit the PDF in 
Affinity instead of 
editing the original .af 
file
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Exporting to PDF for digital distribution
To share an Affinity document with others online, an Adobe® PDF file is often the 
best format. While your computer may allow you to print to a PDF file, it is 
better to export to PDF to take advantage of the options Affinity offers.

Creating a PDF for digital distribution is similar to exporting to PDF for printing 
on a commercial press but the settings are somewhat different.

To export a publication for digital distribution:

1. Preflight your document and resolve any issues. Refer to Preflighting docu-
ments on page 394. Exporting your document will run preflight automatically 
unless you’ve disabled it, but it’s a best practice to resolve any issues and 
resave the document before exporting.

2. Choose File > Export.

The preview of the first page and the estimated size of the exported PDF file 
may take some time to appear, especially for long documents, and it’s not 
necessary to wait. The preview and file size will also be recalculated as you 
change options in the window.

3.  File format: Select PDF from the list of formats on the left of the window.

4.  Preset: Select PDF (digital - high quality) from the list that appears. If you 
need to reduce the file size, select PDF (digital - small size) to reduce the 
quality of the document’s images.

Preset Downsample Raster DPI JPEG quality

Digital – high quality 375 dpi 300 dpi 98%

Digital – small size 90 dpi 72 dpi 85%

Tip: Click on the 
preview and press ⌘
(macOS) or Ctrl
(Windows) and + or - 
to zoom in or out on 
the Preview

Press ⌘ or Ctrl with 0
to zoom to fit, or with 
1, 2, 3, or 4 to zoom to 
100%, 200%, 400%, or 
800%, respectively

Use pinch-to-zoom on 
a trackpad or hold ⌥
(macOS) or Ctrl 
(Windows) while using 
a mouse scroll wheel 
to zoom

Use two-finger drag 
on a trackpad to pan 
in any direction; use a 
mouse scroll wheel to 
pan vertically or hold 
Shift while scrolling to 
pan horizontally
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5. Set the export settings. The number of options can be intimidating but the 
most important is Area. You can leave the other options unchanged until 
you’re more familiar with the range of options.

• Area: Select All Pages unless your document is a single page in which case 
you would select Whole Document.

• Pages (Optional): Enter a page range to limit the pages that will be 
exported.

• Preview export when complete: Select to open the PDF in your com-
puter’s default PDF viewing application.

• Rasterise: Select Unsupported properties (default, recommended) to ras-
terise only the objects that aren’t compatible with the selected PDF format. 
Select Everything to rasterise all objects or Nothing to omit objects that 
aren’t compatible with the PDF format.

• Use document resolution: Select to export the document at its native 
resolution, or deselect and enter the Raster DPI (resolution) at which 
effects and unsupported properties are rasterised. Leave this unchanged if 
you’re unsure which to use.

• Downsample images: Select and enter a resolution Above which raster 
images will be downsampled to that resolution to reduce file size.

• Resample: Select the resampling method to use if an image is up- or 
downsampled on export.

Resample options Description

Nearest Neighbour Fast but lower quality; use for hard-edge images

Bilinear Use when scaling images smaller (default)

Bicubic Use when scaling images larger

Lanczos 3 (separable) Very high quality but slower than the above
 options

Lanczos 3 (non-separable) Marginally-higher quality than Lanczos 3
 (separable) but slightly slower

• Allow JPEG compression: Select to compress raster elements to reduce file 
size but some quality may be lost (default, recommended). Deselect to 
export uncompressed. Enter a JPEG Quality level to specify the level of 
compression (default is 98 for high quality, 85 for small size).

• Compatibility: Select the version of PDF to export. This will default to 
PDF 1.6 (Acrobat 7) and in general there is no need to change this unless 
you are creating a custom preset.

• Colour space: Select RGB (default, recommended) because the PDF will 
be viewed on a monitor. You can also select As document to use the 

Tip: Don’t select All 
Spreads for a facing-
pages document 
because this will make 
on-screen viewing of 
the PDF more difficult

Tip: The All Pages
setting is not sticky so 
you must ensure that 
you select it each type 
you export

Tip: The export 
settings are not saved 
for future use unless 
you create a preset; 
refer to Creating 
export presets on 
page 406



414 Publishing

document’s defined colour space (format) or select a different colour 
space.

• ICC Profile: Select SRGB IEC61966-2.1 (default, recommended) because 
the PDF will be viewed on a monitor.

• Embed ICC profiles: Select to embed the colour profiles in the PDF file.

• Convert image colour spaces: Select to convert all images to the colour 
space of the exported file or deselect to allow images to use a different 
colour space. For example, a CMYK image should be converted to RGB 
for on-screen viewing.

• Honour spot colours: This option is not relevant to digital distribution.

• Include hyperlinks: Select to include clickable links in the PDF if you have 
added hyperlinks to the document.

• Include bookmarks: Select to include bookmarks in the PDF to make it 
easier for readers to navigate the document.

• Include layers: Select to not flatten the document. Select Include invisible 
layers to also include hidden layers that have non-hidden child layers.

• Include printers marks: This option is not relevant to digital distribution.

• Embed fonts: Select All Fonts to ensure the document can be viewed 
without installing the fonts used in the document. You can also select 
Uncommon Fonts to reduce the file size by not embedding the basic Post-
Script fonts or No Fonts. Do not select Text as Curves for a long publica-
tion because it will convert all text to paths and increase the file size.

• Subset fonts: Select to include only the glyphs (characters) used in the 
document rather than the entire font.

• Allow advanced features: Deselect this to ensure that the PDF can be 
viewed by PDF viewers that don’t support advanced features, including 
stretched art text, stroked text, linear and radial gradients, and non-solid 
transparencies.

• Tagged: Select to include alt text that you’ve added to images and other 
objects to improve the accessibility of the exported PDF.

Tip: This option does 
not change the 
appearance of hyper-
links; it is up to you to 
format them to appear 
clickable

Tip: Refer to Colour on 
page 447 for a descrip-
tion of colour formats 
(spaces) and profiles
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• Password Protection: Select options to protect your document from being 
opened and/or modified and printed by others. The encryption method 
will be selected automatically based on the Compatibility option you 
selected above. Password Protection requires PDF 1.6 (Acrobat 7) or 
higher.

Option Description

Require Password to Open Select and enter a password below to prevent
 others from opening the exported PDF without
 the password

Require Password for Select and enter a password below to:
Modification and Printing

 No document printing prevent others from printing

 No content modification prevent others from modifying the PDF in an
  application such as Affinity or Adobe®
  Acrobat®

 No content copying prevent others from copying text and images in
  an application such as Affinity or Adobe®
  Acrobat®

• Location: Select Ask for Location to select the export location after click-
ing Export. Select Alongside Document to save the exported PDF in the 
same folder as the document itself.

• Show in Finder (macOS) / Explorer (Windows): Select to open a file 
window to access the file after export.

6. Click Export and then enter a filename to export the document.
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Exporting to PDF for print-on-demand
To send a publication to a self publishing or print-on-demand service such as 
Amazon® Kindle® Direct Publishing (KDP), IngramSpark®, Lulu®, or Blurb®, you 
must convert your Affinity document and all of its resources and fonts to a PDF 
file.

Exporting to PDF for a print-on-demand service is similar to exporting to PDF 
for digital distribution but the settings are somewhat different. Service providers 
frequently require that the cover be uploaded as a separate file and will provide 
instructions on whether the document should be created as RGB or CMYK.

Tip: Refer to your print-on-demand service’s instructions for their specific requirements to 
avoid costly errors.

To export a publication for print-on-demand:

1. Preflight your document and resolve any issues. Refer to Preflighting docu-
ments on page 394. Exporting your document will run preflight automatically 
unless you’ve disabled it, but it’s a best practice to resolve any issues and 
resave the document before exporting.

2. Choose File > Export.

The preview of the first page and the estimated size of the exported PDF file 
may take some time to appear, especially for long documents, and it’s not 
necessary to wait. The preview and file size will also be recalculated as you 
change options in the window.

3.  File format: Select PDF from the list of formats on the left of the window.

4.  Preset: Select PDF/X-1a:2003 from the list that appears. Your print-on-de-
mand service may also support PDF/X-3:2003.

Tip: Click on the 
preview and press ⌘
(macOS) or Ctrl
(Windows) and + or - 
to zoom in or out on 
the Preview

Press ⌘ or Ctrl with 0
to zoom to fit, or with 
1, 2, 3, or 4 to zoom to 
100%, 200%, 400%, or 
800%, respectively

Use pinch-to-zoom on 
a trackpad or hold ⌥
(macOS) or Ctrl 
(Windows) while using 
a mouse scroll wheel 
to zoom

Use two-finger drag 
on a trackpad to pan 
in any direction; use a 
mouse scroll wheel to 
pan vertically or hold 
Shift while scrolling to 
pan horizontally

Tip: Select All Pages
and not All Spreads, 
and unless directed 
otherwise by your 
print-on-demand 
service, select PDF/X-
1a:2003
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5. Set the export settings. The number of options can be intimidating but the 
most important is Area. You can leave the other options unchanged until 
you’re more familiar with the range of options.

• Area: Select All Pages.

• Pages (Optional): Enter a page range to limit the pages that will be 
exported.

• Preview export when complete: Select to open the PDF in your com-
puter’s default PDF viewing application.

• Rasterise: Select Unsupported properties (default, recommended) to ras-
terise only the objects that aren’t compatible with the selected PDF format. 
Select Everything to rasterise all objects if the file is rejected by your print-
on-demand service due to transparency issues.

• Use document resolution: Select to export the document at its native 
resolution, or deselect and enter the Raster DPI (resolution) at which 
effects and unsupported properties are rasterised. Leave this unchanged if 
you’re unsure which to use.

• Downsample images: Select and enter a resolution Above which raster 
images will be downsampled to that resolution to reduce file size.

• Resample: Select the resampling method to use if an image is up- or 
downsampled on export.

Resample options Description

Nearest Neighbour Fast but lower quality; use for hard-edge images

Bilinear Use when scaling images smaller (default)

Bicubic Use when scaling images larger

Lanczos 3 (separable) Very high quality but slower than the above
 options

Lanczos 3 (non-separable) Marginally-higher quality than Lanczos 3
 (separable) but slightly slower

• Allow JPEG compression: Select to compress raster elements to reduce file 
size but some quality may be lost (default, recommended). Deselect to 
export uncompressed. Enter a JPEG Quality level to specify the level of 
compression (default is 98 for high quality, 85 for small size).

• Compatibility: This will default to PDF/X-1A:2003 or PDF/X-3:2003 as 
you selected from Preset. There is no need to change this setting.

• Colour space: Select As document to use the document’s defined colour 
space (format) or select a different colour space.

• ICC Profile: Select Use document profile to use the document’s defined 
colour profile.

Tip: Refer to Colour on 
page 447 for a descrip-
tion of colour formats 
(spaces) and profiles

Tip: The export 
settings are not saved 
for future use unless 
you create a preset; 
refer to Creating 
export presets on 
page 406

Tip: The All Pages
setting is not sticky so 
you must ensure that 
you select it each type 
you export
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• Embed ICC profiles: Select to embed the colour profiles in the PDF file.

• Convert image colour spaces: Select to convert all images to the colour 
space of the exported file.

• Honour spot colours: Deselect because print-on-demand services gener-
ally do not offer spot colours.

• Overprint black: Select to print black over CMYK elements instead of 
knocking out the CMYK colour below to avoid registration issues.

• Include bookmarks: This setting isn’t relevant because the PDF file will be 
printed.

• Include printers marks: Deselect this option for print-on-demand.

• Embed fonts: Select All Fonts.

• Subset fonts: This setting isn’t important for print-on-demand.

• Allow advanced features: Select because it should work for most print-on-
demand services but consider deselecting it if the uploaded PDF file is 
rejected. Deselecting will disable advanced features such as stretched art 
text, stroked text, linear and radial gradients, and non-solid transparen-
cies.

• Tagged: Deselect because the PDF file will not be interacted with on 
screen.

• Password Protection: Deselect because the PDF file will not be distributed 
to others.

• Location: Select Ask for Location to select the export location after click-
ing Export. Select Alongside Document to save the exported PDF in the 
same folder as the document itself.

• Show in Finder (macOS) / Explorer (Windows): Select to open a file 
window to access the file after export.

6. Click Export and then enter a filename to export the document.
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Exporting to EPUB
The export settings for Fixed-Layout and Reflowable EPUB are markedly differ-
ent but the process is similar.

You should test the exported EPUB files on multiple apps or devices because text 
may be flowed or rendered in different ways. The W3C organisation also pro-
vides the free EPUBCheck tool to validate EPUB documents. Some apps and 
devices require use of this tool before publishing a book.

There is not a universal limit on EPUB file size but each reader app and device 
may have its own limits.

Apple Books 2 GB limit, 500 MB recommended, but only 10 MB of
 unencoded image data per story

Amazon Kindle 650 MB limit but Send to Kindle is limited to 200 MB and many
 users believe 50 MB is the practical limit

Google Play Books 100 MB limit

Rakuten Kobo 100 MB limit

To export a publication for EPUB:

1. Preflight your document and resolve any issues. Refer to Preflighting docu-
ments on page 394. Exporting your document will run preflight automatically 
unless you’ve disabled it, but it’s a best practice to resolve any issues and 
resave the document before exporting.

2. Choose File > Export.

The preview of the first page may not appear for Reflowable and the estimated 
size of the exported EPUB file may take some time to appear, especially for 

Tip: Click on the 
preview and press ⌘
(macOS) or Ctrl
(Windows) and + or - 
to zoom in or out on 
the Preview

Press ⌘ or Ctrl with 0
to zoom to fit, or with 
1, 2, 3, or 4 to zoom to 
100%, 200%, 400%, or 
800%, respectively

Use pinch-to-zoom on 
a trackpad or hold ⌥
(macOS) or Ctrl 
(Windows) while using 
a mouse scroll wheel 
to zoom

Use two-finger drag 
on a trackpad to pan 
in any direction; use a 
mouse scroll wheel to 
pan vertically or hold 
Shift while scrolling to 
pan horizontally

https://www.w3.org/publishing/epubcheck/
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long documents, and it’s not necessary to wait. The preview and file size will 
also be recalculated as you change options in the window.

3.  File format: Select EPUB (Fixed-Layout) or EPUB (Reflowable) from the list of 
formats on the left of the window.

4.  Preset: For Reflowable, the only option is EPUB (Reflowable). For Fixed-Lay-
out, select EPUB (document settings) to export your document using its native 
size and resolution or select EPUB (high quality) for professional quality. If 
you need to reduce the file size, select EPUB (small size) to reduce the quality 
of the document’s images.

Preset Downsample Raster DPI JPEG quality

Document settings Actual dpi Actual dpi  85%

High quality 375 dpi 300 dpi  98%

Small size 90 dpi 72 dpi  85%

5. Set the export settings. The number of options can be intimidating but the 
most important is Area. You can leave the other options unchanged until 
you’re more familiar with the range of options.

• Area: For Reflowable, the only option is Whole Document. For Fixed 
Layout, select All Pages and optionally reduce Width, Height, or Page DPI
to reduce the file size.

• Use document resolution: Select to export the document at its native 
resolution, or deselect and enter the Raster DPI (resolution) at which 
effects and unsupported properties are rasterised.

• Downsample images: Select and enter a resolution Above which raster 
images will be downsampled to that resolution to reduce file size.

• Resample (Fixed-Layout only): Select the resampling method to use if an 
image is up- or downsampled on export.

Resample options Description

Nearest Neighbour Fast but lower quality; use for hard-edge images

Bilinear Use when scaling images smaller (default)

Bicubic Use when scaling images larger

Lanczos 3 (separable) Very high quality but slower than the above
 options

Lanczos 3 (non-separable) Marginally-higher quality than Lanczos 3
 (separable) but slightly slower

• Allow JPEG compression: Select to compress raster elements to reduce file 
size but some quality may be lost (default, recommended). Deselect to 

Tip: The All Spreads, 
Current Spread, Current 
Page, and Pages (page 
range) options for 
Area are not 
recommended

Tip: The export 
settings are not saved 
for future use unless 
you create a preset; 
refer to Creating 
export presets on 
page 406
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export uncompressed. Enter a JPEG Quality level to specify the level of 
compression (default is 98 for high quality, 85 for small size).

• Rasterised text @ 1440 DPI (Fixed-Layout only): If a glyph used in the 
document’s text is incompatible with EPUB and must be rasterised, select 
to rasterise them at 1440 DPI instead of at a much lower resolution. It is 
rare to need to rasterise a glyph and individual glyph images are small so it 
is recommended to leave this selected.

• Convert numbered/bulleted lists to text (Reflowable only): Select to not 
automatically tag numbered and bulleted lists with <ol> (ordered), <ul>
(unordered), and <li> (list item) tags in the exported XHTML code. The 
bullets and numbers will be inserted as regular text. These options are 
generally used when the bulleted and numbered paragraphs aren’t actual 
lists and the bullet and number glyphs are decorative in nature.

• Remove line breaks (Reflowable only): Select to remove all forced line 
breaks which are often used in printed books for layout purposes but may 
cause flow issues in Reflowable EPUB on small screens.

• Generate CSS from styles (Reflowable only): Select to export a CSS class 
for each text style that has Emit CSS enabled. This option has no effect on 
custom CSS files added with the EPUB panel.

• Preserve local overrides (Reflowable only): Select to generate a CSS class 
for each local override (when local formatting has been applied without a 
text style). When selected, this option will maintain the original format-
ting but if deselected, local overrides will be ignored.

• Hide TOC page numbers (Reflowable only, highly recommended): Select 
to automatically remove the page numbers from the tables of contents to 
avoid confusing readers with fixed page numbers that don’t match the 
presentation on their app or device.

• Cover Page: Select None to omit a cover image which will result in most 
EPUB readers generating a cover page with a solid cover and the docu-
ment title.

Option Description

Rasterise first page Convert the first page to an image (Reflowable
 only)

Rasterise page Convert a page to an image (Fixed-Layout only)
 and enter a Page number and Alt Text below

Use image file Click Choose Image File… to select a raster image
 to use as the cover and enter Alt Text below

• Pagination source (Reflowable only): Select None (default) to set origin or 
starting point of page numbers in Reflowable EPUB to the start of the 
document. To use pagination that matches a print edition for citations, 

Tip: Kindle requires 
that EPUB files have a 
cover image so if you 
do not have a cover 
design then set Cover 
Image to Rasterise First 
Page

Tip: Kindle’s recom-
mended cover image 
size is 1600×2560 px
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select ISBN Number and enter a unique URN. You can also select Other 
Source and enter the name of a custom source.

• Location: Select Ask for Location to select the export location after click-
ing Export. Select Alongside Document to save the exported EPUB in the 
same folder as the document itself.

• Show in Finder (macOS) / Explorer (Windows): Select to open a file 
window to access the file after export.

6. Click Export and then enter a filename to export the document.
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Quick Export
The Quick Export panel allows you to export a document or image without 
navigating all of the options of the normal Export window opened by File > 
Export. It is best for repeated exports using the same preset.

Facing-page documents are usually exported to PDF as single pages but the Area
option is not available in Quick Export and is not included in Export presets so 
Quick Export is not recommended for facing-page documents.

To use Quick Export:

1. Choose Window > General > Quick Export to display it as a panel that you 
can keep open.

Or click the caret on the right side of the Quick Export  button in the 
Context Toolbar to open it as a temporary popup window.

Or click the Quick Export  button to immediately export the docu-
ment using the last-used export settings. Do not use this unless the button is 
labeled with the desired format.

2. Set the export settings. Some of the settings are relevant only to bitmapped 
images and can be ignored.

• Format: Select PDF from the buttons at the top of the panel. If PDF is not 
listed, click the Add Format button in the upper-right corner and select it 
from the popup that opens. Selecting a format will set the default format 
for the next time you use the Quick Export button in the Context Tool-
bar, and it will reset the Export Preset to the default preset for the format.

• Export Preset: Select a default or custom preset. Selecting a preset will 
override the Format if you select a preset for a different format.

Tip: Quick Export
cannot be used to 
export to EPUB

Panel menu

Add export Format button

Add export Format button

Export Preset

Ask for Location

Open Export 
window

Export

Preview
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• Advanced: Click to open the normal Export window.

• Location: Select Ask for Location to select the export location after click-
ing Export. Select Alongside Document to save the exported PDF in the 
same folder as the document itself.

• Show in Finder (macOS) / Explorer (Windows): Select to open a file 
window to access the file after export.

3. Click Export.

424 Publishing
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We all have different ways of working and it’s important to cus-
tomise our tools to the way we work to increase efficiency. 
Affinity provides many ways to customise the application but the 
best approach for you will depend on your computer and moni-
tor setup, your keyboard and pointing device, and your personal 
preferences.

Affinity allows you to customise the interface by moving, scaling, 
and hiding the toolbars and panels and you can save your pre-
ferred configurations as panel presets. You can also change many 
options and keyboard shortcuts and install additional spelling 
and hyphenation dictionaries.

In this chapter
Customising the interface .......................................................................426
Changing settings or preferences ........................................................444
Installing additional dictionaries ..........................................................463

Customising 11



426 Customising

Customising the interface
Affinity’s features are accessed through a combination of menu commands, 
studios, tools, and panels. Studios are specific combinations of tools and panels 
for different tasks. Tools and panels are windows that remain open while you 
work and you can choose which ones to open and where they are displayed.

You can customise the Studios, Toolbar, Context Toolbar, Tools, and panels
independently and then save the interface at any time as a panel preset that you 
can load in the future to restore the interface to your preferred setup.

Customising the Studios
Affinity combines photo editing, vector design, and page layout features in a 
unified application so you can select the Studio appropriate to your current task. 
Selecting a studio allows you to streamline the user interface with relevant tools 
and panels.

Affinity includes default studios for Layout, Vector, and Pixel tasks which are 
equivalent to the previous Publisher, Designer, and Photo applications. The 
Canva AI (Artificial Intelligence) studio offers AI tools for those who want to use 
AI in their projects. Most users working on long documents will prefer to use the 
Layout studio or a personal variation of it.

Default Studios Purpose

Layout For page layout and publishing

Vector For vector design and illustration (drawing)

Pixel For photo editing and raster (bitmapped) illustration

Canva AI For generative AI (Artificial Intelligence) and machine
 learning (ML) tools

Affinity also includes several optional studios for specific tasks. The Slice studio 
is equivalent to the former Export Options persona of Designer and Photo.

Optional Studios Purpose

Slice For creating and exporting slices of an illustration

Retouching For retouching portraits

Colour Grading For fast access to adjustments and colour evaluation

Typography For focusing on fine typography

Compositing For mixed media workflows

Note that the Develop, Liquify, and Tone Mapping personas of Photo and its 
related Astrophotography and Panorama features are similar to Affinity studios 
because they can have their own panel presets and unique shortcuts, but they’re 
invoked temporarily by choosing a command or clicking a button and not by 
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switching to a studio. They are not available in the Studio Switcher so you cannot 
export them as studios for later import.

Affinity also allows you to create your own studios that match your personal 
workflows.

To switch studios:

1. Click the Studio Switcher in the main Toolbar to select a studio.

To select a studio that isn’t currently enabled, click the Studio Manager more 
 icon and select the studio name from the list. You do not have to enable a 

studio to switch to it.

2. To change to a studio whose name doesn’t fit into the Studio Switcher, click 
the Overflow control to select from a list.

3. Or press F1, F2, F3… on macOS or F2, F3, F4… on Windows to switch to the 
first, second, third, and other studios. The numbers correspond with the 
order of the studios in the Studio Switcher.

4. Or choose the studio name from the Affinity > Studios menu (macOS) or 
File > Studios menu (Windows).

To customise the Studio Switcher’s appearance:

1. To change which studios are available in the Studio Switcher, click the Studio 
Manager more  icon and toggle the switches for the studios you want to 
enable or disable.

Overflow

Studio ManagerInactive studios Active studio

Tip: Only enabled 
(visible) studios are 
assigned function keys 
on macOS while all 
studios, including 
disabled ones, are 
assigned function keys 
on Windows, so the 
numbers may not 
correspond to the 
visible studio order

Active studio

Enabled studio

Disabled studio
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2. To change the order of studios in the Studio Switcher, click the Studio Man-
ager more  icon and drag a studio to a new position in the list. A blue line 
will appear to indicate where the studio will be moved.

3. Right-click anywhere on the Studio Switcher and choose Icon and Text
(default) to display studios as icons with their name beside them. Choose 
Icon Only to hide the studio names or Auto to display the name only for the 
active studio.

4. Right-click anywhere on the Studio Switcher and select Rich Tooltips
(default) to display a description of a studio when hovering over it, or deselect 
it to display only the studio name and shortcut.

To create a custom studio:

1. Click the Studio Manager more  icon.

2. Click Create Studio and select the studio’s options:

The Slice studio will be moved to 
this position when the mouse 
button is released

Active studio

Enabled studio

Disabled studio

Create a new studio

Tip: If you need more 
space in your Toolbar 
to add other controls, 
consider changing the 
Studio Switcher to 
Auto
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• Name: Enter a name for the new studio.

• Clone From: Select a studio to use as the base for the new studio. If you 
select None, the studio will have no tools or panels so it’s usually better to 
start from the most similar studio.

• Studio Icon: Select one of the standard icons, click the icon preview to 
upload a custom icon, or drag a custom icon onto the icon preview.

For best results and to match the standard icons, custom icons should be a 
white vector or raster design that fits in a 74 px square area in the centre of 
a 128 px square canvas on a transparent background with Remove Icon 
Colour selected. The supported file formats are .png, .jpeg, .tiff, .gif, .webp, 
and .af.

To delete a custom icon, simply select any of the standard icons.

• Remove Icon Colour: Select to use a black icon or deselect to use the 
icon’s actual colour.

• Studio Colour: Select one of the preset colour swatches or click the small 
colour swatch to the far right of the Studio Colour label to set a custom 
colour.

Name

Icon Preview Clone from (base on)

Studio colour

Studio colour presets

Studio icon

Change the Fill Foreground/
Background Colour control in the 
Tools panel to Fill and Stroke

Icon colour

Tip: Adding a custom 
icon will reset Studio 
Colour and Remove 
Icon Colour so you 
must review those 
settings

Tip: Custom icons 
saved as .af must be 
dragged to the icon 
preview on macOS 
and are not currently 
supported on 
Windows
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• Show Fill Context as Fill and Stroke: Select to configure the Fill Context
colour control at the bottom of the Tools panel for setting fill and stroke 
colours for layout and vector work instead of foreground and background 
colours for pixel work.

• Studio Description: Enter the description you wish displayed when hover-
ing over the studio in the Studio Switcher with Rich Tooltips selected.

3. Click Create to create the studio and switch to it.

4.  Recommended: Right-click the Studio Switcher and choose Update <name> 
Studio to save the current panel setup with the new studio.

To edit (change) a studio:

1. Switch to the studio, right-click the Studio Switcher, and choose Edit 
<name> Studio.

Or click the Studio Manager more  icon, right-click the studio name in the 
list, and choose Edit.

2. Change the studio’s options.

3. Click Update.

To save a studio’s UI setup, revert to the saved version, or reset to the 
master:

You can save a studio’s user interface (UI) setup so that you can revert to it at any 
time. Saving the UI setup saves the states of the main Toolbar, Tools, and panels.

1. To save a studio’s UI setup, switch to the studio, right-click the Studio 
Switcher, and choose Update <name> Studio.

2. To revert to the saved UI setup for a studio, switch to the studio, right-click 
the Studio Switcher, and choose Revert <name> Studio.

3. For the standard studios, you can also revert to the original version of the 
studio without losing your panel presets. Switch to the studio, right-click the 
Studio Switcher, and choose Reset <name> Studio to Master.

Fill Context in the Tools panel 
with Show Fill Context as Fill 
and Stroke selected so that you 
can set fill and stroke colours 
for layout and vector work

Fill Context in the Tools panel 
with Show Fill Context as Fill 
and Stroke deselected so that 
you can set foreground and 
background colours for pixel 
work

Tip: Show Fill Context
must be selected in 
Customise Tools or 
the control will not be 
visible in the Tools
panel
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To import and export studios:

You can export a studio to share with another computer or user. An exported 
studio includes the settings in the Create/Edit Studio window as well as the 
states of the main Toolbar, Tools, and panels. The position of floating panels is 
not exported nor are any panel presets.

1. To export a studio, click the Studio Manager more  icon, right-click the 
studio name in the list, and choose Export… Enter a file name and click Save. 
Affinity will save the studio as a .afstudio file.

2. To import a studio, right-click the Studio Switcher, and choose Import…
Select a .afstudio file and click Open. Affinity will switch to the imported 
studio automatically.

Studios don’t need to have unique names but they have a unique identifier 
known as a GUID. If you import a studio that already exists, you will be 
prompted whether you want to Overwrite the existing studio or Make a Copy
of it.

Tip: The position of 
floating panels cannot 
be exported because 
they might open off 
screen if the studio is 
later imported on a 
smaller display
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Customising the Toolbar
The Toolbar provides quick access to several commonly-used features. You can 
choose which controls are shown in it and you can hide it entirely but note the 
Status control provides the main indication of the current magnification level so 
it’s recommended that you keep it open.

On macOS, the Close, Minimize, and Maximize buttons (red, yellow, and green 
controls) are located in the Toolbar so closing it will also leave you without 
access to these standard controls. The background of the Toolbar also provides 
the easiest way to drag the document window but if you close it you can drag 
from an empty part of the Tools panel or the Status Bar at the bottom of the 
screen to move the window.

To open or close the Toolbar:

1. Choose View > Show > Toolbar to open or close the main Toolbar.

2. You can also close the Toolbar by right-clicking its background and choosing 
Hide Toolbar.

To customise the Toolbar:

1. The View Mode selector can be customised separately from the other con-
trols. Right-click the View Mode selector and choose Advanced to show the 
four most-common modes or deselect Advanced to show just the Vector and 
Pixel modes.

2. Choose View > Customise Toolbar… or right-click the background of the 
Toolbar and choose Customise Toolbar… to view all the icons that can be 
added to the toolbar.
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3. Drag icons you don’t use frequently out of the Toolbar and release them 
anywhere to remove them. Drag icons you want to add from the Customise
window onto the Toolbar between other icons—use the space icons and 
separator icons to organise the icons in the Toolbar.

4. To restore the Toolbar icons to their default state, drag the default set to the 
Toolbar.

5. Choose Icon and Text from Show to display labels below the icon groups or 
Icon Only to hie the labels. You can also right-click the background of the 
Toolbar to choose these same commands.

6. Click Done (macOS) or Close (Windows)

Showing the Context Toolbar
Below the main Toolbar is a second toolbar named the Context Toolbar. You 
cannot choose which controls are shown in this toolbar because they change 
dynamically based on the current tool and selected text or objects.

To show, hide, dock, and undock the Context Toolbar:

You can show, hide, dock, and undock the Context Toolbar. Docked is best for 
small screens because it will leave more space for your document while 
undocked is ideal for large screens so that you can drag it closer to where you are 
working.

It is recommended that you keep the Context Toolbar visible because it provides 
quick access to the most frequently-used features.

1. Choose View > Context Toolbar > Show to open or close the Context 
Toolbar.

2. Choose View > Context Toolbar > Dock or double-click anywhere on its 
background to dock or undock the Context Toolbar from the application 
window.

To snap the Context Toolbar to an anchored position:

You can snap Sub Tools to six anchor positions at the top and bottom of the 
document window.

1. If the Context Toolbar is not visible, choose View > Tools > Context Toolbar.

2. If the Context Toolbar is docked to the application window, choose View > 
Context Toolbar > Dock or double-click anywhere on its background to 
undock it.

3. Drag the Context Toolbar toward a corner of the document window or to the 
centre of its top or bottom edges and a light blue square will appear to indi-
cate an anchored position.
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4. A dark blue rectangle will appear when the mouse is over the anchored 
position to indicate that releasing the mouse button will snap the panel to it.

5. The Context Toolbar for the Frame Text , Art Text , and Table  tools 
will be have two rows of tools when undocked to avoid a panel that would be 
too wide for some screens. This isn’t an issue when docked because controls 
that don’t fit will be accessible with the overflow chevron  on the right side 
of the toolbar.
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Customising Tools
The Tools panel is different from other panels because it cannot be docked in a 
panel dock. It can be shown docked on the left side of the document window or 
undocked as a floating panel that you can position on the screen.

Tools can be stacked in the panel to save space. You can select from the tools in a 
stack by clicking the fly-out triangle at the bottom-right of the stacked tool and 
then selecting the tool from the fly-out menu. The selected tool will be shown in 
the panel. If the Sub Tools panel is not hidden, it will be displayed when you 
click a tool stack and then you can click another tool in Sub Tools.

You can customise the selection of tools in the panel, change the number of 
columns, and dock and undock it. 

To show, hide, dock, and undock the Tools panel:

You can show, hide, dock, and undock the Tools panel. Docked is best for small 
screens because it will leave more space for your document while undocked is 
ideal for large screens so that you can drag it closer to where you are working.

Tools panel with Sub Tools fly-out open Tools panel with Sub Tools panel beside it
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1. Choose View > Tools > Show to open or close the Tools panel. You can also 
right-click the panel and choose Hide to close it.

2. Choose View > Tools > Dock to dock or undock the Tools panel from the 
application window. You can also right-click the panel and choose Dock or 
double-click the bottom of the Tools panel.

To show and hide the Sub Tools panel:

You can show and hide the Sub Tools panel. You can still access the tools in Sub 
Tools from the fly-out menu of stacked tools so you would want to keep it open 
so that you can drag it closer to where you are working. If you don’t need fre-
quent access to it, you may wish to hide this panel.

1. Choose View > Tools > Sub Tools to open or close the Sub Tools panel. It will 
be displayed only when a stacked tool is selected. You can also right-click the 
Sub Tools panel and choose Hide Sub Tools to close it.

2. Right-click the Sub Tools panel and choose Horizontal to display its tools 
horizontally.

To snap Sub Tools to an anchored position:

You can snap Sub Tools to nine anchor positions in the document window.

1. Select a stacked tool.

2. If Sub Tools is now shown, choose View > Tools > Sub Tools.

3. Drag the Sub Tools panel toward a corner of the document window or to the 
centre of its top, left, right, or bottom edges and a light blue square will appear 
to indicate an anchored position.

4. A dark blue rectangle will appear when the mouse is over the anchored 
position to indicate that releasing the mouse button will snap the panel to it.

Dragging the Sub Tools
panel and approaching a 
anchored position (left) 
and over the anchored 
position (right)
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To change the tools in the Tools panel:

1. Choose View > Customise Tools to view all the tools that can be added to the 
Tools panel. You can filter the list of tools by their type with the list in the 
window’s upper-left corner or by entering part of a tool’s name.

2. To remove tools you don’t use frequently, drag the tool icons out of the Tools 
panel on the left and release them anywhere else.

3. To add a new tool, drag the icon you want from the Customise window onto 
the Tools panel between other icons. Some tools are available stacked and 
unstacked—stacks group similar tools that can display a popup menu from 
which you can choose a different tool. The currently-selected tool will be 
shown in the Tools panel. Stacks are indicated with triangle cues in the bot-
tom-right corner which you can click to display the popup menu. For exam-
ple, you can add the individual shape tools or the stack of shape tools.

4. Optional: Add separator lines to divide groups of tools.

5. Click Reset to restore the Tools panel icons to their default state.

6. Choose the Number of Columns if you’d prefer to view the tool icons in 
multiple columns. This is useful if you use a large set of tools on a smaller 
screen.

7. You can save the Tool panel’s tools as part of a panel preset, but not the panel’s 
docked or undocked state or its number of columns. Refer to Using Panel 
presets on page 442.

8. Click Done (macOS) or Close (Windows)

Tip: You can also click 
and hold on the tool 
to display the popup 
menu

Tip: The None swatch 
won’t be displayed for 
the Colour Selector
when tools are 
arranged in a single 
column

Tip: The Colour 
Selector control 
cannot be removed 
from the Tools panel 
and is not shown 
when customising the 
panel 
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To show or hide Rich tooltips:

1. Right-click the Tools panel and choose Rich Tooltips to show or hide the 
larger (rich) tooltips.

To show the Colour control as Fill/Stroke or Foreground/Background:

1. Right-click the Tools panel and choose Show Fill Context as Line to toggle 
between showing the Colour control at the bottom of the Tools panel as fill 
and stroke colours for vector and layout work or as foreground and back-
ground colours for pixel work.

Fill Context with Show Fill 
Context as Line selected

Fill Context with Show Fill 
Context as Line deselected

Rich tooltips (left) vs. 
normal tooltips (above)
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Customising the panels
Most of Affinity’s features can be accessed from panels that can be left open while 
you work. You can open additional panels with the Window menu and close a 
panel by choosing Close from its panel menu .

Panels can be positioned anywhere on the screen as floating windows or docked 
on the left and right sides of the screen in panel docks which you can show and 
hide independently by choosing Window > Panels > Show Left and Show Right. 
The docks provide a convenient way to keep your panels organized without 
overlapping your document. Affinity for Windows can display two columns of 
panels in each panel dock while Affinity for macOS can display only a single 
column on either side.

Panels can be grouped horizontally in panel groups to save screen space—only 
one panel will be visible at a a time but you can click the tab for another panel to 
change the visible panel. You can close an entire group at once by choosing Close 
Panel Group from its panel menu . You can also adjust the height of panel 
groups and collapse groups to make more vertical space for other panels.

Panels and panel groups can be stacked vertically in as many rows as there is 
space on your screen. Undocked panels can be snapped to the top or bottom of 
floating panels so that they can be moved as a single unit by dragging the top 
panel.

You can save your favourite panel setups as Panel Presets that you can switch 
between with the Window > Panels menu.

Tip: Affinity will 
automatically shorten 
panel names if there 
are more panel tabs in 
a group than will fit 
within the panel 
group

Definition: Panel docks
are containers for 
panels on either side 
of the document 
window

Definition: Panels are 
windows that remain 
open while you work

A docked panel group (top) 
with four panels and a second 
panel group (bottom) with 
three more panels
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To open or close a panel dock:

1. Choose Window > Panels > Show Left/Right to open or close a panel dock.

2. Or choose Window > Panels > Hide to close or open both panel docks at 
once.

To open or close a single panel:

1. Choose the panel name from the Window menu to open or close it—the 
panels are grouped as General, Layout, Pixel, Vector, etc. When you open a 
panel, it will be displayed in its default or last-used location which may be 
docked in the left or right panel dock or floating undocked above the docu-
ment window.

2. Close a panel by choosing Close from the panel menu  or by choosing its 
command again. If the panel is undocked and not part of a panel group, you 
can also click its Close  icon.

You can also open and close panels by choosing Panels… from any panel 
menu  and toggling on and off panels. There are a lot of panels in Affinity so 
you can also search by name.

To group panels:

1. To add a panel to an existing group—a row of panel tabs—drag the panel’s tab 
into the group’s row of tabs and position it between the desired tabs.

2. To create a new group—a new row of panel tabs—drag the panel’s tab above 
or below an existing panel until you see a blue rectangle appear and then 
release the mouse button.

Tip: When adding a 
panel to a group, do 
not release the mouse 
until the blue rectan-
gle disappears or you 
will create a new panel 
group
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3. To merge two panel groups, drag one group’s dragger  icon into the other 
group’s row of tabs and position it between the desired tabs. If the group has 
only a few tabs you can also drag the blank area to the right of the last tab.

To expand/collapse a panel group:

You can collapse a group of panels to the height of their tabs to provide more 
space to view the panels in another group.

1. To collapse a panel group, double-click any of the group’s panel tabs.

2. To expand a panel group, click the tab you wish to make active.

To close a panel group:

1. Choose Close Panel Group from the panel menu . If the group is undocked 
you can also click its Close  icon.

To dock and undock panels:

1. To add a floating panel to a panel dock, drag the panel’s tab into a dock and 
add it to an existing panel group or above or below a panel create a new 
group. A blue rectangle will appear to indicate when a new panel group will 
be created.

2. To float a panel as a standalone window, drag the panel’s tab out of the panel 
dock. To add it to an existing floating panel’s group, drag it onto that panel’s 
tab row.

3. To snap a panel to an undocked panel, drag the panel’s tab to one side of the 
other panel. Snapping it to the bottom of an undocked panel will allow you to 
drag the two panels as a single unit.

To resize panels, panel groups, and panel docks:

1. To change the width of a panel dock and the panels in it, position the mouse 
pointer anywhere over the dock’s interior borders. When the mouse pointer 
changes to the horizontal resize  pointer, drag the border to the desired 
width.

The blue rectangle indicates 
that releasing the mouse now 
will create a new panel group 
for the Fields tab that is being 
dragged into the left panel 
dock
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2. To change the height of a panel group in a panel dock, position the mouse 
pointer anywhere over the group’s horizontal border. When the mouse 
pointer changes to the vertical resize  pointer, drag the border to the desired 
width.

3. To resize a floating panel, drag from any of its sides or corners. When the 
mouse pointer changes to the appropriate resize pointer, drag the border or 
corner to the desired width or height.

To reset the panels to their default configuration:

1. Choose Window > Panels > Reset.

Using Panel presets
Once you have the panels set up the way you want them you can save the setup as 
a panel preset so that you can easily restore the interface to this configuration. If 
you normally work on a large display or multiple displays you might want to 
create a second preset for use on a laptop screen. Or you may wish to create 
presets for different styles of working without creating another studio.

Panel presets save the position, size, and dock status for the panels and the panel 
areas in which they can be docked, including which panel is active and the 
vertical height of panel groups.

Panel presets are not saved with studios.

To save a Panel preset:

1. Choose Window > Panels > Add Preset…

2. Enter a name for the preset and click OK.

To load a Panel preset:

1. Choose Window > Panels > preset name. 

To rename or delete a Panel preset

1. Choose Window > Panels > Manage Presets.
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2. Select a preset and then click Rename or Delete, and then enter a new name 
or confirm the deletion.
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Changing settings or preferences

General
Some of the most important settings are grouped together in the General settings 
pane

To customise general settings:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click General in the left pane.

2. Customise the Document settings:

• Reopen document(s) on startup: Select to reopen documents when 
starting Affinity. On macOS, this control will do nothing unless you have 
also deselected Close windows when quitting an application in macOS 
System Settings > Desktop & Dock.

• Switch studio based on file type: Select to automatically switch to the 
appropriate studio such as Pixel for a PNG or JPEG image. Deselect to 
always open files in the current studio.

• Limit initial zoom to a maximum of 100%: Select to avoid zooming in 
more than 100% when opening documents with small dimensions. When 
deselected, Affinity will adjust the view magnification to fit the window.
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• Documents open in a new floating window (Windows only): Select to 
open documents in a floating window instead of in the main application 
window.

• Documents open in the current active group (Windows only): Select to 
open documents as a new tab in the active window.

• Hide file extension (macOS only): Select to hide the file extension in the 
macOS Finder. Files will still have a file extension but this option will hide 
them for files saved from Affinity. Note that hidden file extensions will still 
be shown if you select Finder > Settings > Advanced > Show all filename 
extensions.

• Automatically update linked resources when modified externally (rec-
ommended): Select so that linked resources such as images and linked text 
files that you have modified outside of Affinity will be updated automati-
cally. If this option is deselected, you must manually update each modified 
resource.

• Save thumbnails with documents: Select to generate a custom thumbnail 
for a file based on the document’s first page. If this option is deselected, a 
generic thumbnail will be used for Affinity’s files.

• Enable “Save” over imported PSD files: Select if you’re exchanging PSD 
files with a Digital Asset Management program or deselect which will 
cause Affinity to save the document in a new Affinity format file. Note that 
some Affinity features are not supported by the PSD file format.

3. Customise the Text settings:

• Normalize breaks on copy plain text: Select to convert paragraph breaks 
to line breaks for text copied to the pasteboard (clipboard) as plain text or 
deselect to preserve paragraph breaks. Text is copied to the pasteboard in 
multiple formats and only applications that don’t support rich (formatted) 
text use the plain text version.

• Insert filler text as text: Select to insert filler text as static, editable text 
rather than as a dynamic field that expands to the length of the story. Filler 
text inserted as a field can be converted to static, editable text with Text > 
Expand > Expand Field.

• Import PSD text as text instead of as bitmap: Select if you want to edit 
the text in a PSD file or deselect to rasterise the text.

4. Customise the Miscellaneous settings:

• Copy items as SVG: Select to copy the selection in SVG format for better 
compatibility with some applications in which you want to edit the copied 
objects or text. Selecting this option may result in pasting SVG code as 
text in some applications.

• Prefer to keep selection after delete: Select so that when you delete an 
object, the object below it in the layer stack will be automatically selected.
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• Prefer metafile to raster when pasting from external application (Win-
dows only): Select to paste the metafile (vector) version of the pasteboard 
(clipboard) rather than the raster (bitmap) version. Objects copied to the 
Windows clipboard by other applications may be copied in both formats 
and selecting this option directs Affinity to use the metafile version.

• Load metadata from XMP sidecars: Select to automatically load metadata 
from matching sidecars for XMP files. A sidecar file can be used to store 
metadata information that isn’t compatible with certain image formats, so 
selecting this option directs Affinity to load metadata from an image’s 
companion sidecar file.

• Refine HEIC depth maps: Select to load an HEIC image file’s depth map 
as a separate editable layer. Depth maps are used for blurring backgrounds 
in portrait mode and for transparency.

• Send usage and performance data to Affinity: Select to allow anonymized 
data about your computer, operating system, and application setup to Serif 
to assist with improving Affinity. No personal information will be 
collected.

• Help improve the product by automatically uploading crash reports
(Windows only): Select to automatically send crash reports to Affinity to 
help with resolving issues. macOS users can choose whether to send crash 
reports when a crash report is displayed.

5. Customise the user interface Language: Select Default to use your operating 
system’s language if it matches one of the options, or select another of the 
options manually.
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Colour
Affinity allows you to set the default colour profile for each colour format 
(space). The default profile is used when creating a new document.

Affinity uses the ICC colour profiles installed on your computer and you can 
install additional profiles recommended by your printer.

If you’re new to working with colour printing, you should understand that 
colours are displayed on screen in RGB (Red, Green, Blue) and printed in CMYK 
(Cyan, Magenta, Yellow, Black). LAB (Luminance, A for Green to Red, B for 
Yellow to Blue) is a three-dimensional colour model that can represent any 
colour in the range of human vision and is popular for enhancing and converting 
photographs. CMYK is the best colour format (space) for colour printing.

To install a colour profile on macOS:

Quit Affinity before installing a colour profile because it checks for profiles when 
it is started.

1. Copy the .icc file(s) to /users/<username>/Library/ColorSync/Profiles. The 
default colour profiles are stored in a similar folder for all users of your com-
puter so this folder will be empty if you haven’t previously installed a colour 
profile.

2. Restart Affinity.

To install a colour profile on Windows:

1. Open Colour Management via the Control Panel or by searching for it in the 
Settings app.

2. Select the All Profiles tab.

3. Click Add, select the .icc file, and click Add.

4. Restart Affinity.

Tip: You can also 
install a colour profile 
into Affinity by choos-
ing File > Import ICC 
Profile…, but the 
profile will not be 
available to other 
applications on your 
computer
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To change colour settings:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Colour in the left pane.

2. Select the default colour profile for each colour format (space).

• RGB Colour Profile: Select the default for RGB/8 and RGB/16 documents; 
not recommended for publishing

• 32bit RGB Colour Profile: Select the default for RGB/32 (HDR) docu-
ments; not recommended for publishing

• CMYK Colour Profile: Select the default for CMYK/8 and CMYK/16 
documents; refer to the list of Popular CMYK colour profiles on page 450 
for more information

• Greyscale Colour Profile: Select the default for Grey/8 and Grey/16 
documents

• LAB Colour Profile: Select the default for LAB/16 documents; not recom-
mended for publishing

3.  Rendering Intent: Select an option for converting colours from the document 
or image’s colour gamut that are not reproducible in the output colour gamut. 
The Perceptual and Saturation rendering intents are used for re-purposing, 
such as the display or printing of photographs, while Absolute and Relative 
Colourimetric are used for proofing, such as proofing a CMYK print job on a 
6-colour inkjet printer.
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• Perceptual: Typically used to process digital and scanned photographs 
with highly saturated colours. All colours are shifted to allow out-of-
gamut colours to be shown but the relationships between colours are 
retained to preserve the overall perception.

• Saturation: Typically used for business graphics because colours are 
shifted to maximize saturation and make the image more vibrant at the 
expense of colour accuracy.

• Absolute Colourimetric: Used for side-by-side comparisons of outputs 
from different printers and when complete accuracy is required, such as 
for a logo. All colours of the original colour gamut are shifted so that the 
white points are aligned.

• Relative Colourimetric: With identical papers, Absolute and Relative will 
produce identical results but Relative accounts for differing white points, 
such as one printer using a yellowish paper.

4.  Black point compensation: Select to adjust the document’s black point for the 
current colour profile while maintaining the current contrast. Deselecting this 
may impact contrast.

5.  Convert opened files to working space: Select to automatically convert all 
opened documents with their own colour profile to the default colour profile 
set for their colour format (space). Select the And warn option so that Affin-
ity displays a temporary alert to notify you of the conversion:

6.  Warn when assigning working profile to unprofiled photos: Documents 
without a colour profile are always converted to the default colour profile set 
for their colour format (space). Select this option so that Affinity displays a 
temporary alert to notify you of the conversion.

7.  Enable HDR/EDR by default in 32-bit RGB views: Select if you have a 
compatible HDR/EDR display and want to use the full dynamic range. You 
may not want to use this if creating images for other uses. This option is 
named HDR on Windows and EDR on macOS.

8. OpenColorIO and OpenEXR: These options aren’t relevant to publishing as 
they are intended for motion picture production.

Example: When opening an RGB document without a 
colour profile in Affinity with its RGB default set to 
sRGB IEC61966-2.1, the document would be con-
verted to the default and this alert shown

Example: When opening a CMYK document set to 
Coated GRACoL 2006 (ISO 12647-2:2004) in Affinity 
with its CMYK default set to U.S. WEB COATED (SWOP) 
v2, the document would be converted to the default 
and this alert shown
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Popular CMYK colour profiles

North America Description Included

U.S. Web Coated (SWOP) v2 for printing on rolls of coated paper on a web offset press; ✓
 default for most publishing applications

U.S. Web Uncoated v2 for printing on rolls of uncoated paper on a web offset press ✓

Coated GRACoL 2006 (ISO 12647-2:2004) for printing on grade 1 paper such as for a brochure on a
 sheetfed press

Web Coated SWOP 2006 Grade 3 Paper for printing on bright, glossy lightweight paper such as for
 a magazine on a web offset press

Web Coated SWOP 2006 Grade 5 Paper for printing on lower quality lightweight paper on a web
 offset press

U.S. Sheetfed Coated v2 for printing packaging and brochures ✓

U.S. Sheetfed Uncoated v2 for printing packaging and brochures ✓

US Newsprint (SNAP 2007) for printing on rolls of newsprint on a web offset press

Europe and Australia Description

Coated FOGRA27 (ISO 12647-2:2004) for printing on paper type 1 on a web offset press, super- ✓
 seded by FOGRA39; 350% total ink coverage

Coated FOGRA39 (ISO 12647-2:2004) for printing on paper type 1 on a web offset press; 350%
 total ink coverage ✓

Web Coated FOGRA28 (ISO 12647-2:2004) for printing on paper type 3 on a web offset press; 350%
 total ink coverage ✓

Uncoated FOGRA29 (ISO 12647-2:2004) for printing on paper type 4 on a web offset press; 350%
 total ink coverage ✓

Euroscale Coated v2 for printing on paper type 1 or 2 (bright white) using
 Euroscale inks on a web offset press; 350% total ink coverage

Euroscale Uncoated v2 for printing on uncoated white paper using Euroscale
 inks on a web offset press; 260% total ink coverage

Tip: Included means 
the profile is included 
with Affinity but it is 
not in a user-accessi-
ble location
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Japan Description

Japan Color 2001 Coated for printing on paper type 3 on a sheetfed press; 350%
 total ink coverage ✓

Japan Color 2001 Uncoated for printing paper type 4; 310% total ink coverage ✓

Japan Color 2002 Newspaper for printing on rolls of newsprint on a web offset press;
 240% total ink coverage ✓

Japan Color 2003 Web Coated for printing on paper type 3 on a web offset press; 350% ✓
 total ink coverage

Japan Color 2011 Coated for printing on paper type 1 on a sheetfed press

Japan Web Coated (Ad) for printing magazine advertisements

Generic Description

Generic CMYK Profile for printing on a desktop colour printer with CMYK ink or toner;
 don’t use for commercial printing

Photoshop 4 Default CMYK  don’t use for commercial printing

Photoshop 5 Default CMYK  don’t use for commercial printing
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Keyboard shortcuts
Most users press keyboard shortcuts to invoke frequently-used menu commands 
and while Affinity has a standard set of shortcuts, some users are more familiar 
with other software and prefer to use the same shortcuts they’ve used for many 
years. Affinity allows you to change the keyboard shortcut for any menu com-
mand as well as for the tools, panels, and text input.

Some of the default shortcuts might not work with your keyboard. For example, 
the default shortcut to move the text cursor to the end of the story is ⌘ + End
(macOS) or Ctrl + End (Windows) but if you use a laptop you may not have an 
End key on your keyboard.

Once you have the keyboard shortcuts set the way you prefer you can save the 
shortcuts to a file that you can load again at any time in case you make changes 
you regret.

Shortcut files can generally only be opened in the same major version of Affinity 
for the same operating system that they were saved from. For example, a short-
cuts file saved from Affinity 2.6.0 will work in 2.6.1 but not in 3.0.0. If you save 
and load your shortcuts, it’s a good idea to save a new copy after upgrading 
Affinity to a new major version.

Affinity includes shortcuts for some of the most frequently-used menu com-
mands doesn’t have default shortcuts for some of the features used in creating 
long publications, including cross-references, indexing, and notes. If you use 
these features you should consider adding shortcuts to save time.

The symbols shown for the modifier and special keys in the shortcuts editor are:

Symbol Key Symbol Key

 Command (macOS)   Ctrl

 Shift   Option (macOS) or Alt (Windows)

 Arrow Left   Arrow Up

 Arrow Right   Arrow Down

 Home   Page Up

 End   Page Down

 Tab   Esc

 Delete   Return (macOS) or Enter (Windows)

 Function (Fn)

To change a keyboard shortcut:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Shortcuts in the left pane.

Tip: Be careful when 
editing shortcuts, 
there is no undo 
feature but you can 
restore the shortcuts 
to Serif’s defaults or 
load your own saved 
shortcuts file
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There are two unlabeled lists at the top of this window. The first is Studios
and the second is Elements.

2. Choose the Studio and user interface Element for which you wish to set 
shortcuts. Elements are groups of shortcuts corresponding to the menus, the 
tools, panels, text input, and blend modes. On macOS, the first option is 
Affinity which corresponds to the application name menu while on Windows 
the first option is the File menu.

3. Select Apply to All if you want the changes you make to apply to the same 
command in all personas, if applicable. This is on by default because it’s 
confusing to use different shortcuts for the same feature in different personas.

4. Select Ignore Modifier to create shortcuts for characters that require a modi-
fier to type. For example, to use a left parenthesis as a shortcut requires press-
ing Shift + 9 on English keyboards. If you were to press those keys to create 
the shortcut, you’d create a shortcut for a shifted-9 rather than a left parenthe-
sis. The shortcut would work, but it would appear as ⇧ 9 (macOS) or Shift+9
(Windows) rather than as (. Selecting Ignore Modifier before creating the 
shortcut will ensure the shortcut is shown correctly in the menu.

5. To add or change a keyboard shortcut, click in the box to the right of the 
command, tool, or operation you want to change and then press the shortcut 
combination you want to use. If that shortcut is already in use a warning 
icon will appear. Mouse over that icon to learn which shortcut is in conflict.

6. To delete a keyboard shortcut, click the delete  icon to the right of the 
shortcut. Do not press the Delete key to delete the shortcut or Esc to cancel 
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because that will assign the Delete or Esc keys as a shortcut for that command 
or operation.

7. Click Serif Defaults (macOS) or Reset (Windows) to restore all of the key-
board shortcuts for all personas and user interface elements to the default 
settings. On macOS, click Apple Defaults to use a more Mac-like combina-
tion of Text Input shortcuts, but note that it changes all shortcuts and not just 
Text Input.

8. Click Clear All Shortcuts to remove all shortcuts. This option is not recom-
mended because you will lose all the basic and most common shortcuts.

To save the current shortcuts:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Shortcuts in the left pane.

2. Click Save and enter a filename and select a location for the file. Affinity will 
save the shortcuts as an .affshortcuts (macOS) or .afshort (Windows) file that 
you can load at any time.

To load shortcuts from a file:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Shortcuts in the left pane.

2. Click Load and select an .affshortcuts (macOS) or .afshort (Windows) file 
from your computer.

Recommended shortcuts for references

Affinity doesn’t have default keyboard shortcuts for notes, cross-references, 
anchors, and hyperlinks. If you’re using the references features for a book you 
might find these shortcuts helpful but some will require changing the defaults for 
the listed commands. Windows users, substitute Ctrl for ⌘.

Command Shortcut Availability

Insert Cross-Reference ⌘ + R Used by Show Rulers

Edit Cross-Reference Shift + ⌘ + R Used by Rename Layer

Insert Anchor ⌘ + Y Used by Last Used (View Mode > Wireframe)

Anchor Properties Shift + ⌘ + Y Available

Insert Hyperlink ⌘ + K Used by Find in Layers

Hyperlink Properties Shift + ⌘ + K Available

Insert Footnote Shift + ⌘ + N Available: use this shortcut for whichever type
  of note you’re using
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AutoCorrect, Abbreviations, and Title exceptions
AutoCorrect allows you to automatically replace specified text with other text as 
you type. For example, you can convert straight quotation marks to typographic 
ones and replace teh with the. AutoCorrect can also automatically capitalise the 
first word of a sentence.

Abbreviations allows you to define exceptions to the automatic capitalisation of 
text. For example, you wouldn’t want to capitalise the first word after vs. which is 
typically used within a sentence.

Title exceptions allows you to define exceptions to the capitalisation of phrases 
that are formatted with the Title Case formatting option. For example, “and”
should not be capitalised with Title Case so it should be included in this excep-
tion list.

Affinity uses its own lists for each type of text replacement for every language it 
supports and doesn’t rely on the similar text replacement features built into 
macOS and Windows. This is important because while you might want the same 
corrections for basic text some of the corrections you use in Affinity may be 
more typographic and not suitable for your other applications. macOS also lacks 
separate text replacement lists for each language so Affinity’s custom feature is 
important for those who work in multiple languages.

Affinity includes default lists of AutoCorrect, Abbreviations, and Title Exceptions 
for the languages for which it provides a user interface. You must create your 
own lists for other languages. Although Affinity includes useful default lists for 
UK, American, Canadian, and Australian English, it does not include them for 
other variations of English, and you cannot easily copy the UK or American lists 
to use as a starting point.

On macOS, the user interface language and the language used for formatting text 
are not consistently spelled out for British and American English. On Windows, 
they are written as English (United Kingdom) and English (United States) but on 
macOS they are written as shown below:

Text language Interface language Defaults included for
AutoCorrect Abbreviations Title Exceptions

English (United Kingdom) English ✓ ✓ ✓

appleEnglish English (United States) ✓ ✓ ✓

�English English (United States) ✓ ✓

appleEnglish (Australia) n/a ✓ ✓ ✓

�English (Australia) n/a

appleEnglish (Canada) n/a ✓ ✓ ✓

�English (Canada) n/a

French français ✓ ✓
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Text language Interface language Defaults included for
AutoCorrect Abbreviations Title Exceptions

French (Canada) français (Canada)

German Deutsch ✓ ✓

Spanish español ✓

Italian italiano ✓

Portuguese (Brazil) português (Brasil)

Turkish Türkçe

Indonesian Indonesia

To add or remove AutoCorrect text:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click AutoCorrect in the left pane.

2. Customise the AutoCorrect rules:

• Capitalise first letter of sentence: Select to use automatic sentence capital-
isation. You can define exceptions to this rule with Abbreviations.

• Change straight quotes to typographic quotes: Select to automatically 
change single and double quotation marks as you type, for example, "x" to 
“x” and 'x' to ‘x’.
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Text language Typographic quotes

English “test”

Français [French] « text » with narrow non-breaking spaces (U+202F)

Deutsch [German] „text“

Čeština [Czech] „text“

Magyar [Hungarian] „text“

Română [Romanian] „text“

Polski [Polish] „text“

Norsk [Norwegian] «text»

Dansk [Danish] »text«

Suomi [Finnish] ”text”

Svenska [Swedish] ”text”

Türkçe [Turkish] “test”

Indonesia [Indonesian] “test”

Most other languages “text”

• Support language-dependent single typographic quotes: Select to auto-
matically change single quotation marks as you type in languages other 
than English, for example, 'x' to ‚x‘.

• Use tab to alter paragraph level instead of inserting a tab: If the text style 
has Next Level set to another text style, pressing Tab at the start of the 
paragraph will change the text style to that defined in Next Level instead of 
inserting a tab. For example, it would change Heading 1 to Heading 2. 
Pressing Shift + Tab will change to the previous level’s text style.

• Correct two initial, consecutive capitals: Select to change this common 
typo situation, for example, THe to The.

• Superscript ordinals as they are typed: Select to automatically change 
ordinals as you type, for example, 1st to 1st.

• Automatically create bulleted lists: Select to automatically change para-
graphs starting with “* ” (an asterisk and space) to a bulleted list. Note that 
this will not apply the default Bullet 1 text style.

• Automatically create numbered lists: Select to automatically change 
paragraphs starting with “1. ” (a 1 followed by a period and space) to a 
numbered list. Note that this will not apply the default Numbered 1 text 
style.

Tip: If the font sup-
ports true ordinals, use 
those instead of the 
AutoCorrect feature to 
typeset ordinals as the 
font designer 
intended; refer to 
Ordinals on page 163
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3.  Replace Text While Typing: Select to replace certain text with other text as 
you type.

4.  Language: Select the language you wish to customise. This step is required 
because each language has its own list of AutoCorrect replacements.

5. Enter the word to replace in Replace, for example, teh., and the replacement 
word or phrase in With, for example, the.

If the text in the Replace field is lowercase, then typing that text in any capi-
talisation will be replaced when you type. If you enter mixed case in the 
Replace field, typing only that specific capitalisation will be replaced. For 
example, typing MDs would normally autocorrect to Mds if Capitalise first 
letter of sentences is selected. Setting Replace to mds and With to MDs would 
allow these characters to be replaced regardless of how you typed them.

To enter a special character such as a non-breaking space or soft hyphen, copy 
it from a document and paste into With; special characters will not be visible 
in the field but they will work when the text is replaced.

Click Add to add the text replacement to the list below.

6. To delete an existing text replacement pair, select it from the list and click 
Remove.

Tip: When editing a 
variation of English 
other than British and 
American English, 
ensure you are editing 
the right text because 
this window defaults 
to your user interface 
language, not to the 
language of your text
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To add or remove Abbreviations:

You can define exceptions to the automatic capitalisation of text following com-
monly-used abbreviations.

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Abbreviation in the left pane.

2.  Language: Select the language you wish to customise. This step is required 
because each language has its own list of abbreviations.

3. Enter the abbreviation into the text field. You can enter any text string but 
only text that ends with a period will have any effect because text will not be 
automatically capitalised following abbreviations without periods. Click Add
to add the abbreviation to the list below.

4. To delete an existing abbreviation, select it from the list and click Remove.

Tip: When editing a 
variation of English 
other than British and 
American English, 
ensure you are editing 
the right text because 
the window defaults 
to your user interface 
language, not to the 
language of your text
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To add or remove Title Exceptions:

You can define exceptions to the capitalisation of phrases that are formatted with 
the Title Case formatting option.

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Title Exceptions in the left pane.

2.  Language: Select the language you wish to customise. This step is required 
because each language has its own list of title exceptions.

3. Enter the title exception into the text field. Click Add to add the abbreviation 
to the list below.

4. To delete an existing abbreviation, select it from the list and click Remove.

Tip: When editing a 
variation of English 
other than British and 
American English, 
ensure you are editing 
the right text because 
the window defaults 
to your user interface 
language, not to the 
language of your text
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Filler text
Filler text, also referred to as placeholder text, is used to demonstrate a layout’s 
design without using actual words that may not be ready yet and which could be 
distracting.

Designers have long used Lorem Ipsum as filler text, adapted from a Latin dia-
logue by the Roman statesman Cicero. Affinity allows you to insert filler text 
automatically by choosing Text > Insert Filler Text. The filler text will fill all the 
space in the text frame or series of linked frames without overflowing the frames. 
Affinity will select a random sentence from the filler text to avoid identical blocks 
if you inserted it into multiple frames on the same spread.

You can replace Affinity’s default filler text with your own, and use different filler 
text for various languages if the Latin text is not suitable for your purposes.

To replace Affinity’s filler text:

1. Create or open a document—you cannot set Filler Text defaults without an 
open document.

2. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click Filler Text in the left pane.

3.  Language: Select the language you wish to customise. The text field below will 
be blank if you have not customised the filler text for this language. This step 
is required because each language can have its own custom filler text.

4. Enter the new filler text. Use at least a few sentences or paragraphs so that 
there is sufficient text for Affinity to randomize the starting sentence.
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You can test it before saving it as the default by drawing a text frame and 
choosing Text > Insert Filler Text. If you have already done that, doing 
anything to the document including changing the zoom level or page will 
update the filler text.

5. Until you save the filler text as the default, it will remain a document-level 
setting and not a global setting and will not be available to other open docu-
ments. To save the current document’s filler text as Affinity’s default, click 
Save as Default. This command saves only the selected language’s filler text.

6. To undo changes you have made to the Filler Text for the current document, 
click Revert to Default. This command reverts only the selected language’s 
filler text.

7. To revert the Filler Text to Affinity’s original default, click Factory Reset. This 
command resets only the selected language’s filler text.

To insert filler text as text instead of as a field:

1. Choose Affinity > Settings… (macOS) or Edit > Settings… (Windows) and 
then click General in the left pane.

2. Click Insert filler text as text. From now on when you choose Text > Insert 
Filler Text, it will insert enough filler text as regular text to fill the frame(s).

Tip: If you insert filler 
text as a field (with 
Insert filler text as 
text disabled), you can 
convert it to regular 
text by right-clicking it 
and choosing Expand 
Field
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Installing additional dictionaries
Affinity uses the spelling dictionaries included with macOS and a limited selec-
tion of dictionaries is included with Affinity for Windows. Affinity for both 
platforms includes a selection of hyphenation dictionaries.

You can install additional dictionaries if the spelling or hyphenation language 
you want isn’t included listed in the Spelling and Hyphenation language lists in 
the Character panel. Affinity uses the widely-available Hunspell dictionary 
format used by many other applications.

A list of the included and available dictionaries is shown on the following pages. 
You can download Hunspell dictionary files from many websites but Serif has 
provided a convenient list of download links on the previous Affinity forum. All 
of the files will be named xx_XX where xx is the language and XX is the region, for 
example, pl_PL represents Polish and Poland.

To install an additional dictionary on macOS:

1. To install a spelling dictionary, copy the downloaded xx_XX.dic and xx_XX.aff
files to /users/<username>/Library/Spelling/. Both files are required for a spell-
ing dictionary.

2. To install a hyphenation dictionary, create a folder named xx_XX in 
/users/<username>/Library/Spelling/ and copy the downloaded hyph_xx_XX.dic
file into it.

3. Restart Affinity for the changes to take effect.

To install an additional dictionary on Windows:

1. The default folder for installing additional dictionaries is 
C:\ProgramData\Affinity\Common\3.0\Dictionaries\ but you can change this if 
desired by choosing Edit > Settings…, select Tools from the left pane, and 
click Browse.

2. To install spelling and hyphenation dictionaries, create a folder named xx_XX
in C:\ProgramData\Affinity\Common\3.0\Dictionaries\ or your custom location 
and copy the downloaded xx_XX.dic and xx_XX.aff spelling dictionary files 
and/or the hyph_xx_XX.dic hyphenation dictionary file into it.

3. Restart Affinity for the changes to take effect.

German dictionaries
The German orthography reform of 1996 simplified German spelling but some of 
the changes proved controversial and were removed in 2006. macOS includes a 
German dictionary based on the 2006 reforms while Affinity for Windows 
includes a dictionary based on the 1996 reforms.

Users of Affinity for Windows who wish to use a German dictionary based on 
the 2006 reforms should download the de_DE_frami.aff and de_DE_frami.dic from 
the list of download links on the previous Affinity forum. Install the files using 

Tip: Affinity does not 
include a matching 
hyphenation dictio-
nary for every spelling 
dictionary, nor are 
they available for 
every language

Tip: Some dictionary 
files are named xx_XX 
while others are 
named xx-XX with a 
hyphen instead of an 
underscore—this isn’t 
important

Tip: When changing 
the location of dictio-
naries, select the 
folder containing the 
language folder(s) and 
not the language 
folder (xx_XX) you 
created

https://forum.affinity.serif.com/index.php?/topic/190021-how-do-i-add-additional-dictionaries-to-affinity-v2/&do=findComment&comment=1134760
https://forum.affinity.serif.com/index.php?/topic/190021-how-do-i-add-additional-dictionaries-to-affinity-v2/&do=findComment&comment=1134760
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the instructions above, but first remove the _frami suffix from the names of the 
downloaded files.

French dictionaries
The Rectifications orthographiques du français en 1990 simplified some French 
spelling but proved controversial. macOS and Affinity for Windows come with a 
version of the dictionary that uses pre-1990 spelling rules.

Affinity users who wish to use a dictionary based on the 1990 reforms should 
download Grammalecte for LibreOffice from https://grammalecte.net/
#download. After downloading the file, rename the file extension from .oxt to .zip
and open the file. Install the Grammalecte-fr-v2.1.2/dictionaries/fr-reforme1990.aff
and fr-reforme1990.dic files using the instructions above, but first remove the 
-reforme1990 suffix from both files.

Included and available dictionaries
This table lists all of the included spelling and hyphenation dictionaries as well as 
some other common ones but you are not limited to those listed here. Dictionar-
ies marked as ✓ are included with macOS or with Affinity for Windows.

Hyphenation dictionaries marked as auto aren’t necessary because hyphenation 
is generally the same for each regional variant of a language (for example, Span-
ish for Spain and Mexico) so Affinity automatically uses the main hyphenation 
dictionary for that language when Language > Hyphenation is set to Auto in the 
Character panel.

For all variants of English other than English (United Kingdom), setting hyphen-
ation to Auto will default to the English (United States) hyphenation dictionary.

  macOS   Windows
Locale Language Spelling Hyphen. Spelling Hyphen.

en_US English [United States]  ✓ ✓ ✓ ✓

en_GB English (United Kingdom)  ✓ ✓ ✓ ✓

en_AU English (Australia)  ✓ auto (US)    auto (US)

en_CA English (Canada)  ✓  auto (US)    auto (US)

en_IN English (India)  ✓  auto (US)    auto (US)

en_SG English (Singapore)  ✓  auto (US)    auto (US)

en_ZA English (South Africa)  ✓  auto (US)    auto (US)

en_NZ English (New Zealand)  ✓  auto (US)    auto (US)

en_JP English (Japan)  ✓  auto (US)    auto (US)

de_DE Deutsch [German]  ✓  ✓ ✓  ✓

de_AT Deutsch (Österreich) [Austria]

de_CH Deutsch (Schweiz) [Switzerland]

Tip: (macOS) If the de_
AT or de_CH files you 
downloaded include 
_frami in their file-
names, remove _frami
from the names before 
installing

Tip: On macOS, English 
(United States) is 
written as English
without United States
in parentheses

https://grammalecte.net/#download
https://grammalecte.net/#download
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  macOS   Windows
Locale Language Spelling Hyphen. Spelling Hyphen.

es_ES Español [Spanish]  ✓  ✓ ✓  ✓

es_MX Español (México)    auto    auto

es_AR Español (Argentina)    auto    auto

es_BO Español (Bolivia)    auto    auto

es_CL Español (Chile)    auto    auto

es_CO Español (Colombia)    auto    auto

es_CR Español (Costa Rica)    auto    auto

es_EC Español (Ecuador)    auto    auto

es_PE Español (Perú)    auto    auto

es_PY Español (Paraguay)    auto    auto

es_US Español (Estatdos Unidos)    auto    auto

es_UY Español (Uruguay)    auto    auto

es_VE Español (Venezuela)    auto    auto

fr_FR Français [French]  ✓  ✓ ✓  ✓

fr_CA Français (Canada)    auto    auto

fr_BE Français (Belgique)    auto    auto

fr_CH Français (Suisse)    auto    auto

fr_LU Français (Luxembourg)    auto    auto

id_ID Indonesian  ✓  ✓ ✓  ✓

it_IT Italiano [Italian]  ✓  ✓ ✓  ✓

pt_BR Português (Brasil)  ✓  ✓ ✓  ✓

pt_PT Português (Portugal)  ✓  auto    auto

tk_TM Türkçe [Turkmen]  ✓  ✓ ✓  ✓

cs_CZ Čeština [Czech]  ✓

da_DK Dansk [Danish]  ✓

ga_IE Gaeilge [Irish]  ✓

hu_HU Magyar [Hungarian]  ✓

nl_NL Nederlands [Dutch]  ✓

nb_NO Norsk Bokmål [Norwegian]  ✓

nn_NO Norsk Nynorsk [Norwegian]  ✓

pl_PL Polski [Polish]  ✓

Tip: The only available 
dictionary for French is 
the main fr_FR dictio-
nary; if you import text 
formatted as Français 
(Canada) or one of the 
other three variants, 
download the fr_FR 
dictionary files from 
the Affinity forum and 
rename them as 
required to avoid 
seeing the missing 
dictionary error in 
Preflight
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  macOS   Windows
Locale Language Spelling Hyphen. Spelling Hyphen.

ro_RO Română [Romanian]  ✓

fi_FI Suomi [Finnish]  ✓

sv_SE Svenska [Swedish]  ✓

sv_FI Svenska (Finland)

vi_VN Tiếng Việt [Vietnamese]  ✓

el_GR Ελληνικά [Greek]  ✓

bg_BG Български [Bulgarian]  ✓

uk_UA українська [Ukrainian]  ✓

ru_RU Руссĸий [Russian]  ✓

af_ZA Afrikaans (Suid-Afrika)

bs_BA Bosanski (Bosna | Hercegovina)

et_EE Eesti [Estonian]

gl_ES Galego (España) [Galician]

hr_HR Hrvatski (Hrvatska) [Croatian]

lv_LV Latviešu (Latvija) [Latvian]

lt_LT Lietuvių [Lithuanian]

Mk_MK Macedonian

mn_MN Mонгол [Mongolian]

sk_SK Slovenčina (Slovensko) [Slovak]

sq_AL Shqip (Shqipëri) [Albanian]

sl_SL Slovenščina (Slovenija) [Slovenian]

ca Català [Catalan]

ca_valencia Català (Valencian)

gd_GB Gàidhlig (An rìoghachd Aonaichte) [Gaelic]

la Latin   ✓   ✓

Tip: The Latin hyphen-
ation is included to 
support hyphenating 
Filler Text which is 
similar to Latin but the 
spelling dictionary is 
not included because 
Filler Text isn’t identi-
cal to Latin and should 
not be spell checked; 
you can also name the 
la files as simply la_VA
but that will cause the 
language to appear as 
Latin (Vatican City)

466 Customising



Expert Guide to Affinity by Canva 3.0 467Expert Guide to Affinity by Canva 3.0 467

Appendices
Appendix A – Special characters
To type a special character:

1. Type the character’s Unicode value and choose Text > Toggle Unicode, or 
choose Text > Insert and select from the list.

2. Choose Text > View Special Characters to show the invisible symbols for 
special characters. This will not display anchors, index marks, or fields which 
you must enable separately with their respective commands.

Whitespace * Not in menu

 Space U+0020

 Em Space, non-breaking U+2003

 En Space, non-breaking (½ em) U+2002

 Third/Thick Space, non-breaking (1⁄3 em) U+2004

 Quarter/Mid Space, non-breaking (¼ em) U+2005

 Thin (Fifth) Space, non-breaking (1⁄5 em) U+2009

 Sixth Space, non-breaking (1⁄6 em) U+2006

 Hair Space, non-breaking (1⁄12 em) U+200A

 Punctuation Space, non-breaking (width of period) U+2008

 Figure Space, non-breaking (often the width of a 0) U+2007

 Medium Mathematical Space, non-breaking (4⁄18 em) U+205F*

 Non-Breaking Space U+00A0

 Narrow Non-Breaking Space (1⁄7 em) U+202F
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Whitespace, continued * Not in menu

 Tab U+0009

 Right Indent Tab

 Indent to Here

 Em Quad/Mutton – no symbol shown U+2001*

 En Quad/Nut – no symbol shown U+2000*

 Ideographic Space – no symbol shown U+3000*

Hyphens

 Automatic Hyphen-

 Soft Hyphen, inline/end of line U+00AD

 Non-Breaking Hyphen – no symbol shown U+2011

Breaks and Joiners

 Line Break U+2028

 Paragraph Break U+2029

 Column Break

 Frame Break

 Page Break U+000C

 Odd/Even Page Break

 End of Story
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Breaks and Joiners, continued * Not in menu

 Zero-Width Space (breaking, discretionary line break) U+200B

 Zero-Width Non-Breaking Space U+FEFF*

 Zero-Width Non-Joiner U+200C

 Zero-Width Joiner U+200D*

 Word Joiner U+2060*

Markers

 Anchor position

 Pinned object position

 Index Mark

 Note Mark

 Endnote brackets (type between)

 Broken endnote brackets and number

 Field (field value is shown)
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Appendix B – Using field input expressions
You can enter expressions into fields such as Font Size and Width to change the 
value by a relative amount instead of to a specific absolute amount.

For example, instead of entering 12 pt, you could enter *2 to multiply the current 
value by 2. Or you could enter a variable such as x+10 into the Y coordinate field 
to mean the X coordinate plus 10.

You can also mix measurement units. For example, 5 in + 5 pt.

Expression Result

+=10 Sets to current value plus 10; you could also enter just +10

-=10 Sets to current value minus 10; you cannot enter just -10
 because that would enter an absolute value of -10

*2 Sets to double the current value

/2 Sets to half the current value

90% Sets to 90% of the current absolute value

Object transformation Result

w+10 Sets to object width plus 10

h+10 Sets to object height plus 10

x+10 Sets to object’s X coordinate plus 10

y+10 Sets to object’s Y coordinate plus 10

r+10 Sets to object’s rotation plus 10

s+10 Sets to object’s shear plus 10

sw/2 Sets to half of the spread width

sh/2 Sets to half of the spread height

sl+10 Sets to the spread’s left edge plus 10

Sr-10 Sets to the spread’s right edge minus 10

st+10 Sets to the spread’s top edge plus 10

sb-10 Sets to the spread’s bottom edge minus 10

ml+10 Sets to the spread’s left margin plus 10

mr-10 Sets to the spread’s right margin minus 10

mt+10 Sets to the spread’s top margin plus 10

mb-10 Sets to the spread’s bottom margin minus 10

Tip: For use in the 
Transform panel and 
related fields in the 
Context Toolbar
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aw+10 Sets to the width of the area between the left and right
 margins plus 10

mb-10 Sets to the height of the area between the top and bottom
 margins minus 10

Document setup Result

w+10 Sets to spread width plus 10

h+10 Sets to spread height plus 10

l+10 Sets to left margin plus 10

r+10 Sets to right margin plus 10

t+10 Sets to top margin plus 10

b+10 Sets to bottom margin plus 10

Tip: For use with New 
Document, Document 
Setup, and Spread 
Setup
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Appendix C – Clearing user data
If Affinity starts to act strangely, such as if a panel won’t display when you choose 
its menu command, you might need to clear your user data for a fresh start.

To clear user data:

1. Before starting Affinity:

• macOS: Start Affinity and then immediately press and hold Ctrl. Don’t 
press Ctrl before clicking the app icon or a context menu will appear.

• Windows: Press and hold Ctrl and then start Affinity.

2. Release Ctrl when the Clear User Data window appears.

3. Select which data to clear and click Clear. Your preference settings, text 
formatting defaults, and other options are grouped together as the first item, 
User Defaults, but other settings can be cleared independently.

The options are slightly different for macOS and Windows but most of them are 
the same.

Tip: Windows: If you 
don’t have the app 
icon pinned in the Task 
bar and the Clear User 
Data window doesn’t 
appear, wait for the 
icon to appear and 
then click it

472
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Appendix D – Keyboard shortcuts
The table lists the default keyboard shortcuts for the Layout studio menus and text selection and format-
ting. Commands with a apple symbol are for macOS only while some Windows commands are in different 
menus. Some macOS commands may appear only when ⌥ (Option) is pressed.

Affinity menu macOS Windows

Settings… (  in Edit menu) ⌘ + , Ctrl + ,

Hide apple ⌘ + H n/a

Hide Others apple ⌥ + ⌘ + H n/a

Quit (  in File menu) ⌘ + Q Ctrl + Q

Quit and Keep Windows apple ⌥ + ⌘ + Q n/a

File menu macOS Windows

New… ⌘ + N Ctrl + N

New from Last Preset… ⌥ + ⌘ + N n/a

New from Clipboard ⌥ + Shift + ⌘ + N Ctrl + Alt + Shift + N

Open… ⌘ + O Ctrl + O

Open Recent > More… Ctrl + ⌘ + O Ctrl + Shift + O

Close ⌘ + W Ctrl + W

Close All ⌥ + ⌘ + W Ctrl + Alt + W

Save  ⌘ + S Ctrl + S

Save As… Shift + ⌘ + S Ctrl + Shift + S

Place… Shift + ⌘ + M Ctrl + Shift + M

Export… ⌥ + Shift + ⌘ + W Ctrl + Alt + Shift + W

Print… ⌘ + P Ctrl + P

Edit menu macOS Windows

Undo ⌘ + Z Ctrl + Z

Redo Shift + ⌘ + Z Ctrl + Shift + Z

Find > Find… ⌘ + F Ctrl + F

Select All ⌘ + A Ctrl + A

Deselect ⌘ + D Ctrl + D

Cut  ⌘ + X Ctrl + X

Copy ⌘ + C Ctrl + C

Duplicate > Selection ⌘ + J Ctrl + J

Paste ⌘ + V Ctrl + V

Paste Style Shift + ⌘ + V Ctrl + Shift + V

Paste Inside ⌥ + ⌘ + V Ctrl + Alt + V

Paste Without Format ⌥ + Shift + ⌘ + V Ctrl + Alt + Shift + V
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Document menu macOS Windows

Pages > New Shift + ⌘ + ↓ Ctrl + Shift + ↓

Pages > Previous Page ⌘ + ⇞ Ctrl + ⇞
Pages > Next Page ⌘ + ⇟ Ctrl + ⇟
Setup > Document Setup… Shift + ⌘ + P Ctrl + Shift + P

Text menu macOS Windows

Character Traits > Bold (when editing text) ⌘ + B Ctrl + B

Character Traits > Italic (when editing text) ⌘ + I Ctrl + I

Character Traits > Underline (when editing text) ⌘ + U Ctrl + U

Size > Bigger ⌘ + > Ctrl + >

Size > Smaller ⌘ + < Ctrl + <

Size > Precise Bigger ⌥ + ⌘ + > Ctrl + Alt + >

Size > Precise Smaller ⌥ + ⌘ + < Ctrl + Alt + <

Spacing > Tighten ⌥ + ← Alt + ←

Spacing > Loosen ⌥ + → Alt + →

Spacing > Tighten More ⌥ + ⌘ + ← Alt + Shift + ←

Spacing > Loosen More ⌥ + ⌘ + → Alt + Shift + →

Baseline > Superscript ⌃ + ⌘ + + Ctrl + Alt + +

Baseline > Subscript ⌃ + ⌘ + - Ctrl + Alt + -

Baseline > Raise Baseline ⌥ + Shift + ↑ Alt + Shift + ↑

Baseline > Lower Baseline ⌥ + Shift + ↓ Alt + Shift + ↓

Baseline > Precise Raise Baseline ⌥ + Shift + ⌘ + ↑ Ctrl + Alt + Shift + ↑

Baseline > Precise Lower Baseline ⌥ + Shift + ⌘ + ↓ Ctrl + Alt + Shift + ↓

List > Increase Level ⌃ + Shift + [ Alt + Shift + [

List > Decrease Level ⌃ + Shift + ] Alt + Shift + ]

Paragraph Leading > Increase ⌥ + ↓ Alt + ↓

Paragraph Leading > Decrease ⌥ + ↑ Alt + ↑

Paragraph Leading > Precise Increase ⌥ + ⌘ + ↓ Ctrl + Alt + ↓

Paragraph Leading > Precise Decrease ⌥ + ⌘ + ↑ Ctrl + Alt + ↑

Insert > Dashes and Hyphens > Em Dash ⌥ + Shift + - Alt + Shift + -

Insert > Dashes and Hyphens > En Dash ⌥ + - Alt + -

Insert > Dashes and Hyphens > Soft Hyphen Shift + ⌘ + -  Ctrl + Shift + -

Insert > Dashes and Hyphens > Non-Breaking Hyphen ⌥ + ⌘ + -  Ctrl + Alt + -

Insert > Spaces and Tabs > Non-Breaking Space ⌥ + Space Alt + Space

Insert > Spaces and Tabs > Right Indent Tab Shift + Tab Shift + Tab

Insert > Spaces and Tabs > Indent to Here ⌘ + \ Ctrl + \

Insert > Breaks > Line Break Shift + Tab Shift + Enter
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Spelling > Spelling Options… Shift + ⌘ + ; Ctrl + Shift + ;

Index > Insert Index Mark ⌥ + Shift + ⌘ + [ Ctrl + Alt + Shift + [

Layer menu macOS Windows

Select > Next Layer ⌥ + ⌘ + ] Ctrl + Alt + ]

Select > Previous Layer ⌥ + ⌘ + [ Ctrl + Alt + [

Select > Parent Layer ⌘ + ↑ Ctrl + ↑

Select > All Layers ⌥ + ⌘ + A Ctrl + Alt + A

Select > Cycle Selection Box  .  (period)  .  (period)

Select > Set Selection Box ⌘ +  .  (period) Ctrl +  .  (period)

Convert > To Picture Frame Shift + P Shift + P

Arrange > Move > To Front Shift + ⌘ + ] Shift + Ctrl + ]

Arrange > Move > Forward One ⌘ + ] Ctrl + ]

Arrange > Move > Back One ⌘ + [ Ctrl + [

Arrange > Move > To Back Shift + ⌘ + [ Shift + Ctrl + [

Arrange > Move > Inside ⌥ + ⌘ + G Ctrl + Alt + [G

Arrange > Move > Outside Shift + ⌥ + ⌘ + G Shift + Ctrl + Alt + [G

Rename… Shift + ⌘ + R Shift + Ctrl + R

Group ⌘ + G Ctrl + G

Ungroup Shift + ⌘ + G Shift + Ctrl + G

Unlock All ⌃ + ⌘ + L Shift + Ctrl + Alt + L

Master Page > Edit Detached Shift + ⌘ + D Shift + Ctrl + D

Master Page > Edit Frame Content Shift + ⌘ + C Shift + Ctrl + C

Show All ⌃ + ⌘ + H Shift + Ctrl + Alt + H

Find in Layers Panel ⌘ + K Ctrl + K

View menu macOS Windows

Zoom > Zoom In ⌘ + + Ctrl + =

Zoom > Zoom Out ⌘ + - Ctrl + -

Zoom > Zoom to Fit ⌘ + 0 Ctrl + 0

Zoom > Zoom to Width ⌥ + ⌘ + 0 Alt + Shift + 0

Zoom > Zoom to Selection Shift + ⌘ + 0 Ctrl + Alt + 0

Zoom > Zoom to Document ⌥ + Shift + ⌘ + 0 Ctrl + Alt + Shift + 0

Zoom > 100% ⌘ + 1 Ctrl + 1

Zoom > 200% ⌘ + 2 Ctrl + 2

Zoom > 400% ⌘ + 3 Ctrl + 3

Zoom > 800% ⌘ + 4 Ctrl + 4

Zoom > Actual Size ⌘ + 8 Ctrl + 8

Zoom > Pixel Size ⌘ + 9 Ctrl + 9
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Rotate > Reset Rotation ⌃ + Shift + ⌘ + R Ctrl + Alt + Shift + R

Show > Guides ⌘ +  ;  Ctrl +  ; 

Show > Grid ⌘ +  ’  Ctrl +  ’ 

Show > Rulers ⌘ + R Ctrl + R

Show > Toolbar ⌥ + ⌘ + T Ctrl + Alt + T

Preview Mode ⌃ + W Ctrl + Shift + ‘

Clip to Canvas \ \

Toggle UI Tab Tab

Window menu macOS Windows

Panels > Hide Shift + ⌘ + H Ctrl + Shift + H

Text > Character ⌘ + T Ctrl + T

Text > Typography Shift + ⌘ + T Ctrl + Shift + T

Toggle Full Screen apple ⌃ + � + F n/a

Navigate text macOS Windows

Move one character left or right � or � � or �

Move one line up or down ↑ or ↓ ↑ or ↓

Move to the start or end of the current word and then ⌘ + � or � Ctrl + � or �
to subsequent words

Move to the start or end of the current paragraph and ⌘ + ↑ or ↓ Ctrl + ↑ or ↓
then to subsequent paragraphs

Move to the start or end of the current line fn + � or � Home / End

Move to the start or end of the story fn + ⌘ + � or � Ctrl + Home / End

Select text macOS Windows

Extend selection one character left or right Shift + � or � Shift + � or �

Extend selection one line up or down Shift + ↑ or ↓ Shift + ↑ or ↓

Extend selection to the start or end of the current word Shift + ⌘ + � or � Shift + Ctrl + � or �
and then to subsequent words

Extend selection to the start or end of the current Shift + ⌘ + ↑ or ↓ Shift + Ctrl + ↑ or ↓
paragraph and then to subsequent paragraphs

Extend selection to the start or end of the current line Shift + fn + � or � Shift + Home or End

Extend selection to the start or end of the story Shift + fn + ⌘ + � or � Shift + Ctrl + Home or End

Delete text macOS Windows

Delete the previous character Delete Backspace

Delete the next character fn + Delete Delete
 or ⌦ Delete

Delete to the start of the current word and ⌥ + Delete Ctrl + Backspace
then to subsequent words

Delete to the end of the current word and ⌥ + fn + Delete Ctrl + Delete
then to subsequent words or ⌥ + ⌦ Delete

Delete to start of line fn + ⌘ + Delete n/a
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Index
A
Abbreviation settings, 6, 455, 459
Accessible PDF, 370
Aligning objects, 244
Alignment (text), 168
All caps, 164
All Petite Caps, 164
Alt text, 382
Anchoring objects, 197
Anchors, 362

Change hierarchy, 364
Delete, 364
Insert, 363
Panel, 362
Rename, 364
Show, 363

Arranging objects, 245
Arrowheads, 253
Artboards, 23
Articles (Reading Order), 379
AutoCorrect, 140
AutoCorrect settings, 5, 455–456
AutoFlow, 117
Automatic layout, 282

B
Baseline grid, 90

Independent by text 
frame, 120, 123

Baseline grid, paragraph 
override, 173
Baseline offset, 156
Bleed

Creating a document, 25
Bold, 150
Bookmarks, 362

Export as PDF, 365
Books, 282

Add chapters, 291
Anchors, 362
Chapters, 286
Close, 292
Create, 290
Cross-references, 298

Duplicate, 292
Export, 299
Hyperlinks, 367
Index, 298
Lists, 295
Notes, 295
Open, 291
Page numbering, 295
Panel, 287
Parts of, 282
Preflight, 287, 299
Print, 299
References, 298
Remove chapters, 291
Save, 292
Sections, 284
Splitting, 286
Story, 284
Stray pages, 288
Sync chapters, 294
Sync master pages, 293
Sync swatches, 293
Sync text styles and table 
formats, 293
Syncing, 293
Table of contents, 298

Breaks, Column, Frame and 
Page, 118
Bulleted lists, 180

Expand list, 180

C
Capital Spacing, 164
Case-sensitive forms, 164
Character

Attributes, 147
Decorations, 154
Font, 147
Language, 158
Optical alignment, 160
Panel, 148
Position and transform, 155
Style, 150, 204
Typography, 161

Character variants, 165
Clear user data, 472
Colour, 249

Creating a document, 23
Format, 23
Gradient, 251
Profile, 23
Settings, 447
Swatches, 251

Column guides, 80
Context Toolbar, 433
Contextual alternates, 162
Contextual Swash, 165
Copying text, 129
Crop (vector) tool, 272
Cropping images, 269, 272
Cross-references, 302

Add, 304
Books, 298
Create preset, 306
Delete, 307
Edit, 307
Panel, 303
Share preset, 308
Update, 309

CSS (EPUB), 377
Custom CSS (EPUB), 377
Customising

Studios, 426

D
Dashed lines, 253
Decorations (character), 154
Decorations (paragraph), 190
Deleting text, 130
Dictionaries, 2

Installation, 2, 463
Distributing objects, 244
Document Metadata, 384
Document Setup, 33
Documents

Bleed, 25
Change options, 33
Close, 32
Colour, 23
Create, 22
Margins, 25
Model, 34
Pages, 24
Presets, 11, 22, 26
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Scaling, 34
Setup, 33
Templates, 31

Dot leaders, 175
DPI, 23
Drawing scale, 26
Drop caps, 187

E
Embedding images, 274
Enable Transform Origin, 235
Endnotes, 339
EPUB, 370

Cover page (image), 376, 421
Export, 419
Fixed-Layout, 370
Hyperlinks, 391
Panel, 377
Reflowable, 370
Table of contents, 387

EPUB panel, 377
Export

Books, 299
Create preset, 406
EPUB, 419
PDF (commercial press), 408
PDF (digital), 412
PDF (print on demand), 416
Quick, 423

Export tags, 373
Emit CSS, 374

F
Facing pages, 37
Field Input Expressions, 470
Fields, 354

Custom, 360
Date and time formats, 358
Delete, 355
Edit, 355
Expand (convert to text), 355
Format, 357
Insert, 355
Metadata, 354
Panel, 354, 384
Show, 355
Types, 355

Figure style, 166
Figure width, 166
Fill, 249
Filler text, 461

Insert, 127
Finding and replacing, 134

Regular expressions 
(GREP), 136

First line indent, 170
Fixed-Layout EPUB, 370
Float with text, 197
Floating window, 445
Flow (paragraph), 178
Flow text, 111, 282

Controls, 111
Interrupting, 118

Font, 147
Background colour, 150
Colour, 150
Default for CJK, 194
Outline, 154
Size, 149
Style, 149
Traits, 149
Variable, 151

Footers, 66
Page numbering, 67

Footnotes, 339
Formatting characters, 147
Formatting paragraphs, 167
Fractions, 163

G
Glyph browser, 126
Gradients, 251
Grid (snapping), 85
Grouping objects, 246
Guides, 78

Column, 80
Margin, 25, 80
Ruler, 82

H
Hanging punctuation, 160
Headers, 66

Page numbering, 67
Running, 72

Hide Selection While Drag-
ging, 235
Hiding objects, 247
Historical Forms, 165
Hyperlinks, 366

Delete, 368
EPUB, 391
Insert, 366
Panel, 366

Hyphenation, 185
Default language, 3
Installing dictionaries, 463
Language, 158

I
Images

Embedding, 274
Fill and stroke, 277
Linked, 24, 274
Missing, 145, 275
Move, 276
Picture frames, 258
Place, 261
Raster, 256
Replace, 263
Resolution (DPI), 257
Types, 256
Update, 274–275
Vector, 256

Import text, 142
Indents (paragraph), 170
Index, 326

Add cross-reference, 332
Add entry, 330
Add subtopic, 329
Add topic, 328
Books, 298
Capitalize entries, 336
Change parent topic, 329
Delete, 333
Delete entry, 332
Delete topic, 329
Dot leader, 335
Format, 334
Generate, 333
Import topics, 329
Multiple, 337
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Multiple occurrences, 331
Panel, 327
Topic list, 328
Update, 333

Initial words, 189
Inline in text, 197
Insert Behind / Inside / Top, 233
Invisibles, 467
Island spreads, 37
Italic, 150

J
Justification, 168
Justification options, 176

K
Keep together, 178
Kerning, 155

L
Language, 158

Default, 3
Interface, 2

Layer stack, 245
Layers, 220

Layers panel, 220
Rename, 222
Stack order, 59, 245

Layout
Automatic, 282
Creating a document, 22
Static, 282

Leading, 170
Modern Leading, 173

Leading override, 157
Ligatures, 162
Lines

Arrows, 253
Create, 228
Dashed, 253
Modify, 229

Link text frames, 111
Linked images, 24, 274
Linked text files, 24

Find, 145
Move, 146

Update, 144
List of figures or illustrations, 279
Lists

Books, 295
Figures or illustrations, 279
Global, 181
Running, 181

Lists (bulleted and numbered), 180
Locking objects, 248

M
Margin guides, 25, 80
Margins

Creating a document, 25
Master pages, 36

Apply, 50
Change options, 49
Change stack order, 59
Convert page to, 54
Create, 47
Delete, 48
Edit objects, 57
Import, 55
Override, 57
Properties, 52
Unassign from page, 54

Measurement units, 23, 76
Metadata, 354

Alt text, 382
Document, 384
XMP, 382

Move / Duplicate, 233, 237
Move to Front, 245
Multi-page spreads, 37

N
Navigator panel, 93
No break, 157
Notes (footnotes, endnotes, 
sidenotes), 339

Add, 341
Add multiple references, 342
Books, 295
Convert formatting, 345
Convert type, 344
Default, document-wide, and 
custom settings, 345

Delete, 341
Edit, 341
Endnote positioning in 
Books, 297
Find, 341
Format, 348
Import from Microsoft 
Word, 353
Numbering, 347
Panel, 340
Position, 350
Separate multiple refer-
ences, 342
Set defaults, 346
Settings, 345

Nudge Objects, 238
Numbered lists, 180

Expand list, 180

O
Object

Colour, 249
Fill, 249
Stroke, 249, 253

Objects, 220
Align, 244
Arrange, 245
Distribute, 244
Duplicate, 232
Enable Transform Origin, 235
Flip, 236
Group / Ungroup, 246
Hide / Show, 247
Hide Selection While 
Dragging, 235
Insert Behind / Inside / 
Top, 233
Lock / Unlock, 248
Move, 235
Move / Duplicate, 233, 237
Nudge, 238
Rotate, 235
Scale, 235
Scale Override, 239
Scale with Object, 239
Select, 230
Shapes, 223
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Show Alignment Han-
dles, 235
Snap to…, 240
Space, 244
Stack order, 245
Transform, 235
Transform Panel, 238
Transform Separately, 237

OpenType, 161
Optical alignment, 160
Ordinals, 163

P
Page Box (PDF), 266
Page numbering, 67

Books, 295
Continued on, 70
Format, 68
Sections, 69

Pages, 36
Add, 39
Creating a document, 24
Delete, 43
Duplicate, 42
Go to Master, 41
Go to Page, 41
Import from another 
document, 43
Numbering, 67
Panel, 37
Reorder, 42
Select, 38
Size, 44
View, 41

Pages panel, 37
Panels

Customise, 439
Presets, 442

Paragraph
Alignment (justification), 168
Attributes, 167
Background and borders, 190
Baseline grid override, 173
Bullets & numbering, 180
Decorations, 190
Drop caps, 187
Flow options, 178

Hyphenation, 185
Initial words, 189
Justification options, 176
Panel, 168
Rules above and below, 190
Spacing, 170
Style, 169, 204
Tab stops, 174

PDF, 371, 408, 412, 416
Accessible, 370–371
PDF/UA, 370

PDF/UA, 371
Petite Caps, 164
Picture frames, 258

Create by drawing, 258
Create by entering values, 259
Fill and stroke, 277
Move, 268
Replace image, 263
Scaling and rotating, 269
Select, 267
Shape, 259

Pinning
Objects, 197

Pinning objects, 197
Placing documents (PDF and 
Affinity), 264
Placing images, 261
Placing text, 142
Preferences, 444

Abbreviations, 6, 455, 459
AutoCorrect, 5, 455–456
Colour, 447
Filler text, 461
Shortcuts, 452
Title exceptions, 7, 455, 460

Preflight, 394
Books, 299
Cross-references, 309
Export and import pro-
files, 88, 400
Index, 333
Panel, 394
Presets, 395
Resolve issues, 401
Settings, 395
Table of contents, 313

Preview mode, 96
Printing

Booklet, 405
Books, 299
Commercial press, 408
Direct to printer, 402
N-Up, 404

Q
Quick Export, 423
Quick grids, 227

R
Reading Order panel, 379
References

Books, 298
Reflowable EPUB, 370
Regular expressions (GREP), 136
Ruler guides, 82
Rulers, 76
Rules above and below para-
graph, 190
Runaround text, 195
Running headers, 72

S
Scale Override, 238–239
Scale with Object, 239
Sections, 66

Books, 284
Change or delete, 70
Go to, 39
Use as chapters, 71

Selecting Text, 128
Send to Back, 245
Settings, 444

Abbreviations, 6, 455, 459
AutoCorrect, 5, 455–456
Colour, 447
Filler text, 445, 461
General, 444
Shortcuts, 452
Title exceptions, 7, 455, 460

Shape text, 105
Shapes, 223

Create by entering values, 224
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Create grid, 227
Draw, 223
Modifying, 226
Options, 224

Show Alignment Handles, 235
Sidenotes, 339
Size handles

Change size, 112
Small caps, 164
Snapping, 240

Grid, 85
Guides, 78
Presets, 243

Spacing (paragraph), 170
Spacing objects, 244
Special characters, 467

Select, 126
Type, 126

Spelling
Check, 138
Default language, 3
Install dictionaries, 2, 463
Language, 158

Spreads, 37
Static layout, 282
Story, 101, 282

Books, 284
Split, 114

Strikethrough, 154
Stroke, 249
Studios

Creating, 428
Customise, 426
Customise Studio 
Switcher, 427
Edit, 430
Import and Export, 431
Save, Revert, and Reset the 
User Interface, 430
Switch, 427

Style Picker tool, 131
Stylistic sets, 165
Sub Tools, 10, 435
Super/subscript, 157, 163
Swash, 165
Swatches, 251

T
Tab stops, 174
Table of contents, 310

Bookmarks, 317
Books, 298
Chapter prefixes, 319
Delete, 313
Dot leader, 316
EPUB, 387
Exclude heading, 318
Format, 314
Generate, 312
Import styles, 320
Include hidden headings, 318
Insert, 312
Multiple, 322
Panel, 311
Pictorial, 324
Print and digital, 319
Scope, 313
Text styles, 316
Update, 313

Tags panel, 382
Templates, 31
Text

AutoFlow, 117
Copying, 129
Default formatting, 112
Deleting, 130
Find and Replace, 134
Flow, 111
Flow controls, 111
Import (Place), 142
Place (import), 142
Regular expressions 
(GREP), 136
Select, 128

Text cursor
Position, 125

Text files
 Linked, 24

Text flow, 282
Text Frame panel, 119
Text frames, 102

Balance columns, 121
Baseline grid, 120, 123

Column rules, 122
Columns, 121
Create, 102
Delete linked, 113
Fill and stroke, 120
Link, 111
Overflow, 120
Properties, 119
Scaled text, 112
Shape text, 105
Unlink, 114
Vertical alignment, 122

Text styles, 204
Apply, 208
 Based on, 212
Character, 150, 211
Clear override, 210
Create, 211
Delete, 214
Duplicate, 214
Edit, 216
Export, 218
Export Tags, 373
Import, 217
 Keyboard shortcut, 212
Next level, 212
Next style, 212
Override, 210
Panel, 206
Paragraph, 169, 211
Remove, 209
Set default, 217
Show in both panels, 212
 Type, 212
Update, 216

Text wrap, 120, 195
Title exception settings, 7, 455, 460
Toolbar

Customise, 432
Tools

Customise, 435
Sub Tools, 10, 435

Tracking, 156
Transform Objects Separately, 237
Transform Origin, 235
Transform Panel, 238
Transparent background, 23
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Typography, 161

U
Underline, 154
Unlink text frames, 114
User data

Clear, 472

V
Variable fonts, 151
Variables, 354

User, 360
Vector crop tool, 272
View magnification, 93
View Modes, 96

W
Widow and orphan control, 178
Word count, 141
Word position forms, 166

X
XMP metadata, 382

Z
Zoom level, 93
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